Search the Community

Showing results for tags 'sysmac studio encoder'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Found 217 results

  1. Average motor speed

    Hi Guys!   There is a task. I have a motor, and I can monitoring the actual speed. The question is how can I to determine the average speed, if I know just the actual speed. If the speed is zero, it must be ignored. So I have to measure when the motor moves. Anybody have any idea? How can I solve this problem. RSLogix 5000.  Thank you.  
  2. Torque Control

    Hi, For my system I use the functions Mc_MoveAbsolte and Mc_TorqueControl. my problem is when i use absolute function after torque control for zero point. the servo turns the torque point control. For example: Target 1: 200 mm target 2: 150 mm Target 3: 240 mm ( Start point of torque) Taget 4: 330  mm (end of process) Target 5: 0 mm After "end of process" the servo turns  to "start point of torque" Can you help me please    
  3. Hello,  I have a NX1P2 controller that would control a DC motor, currently it's open loop. I can control the speed and the direction. I'd like to add an encoder to it. The motor I have is from MidWest motion S27 series and they told me I can use their encoder but the problem is it output TTL My question is, how do I read this encoder output in the PLC since it's TTL?  Second, is there a high speed counter in Sysmac Studio for the PLC I have?  Thank you everyone in advance   
  4. My apologies for being a newbie on this, but could someone save me on this... I have a Viper 650 and an eMB-60R controller which I want to control by ePLC connection using an NJ501-1300 PLC unit, SYSMAC Studio with EIP Adept Library for Robot... All are starting up well, and I connect all components to a switch hub...  But following the ePLC guidelines, the IP Address showing on the controller is 172.16.132.111 I change the IPV4 IP Address on the PC settings to 172.16.132.10 and the subnet to 255.255.0.0 but the Adept IP Address Setting Tool on SYSMAC doesn't detect the Robot IP Address, also i tried ipconfig on command prompt which shows a different IP Address IPV4 169.254.197.75 and subnet of 255.255.0.0, I changed the previous setting on the PC setting to 169.254.197.10 with the same subnet. But still PC doesn't recognize. I tried both configurations if ACE Software can detect it but the same ACE can not detect it also... Appreciate any thoughts on what's wrong in my configurations. Thank you.
  5. Hi all, I uploaded SW from working PLC NJ301 1100 v 1.9. Uploading worked, but when I tried to open program, all rungs were empty (see picture). Does anyone know the cause?
  6. The hyphens (dashes) in Sysmac Studio have been replaced by ASCII "boxes."  Anyone having this problem?  See attached screenshot. Sysmac Studio 1.220.80, Windows 7
  7. Hello, I need to Synchronize two 4kW motors connected to their own individual AltiVar VSDs. To put it simply the two motors are pulling cables on a pulley and when loaded the motor's slip and the speed varies. I have an Omron CP1L-EM PLC and 2x Omron Rotary Encoders ( E6C2-CWZ5B encoders - 360 PPR) - connected to each motor,   What is the best way to read the pulses from the two rotary encoders then convert to RPM? 1) Using  PRV or PRV2(883) instruction,  - this would be the best option as it would convert the value to RPM - however, can I use this instruction on both Counter 0 & Counter 1? 2) Or read the raw value from  Counter 0:  A270 (connected to motor one's encoder) Counter 1: A272 (connected to motor two's encoder) Convert the pulses to RPM - then compare and adjust? 3) Or using CTBL. - is this a useful instruction for this application?   Once I get the RPM speed from each motor - I can then do a compare instruction - see if there is a mismatch and if so send a scaled analogue output to the VSDs to correct the speed if required. (10-50Hz) What would be your recommendations? any help would be most helpful. Thank you.
  8. Homing servo motors

    Hello everybody, I have a question about homing servo motors. I have a project with new servos from Omron and I would like to know what is the best way to do homing for the servos and how often. Before when we have servos with encoders I was making special homing sequence and was calling by some event. I heard that new servos from Omron pretty smart and remember own position without batteries. So with this 'new generation' of servos what is the key to keep machine robust, easy for motor replacement without useless programming stuff. Regards, Scotty
  9. I currently have certain amount of Recipe data located in form of Excel file on to a PC with static IP address. Is there a way to get that data inside the Nj501 without using an SQL server as I currently have NJ501-1300 which doesn't support SQL. I am okay to send data to the SD card I currently have on NJ PLC as it is easy to get data from SD card to the NJ501.  If there is any example code or a link that helps me create i would be helpful. Thanks in advance. FYI: I am currently using NB10 HMI with NJ PLC.
  10. I am trying to connect a Delta ASDA-A2 Servo internal motor encoder to a Delta DVP28SV high speed counter input.  I was successful in connecting the servo to the plc on position mode with an external encoder connected to PLC high speed counter.  Currently having trouble in finding the correct wiring between the servo drive and the plc to count the pulses from the internal motor encoder.  Attached are some figures from the servo drive manual. OA --> X0 is obvious, tried s/s to GND, COM-, VCC and VDD... no result. Any suggestion would be highly appreciated.  
  11. Any new tags I add in studio 5000 the HMI project shortcut cannot locate the tags, it says unresolved route to processor. It's the same shortcut all of the other tags are using. Please help. 
  12. This is my first time to the forum and I am still very new to plc programming. I just had to move all of our software over to a new computer ( kind of new) it's running windows 7 pro. The same is as the computer before. Same computer name, same I'm, same file directory. However when I add tags in studio 5000 and reference them in the HMI, it says it is unresolved in route to the processor. It only does this for the new tags. I used the same shortcut and everything so I am at a complete loss here. What do I do.
  13. Struct as FB input

    Hello,  I am trying to define a struct as an input variable for a Function or Function Block. For example the function AddDelimiter (This is a standard Sysmac function), has a input variable with the variable type Struct, an it is possible to couple a struct to this input (See picture below). If i try to make my own function block with a struct or Structure as an input data type, i get the following error (See picture below). When I try to define a struct from the data types (In this case struct: Test) it doesn't give a error. But when I try to couple a struct to this input, that is a layer deeper than the function block struct i get the following error (See picture below). How can i define a struct as an function/ function block input? Thanks in advance.
  14. I am looking to replace a SIC Hiperface encoder with a standard 1024 encoder. I see how to change the protocol here but am wondering what else I would have to change. Thanks for your help!
  15. Using Rotary Encoder

    Hello dear, may i need some help .. I want to use a rotary encoder for my CJ2M CPU32 , but i don't know what anything must i prepare for it. such as type slot for plc and what kind program for read pulse from rotary encoder ... Thanks before  
  16. OS: Windows 7 Ultimate 64-bit running on VMware virtual machine. Installed software: Studio 5000 V21.0 Licence: Concurrent (served by licence server on another PC). On starting Setup.exe from the VM's desktop I get the message     "Studio 5000 does not support this version of windows" Any ideas how to proceed?
  17. Remote I/O weidmuller

    Hello,  I am trying to connect a Weidmüller UR20 Ethernet I/P  (Hardware version 1) to a Omron NX1P2 PLC via Sysmac Studio. I have imported the Weidmüller EDS file into Sysmac studio and connected two tags to the target variable 101 and 102 (I also tried using a array of bytes and a single word).   When I transfer this configuration to the controller and set the controller in run i get the following error: Tag Data Link Connection Failed (0x84070000). I have tried to update the firmware of the Weidmüller I/O but this doesn't seem to help. Also the web interface shows no connection with the PLC. I also tried to setup the connection with the CX network configurator but this gave the same result. Is there someone who can help me with this problem Thanks in advance.
  18. Hello,   I want to do a small scada for Allen bradley plc  on C#. I did a hmi/scada for Siemens S7-1500 plc on C#, it is working and free. I dont want to use Advanced  Hmi. it is looking free but I can not use it in industries as free. so I decided to use direct C#. Do anybody has sample program, code, document, library, link, etc.. about C# and Rockwell plc communication? second solution and question, if anybody has no solution; I may solve it with modbus TCP. but I dont know Compact logix L27ERM CPU support direct modbus tcp protocol. if anybody has knowledge about the modbus tcp protocol document, sample program etc.. I can try to communicate with modbus tcp C# and Allen Bradley.   Thank you in advance. 
  19. Is there any way to establish a variable as min/max value of a gauge on sysmac studio?
  20. I am using an Omron NJ controller and a Cognex Dataman 260 bar-code scanner.   At this point I can trigger the scanner and receive data from the scanner via ethernet/ip. My issue is in converting the response from the scanner to something human readable. The bar-code I scanned reads "872-3GSq".  The results of the scan are located in the variable Dataman_to_NJ[8]-[11]. At some point I know I need to use the SWAP function but I believe my lack of data type knowledge in this system is hindering me. How can I convert the value in Dataman_to_NJ[8] to the string "87"? Any assistance would be appreciated.  
  21. Hello everyone, I am working with a NB10W HMI connected to a PLC NJ by Ethernet protocol, I would like to know where to start regarding the sending of data from the PLC to the HMI. I have a 50x15 array and should show all those values in the HMI for read / write. How to proceed? I started working with PLC for a while. I'm using Sysmac Studio to programm the PLC and NB designer to the HMI.
  22. HMI VIEWER APP

    Hi recently I have seen Omron Europe and I have download an app for Android and iOS, that app can allow you to remote view HMI types NB,NS and NA9last from Omron). The reason of all of this, is if some body have try this app and also if communication and remote view was creat it. I have try all my best but still can't make it, if some body did it, could you please share it?. Thanks, Jose
  23. ENCODER IN MICROLOGIX 1400

    Dear Sir, Kindly Tell me how to use encoder with micrologix 1400. Thanks
  24. Hello Everyone, I am struggling with interfacing Incremental encoder with FX5U PLC, Does anyone have parameter setting and sample program for same. i am unable to fetch counts...   Encoder: 500ppr, 24V line drive, A-B phase,  PFA datasheet Hollow Shaft encoder.pdf
  25. Hello Everyone, I am struggling with interfacing Incremental encoder with FX5U PLC, Does anyone have parameter setting and sample program for same.   Encoder: 500ppr, 24V line drive, A-B phase,