Search the Community

Showing results for tags 'sysmac studio encoder'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Found 207 results

  1. There appear to be bugs with the EditVariable method that are not documented anywhere.  Firstly code below will not work and at same time Sysmac will not report this as an error where the variable to be edited is declared inside a subroutine. The program will compile fine but keypad will not appear when the sub is executed. However, if the variable is declared in the Global Variables table, the keypad will appear and the variable can be edited. I have also tried declaring the variable as Public out side of the subroutine and keypad still fails to appear. Sub EditValue     Dim Index As UShort     EditVariable("Index") End Sub Second issue is that EditVariable will not work if the variable to be edited is an array using variable as the index into the array. For example EditVariable("myArray(Index)") will not work whereas EditVariable("myArray(1)") will work. The above issue also appears when using a DataEdit object and trying to use an array with a variable as the index as the variable of the data edit object. Stupid thing about this is that MinimumValue and MaximumValue fields in the same DataEdit object will take an array with a variable as the index. Has anyone found a way around these problems?
  2. Hello! I have been working with a Factory Talk Studio V8.0 and my computer was crashed, "blue screen". After this, I can not open my panel project anymore, I only get information Failed to open factory talk private directory for the application. How to save my project?  
  3. Hello, Does anyone have a pdf version of the user manual? Thanks...
  4. Hey, I am fairly new to the NA screen so I didn't get time to research much but for some bizarre reason, if my alarm message is long instead of going to the next line it just continues. Is there a specific way of creating a multiline alarm. Any suggestion or if you have inside for a crash course on NA screen would be helpful. Thanks
  5. Sysmac HMI

    I am fresh out of school and new to automation programming. My employer has asked me to come up with a way to show through the HMI the position of an encoder. Are there any HMI tools that do this in sysmac? Again I have limited experience.    Thanks
  6. Hello:   I need to link  a lot of variables, pointing to CIO address, like "AT" field, but is a large volume of tags to create, so, I have a chance to assign a memory location to a variable in ST like:  my_tag := %100;  (trying to assign tag address to CIO 100) ? If not, there is a method to import tags from a Excel ?   Thanks.    
  7. Hello:   Im new on this foroum, and Im glad to become a member, and new on the Sysmac studio too . I have the following ST program line: My_array[0]:= y[0];   Where My_array, is a array of bool, and y array too. After load and all, on monitoring return a "!" Sign, and trying to change value retuns "Failed to write variable, check if variable or memory area are alloed to write". I tried to move both arrays from global to local, and change adressing in "AT" field, witout changes. Any help will be wellcome. Thanks in advance Dante  
  8. C-mode hostlink library for NJ/NX1P or CP1L

    Anyone knows if there is a C-mode hostlink library for NJ/NX ? Also, a C-mode hostlink library for CP1L could be helpful, to translate such a library to work with NX1P is probaly less work whan writing a new library.  Maybe Omron France has developed such a library? - they seem very active..   Background: Looking into writing a programmatic c-mode hostlink master for NX1P12, this is for connecting the handheld NSH5 HMI to the NX1P12 via RS232C using a CIF01. I have the hardware set up, and an machine built, expected some compatibility efforts by Omron.... but the NSH5 seems to talk C-mode hostlink, and the CIF01 only seems to support the FINS version hostlink.   On the NJ you can of course add an SCU module, thus not need a library.  But working with NX1 ( due to limited space available ), you are dependet on available CIF-modules which do not support C-mode hostlink.  
  9. How to watch the value in decimal directly in the ladder page ?  Default Hexadecimal The only way I can do it is in Watch Tab and I/O map per example Thank you
  10. i am new in indusoft web studio. i am facing a problem about communication of indusoft with plc.   i am communicating with plc through fx2n-422-bd card.   can some one guide me the steps of communication.  he/she will be a life saver.. as i am  in a deep trouble
  11. Omron Servo Encoder

    Hello All  I am new to PLC programming , i have a question regarding omron PLC and High speed counters. I am using Cp1H-XA model plc . I connected HSC port 0 with a encoder and i was able to get the speed of the encoder using PRV2 instruction. Now i am trying to connect the second  encoder from the servo motor that i am using to HSC port 1. I am getting the PV signal using PRV instruction . Is there a way to calculate the speed of the servo encoder connected the HSC port 1 using PRV command , since i can't use the PRV2 command for the servo encoder .   Thanks in advance .
  12. Hi. I am new to Allen Bradley PLCs and bumped into the following issue, that I cannot find any solution to. When trying to add a module to the I/O configuration I get the attached error, error code 80131940. This prevents me from adding any hardware configurations in Logix Designer. I have tried to reinstall Logix Designer and uninstall all AOPs. I am running V30.00.00 on a Windows 7 Enterprise SP1 OS. Your feedback is very much appreciated.
  13. How to set Homing parameter slot with _sHOMING_REF data. Please suggest me to setting MC_HomeWithParameter instruction or show example for using MC_HomeWithParameter instruction. Thank a lot
  14. Hi, is it possible to communicate between the Sysmac studio simulator and the CX-Programmer simulator? I want to test the exchange of data between a NX1P2 and a CJ2H, but I don't have the controllers with me. Thanks and have a great day!
  15. Average motor speed

    Hi Guys!   There is a task. I have a motor, and I can monitoring the actual speed. The question is how can I to determine the average speed, if I know just the actual speed. If the speed is zero, it must be ignored. So I have to measure when the motor moves. Anybody have any idea? How can I solve this problem. RSLogix 5000.  Thank you.  
  16. Torque Control

    Hi, For my system I use the functions Mc_MoveAbsolte and Mc_TorqueControl. my problem is when i use absolute function after torque control for zero point. the servo turns the torque point control. For example: Target 1: 200 mm target 2: 150 mm Target 3: 240 mm ( Start point of torque) Taget 4: 330  mm (end of process) Target 5: 0 mm After "end of process" the servo turns  to "start point of torque" Can you help me please    
  17. Hello,  I have a NX1P2 controller that would control a DC motor, currently it's open loop. I can control the speed and the direction. I'd like to add an encoder to it. The motor I have is from MidWest motion S27 series and they told me I can use their encoder but the problem is it output TTL My question is, how do I read this encoder output in the PLC since it's TTL?  Second, is there a high speed counter in Sysmac Studio for the PLC I have?  Thank you everyone in advance   
  18. My apologies for being a newbie on this, but could someone save me on this... I have a Viper 650 and an eMB-60R controller which I want to control by ePLC connection using an NJ501-1300 PLC unit, SYSMAC Studio with EIP Adept Library for Robot... All are starting up well, and I connect all components to a switch hub...  But following the ePLC guidelines, the IP Address showing on the controller is 172.16.132.111 I change the IPV4 IP Address on the PC settings to 172.16.132.10 and the subnet to 255.255.0.0 but the Adept IP Address Setting Tool on SYSMAC doesn't detect the Robot IP Address, also i tried ipconfig on command prompt which shows a different IP Address IPV4 169.254.197.75 and subnet of 255.255.0.0, I changed the previous setting on the PC setting to 169.254.197.10 with the same subnet. But still PC doesn't recognize. I tried both configurations if ACE Software can detect it but the same ACE can not detect it also... Appreciate any thoughts on what's wrong in my configurations. Thank you.
  19. Hi all, I uploaded SW from working PLC NJ301 1100 v 1.9. Uploading worked, but when I tried to open program, all rungs were empty (see picture). Does anyone know the cause?
  20. The hyphens (dashes) in Sysmac Studio have been replaced by ASCII "boxes."  Anyone having this problem?  See attached screenshot. Sysmac Studio 1.220.80, Windows 7
  21. Hello, I need to Synchronize two 4kW motors connected to their own individual AltiVar VSDs. To put it simply the two motors are pulling cables on a pulley and when loaded the motor's slip and the speed varies. I have an Omron CP1L-EM PLC and 2x Omron Rotary Encoders ( E6C2-CWZ5B encoders - 360 PPR) - connected to each motor,   What is the best way to read the pulses from the two rotary encoders then convert to RPM? 1) Using  PRV or PRV2(883) instruction,  - this would be the best option as it would convert the value to RPM - however, can I use this instruction on both Counter 0 & Counter 1? 2) Or read the raw value from  Counter 0:  A270 (connected to motor one's encoder) Counter 1: A272 (connected to motor two's encoder) Convert the pulses to RPM - then compare and adjust? 3) Or using CTBL. - is this a useful instruction for this application?   Once I get the RPM speed from each motor - I can then do a compare instruction - see if there is a mismatch and if so send a scaled analogue output to the VSDs to correct the speed if required. (10-50Hz) What would be your recommendations? any help would be most helpful. Thank you.
  22. Homing servo motors

    Hello everybody, I have a question about homing servo motors. I have a project with new servos from Omron and I would like to know what is the best way to do homing for the servos and how often. Before when we have servos with encoders I was making special homing sequence and was calling by some event. I heard that new servos from Omron pretty smart and remember own position without batteries. So with this 'new generation' of servos what is the key to keep machine robust, easy for motor replacement without useless programming stuff. Regards, Scotty
  23. I currently have certain amount of Recipe data located in form of Excel file on to a PC with static IP address. Is there a way to get that data inside the Nj501 without using an SQL server as I currently have NJ501-1300 which doesn't support SQL. I am okay to send data to the SD card I currently have on NJ PLC as it is easy to get data from SD card to the NJ501.  If there is any example code or a link that helps me create i would be helpful. Thanks in advance. FYI: I am currently using NB10 HMI with NJ PLC.
  24. I am trying to connect a Delta ASDA-A2 Servo internal motor encoder to a Delta DVP28SV high speed counter input.  I was successful in connecting the servo to the plc on position mode with an external encoder connected to PLC high speed counter.  Currently having trouble in finding the correct wiring between the servo drive and the plc to count the pulses from the internal motor encoder.  Attached are some figures from the servo drive manual. OA --> X0 is obvious, tried s/s to GND, COM-, VCC and VDD... no result. Any suggestion would be highly appreciated.  
  25. Any new tags I add in studio 5000 the HMI project shortcut cannot locate the tags, it says unresolved route to processor. It's the same shortcut all of the other tags are using. Please help.