Search the Community

Showing results for tags 'sysmac studio uploading'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Found 156 results

  1. Our IT department is on their annual crack down on administrator access and 'unauthorized' software. This year they are demanding to know why I need to run my laptop with administrator access. Besides the Simulator, what other functions will I not be able to use without administrator access? 
  2. Hi guys, I just starting to use Sysmac Studio. Its a bit confusing as I am currently used to CJ series PLC. Usually, we can use P_1sec, P_0_2s and so on to create a simple clock pulse timer function. However, I couldn't find the command or FB to do that in Sysmac Studio. Anybody could explain on how to do that in Sysmac? Thanks 
  3. Dear All ;  As Derstagram Akademi (Turkish) , I created a course for udemy about sysmac studio then I changed my mind and I'm uploading these videos to youtube channel. If you search this channel name  Derstagram or Derstagram Akademi on youtube , you can find a channel and you can reach a 53(19 uploaded) videos as free.   Have a good work. I hope this education series can help you a lot. Br Mustafa
  4. Ok so I recently got the Factory i/o software to practice plc programming more in depth.  I got it working easily enough with the siemens TIA software and I am now trying to get it to work with the Omron Sysmac Studio software.  I am not sure if it is possible or not.  I have access to the hardware but I was really hoping to use the simulation like I can in TIA.  Any insight would be appreciated on the subject.
  5. Simulator Platform

    Hi. I am new with omron and i am looking for a suitable platform to simulate sysmac studio.  For example Siemens PLC have a special interphase whereby its simulator can connect with Factory IO software  so the simulation can be done using 3D like objects.  is there any open source (if possible ) platform that can connect with sysmac studio simulator to help with the 3d simulation?  Any suggestions? 
  6. Hi:         I am planning to use NX with Encoder Card  couple with Omron Rotary Encoder for measuring product length. ( GX-EC0211 /EC0241) or may be (NX-EC0112, I read there is proble with this card , here https://forums.mrplc.com/index.php?/topic/34896-problem-pulse-reading-with-fast-counter-card-in-nx2/ ), but whatever it is I need to know is there any specific Instruction in Sysmac Studio that is tailored for Fast Counter or Encoder (something Like PRV in CX Programmer or special function in CJ-CT021 where start/stop counter and changeable preset counter are available).  The Length measurement is straight forward and is only a small part of the overall program.  Basically is Start ---> measure to length----> Cut --->Repeat again.  I read through the Instruction Reference Manual and I am unable to find one.   Anyone have any idea or any sample program (Sysmac Studio only ) that I can refer to ?    Thanks     
  7. Sysmac Studio 1.31.0.10 crash sometimes, often when copying things like color palettes, string in the Output Window, etc. It's always with NA not NX. I have a corrupted project because Sysmac Studio crash and save the project. NEVER use this file, restarts with the old file is better. The text fields does not appear on all objects on the HMI and it's never the same object each time your download to HMI! Check images below. Font is "No Value". Do you know how to resolve this problem?
  8. Humming Noise in Motor

    We are using NX1P2 Controller with servomotor compatible with servo drive R88D-1SN it produces noise during operation low noise at low speed and hig noise at high speed we have 2 more axis which doesn't produce any such type of noise.   It also produces vibration in the motor.
  9. I am trying to display the time from an Accumulation timer. Using a data display object I am able to see the time in the following format 00:00:00.0000000. Is there a way to format the time without the decimal seconds I just want to see 00:00:00 (hours:minutes:seconds)
  10. Hi there, I have a controller NX1P2-1140DT. I want to control a VFD with modbus serial communication. Can someone help me start from scratch ?
  11. NX1P2 Modbus RTU Code and Write Up. View File This code is designed to implement Modbus RTU on an NX1P2 Controller using the NX1W-CIF11, NX1W-CIF12 or NX-CIF105 module (mounted to controller or EtherCAT coupler).  Created by an Omron Engineer. Submitter Michael Walsh Submitted 05/22/20 Category Tutorials and Quickstarts
  12. Version 2.12

    98 downloads

    This code is designed to implement Modbus RTU on an NX1P2 Controller using the NX1W-CIF11, NX1W-CIF12 or NX-CIF105 module (mounted to controller or EtherCAT coupler).  Created by an Omron Engineer.
  13. As the title says, Studio 1.40 crashes if I try to run it in VMWare Workstation (version 14.1.8). I had to disable the "Accelerate 3D graphics" option in VMWare in order to install this upgrade, this has never been an issue before on earlier versions of Studio. I thought I could then re-enable it but this causes Studio to crash as soon as you start it up. I've not spent any time running it with 3D graphics disabled to know if it can run stable. Or if having it disabled causes problems with Studio or other software on my Omron VM. Has anyone else experienced this issue or have any insight?  
  14. Hello all,   My coworker is running into an issue where his version of Sysmac Studio has been updated, but this is causing a version mismatch from an existing project.  He has called Omron, and they are saying that there's no way to downgrade the OS.    Project operating system version = 7.4.0 Device Operating System version =  7.3.0   So the OS on the NA5 would need to be upgraded to match the version of Sysmac.  Does anyone have any suggestions to revert the automatic upgrade that has occurred? Any help would be appreciated!
  15. Has anyone had issues using the Auto-Updater and Administrative Rights?  I am running Windows 10 Pro, 64Bit.  I need to update Sysmac Studio from 1.31 to 1.4.....when I run Auto Updater (as Administrator) I always get the error "Log on the PC as a user who has an administrative right when install" and it never makes it past the first module of the CX-One Update.  I even gave the issue over to my IT guy and he has absolute full rights to every nook and cranny on my laptop. I was told that I needed to allow the CX-One to updates as well since they share some of the same components. My IT guy even tried to do the "download" and install individual modules of the update and that still didn't work. Currently waiting on callback from OMRON Tech Support, thought I'd pose the question here as well....thanks.
  16. Friends kindly help me I need to create ton and counter macro function in factorytalk view studio 
  17. Setting the NB Clock based on the NJ NX Clock View File This document details the updating of the clock on the NB based on the clock in a Sysmac Controller. Submitter Michael Walsh Submitted 05/14/20 Category Tutorials and Quickstarts
  18. Version 1.0.0

    15 downloads

    This document details the updating of the clock on the NB based on the clock in a Sysmac Controller.
  19. Axis Attribute Error

    Hello All, First time working with PLC. Get the hang of it from stuff I researched. Having an issue with an axis setup for a servo motor.  When I try to do an auto tune it gives me an error that axis is not configured.  Source: Config Fault    Condition: MotorDeviceCode- INvalid attribute      ACtion: Immediate Stop Fault Entry: Type 8, code 9 subcode: 1314 stopaction: 4 Statechange: 3   I was wondering what am I doing wrong? Any leads or source information I can use to solve this. 
  20. MPG WITH OMRON NX CONTROLLER

    How we can connect MPG with omron NX SERIES CONTROLLER. PLEASE HEALP 
  21. NA Data History Program

    Does anyone have any idea how I can create a Data History though the NA screen. I know I can do a Data Log with a Data Set then use a Trend Graph but, I want to create the "Table Like" Data History found in the Omron NB screen. I use data histories for a UI to an operator to review previous Cycle Times, Poka Yoke values, and Temperatures monitoring with a time stamp as to when the data was recorded. Any ideas?  I am using a NX102-9020 NA5 Screen
  22. Hi, I'm fairly new to motion applications and I have an interesting (to me) problem to solve. I'm using Kinetix 5700 with MPL motors to drive a pick&place carousel and a conveyor belt. I have a virtual master that driver the carousel in 1:10 ratio. The virtual master also drives the conveyor belt, the ratio is given by the carousel diameter and the conveyor driving cylinder diameter +  2x the belt thickness. And I'm using MAJ to drive the master and the MAG instruction to drive the carousel and the conveyor. This all works well. BUT: the carousel does not pick the product in the same place every time. That creates irregular gaps, or pitch, between the product on the conveyor which causes some issues down the line. Is there a way how to superimpose a value to the conveyor axis to ensure the pitch is regular at all times. Something like the ADDAX instruction it Trio motion controller for example? I'd want to have a sensor that detects the edge of the product and compares he encoder value to an expected value and slows downs or speeds up the conveyor accordingly. Thanks a milion.
  23. AVE instruction Error

    A little background information here, I am trying to create a moving average so I accomplished it with the code (imaged attached) The problem i am having is the AVE instruction error bit goes true. it leaved me with a result of 1.#QAN  I did some googling and it said this is typically done when dividing by zero?? so i added a NEQ to 0 prior to loading the array. then it happened again. so i put the error bit in front of the FFL so it will stop loading the array when i get the error bit so i can see what values are in the array when it errors out. Has anyone else had this issue and what could you do to resolve it? I haven't had any luck find something that points me in the right direction. Thanks in advance for your help.
  24. Hello there, I am using a Kinetix 5700 drives to control bunch of axis. HW used : 5069-L320ERMS2 GurdsLogix, 2198-S086-ERS4 Servo Drive with MPM-B2152M-M motor and the 843ES-SIP12BA6 safety encoder. All is working fine except I can't figure out how to dynamically change an axis velocity  controlled by a MAG instruction. I have a virtual master axis controlling the velocity and each physical axis is controlled by a MAG instruction with a gear ratio. In my safety program I have SFX and SLS function block used to determine the safe speed limit. The  SLSLimit output of the SLS function block is linked to a SS1 Request of my servo drive. This causes the axis to stop when safe speed limit acceded.  What I'd like to be able to do is to dynamically change velocity (limit it to safe speed if SLS instruction is active) of each axis without having to change the gearing ratios and thus avoid the SS1 safe stop action.  I know how to do that using JOG or MOVE but is it even possible to do that using the MAG instruction? Regards Martin
  25. Hello, In my ladder program I have 7 different arrays (containing REAL values) all members of a structure and I wish to extract certain values from the arrays and put them on another structure consisting of REAL values (not arrays). Which is the best way to do that ? I tried AryMove command but I get an error "Conversion from REAL to ANY_ELEMENTARY[], ENUM[], STRUCT[] is impossible. To get a better understanding of my structures and arrays here is an example: Struct wheel_data Global variable SWheel of wheel_data rad[1...10] of real, vary[1...10] of real, varx[1...10] of real struct. 2 wheel Global variable Wheel1, .... , wheel10 of wheel rad REAL, vary REAL, varx REAL what I wish to do is to copy Swheel.rad[1]  to wheel1.rad,  Swheel.vary[1] to wheel1.vary, Swheel.varx[1] to wheel1.varx 2nd structure Swheel.rad[2]  to wheel2.rad,  Swheel.vary[2] to wheel2.vary, Swheel.varx[2] to wheel2.varx until I fill all 10 wheel structure instances with values Thanks in advance.