Search the Community

Showing results for tags 'somachine motion'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Found 53 results

  1. Hi everyone, I have an annoying fault on my Kinetix 5700 drive: M01-Safety Feedback. I know this fault is generated by  the SFX instruction in my Safety program that sets tag: "Axis.SFXFault" to 1. The problem is that the instruction is NOT in Fault (Fault code 1 = no fault). This error occurred after Safety encoder 843ES lost it's IP address. I used Bootp to set it gain. And reset the SFX instruction. I can see the encoder in studio 5000 rev 32.12 running and ok.  Does anyone encountered this problem? How can I clear the fault?   Thanks
  2. This is hard work! I've installed the CODESYS OPC Server V3 in the hope of using it to communicate with my Schneider PacDrive LMC. Apparently the PLC doesn't support OPC tag browsing so I need to export the symbols from the SoMachine Motion project file in a format that the OPC server can use. I've got the Symbol Configuration panel open and can see the symbol tree. What do I do next?
  3. MDS instruction would not complete

    Hany any you of guys dealt with MDS instruction not completing and being stuck on .EN bit but the motor itself just stopped running out of nowhere? I did read the tech note on this on Rockwell's website. Am mostly wondering if any of you have dealt with this and what you did to fix this.
  4. Hello everyone, I have a Kinetix 6000 CIP drive (unwind) and I need to control its speed by a PID controller. I have everything working except the MCD instruction doesn't pick up on the PID output value change. It changes the JOG speed, which I use to control the unwind, if I set the speed manually, which is slow. The PID changes the speed almost continuously. Any suggestions are welcome. This is how I'm attempting to control the speed: A1_r_JogSpeed = PID output value   Thank you    
  5. Hello! I am new at PLC programming. I am using TM221CE16R PLC with TM3AI8 analog input module and SoMachine Basic v1.6. I am trying to scale analog input value. I am using 4-20 mA pressure sensor. I managed my wiring so that I get raw values in SoMachine Basic. But I don't know how to scale these values to usable values. My sensor works in range 0 - 16 bar. What is best way to get values? Is it PID function block or multioperand function block using equations to get range 0 - 16? I will appreciate your help.   Thanks in advance!
  6. Hi all, I am studying how to control servo with PLC Mitsubishi Q-series. When I click Servo_parameter in Simple motion module setting tool, this annoucement appears.  Does anyone know why it appears? I tried reinstalling MR-configurator 2 but it didn't help. Please give me some advices. Thank you all!
  7. Hi Every one, I have two 2198-P070 bus power supplies for that I’m using for four Kinetix drives, 2 drives per power supply, all controlled by one processor (5069-L350ERMS2). I have an enable contactor setup for each power supply for each set of drives. I have them configured as DC bus groups 1 and 2 respectively. I had the first set of drives working, setup inside the motion group, with no issues. When I added the second power supply and drives. I found that when I added them to the motion group I couldn’t get the enable contactor to close for the first set of drives. I f I took them out of the motion group and made them ungrouped then the first contactor would close but then I couldn’t get the contactor on the second set to close. Do you have any thoughts as to what I might be missing to get these to work? See the screen shots for more detail. Let me know what you think.  Also, I have heard that only one motion group is allowed per PLC, but my question is : Can I use  sevral axes and Power units in the same motion group? 
  8. I am desperately trying to understand the OMRON way of programming (28 yr. AB programmer) when it comes to Motion Control.  I am pouring over example programs and what I can understand in Omron manuals.....  What I cannot find is where you get all the bit level information from for individual axis....  For example, just a simple bit signaling a Servo Fault; I have a program that I have been studying and there is a bit with the variable MC_NailPunch_Station.MFaultLvl.Active, it obviously comes from the Axis "MC_NailPunch_Station", but I cannot find the reset of that variable anywhere in the program, in any setup....nothing. Is there a list somewhere of things like this I can use in my program for status bits etc.?   Thanks,
  9. Hello! I am new at programing PLCs. I am using TM241CE24R PLC with TM3AI4 analog input module. I can successfully read temperature from 4-20 mA sensor. I want to communicate with my PC (SCADA) via Modbus TCP. For testing purposes I am using CAS Modbus Scanner. I can read digital inputs, coils and holding registers successfully. Problem is that I can't read analog inputs (#300001 etc.).  I have nothing defined in GVL list. Is this causing problem? I also don't have any Modbus TCP Slave device in Ethernet_1. But how can be all the other registers read successfully?  Please take a look at screenshots below. Also check Error message from CAS Modbus Scanner. Where is problem? Please help. Thanks in advance!
  10. Hi guys, I have an M221 and trying to read process data from a HACH controller via Modbus 485. In the Read_Var function block I need to configure ObjType, FirstObj, Quantity and IndexData. Slave ID is 3 and I am using SL2. So, say if I wanted to read to following registers, Register #40001, Data Type Integer, Length 1, Description- Sensor Measure Register #40005, Data Type Float, Length 2, Description - Sensor Temp Register #40007, Data Type String, Length 6, Description - Sensor Name what do I put into the Read_Var function ? I am completely new to this and it's just not clear to me. Thanks John   
  11. Hi, I am learning on Schneider PLC  Programming. May I know is the Schneider PLC Programming have a same function of "Block move"  in Mitsubishi PLC which can move a few number of address value to another address in once time. What is the code of it?Example,  I wish to move %MW1 (Int) until %MW10 (Int) to %MW100 (Int) until %MW110 (Int). Is there any code can done it in once? I am using Schneider PLC TM241 model with Somachine V4.3 Programming Software.  @Wasan, Hi, Do you familiar with Schneider PLC Programming?     
  12. Hi all. I have a Kinetix 350 and an AB TLY servo motor. I'm using the drive's STO function. AC power is supplied into the drive, passing through an "M1" contactor. It makes sense to m e to keep that contactor open, preventing AC power to the drive, until the drive is fully awake.  Is that what you guys do? Someone suggested to me in another forum ( http://www.plctalk.net/qanda/showthread.php?t=121021&highlight=drive+awake ) that there is no reason not to supply power to the drive right away because the STO function is inhibiting power to the motor anyway. 
  13. Hello I have a M251, running a webvisu. I have created a program to create a test report to a *csv file and store it on sd card. What I want to do next is to allow the user to download the * csv from the webvisu and not via ftp client like Filezilla. On codesys forums I see there are file up and download options for buttons (click behaviour) but they are not available in Somachine 4.3. One option I am considering is using the TCP server and steam the file manually from a button click. I dont want a ftp client as now the customer will then needsoftware on his pc, this plc is a portable test system and will be controlled by many different pc's. Is anyone aware of a simpler way to do this?
  14. Bonjour, Hello, I use a l33erm automaton and a Kinetix servo motor . This servo motor drives an engine with a chain moving in steps of 100 millimetres (there are 15 steps on the chain ) At each top of a cell this motor advances by 100 millimetre. in reality it advances from about 0 to about 100. Sometimes it is 100,002 times to 99,997 (this is important further) and when I give it a top it goes back to about 100 (100,003 times to 99,996) And so on and so forth up to no problem, I use a MAM with an absolute type of movement. It works.     However, this does not work any more after a rearmament following an emergency shutdown. if it is a 100,002 no problem at the next top the chain advances one step But when the engine is shut down at 99,997 and I give it the order to go to 100 it advances only by 0,003.  This only happens after an emergency stop (or door opening). Thank you for the help you can give me excuse my English this is a machine translation Un séjour sans faille
  15. Hello,, I have motion controller A series A172SHCPUN,, I have written the program ladder into the CPU, but I can't write the motion program.. i dont have the program to open file the program motion and I want to ask if I have the software SW3RNC-GSVE, my os computer is window XP, Can it be installed? and is the cable transfer used the same as the ladder transfer program cable (SC09)?
  16. Hello, I have an interesting problem that no one in our company can really answer for me.  We are using Drive Logix with a powerflex 700S phase 2 drive and controlling a machine that rotates 360 degrees, sits for a moment, then return back to zero degrees.  We are using the MAM instruction to tell the drive to run the motor to its desired degree.  The problem we seem to face, is when they change jobs, the weight changes and we have to adjust speeds in order to get the machine to rotate back up to 360 degrees.  Otherwise, the motor stops short.  It usually never faults or alarms, it just stops short.  For example, they might run it and it will stop at 240 degrees or 315 degrees rather than the 360.  My question is, why doesn't the drive continue to push the motor to 360 degrees?  Why wouldn't the drive fault out on something like over current?  It seems that it just stalls and stops.  Sometimes, the machine will be running great, but on occasion (1 or 2 times a shift), the machine will stop short again.  I am curious what causes this and how I might be able to fix this to force the drive to continue to try and get to that desired degree. Thank you for any help or input!
  17. hello everyone,,,, I want to running the motor in 100 rpm but how to setting electronic gear to control speed in servo motor HG-SR502,, does anyone know how?
  18. Pls help set up QD75P4N

    Good day sirs,  i am a newbie at this motion controller setting. I would kindly like to ask for an assistance from all of you. i copied all the necessary data that i have on this project. I installed the wiring correctly i am able to Jog the servo motor. But when i try to Jog the motor Using GXWorks 2 i wasn't able to do so because its not showing any movement on the Mr J4 and the motor it self. is there any settings that i should have change? thank you for the time if you will need any information i am willing to give it thank you   I have also attached the GXworks program and the servo conifiguration   Please help me thank you project 1.gxw Servo 1.mrc2
  19. From PM this morning

    Fairly new programmer doing first analog section in project at new job. Im using NCF motion with parameter for torque control to send the torque values  a+8 (leftmost word) and a+9 (right most word) to CX programmer. From there is where I get confused will I just simply be moving both cio 108 and 109 to to a D register?? or will I have to combine the a+8 and a+9 to make a Dword??? and then taking that value to HMI broken line graph. sorry again for creeping in your inbox but ive been looking online for 6 hours. would greatly appreciate any help
  20. Hi, I am trying to do a merge move on 1S Servo. The condition are as follows: Task: Move 2 in(absolute value) and then Move back to 1 in (absolute value). I have to do this move 10 times in a row.  The application is material leveling after dumping in the mold. The only question i have is if I use just MC_MoveAbsolute command, the only buffer mode for transition available is velocity. Is there a way i can do it with position. I dont want to stop when I can go from 1 to 2 and 2 to 1 again and again. Its time consuming. But rather a nice oscillation motion without stopping to mimic leveling. Can anybody please help me out with this problem.   Thanks
  21. Hi,  I'm new to TwinCAT 2 and i'm upgrading a long time design (hence the TwinCAT 2 reference), to read a more sensitive torque signal.  I'm using a Beckhoff CX1030 as my PLC Controller.  I needed to add 'homing' to my motor sequence and confirmed with Maxon, im using the function blocks correctly and in the correct sequence to establish my 'absolute zero'/'home' position.  The motor has an output to write to:  ControlWord, which tells the motor that the position it is sitting in is '0.'  My program compiles, it runs, it writes each function block, but it's not seeming to get back to the test run opMode, even though i tell it to and the function block performs the 'Write' function.  it's stuck at zero and not reading an analog input signal from my torque sensor.  so im getting an artificial torque reading through every test.   i think this is related to my tare motion.  I start the program, home the motor, get into profile velocity mode, tare my sensor, enter profile position mode, go back to position 0, then back to profile velocity mode, run a test, sample data, go back to 'home' or '0.'  I wonder 1st, is my variable not linked properly through the system manager?  2nd, i set a boolean variable to set the 4th bit to 1 in my control word write (setting the 4th bit high will set my current position to absolute zero), but did i not connect the program to the main sequence properly?  looking to read a valid signal again and see that my motor moves back to 'home' each time.  Do i not need to home the motor after the tare, since the tare nulls out the torque value after the tare? after this i need to program my sample period, instead of it being fixed, as it is currently written and then use my home position as my trigger to start sampling.... Beckhoff applications department is overloaded, currently and can't help and this is all beyond the knowledge of the general support line.  I've gotten fairly far, on my own, but of course, the project is under a time crunch.   Does anyone know twincat well enough to help guide me?
  22. RS logix 5000 motion control

    Hi Guys! I have a problem with Motion axis move (MAM) command. There is an Allen bradley servo motor what is working well. But I need to add a new program section, wich is in  a specified moment, the axis should move a certain distance. I think I need to use the mam command, just I dont know how can I configure the motion control part. I need to make a new tag ? or what ? I need to use a user define ? PLS help me.   
  23. This isn't urgent but a TIME value is failing a comparison test for me. t_delay : TIME; // Declaration ----- IF t_delay <= 0 THEN     t_delay := T#3S END IF If I modify the variable value to T#2S the IF sets it back to T#3S. Internally the TIME variables are integer. Why would a compare not work as I intend? Many thanks.
  24. hey, I'm making a program to controlle mutliple machines. But the problem is that i'm working on 2 plcs to controll it all, but there are some %MW that i need in both PLCs. Is there a way to connect the PLCs so they share these %MWs to both PLCs know what value is in it?
  25. Hi Everyone, I just finished my first project and I don't know how to make comments next to my "actions". I'm using SFC. I'm use to writing C code so this is so different!