Search the Community

Showing results for tags 'simulation in somachine lmc058 with ethernet port'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Found 279 results

  1. Hello All, I would like to control Powerflex 525 drive with Omron NJ301-1200 PLC via Ethernet/IP (Set speed, start, stop). I've gotten until the part where I downloaded the necessary .eds files of the drive and imported into my Sysmac studio. However, I'm stuck after this point while assigning target variables and Originator variables and eventually setting speed and controlling the vfd. I've attached images for your reference.
  2. I'm trying to understand the basics of using a serial to ethernet converter such as this Comtrol DM-EIP-2101, with Studio5000 code. Basically I have a weighing machine that only outputs data via RS-232 and I need to send that data to a PC that will process it through a Studio5000 program and have the data displayed on an HMI using FTview SE. Is it as simple as just connecting the serial and ethernet to the converter and it does all the work? Obviously checking ip addresses and firmware will need to be verified. The main thing I am unsure of is the process of passing the individual data packets from the machine to the Logix code on the PC,  things like what the weight of the item was, was it over weight or under, etc....  Would there be an AOI or tags built into the software for a machine like this Checkweigher? I've worked with much smaller items like Cognex Dataman cameras and I know you can just use their AOI that allows you to simply call a tag if you want to display information like if a scanned barcode was correct or whatever. If anyone has done something similar I'd appreciate any guidance. It can be difficult getting the information from the manufactures so I'm looking for answers anywhere I can. EDIT: I guess I should also clarify that only using one or the other (serial or E/IP) is not an option. It will be a serial connection from the Weighing machine to the converter and then Ethernet to the PC.
  3. Dear forum, I am facing a trouble at the moment and hoping somebody can assist. I have one HMI software, GT Designer 3, HMI: GS2107 and/or GT2107, the software works so far so fine. The software is used on several products, I dont want to maintain two or even more software versions. Two serial devices are connect: 1x MODBUS RS-485 1x MODBUS RS-232. The data transfer is done via DDT, no direct calls. The DDT transfer the MODBUS address to the internal GD-Registers. The GD-Registers are used within the HMI. My trouble is that in some cases, there is no RS-232 device connected. This creates time outs, slows down the HMI and its just not nice looking (I have a warning implemented "WARNING NO CONNECTION TO SERIAL DEVICE RS-232". Is there a way, that I can select (retained) that the RS-232 is connected / or not? Once the software is configured "NO RS-232 CONNECTED" I can handle the rest of the software.   Anybody an idea how to do this? Many thanks.
  4. Hey, does anyone know why the simulation mode is on? how to change it? (LED SIM )
  5. I'm trying to set up an Ethernet/IP communication with a CIP block between a Micro850 and a SMC EX600-sen3 pneumatic Module. I can read the inputs of the module with the configuration below, but I CANT write to SET or RESET the digital outputs. There are NO errors showing communications issues in the CIP Generic Block I am using... I read that for some reason, it seems that there are problems with writing thru Ethernet/IP protocol between Micro family and other devices not from Rockwell... Does anyone know if there is a way to make it work? Configuration that is working to READ: CIP Service Code:     14 CIP Class ID:         4 CIP Instance ID:     100 CIP Attribute:         3 CIP Member ID:         0 Configuration that is NOT working to WRITE: CIP Service Code:     16 CIP Class ID:         4 CIP Instance ID:     150 CIP Attribute:         3 CIP Member ID:         0
  6. Hmi modbus TCP/IP device communication

    Hi all; I have Delta DOP110 IS hmi and i have a modbus tcp device. I want to communicate hmi and device with modbus tcp/ip but i didnt understand device's register address. For example, input bytes 0,1 analogue control word, What is the register address? 40.000 or 40.001 can you help me ?  
  7. hello, Somebody have suggest how need read data from slave using modbus RTU. I am using M241 PLC and read_var function. The picture you can see my PLC program. The data of slave is placed 3394 address. Then I try to read, always "READ_VAR" function get "CommError" which number is 254 that means "The detected operation error contains protocol- specific code"  and "OpenError" which number is 3 that means I don't know. How need read from slave data, which modbuss adress is 3394?
  8. I have a bit of an issue with communication between GOT1000 HMI (I think the exact model is GOT1675V) and Q03UDE PLC over Ethernet. The GOT is set to 192.168.1.4 and PLC is set to 192.168.1.2 but I get the error "Communication Error. Refer to System Alarm in Utility Menu". Now how do I access the utility menu? I have tried to tap and hold on the upper corners of the HMI but nothing happens. I also can not switch between screens when I press buttons even though they are directly linked via screen #. Almost like the HMI froze up. Wonder if anyone had similar issue and what the solution might be. Thanks for your help.
  9. Hi! I would like to ask your help. I want to know more about the communcation systems what allen bradley use. Most important for me, is Ethernet IP communication, Controlnet communication, Sercos (servo) communication, maybe devicenet communication.  I know I can find some manulas on the web, but I thought I ask it here too, maybe you guys have some more documents which is contain more information. Every information is highly appreciated. Thank you very much guys.  
  10. Hi I am looking for a way to read and write data from PLC omron words, bits via FINS or EtherNet/IP protocol using python programming lang. Does anyone have any results in this? I really want to see your work, because all my attempts have failed. Thanks.
  11. I am new to automation systems and devices and I just want to know how to connect two HMI's (each one would control different things) to one PLC using Sysmac Studio and NB-Designer via Ethernet. The model of the PLC is NX1029020 and the HMI's are one NB10W-TW01B and an NB7W-TW01B. I searched for info about this topic online but I couldn't find anything that worked for me, I saw an article from OMRON where they connect two NB's to the CP series, but in my case, NB designer doesn't allow me to insert more than one HMI in the same project, I also found something similar on a youtube video that gave me an idea about how to connect multiple HMIs exporting the pks file and importing it to another HMI project but I still can´t figure out how to add both to my PLC. I would thank you a lot if you could help me with this because I know it's not a rare implementation, just I haven´t found the right way to do it. I also leave the links to the Omron article and the youtube video I found. https://www.myomron.com/index.php?action=kb&article=1554 https://www.youtube.com/watch?v=rXx5lut7G9I
  12. Hey all, I am having some issues with a Keyence IV2 camera which has Ethernet/IP functionality.  To summarize briefly, it has been configured and reading the data into my PLC (NJ501) into a structure data type.  The issue I'm having is that I cannot control this on a bit level for triggering the camera, etc.  I was reading that a Union type is the way to go, but unfortunately, I stopped getting data into the PLC when setting it up that way.  According to the configuration guide for Rockwell and setting it up in the Network Configurator, I needed to go with the SINT type.  When registering the device, the 8-bit option was necessary since the Input/Output sizes needed to match.  This was predetermined by the EDS file for the IV2. I am stumped as to how to get the data to read into the Union Type, and any suggestions would be greatly appreciated. Thanks, -K  
  13. Hello, I have to make communication using Ethernet between omron CP1H and siemens s7-1500 plc. I was thinking about Modbus TCP or Ethernet IP using theese adapters: Modbus TCP - CP1W-MODTCP61 Ethernet IP: CP1W-EIP61 But I am quite new in Omron, and I am looking for some exapmple codes, FB. Do you anyone have experience with that?   Thanks for all responses.
  14. Good day everyone, First post here so hopefully I'm not violating community guidelines in anyway. I've got a system that has some 50 odd Micrologix 1100 and 1400 in use and I'm currently working on setting up an auto timesync for all of them using just 1 of the PLCs that will be my master time PLC. So far I've put together the logic for all the message instructions with the corresponding IP of the slave devices. I'm running. Into an issue with not being able to terminate/break the message connection on a PLC that I have already synced. Is this even possible to do on the ML1100. Once I get to 16-17 messages DN it starts to ER and will not complete any further messages. What I have is a message instruction ladder with a timed trigger to activate a MSG and write the RTC data then time down and connect and write to the next and so on. When it triggers the message instruction of one PLC it also fires an OTE to trigger the BK of the previous message instruction. However it doesn't seem to be actually cutting the message connection and holds it persistent until a power cycle/download event.
  15. I want to establish Ethernet IP communication between the following PLC CPUs. Schneider Electric - BMEP582040 Honeywell - ControlEdge UOC CPU900-CP1. Where the Schneider must be master and Honeywell must ne adapter. Let me know if anyone have done this or can help me to do so.
  16. Salutations! So recently I'm very confused with my CX-Programmer. Everytime I tried to run the Simulator from CX-Programmer, I always got a notice that a certain program called KickEngine.exe is about to Run. I look up for this program and found it inside CX-Simulator folder, so I decide to run it anyway. The problem is the simulator always return the error : "The selected port does not exist". In other words I cannot run the simulation. I understand that the simulator uses ControllerLink comm. between CX-Programmer and CX-Simulator, so I tried to run those two separately and build the connection, but also to no avail. Even so, since CX-Programmer 9.0, I believe there is no need to run the programs separately. Before I had a similar problem where the simulator cannot be run, and the error code is "Failed to Start Ladder Engine". This was solved by removing whole Omron software using CX-Remover, then reinstalling again. However, it doesn't solve the current problem. If possible I don't want to resort to reinstalling the whole OS... T_T Anyone has suggestions or ideas? I had lookup on an older thread and tested the measure taken there, and didn't solve this. Thanks!  
  17. QCPU to 2x kyence iv2

    Hello all, we are using Q03UDECPU and via built-in ethernet port its connected to two IV2-G30. (through unmanaged switch) to establish connection we are using FB LQnUDEEthActive (hereinafter referred to as  FBLQ) two instances of FBLQ in two instaces of our FB which is responsible for creating messages that are then send via FBLQ Both keyence devices have different IPs, ports and connection number. Problem is that it is working flawlessly, except the time its not working :/ from time to time it simply doesnt trigger Keyence device. It looks so far like its independt of turning machine OFF/ON, also both keyence devices are used in different times (about 10-20seconds of difference) Im currently working on sime kind of internal diagnosis to see whats happening when its not working, but im just curious if there is something obvious we are missing? any help will be apreciated Thanks  
  18. Fatek PLC Communication Problem

    hy all. i am having an error while communicating with fatek plc. when i communicate it gives an error. " Com port open fail, plz check if this port is used by other programme when we online the PLC (Fatek/ WinProLadder). kindly Guide me   as it looks like port is already used by another program . and i dont know how to kill that program ..       
  19. Fatek Ethernet PLC Module online

    Dear All,  Anybody can help me in communication between Fatek 20MAR2 & CBEH2A. The jumpers setting are JP1 is on left two pins (No password protected) & JP3 is on right two pins (forced boot operation mode). The Ethernet cable i used is type b T568. Fatek Ethernet module config software detecting module successfully (shown in attached pic) but on online PLC via ethernet cable its showing connection failed.   please help   thanks in advance
  20. hello Every one,    I am using a CP1-L PLC and want to communicate to domino ax350i printer over TCP/IP socket programming. For socket programming, I used Omron Function Block CPU012_SendCommand.  I defined network ID and node address. However, I am getting 0502 error which means routing table is not set yes. So, how can I set routing table for both devices?. my PLC on 192.168.250.1 and Printer is on 192.168.250.123 node 7000.    Can any one suggest me best way to do.  Thank you   attached file is for what I did in setting and program for the communication.      
  21. Monitouch HMI slow screen

    Hi there! I'm having some issues with a FUJI MONITOUCH V9100iSD HMI that communicates with a CJ2 PLC via Ethernet. This HMI is a migration from a previous V810iSD model. The thing is that the previous model worked correctly, but when using the new one, the HMI seems to be pretty slow when switching screens, for example. All parameters are the same, and after reading Fuji's FAQ, I've run out of ideas. Have you faced the same problem? Thanks in advance!
  22. FX3U to FX3U via wifi

    Good day fellow PLC ninjas! I have a question/ concern which I would love your opinions on. We have 3 FX3U PLC’s+ENET cards. Two of the 3 PLC’s move around in an EMS trolley. The other is a ‘base station’ with a GOT2000 connected via Ethernet. Base PLC IP = 192.168.1.11 HMI IP = 192.168.1.31 Carrier 1 IP = 192.168.1.61 Carrier 2 IP = 192.168.1.62 I have programmed the base PLC to use Active communication; we are using fixed buffer communication to send and receive data to/ from the Carriers. The carriers are set up as Fullpassive ‘slaves’. This part works well and the update time changes (using a counter in the base station) from 1s to 100ms (because it enters a different work station).  My issue is the following: using a network sniffer (WireShark), I pick up plenty of re-transmits and sequence number errors coming from the base PLC’s ENET card. This is troublesome and causes delays when the update time is required to be fast (100ms). I am sending and receiving 10 words of data. The wifi seems stable, and there is minimal noise in the area. The power has been turned down and the antennas used are suited well for the application. The antennas are at a similar height to minimize possible loss of signal. I have LOS (line-of-sight) to the carriers at all times; to at least one of the antennas (I am using 802.11n). Has anyone picked up issues or found settings which can be used for comms over wifi? I can easily do this using a S7-1200 Siemens PLC and have done so using 12x S7-1200 clients and 2 AP’s with 1 base PLC. I have also successfully done this using 8xFX3U client with a System Q base PLC. My suspicion is that the delay in reading and writing to/ from the BFM in the ENET card is causing this. I am not sure that if I change to a FX5U will help. The communication cards on the Mitsubishi PLC’s seem very limited. Does anyone have any technical details on the access times between the CPU and communications cards’ BFM? Help is as always, appreciated.
  23. CP1L Unknown IP

    Hello. I have CP1L EM30 with unknown IP. I have tried to use "Direct Ethernet Connection" with "Network Browser" but with no success. I have manually set the ethernet IP4 address to 192.168.20.20 / 255.255.255.0 I've got error: "The OMRON Ethernet Direct Connection Manager service is starting in Safe Mode because Windows APIPA is enabled. (0x82020003)Omron.Cxmw.Modules.SystemLibrary.SysLibException" The PLC does NOT have default ip 192.168.250.1. What Can I do? Please help. Thanks. BR, Andrej.  
  24. Hello! Is there any possibility to connect a Mitsubishi PLC to a program like Siemens Plant Simulation? With Siemens PLC I can do it through OPC UA protocol, or Shared Memory with SIMIT, or stuff like that. But I would need to do it also with Mitsubishi PLC. Can I use for example OPC Server? I couldn't find out, if Mitsubishi PLC-s have that function built-in. (I have a L02 and a FX3S COU, either of them would be great.) Thank you!