Search the Community

Showing results for tags 'simple motion module setting tool'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Found 105 results

  1. Hello Everyone Im working with Coordinated Motion instructions, specifically MCLM instruction and I Would like to know if there is a way to know the exact End position (XYZ) when parameter Command Tolerance is Set since i need to calculate the distance to the end point, there is no problem as long no command tolerance is set cause I can find the distance using  AB=Sqrt ((x2−x1)**2+(y2−y1)**2+(z2−z1)**2)  but as some points have command tolerance the X2,Y2,Z2 are unknown. Hope I was Clear Thank you in Advance.
  2. Motion Control

    Hi Everyone.   I have been tasked with changing out an older Flex Drive servo drive to a more modern Micro Flex drive in a machine that has an Omron CQM1H-CPU51 PLC.  I'm having a few issues but hope that i can gain some clarity around at least one of the hurdles Im facing from here. Biggest issue for me at this moment is My work hasn't yet purchased a programming lead for this PLC (or even the bits required to make one myself) but i have a feeling the control for the Servo is done via motion control in the PLC.  Question here is, if changing from one servo drive to another type, will the motion control code need to be updated to work with the new servo drive?  I have very limited experience with motion control itself at this stage so I'm a bit lost when it comes to these sort of details. Regards Kiwi_man82
  3. Hi All, I just start to setup a rotary servo (rotary transmission load type) and the designer pass me the spec of gear ratio 1:100. In my motion scaling page, I set Transmission I:O as 1:100  and then scaling unit is just position unit with 1:1. However, when i jog my rotary servo, it does not reflect the actual position in degree, so I went to read through the manual but still cant quite get how should i configure my scaling so that I can see that when the motor is rotating, i can see it rotate how many degrees? I try to set scaling 360 degree to 1.0 load rev, and the position feedback seems like much more finer....
  4. NT21 to CP1L-EM

    I am trying to get a NT 21 to link to a CPL1 I have both set to Host link 9600/7e2 I have it set to read a DM All I get is system initialzing I am using the same cable i used to build the screens with NT Series Support tool I sent and recieved the screens so the cable works The com port on thee PLC is flashing I have tried starting the PLC in run mode and Monitor Mode What did i forget to do ??????? Rob  
  5. hello everyone, I using stepper 17HS2408, microstep driver, modul motion QD75D2, PLC QD3UDV,, i've been trying to use program Absolute in axis 2. When I trigger the command to run absolute program the current value is running but the stepper motor still not moving, is there any suggestion about this?
  6. NT Support Tool Ver 4.87

    Hi guys, I need to upload an NT31-123B-EV3 IHM (System Ver 4.2), but the software I have installed is NT Support Tool Ver 4.87, does not include the PT model I need (System Ver 4.2), has only NT31-V2 / V3 (System Ver 3.1 / 4.1). Does anyone have a solution to this problem? obs: * HMI:         NT31-ST123B-EV3 (System Ver. 4.2)         * Software: NT Support Tool Ver 4.87 Best Regards,
  7. Is there a bug in the daylight savings feature of the HMI? I have the checked in the HMI but the time didn't update to fall one hour back in the fall. Now the HMI is showing one hour ahead. Am I missing something here?
  8. Delta 20PM series

    I have a Delta DVP 20pm00m controller , it has O100 is the main program , OX and P are subroutines I can not enable the OX motion subroutine , although O100 and P subroutine are excuted. How can I run the OX motion subroutine??? I wrote               mov H8000 D1868                            mov H1000 D1848 to enable OX0 but it did not execute How can I run the OX motion subroutine??? Thanks a lot
  9. Hey y'all- I have an application that uses an Allen Bradley servo with a brake and a linear actuator to lift a plate vertically. While maintaining a position, the servo drive (Kinetix 5500) will occasionally fault due to over-torque.  I'm thinking it could possibly be due to mechanical issues i.e. bearings in the actuator but my initial thought would be that it would fault while moving up/down as well, so far I've only ever seen it fault while holding a position. This leads me to suspect that there may be something off in the control loop. I'm not involved in the setup but I know we use load observer and I reckon we use auto-tune. Other than that, I wonder if it's something to do with the brake. I also read about mechanical resonance in the manual which seems like a stretch but it could be contributing, the frame that the actuator/motor is attached to does vibrate a fair bit.  I'm familiar enough with basic motion control using Allen-Bradley and understand the basic concepts behind the servo/control loop. However I'm at a loss for why the servo/drive would spontaneously over-torque while maintaining a position.  How would you guys approach troubleshooting this further/solving this issue?  Many thanks!
  10. Good day everybody,    Currently I am working on an application using 3-axis controlled by a QD77MS4 Simple Motion Module.  In this case, I have already set up most of the configuration, but when I try to execute the program, I get the following error:   SP. UNIT ERROR - The location designated by the FROM/TO instruction set is not the intelligent function module/special function module.  - The module that does not include buffer memory has been specified by the FROM/TO instruction.  - The intelligent function module/special function module, Network module being accessed is faulty.  - Station not loaded was specified using the instruction whose target was the CPU share memory.   The QD77MS4 Module is mounted in Base Slot #3, so I use U2\G800, U2\G1500, etc... to Read/Write from it.  The Diagnostics tool indicates the error occurs as soon as I try to access the U2\G800 Buffer Memory. If I set this part of the program to No Execution the error is no longer displayed.  Additionally, if I try to monito the Buffer Memory area of the Module, it says that "The Module Stat Address is incorrect".   I already tried changing the position of the module in the base (Slot 3 --> Slot 1) and changing the corresponding values to reflect that, but still the problem persists.    What am I doing wrong? Is there some kind of configuration I could be missing?    Thanks in advance for your help!   
  11. Hi everyone, To explain the problem a little bit: I have 2 systems that are equal, they have 1 PLC, 1 Inverter and 1 Servo Axis (Image01). The devices are connected via EtherCat. The thing here is tht in these systems the PLC and Servo Axis is the same but the inverter is different. My goal is to have the same project on both systems and depending on the inverter detected use the correct program. What worked: If I add the 2 Inverters and 2 Servo Axis on the project on different nodes (Image02), I can detect which is present using the variable _EC_EntrySlavTb[n]. My issue is that if I want to make more replicas of the systems using different inverters I will eventually hit the Axis Number limit for the PLC while in reality I am only using on Servo Axis at a time. What I wanted: I would like to be able to control 1 Servo Axis with 2 different inverters (only one active per PLC) (Image03). What I tried: The axis parameters can be set using a variable of the type _sAXIS_PARAM, however it seems that the option to change the axis basic settings is not available (Manual: NJ/NX-series Motion Control Instructions Reference Manual (W508) page 5-58) (Image04). The axis basic settings is where the definition of the output device plus control words are set (Image05). Is there a work around to solve this issue? I would really like to avoid having to manually change the output device for the Servo Axis every time I make an update on all the systems.   Best Regards, BR  
  12. Hello! I'm trying to connect my QD75M2 with a MR-J2S40B1 Servo amplifier with an SSCNET cable. The problem is when I try to turn on the Servo ON/OFF on the Intelligent function in GxWorks2, an error occurs saying the servo amplifier is disconnected with my QD75M2. I'm confident that I've wired it properly. What could be the problem? Hoping you might help. Thank you.
  13. simple motion cam curve

    Good afternoon, I have a problem in an application for a rotary knife, I'm using a MR-JE-B servo to make this movement, while my material is powered by an inverter connected to a modbus rs485 network, with a 5v encoder connected directly in motion. I'm having some problems and I think it's my cam curve. I have a very high refeneration, and the system doesn't obey the size of the length I want the cut. It always cuts the same size, regardless of the configuration I use, it always cuts to 245mm. Put some photos, how are my settings. Grateful in advance, if anyone can help me. Dover_roll_1-Motion-configuração_jog_manual.gx3
  14. Hello, My coworker and I are commissioning a new panel. We have a 1732-AENTR series C remote IO thats Rev 6.1. The project file from a previous identical panel has the module at rev5.3 in the project tree. I downloaded the AOP and ran the installer, it worked no issues. My co worker then did the same thing but now the module is unrecognized in the project tree and the module is missing after installing the AOP. Im concerned he corrupted something. I tried uninstalling and reinstalling the AOP but no luck. It works on my computer but not his? TechConnect said something about corrupting the aop core. My coworker did the first install and he was getting confused about zip files and the virtual machine we run rsl5k on. Maybe he broke it? any suggestions?
  15.  What is the difference between Active Immediate homing and passive immediate homing ?   Does Motion servo axis have to be turned ON for active immediate and turned OFF for passive immediate homing ?.
  16. I have seen some programs in which they manually unlatch all bits like in figure 1, and in some programs they don't do that.  The instruction help page, ladder execution says that in pre-scan .EN, .DN, .ER, .IT bits are cleared to false So do we need to unlatch all these bits before giving a motion command like MAM ?  
  17. Hello everyone, I have this weird problem that the PC (process complete) bit of MAS command does not clear after a cycle time.  As you may probably see in the picture attached when the desired torque has been reached, the servo has to be stopped using MAS command; however, this is good only for one cycle!! The PC bit will remain on even when the whole sequence gets unlatched/reset. I have to manually reset this bit. I was wondering if you could help me with this issue, please?  Thank you!  
  18. MT Developer 2

    Good day everyone, I am working on a problem on a Mitsubishi Q series PLC and motion system. The system consist of a Q12H PLC CPU and 2 x Q173CPUN Motion CPUs. The first motion controller controls 23 x MR-2JS-_B Servodrive and thesecont motion controller CPU controls 6 x MR-2JS-_B Servodrives. They are all using SSCNET1 system.The machine have been working fine all along until the machine stoped for 3 months because we were waiting for one spare part that was coming from oversees during covid lockdowns. When we restarted the machine, the servodrives could not home. When we were busy checking for the problem and before finding the problem, the machine just started homing. This keeps on happening over and over. Everytime you stop the machine overnight, it just stop working then when you are busy troubleshooting, it just come to like. In the time when it is not responding, we figured out that when we jog the servodrive controlled by second Motion controller CPU for the HMI, the drives jog fine but the servodrives controlled by first motion controller CPU does not respond. I have tried jogging the servodrives indipendently using Setup161E and they move . I even changed the motion CPU but to no success. When you monitor using MT Developer 2, the are no errors. Is there anyone who might have an idea on what might be the probable cause    
  19. NX1P2 Motion Control

    Hi:       I need to change an old PLC  with NX1p2  to control 3 servo motor by means of Analog Outputs couple with encoders, My job is to change the PLC only. So the servo drives and drivers are untouchable (No budget and involve too much mechanical works).   I observed that Sysmac Sttudio Axes setting has this: Servo Axes, Encoder axes, Virtual Servo Axis and Virtual Encoder Axes.   I believe the Encoder Axes couple with Analog Output is able to to do the Job? If so, what function block should i use? If no, do any body have a suggestion of any function block i can use? Thanks  
  20. password unlock tool

     hi everyone i m traying to   write to plc  a program and getting this message then program is not downloading to plc   'there is a device in the program (main) that is outside of the range  check the program and currect the device that outside of the  range ' I m using mitsubishi fx3ga-60mt  plc. please suggest me about it .                              thank you     hello everyone please let me know about  how to make software  tool for password read from Mitsubishi,delta, omron, siemens plc .                             thank you       
  21. So I'm new to the automation scene and in my training I decided to setup a little test rig, plc, drive, servo, sensor, hmi...etc.  Everything is wired and hooked up. What I'm trying to do is simply get the servo to spin. here is a screenshot showing what I have. I think there are some flags on the servo itself that need to be set but I'm not sure how to do that. In Base(x) I have tried 0, 1, 4, 5, 35. Any help would be appreciated.
  22. Hello Sirs! I have a problem with PF527. I get alarms 'control sync alarm' and 'module sync alarm' occasionally. I suppose this meaning that PLC is missing some data from the PF527 device. How to confirm this or what should I do with the problem? Any ideas? Motion group update period is 8ms. Also this device is the last device in the ethernet line. I am thinking to pull the cable directly to the switch near PLC. I am not sure does it help?  
  23. FX1N sprinkler system control.

    Hello!  I have an FX1N PLC that I want to use to operate a sprinkler system.  It should have two functions.  1. 1x30 minutes of operation every day.  2. 3x10 minutes of operation every day.   Thanks for the help.
  24. Hi Everyone, I've had V32 installed for at least a year but haven't had much need for it until this month. I installed a new activation on Friday that I thought crashed V32, which was weird because all the other Studio versions were working. Any time I tried to open an existing project or even create a new one, I would get an "access violation was generated" fatal error. I reached out to a colleague who found a tech note on the problem. Turns out the activation had nothing to do with the crash but rather, turning on the bookmark tool bar caused it. If you have the bookmarks toolbar turned on in version 32  the Windows desktop needs to be set at 100% magnification, not 125% which is the Windows default. Right clicking on the desktop, picking display settings and changing the scale and layout to 100%, then rebooting the computer fixed it. But now all the Windows icons are really small. I've been spending most of my time in V21 through V28 until recently. Since we're all likely going to be seeing more V32 in the near future, I'd thought I'd pass this on.  
  25. Hi Everyone,   I have  NT31C-ST142-V2 and it has a prompt of "System Program not exist or incorrect." I am trying to transfer via NT Series System Installer but I am getting a time-out error. I have Xm2S-09 serial cable with ATEN serial-to-USB cable.I know it is not broken since I can still Upload/download on a CJ2 PLC. I just want to know what other things I can do upload a systemprogram. I have seen a comment on this site that he remove the battery then tried to upload again.   NT is almost 15 years old. I have a back-up program.   I can't seem to upload by this time for pictures of theH MI and the screenshots of software .