Search the Community

Showing results for tags 'servo control'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Found 137 results

  1. Constant Web Tension Control

    So I'm having trouble writing a FBD within my current program for a slitting line. I need to keep a constant tension on my web as it is being recoiled onto our recoiler. I wrote a simple program using a sensor to read the growing rate of the coil to get a radius and I have feedback on my torque on the recoiler motor. The simplest math for this application without getting into anything too fancy should be Tension(lbs)= Torque(ftlbs)/coil radius. only problem is when its less than a foot then my calculation is thrown off and it actually shows tension goes up until it reaches the one foot mark then it seems to scale correctly. Do I need to scale something else? Any help on this would be appreciated.
  2. Dear all, I had bought a mitsubishi plc fx3s-20MT/ESS which is the source output and I plan to try to send pulse to Mrj3a Servo Drive. According to the manual, it stated that the servo drive able to support the source type plc but I do find out that manual also mention that only sink type plc is suitable for melsec servo drive.  Anyone can help me in this case? 
  3. Can someone please suggest a Control Panel Builder that is located in Germany?   I work for a company in Australia and due to Covid 19, we are struggling to meet an onsite date for a project in Germany.   This project uses Siemens PLC gear, Danfoss drives, and mostly Schneider electrical gear. The enclosures are custom and stainless steal.    I have electrical schematics and enclosure drawings for quoting.
  4. Hi all! We have a problem with a Mitsubishi system. After switch off the machine in home position and back on, it resets the servo encoder value to 0.  I checked the servo parameters, and the Absolute encoder is enabled, the ext. battery is ok and no zero reseting in the program ( I think...). Is there a parameter I should check or some setting in the intelligent module? The system consists Q01CPU, QD77MS2 im., J4 200B amp with 6v battery, and HG-SR152 motor.
  5. Hi all, I am studying how to control servo with PLC Mitsubishi Q-series. When I click Servo_parameter in Simple motion module setting tool, this annoucement appears.  Does anyone know why it appears? I tried reinstalling MR-configurator 2 but it didn't help. Please give me some advices. Thank you all!
  6. I have a Mitsubishi FX5U-32M with 3 MR-JE-40C servos. Our system will be used in a robot cell, and needs to convey some information to the customers system, which is this EtherCAT side of things. They want to know RPM, torque values, position ,etc, of things on our system.. Our Mitsubishi supplier recommended an AnyBus X-Gateway (AB7961). They have a few YouTube videos on configurations, but unfortunately none on the Mitsubishi side i found. I've only been using Mitsubishi for a little over a year, but know my way around GX Works 3 pretty well.  I come from the Rockwell world with EDS Files and tag based setups, and for the life of me cant figure out where to start with this AnyBus. I've gone to the support page, got all the downloads and software, and gotten online with the Anybus. As far as beginning to setup the Anybus in GX Works side, to setup what registers i want to send, im lost... Anyone out there have experience with this sort of thing?
  7. Mitsubishi FX5-4LC

    Hello Guys,                      can anyone help me programming of FX5-4LC temperature control module with FX-5U80MT PLC. I want to Read present temperature value of each channel and want to set Temperature Set value from PLC.
  8. Is it possible to reset " Motor replacement detected error" ( Error code 95.01) using code without connecting to PLC through sysmac studio? If yes please suggest how to do it... Thanks in advance...
  9. Is there a way to monitor the Temperature of a Servo Motor on Allen Bradley Servo motors... MPL? PLC: CompactLogix 1769-L30ERM Drive: Kinetix 6500   Motors: MPL-B310P-MJ72AA, and  MPL-B560F-MJ72AA I would like to be able to monitor the temperature, and flash a warning screen on the HMI if the Motor gets too hot, or perhaps shut down the operation before the Motor overload trips. The drive and PLC are connected through Ethernet IP What I don’t know is if that Motor heatsink temperature information is available to the PLC.
  10. Hi Every one, I have two 2198-P070 bus power supplies for that I’m using for four Kinetix drives, 2 drives per power supply, all controlled by one processor (5069-L350ERMS2). I have an enable contactor setup for each power supply for each set of drives. I have them configured as DC bus groups 1 and 2 respectively. I had the first set of drives working, setup inside the motion group, with no issues. When I added the second power supply and drives. I found that when I added them to the motion group I couldn’t get the enable contactor to close for the first set of drives. I f I took them out of the motion group and made them ungrouped then the first contactor would close but then I couldn’t get the contactor on the second set to close. Do you have any thoughts as to what I might be missing to get these to work? See the screen shots for more detail. Let me know what you think.  Also, I have heard that only one motion group is allowed per PLC, but my question is : Can I use  sevral axes and Power units in the same motion group? 
  11. Virtaul Axis - Simulation

    Is it possible to simulate a servo axis in Sysmac Studio? Can you create a virtual axis and then set velocity & position for this virtual axis? If this is possible, is there an example program that anyone can share with me? Thank you. Happy new Year! 
  12. Getting this error while adding MC_TorqueControl. I want to control torque from HMI value. Using R88D-1SN08H-ECT drive and R88M-1M75030T-S2 Ac servo motor with NX1P2 PLC. Newbie Here. Please support. Error    1    The Axis parameter of the MC_TorqueControl instruction does not support single-axis position control axes.    Program1 Section0    Row 6  
  13. Control Panel

    Is it possible to view the values / states of all inputs, outputs and workbits (e.g. 64.00 through 64.15 on Omron CQM1 PLC) on a single screen or control panel within CX-Programmer software?  I'm trying to troubleshoot some ladder logic that I wrote and need to know the values of 5 or 6 inputs/outputs/workbits simultaneously.  Having to scroll up and down through my ladder logic repeatedly does not work well with code that changes state every 5-10 seconds or so. Any help is welcome.
  14. Control Logix 5561

    Hello  We have just purchased some equipment with a Control Logix 5561 (1756-L61/B Rev 13.40). The compact flash card is missing from the unit but the seller says the unit was running in his facility prior to shipping. Does the 5561 have internal memory where a program is stored? Is the Compact Flash used only for recipes and persistent data? Thank you
  15. Logic to control many motors

    Hi everyone, I trying to develop a logic to control 6 motors. Two motors needs to working and four motor will be in stand by. When one of the two motors fail, one of the four motors will start to work. Another rule is, when one of the motors that is working reach the preset time of working, the controller will stop that motor and start another motor with low working time, and so on. I'm have difficult to solve this problem. Can someone help me, please? Best, R.  
  16. Hello,   I have  a project where I need to run 2 Omron Servos 1S at same time with 1:1 ratio. I created virtual servo axis and attached my 2 physical axis to virtual one ( screenshot from Sysmac studio attached). For some reason when 1 of the axis has a fault, my whole virtual axis goes down. For recovery I need to to do GearOut and GearIn again. In one of the moments I'm losing count in my motion that cause issue later. I believe that I'm doing something wrong.  Can somebody help me to understand how I can keep my synchronized axis all the time? Thank you in advance!  
  17. Control Panel Drawings

    Gentlemen and Ladies,                             This post might come off as generally lazy but this is purely in the interest of saving time. Our company has been building control panels for quite some time. I have been doing the design for about 10 years or so. We typically build Allen Bradley type control panels. Our main customers are water/wastewater so they are typically Compactlogix with basic IO. (AI, AO, DI, DO) modules. Recently i've been using the IO Wiring System modules. These save an incredible amount of time. However, they are quite big and require a decent amount of space. Our smallest control panel size is usually 36x36 and that is pretty tight. My question to all is, does anyone have a set of control panel drawings for an Allen Bradley compact logix system without these wiring modules? I am looking to create a smaller control panel, and I just haven't had much time lately to sit down and do the design. This is indeed a shortcut, but time has been limited on my end as of late. I apologize if this is out of line.   Thank you,  
  18. MR-J4-60GF-RJ Programming

    I am new to Mitsubishi (only done Allen Bradley) and Im tasked with programming a MR-J4-60GF-RJ servo drive with a HG-SR motor. I am using GX Works 3 and have a R02CPU and I am wanting to use CC Link IE Field Basic communication with this. Do I have to use the point table to move this motor from "Point A-B" or can I send absolute positions, speed, etc to a given position. Any advice/programming examples would be great. 
  19. Autotuning Kinetix 350

    Hell PLC World! I have been trying for several weeks in my spare time at work to tune an Allen Bradley Servo Motor.  Below is the list of hardware I am currently using: - CompactLogix Motion Controller (1780-L33ERM) - Kinetix 350 Driver (2097-V34PR5-LM) - MPL Series Rotary Servo Motor (MPL-B310P-MJ74AA) I have been using RSLogix5000 for testing and I plan to use it to develop a simple conveyor type program later.  I have tried a list of things which will be below, but to no avail, I cannot simply jog the motor for any period of time without triggering a position, velocity or bus voltage error.  I have tried changing the motor, driver and feedback cable to no avail.  Here is the process I have used: 1) Add the hardware to RSLogix5000 (PLC, Driver and Motor) 2) Configure the motor 3) Run the hookup test.  This works flawlessly.  The motor will slowly turn independently on the feedback test for as many revolutions as I input.  This is what makes me think I am doing something wrong in the tuning process. 4) Run autotune process with the velocity, acceleration and jerk set well below the limits of the hardware.   5) Attempt manually control motion 6) Recieve error I have tried changing the input from trapezoidal to S-Curve, changed velocity and position limits, manually tuned velocity gains in a myriad of configurations.  I have swapped legs on the 3 phase input (which made matters worse). I suppose it is possible that multiple pieces of hardware are faulty because this equipment was previously used, but I still cannot wrap my head around why the hookup test would work so flawlessly, yet I cannot just get the servo to rotate at an equivalently low speed. If anyone recognizes my mistake, I would be eternally grateful.  I am an intern studying control systems in graduate school and as popular as AB is, I would sure like to get some experience with it.  Thanks in advance!  
  20. Hello, I have a project where I need to synchronize 2 servos. I use GearIn command to sync this servos. I created 1 virtual axis and attached my 2 physical servos to virtual one. Based on application logic I need to stop sync servos when count from sensor reached max value. To stop the servos I'm using ImmidiateStop command. For some reason stop point for this servos variate based on servos speed.    How I can improve my stop point?      Thanks!
  21. Alice Sales Manager Changsha Zhinian Automation Equipment Co;ltd   Te/whatsapp:+8613341312293 Fax: 0086 0731-82292217   Email: info-zna@zhinianauto.com   Main products: PLC: Mitsubishi, Omron, Panasonic Inverter: Mitsubishi,Fuji, Omron,. HMI: Mitsubishi, Omron,, Proface,FUJI, AC Servo: Mitsubishi, Omron,FUJI Sensor: KEYENCE,OMRON   Air cylinder: SMC Below is our best price product list: MITSUBISHI: 1.MR-J2S/ MR-J3/ MR-ES AC servo pack ( amplifier, motor, cables ,connectors) 2.FR-A700, F700, E700, and D700 inverters 3.GOT1000 and GT1500 Human machine interfaces 4.A, Q and FX series PLC(FX1N/FX2N/FX3U/FX3G/FX1S) plc OMRON: 1.C200H/ CQM1/ CS1W/ CJ1W/ CP1H/ CP1L/ CPM1A/ CPM2A/ CPM2AH plc 2.SYSDRIVE 3G3JZ/3G3MX2/3G3JE/3G3RX Series inverter 3.NS5-V2/ NS8-V2/ NS10-V2/ NS12-V2/ NS15-V2 Human Machine Interface 4.E3JK/ E3JM/ E3Z photoelectric switch 5.TL-Q5/TL-W3/TL-N Proximity switch 6.E6B2/E6C2/E6CP rotary encoder 7.G3NA-205B/G3NA-210B/ G3NB-240B Solid State Relays 8.H3CA/H3CR-A/H3DE/H3DS/H3JA/H3Y-2 Solid-State Timer   Contact me if you are interested, thank you !  
  22. Stepper Motor Control

    can anybody Know how to control stepper motor using PLC
  23. GX Works 3 - PID control

    Hi, I am using PID function (PID operation instruction) from GX Works 3 library but it doesn't work. I set all necessary parameters (sampling time, direction and upper/lower limit values + KP, TI). My input PID_Par is array of 25 points (in manual is written: "*1When auto tuning is not used, the same number of points are occupied as when the step response method is used."). For example, in GX Works 2, PID function works ok. Did someone have similar problem? Does someone have mitsubishi library (GW Works 3) with PID function that works correctly?   Regards Luka  
  24. Hello,I am sizing a feeder circuit for a panel according to UL 508A and came into a question:My input current is of 76.5 A (considering all the loads), thus, it is fine for me to use a cable of 4 AWG (max. 85A @ 75 c).For the circuit breaker I did 76.5 A x 1.25 = 96 A and then I selected a breaker of 100A.My question is: Is it ok for me to keep this configuration according to UL 508A? 100A breaker + 4 AWG load side cableOr do I need to level up the cables?Thank you very much in advance!
  25. Mitsubishi FX2N, Servo Output problem

    Hello guys, I am facing a problem that our Servo is generating output for only reverse direction, when we give forward command from HMI the output Y0 is active but when we give reverse command same outut Y0 is high, other output which is Y4 is not high, what could be te possible reasion.