Search the Community

Showing results for tags 'servo; motion; kinetix'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Found 153 results

  1. Motion Control

    Hi Everyone.   I have been tasked with changing out an older Flex Drive servo drive to a more modern Micro Flex drive in a machine that has an Omron CQM1H-CPU51 PLC.  I'm having a few issues but hope that i can gain some clarity around at least one of the hurdles Im facing from here. Biggest issue for me at this moment is My work hasn't yet purchased a programming lead for this PLC (or even the bits required to make one myself) but i have a feeling the control for the Servo is done via motion control in the PLC.  Question here is, if changing from one servo drive to another type, will the motion control code need to be updated to work with the new servo drive?  I have very limited experience with motion control itself at this stage so I'm a bit lost when it comes to these sort of details. Regards Kiwi_man82
  2. QD77GF Error D304

    Hi. I am using PLC Q06UDV wit QD77GF to operate 11 servos, it is my first time using QD77GF and CC-Link IE Field. I've done the parameter setting. but the qd77gf error lamp started to blinking. i try to check it in cc link ie field diagnostic and didn't find anything except the error lamp blinking in monitor view. then i checked system diagnostic , no error showing up but, only historical error when i started the power of plc. it show D304 error.  in manual book the solution are lengthen the operation cycle qd77gf, check the cable, and shorten plc scan time. where can i find this setting sir?  
  3. Motion Scaling Rotary

    Hi All, I just start to setup a rotary servo (rotary transmission load type) and the designer pass me the spec of gear ratio 1:100. In my motion scaling page, I set Transmission I:O as 1:100  and then scaling unit is just position unit with 1:1. However, when i jog my rotary servo, it does not reflect the actual position in degree, so I went to read through the manual but still cant quite get how should i configure my scaling so that I can see that when the motor is rotating, i can see it rotate how many degrees? I try to set scaling 360 degree to 1.0 load rev, and the position feedback seems like much more finer....
  4. Kinetix 5500 lost power

    Hello all,    I have 3 kinetix 5500 drives connected in series but some how the 3rd drive lost power. all the fuses in the cabinet look good. nothing else is tripped either.    any advice is appreciated.  thank you   
  5. Hi everyone,  I am new to Mitsubishi PLC. I am trying to see from where Run or speed commands goes to Servo. I have MELSEC FX2M-32MT with FX2N-1PG cards for the Servo and I am using GX Developer 8.91v  Also, I would like to mention that initially I found out that BATT V light was lit so here what I didi. >I replaced the battery within 20 second while powered ON. Before changing the battery I took upload of the program successfully.  >I have cleared PLC memory and re downloaded the program.  > Checked Memory addresses M8005 8006 both are Low.  Now, when I am trying to run  my machine it is not giving output to two Servos while a conveyor operates when started from the HMI so it means program is inside PLC, right ? Program is attached if someone wants to have a look.  labeling mc 300322.rar
  6. Omron 1S Servo

    Hello:           Does anyone know the details explanation of the Homing Settings for the Axis? Set the homing operation. 0: Proximity reverse turn/home proximity input OFF 1: Proximity reverse turn/home proximity input ON 4: Home proximity input OFF 5: Home proximity input ON 8: Limit input OFF 9: Proximity reverse turn/home input mask distance 11: Limit inputs only 12: Proximity reverse turn/holding time 13: No home proximity input/holding home input   Limit Input referring to Input (I/O) ? How about Proximity Input ? It is confusing with the terms. The manual has no explanation for each of the above selection.   Any one?   Simon
  7. hello everyone, I using stepper 17HS2408, microstep driver, modul motion QD75D2, PLC QD3UDV,, i've been trying to use program Absolute in axis 2. When I trigger the command to run absolute program the current value is running but the stepper motor still not moving, is there any suggestion about this?
  8. Hi, I need help with my program. How do I include the fractional part of the position I set for encoder? I have an Omron PLC and using cx programmer.  I need to command my servo (from HMI number input) to move to a certain position. Now using a manual computation, my servo is supposed to move 95.65mm, however, using my plc program, the resulting position doesn't include the 0.65. I used the FIXL instruction to convert my result from float to 32 bit and it removed the fractional part of the value.   Thank you!
  9. Hi, I have to implement an axis control in a NX1P2 PLC using an inverter (3G3MX2) and an encoder cabled on a EC0122 board. I found something similar implemented  on a CJ2M PLC, but I have no idea how to set up the axis in the configuration of sysmac studio and how to implement the control. Can someone help me? Some sample to catch out the configuration?   Thanks a lot Andrea
  10. Delta 20PM series

    I have a Delta DVP 20pm00m controller , it has O100 is the main program , OX and P are subroutines I can not enable the OX motion subroutine , although O100 and P subroutine are excuted. How can I run the OX motion subroutine??? I wrote               mov H8000 D1868                            mov H1000 D1848 to enable OX0 but it did not execute How can I run the OX motion subroutine??? Thanks a lot
  11. Hey y'all- I have an application that uses an Allen Bradley servo with a brake and a linear actuator to lift a plate vertically. While maintaining a position, the servo drive (Kinetix 5500) will occasionally fault due to over-torque.  I'm thinking it could possibly be due to mechanical issues i.e. bearings in the actuator but my initial thought would be that it would fault while moving up/down as well, so far I've only ever seen it fault while holding a position. This leads me to suspect that there may be something off in the control loop. I'm not involved in the setup but I know we use load observer and I reckon we use auto-tune. Other than that, I wonder if it's something to do with the brake. I also read about mechanical resonance in the manual which seems like a stretch but it could be contributing, the frame that the actuator/motor is attached to does vibrate a fair bit.  I'm familiar enough with basic motion control using Allen-Bradley and understand the basic concepts behind the servo/control loop. However I'm at a loss for why the servo/drive would spontaneously over-torque while maintaining a position.  How would you guys approach troubleshooting this further/solving this issue?  Many thanks!
  12. Problem during tuning

    Hi! I would like to do some tuning on our machine, but the problem is that the machine stops and drops origin positions. I selected User Command method with Basic setting. After 5sec I started the tuning, the machine stops with the roblem of that axis. Is there a parameter bit that goes high (or low) during tuning? There're no strange sounds nor movements..even the amplifier doesn't give error code. Is there something else that i should check? In the Servo-Adjustments parameters, One Touch Tuning setting I found the Permissible Overshoot Amount Level is set to 0.  Can it be the problem? 
  13. Hi there I was reading this thread: And trying to create 3 axes. 1 virtual axis and 2 real axis, I would like to use MC_GearIn for each real axes so both real ones follow  the virtual axis (so both can move in sync motion). But my question is: If I give Move cmd(Absolute or relative)to master virtual axis and since it's virtual, it is not going to move then how can the other real ones follow the master(assuming that it's literally electronic gearing).  Any help will be appreciated!
  14. Anyone know what could be missing to be able to import this stepper motor to sysmac? This is one of the supplied xml files for the stepper motor.     FASTECH_Ezi-SERVO2_EtherCAT - OMRON.xml
  15. Hi there This attached pic I got from Omron motion control manual. I am trying to wrap my head around it. Does it mean that the slave servo axis is gonna follow master encoder axis using GearIn FB?? If so, then Can we executive Move FB on encoder axis? Looking forward to your responses.  
  16. Axis Permanent Control

    Hi Guys, How can I bring an axis into permanent control? that as soon as a value changes, the axis reacts. My Hardware FX5U, FX5SSC MR-JE-20B. Thanks a lot.
  17. Servo tuning

    Hi.  I am planning to do a full scale servo tuning on our producting machine. Is it possible to do it while the servos are in, assambled? I mean no production, no disassembling, servos stay where they are, just tuning them one by one with their empty load..
  18. HELLO EVERYONE THERE IS THIS PROJECT WHERE I CHANGED THE OLD SERVO SETUP WITH NEW SERVO DRIVE MRJ4200A-RJ SERIES. OLD SERVO HAS A REVOLUTION OF 15 BITS BUT NEW SERVO HAS 22 BITS RESOLUTION. PROGRAMMING IS SAME BUT MY DISTANCE CALCULATION IS DIFFERENT NOW AND MACHINE DOES NOT GIVE CORRECT DISTANCE. PLEASE HELP ME
  19. servo training

    Hello . Does anyone from the forum have such a program as on flimik, and he could share a program for f3x and the got1000 panel regards
  20. Good day everybody,    Currently I am working on an application using 3-axis controlled by a QD77MS4 Simple Motion Module.  In this case, I have already set up most of the configuration, but when I try to execute the program, I get the following error:   SP. UNIT ERROR - The location designated by the FROM/TO instruction set is not the intelligent function module/special function module.  - The module that does not include buffer memory has been specified by the FROM/TO instruction.  - The intelligent function module/special function module, Network module being accessed is faulty.  - Station not loaded was specified using the instruction whose target was the CPU share memory.   The QD77MS4 Module is mounted in Base Slot #3, so I use U2\G800, U2\G1500, etc... to Read/Write from it.  The Diagnostics tool indicates the error occurs as soon as I try to access the U2\G800 Buffer Memory. If I set this part of the program to No Execution the error is no longer displayed.  Additionally, if I try to monito the Buffer Memory area of the Module, it says that "The Module Stat Address is incorrect".   I already tried changing the position of the module in the base (Slot 3 --> Slot 1) and changing the corresponding values to reflect that, but still the problem persists.    What am I doing wrong? Is there some kind of configuration I could be missing?    Thanks in advance for your help!   
  21. Hi everyone, To explain the problem a little bit: I have 2 systems that are equal, they have 1 PLC, 1 Inverter and 1 Servo Axis (Image01). The devices are connected via EtherCat. The thing here is tht in these systems the PLC and Servo Axis is the same but the inverter is different. My goal is to have the same project on both systems and depending on the inverter detected use the correct program. What worked: If I add the 2 Inverters and 2 Servo Axis on the project on different nodes (Image02), I can detect which is present using the variable _EC_EntrySlavTb[n]. My issue is that if I want to make more replicas of the systems using different inverters I will eventually hit the Axis Number limit for the PLC while in reality I am only using on Servo Axis at a time. What I wanted: I would like to be able to control 1 Servo Axis with 2 different inverters (only one active per PLC) (Image03). What I tried: The axis parameters can be set using a variable of the type _sAXIS_PARAM, however it seems that the option to change the axis basic settings is not available (Manual: NJ/NX-series Motion Control Instructions Reference Manual (W508) page 5-58) (Image04). The axis basic settings is where the definition of the output device plus control words are set (Image05). Is there a work around to solve this issue? I would really like to avoid having to manually change the output device for the Servo Axis every time I make an update on all the systems.   Best Regards, BR  
  22. Hi there I am working on a project where Omron servo drags a part to a certain position using belt mechanism, But to avoid any slippage we decided to put an external encoder directly on the part. I was wondering what is the best to approach to drive the servo using the position of this external encoder. Is there any way that it can be configured directly with the servo? I am fairly new to coordinated motions, any help will be appreciated. Thanks
  23. Alternative Servo Drives

    I'm sure many of you are in the same boat with supply issues and elongating lead times with the Logix 5500 and 5700 servo drives. Are there any decent alternatives that are easily integrated into a 5380 controlled system, maybe with an AOI? I've looked at Beckoff and Parker systems, but Parker only seem to line CoDeSys as far as I can tell. Do any of you clever clogs have any suggestions for a well stocked alternative? As a side note, I'm not new to PLC programming, but I am only 6 months in to using motion and servo systems so be kind :)
  24. Hello! I'm trying to connect my QD75M2 with a MR-J2S40B1 Servo amplifier with an SSCNET cable. The problem is when I try to turn on the Servo ON/OFF on the Intelligent function in GxWorks2, an error occurs saying the servo amplifier is disconnected with my QD75M2. I'm confident that I've wired it properly. What could be the problem? Hoping you might help. Thank you.
  25. simple motion cam curve

    Good afternoon, I have a problem in an application for a rotary knife, I'm using a MR-JE-B servo to make this movement, while my material is powered by an inverter connected to a modbus rs485 network, with a 5v encoder connected directly in motion. I'm having some problems and I think it's my cam curve. I have a very high refeneration, and the system doesn't obey the size of the length I want the cut. It always cuts the same size, regardless of the configuration I use, it always cuts to 245mm. Put some photos, how are my settings. Grateful in advance, if anyone can help me. Dover_roll_1-Motion-configuração_jog_manual.gx3