Search the Community

Showing results for tags 'rslinx gateway'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Found 47 results

  1. Hi all, I'm new to Allen Bradley but have some experience with TIA/STEP 7 - not that it relates to this issue! We have 2 side by side systems but running a SLC 5/05 CPU, with the same program but different IP addresses, connected via a network switch. All has been fine until both were power cycled - system 1 CPU program has dropped but not system 2? The IP address for system 1 has been reset and can't be pinged from either the switch (but 2 can) or directly connected to the PLC port. Steps I have carried out as below, so would appreciate anyone skimming over and pointing out where I've gone wrong/something else to try; - Used BOOT P DHCP tool directly connected to system 1 plc, add relation assign original IP address, click Disable BOOT P. - Attempt to ping (after changing laptop IP to same loop but different node) = no connection - same cable used to connect to switch and ping system 2 which worked so cable and adaptor settings good. -not going to help with the immediate problem but battery swapped out for new on CPU. Any assistance and advice appreciated!
  2. Hi and thanks for youre time  I am a newbie trying to connect to a 1769-L30ERMS using an Ethernet cable. I am using Studio 5000 and RSLinx Classic lite for programming and communication. However Studio 5000 and RSLinx Classic lite are installed on av virtual machine using VMware.  So my problem is two fold. Connect the VM so that it reads from the real computers ethernet port Find and communicate with the PLC from the VM There are guides on how these problems are addressed seperatly. For example https://www.youtube.com/watch?v=JdArYVceO1I and https://www.youtube.com/watch?v=ERLTvcBBK_w however I have not been able to get them to work together. So I was wondering if you, the sages of PLC programming might have some tips or trix that I could test or perhaps even a guide for how to do? Mvh Eric
  3. Hi All,Cx-Supervisor, NJ501-1340, Sysmac Gateway.I have been writing an update for a project and converting to this new controller.It's a pretty big project.Using a combination of Ladder and ST.Using Cx-Supervisor 3.5.I created some new Variables in Studio and made them Publish only.Started to create Points in Supervisor and made them I/O connected to the variables in Studio. No problems everything was connecting and working just fine.Then one of the points would not update. I could change it in the PLC and it would not change On the HMI.I deleted it and recreated it and it did the same thing. (sometimes points in Supervisor just stop working and recreating them fixes it).I then copied the control and pasted the old point into it and it did the same. Then other started to fail. Showing no reaction.I stopped the gateway and restarted, no help, I rebuilt the HMI, nope.The can check the tags in Sysmac gateway and they always change when the PLC changes but not the HMI.I checked the point maintenance in Supervisor and it would not change.I dumped all the affected variable in the PLC and in the HMI and recreated them. Then it got stranger.I could change some on the HMI and it would show in the PLC but not the other way.This is on Bools and UINTS.Stopped CX-server, tried using it with Win8 compatibility. nope.Pulling my hair out now. I should be coding but I'm trying to get the apps to work.Any ideas will be used with thanks.Peter
  4. Hi all, I'm new here and need an opinion from you guys on how to set the Gateway for PLC CP2E in CX Programmer ? From my discussion with supplier (OMRON), they mentioned it was unable to set any gateway for CP2E model but I found on some sources that for previous model for CP1L is able to set the gateway. Supposed to be the Gateway function can be supported by latest model, am I right ? Need an explanation on this, Thank You
  5. Hello everyone, I am a newbie with PLC. I have a Micrologix 1000. The last time I connected with RSLinx easy, however, I change it to DH485 (I do not remember exactly). And now I can not connect it to RSLinx, I tried many times for all types of drivers. Please help me. Thank you very much.
  6. We have an SLC 5/05 on our automation network, one of several SLC 5/05 processors on site.  It functions perfectly well and no ethernet messaging issues or SCADA drop outs.  The difficulty I am experiencing with it is when I am required to fault diagnose it takes a very long time to get online to it with our laptop running RSLogix500.  It sometimes takes as long as 10 minutes.  It makes no difference whether I use the Ethernet devices or the EtherNet/IP Driver in RSLinx, it nearly always takes an age which is frustrating in a breakdown situation.  I don't ever experience these long wait times connecting to any other of the SLC 5/05 controllers or any other controllers for that matter.  Once I am connected to the problematic controller I don't experience any issues, it's just the initial time getting online.  I try to leave the laptop permanently connected to it to avoid the long wait time to connect.  When I open RSLogix500, select Comms, Who Active Go Online, Ethernet devices driver, I can see that the problematic 5/05 has Active as its Status whereas the other 5/05 processors have Remote Run as their status.  Please can anyone advise as to any possible program parameters, RSLinx settings or hardware faults I should be looking for?  I have considered it could be a network problem but I'm unsure about this given how the processor performs well in every other regard. Neil
  7. I'm trying to develop an email application that will run an a PV+7. I've gotten it far enough that the email activex control quit posting error strings, but my mail server is not receiving anything. I realized that the HMI doesn't know how to get outside via a gateway address. I know I can set it in the HMI itself but it isn't available to me right now so I'm trying to test using the 'test application' feature.  I guess I just don't know where to setup a gateway address in factorytalkview me.    
  8. Hi! I'm using RSLinx Classic, RSLogix Micro English and RSLogix Emulate 500 to emulate a Micrologix 1100 Series B. I'm able to run, program and simulate different input and output with the emulated PLC. Everything works fine. My problem is that I'm writing a program using the nodePCCC library (https://github.com/plcpeople/nodepccc) and I'm not able to connect to the emulated PLC using the address 127.0.0.1 and the port 44818. I tried  running 'netstat -a' on Power Shell and I found out that the port 44818 is not being used.  Could someone help me identify what I'm doing wrong?
  9. First time posting. I'm upgrading an old Panelview Standard to a PanelView Plus on DH+ using a ProSoft gateway.    My question: I believe I do have comms established but I'm getting a host of errors  "Data Table N7:100 in SLC at 10.10.10.100 is too small or missing" It seems as though I'm getting the error for every data table in the old program. I used the import conversion on FT View Studio to replicate the screens and tags and so on. I am diligently doing my research trying to figure out what's going on but thought I'd throw this one into the great ether and see if anyone has an insights. 
  10. C# - Compolet missing

    Hi.  I have the CD with SYSMAC Gateway Runtime V1.6 and installed the full CD. I still cannot add a reference to Omron.Compolet in Visual Studio 2019. And the project i am trying to open, complains about OMRON.Compolet is missing. Any idea whats missing to get the OMRON.Compolet to show up in VS.Net 2019?
  11. Hi All, How can I collect the information provided through RSLinx in a ControlNet network, specifically on the Station Diagnostics Contronet devices? My idea is to generate some statistics errors and avoid some network errors failures.
  12. If this has been asked and answered already, please point me in the right direction. I have a production line that uses Gefran Geflex temperature controllers on a Modbus and Machine Net communication system. The main control panel (MCP) is the master on the Modbus and communicates directly with 3 slave Geflex units (Group Leaders?) which then communicate with the others in that group via a Gefran Machine Net type interface (ribbon cable daisy chained from one unit to the next). The issue is twofold: These temperature controllers are slowly becoming harder to find AND they are a PITA to change out because they have to be put in place and then properly addressed using software on a laptop. This means more downtime waiting for someone who knows how to set these up to get there to do it say on a weekend/middle of the night type situation. (I do like my beauty sleep). I'm looking to replace these units with standard SSRs and control them with a PLC (P-2000 most likely). What I would need to be able to do is interface between the MCP and PLC in some way that the MCP still believes it is controlling 24 units (24 Modbus IDs) and have the PLC receive the reads and writes from the MCP and know which ID it was meant for in order to set the SV and respond with the PV and/or alarm codes as that ID. I hope that all makes sense. Basically I need a way for a PLC to act as if it were 24 separate Modbus slave units. Could I just use a separate HMI next to the MCP? Yes, but there are temperature dependent routines in the main operation of the line (extruder run inhibit, etc.) that requires the information reported back on the Modbus. I've looked into Modbus Gateways but the MGs I've found so far don't seem to be capable of assuming the role of 24 different slaves and interfacing with the PLC in a way that would allow the individual control.  Any ideas would be greatly appreciated.
  13. Hello everyone! This is the first time I use Micro850 controller (2080-LC50-48QWB) and after I made a really simple programme (just for testing) I wanted to download it to my controller (which I was able to see and connect to via Ethernet and USB normally) and I got a message saying that firmware version didn't match (programme - v9, and PLC - v4). So I found some datasheet where was explained how to upgrade device firmware with ControlFLASH. I started the mentioned software, choose the right controller, and I choose the version 9 and the process started, but near the end I got the ERROR message, and the update wasn't finished successfully. So my controller went to fault (FAULT red light flashes) and now I can not see it in RSLinx nor via Ethernet nor USB. Does anyone have any idea what could I do to try to establish connection with my controller? I have tried to change from prog mode to run, and back to prog, but the fault remains. I really hope that I didn't make some serious mistake, because we need this PLC very soon for work. Thanks  in advance!
  14. Currently I am using DDE links in Excel to run a live "dashboard" with our cycle times and faults/downtime. I was wondering what the best solution would be if I wanted to display a dashboard with this information on a TV within the plant but I only have 1 license of RSLinx Gateway. OPC perhaps? SQL? I attached a picture describing what I need
  15. Hello PLC expert i need your help. i want to use OPC communication and Matlab to read and write data from/to a Logix5561. A Topic is already configured on RSLinx. On my PC i installed MATLAB and i can connect to the OPC Server using Simulink opc Toolbox. My Problem occurs when i want to add Items, i receive a Simulink error saying Name space Browsing not avaible. and Matlab says could not retrieve name space for Server. Error was: StartItemId is not a branch in the Server Namespace Additionaly i have RSView32 as an OPC Client too and although it is working fine, there is an error saying: OPC Error :Server the item is no longer available. could the error in RSView32 be the root cause of my Problem ? edit: I forgot to mention, that on Simulink opc read and opc wirte box have the Mention disabled in brace .
  16. Hi guys, I installed new MachineExpert v1.2 and Vijeo 6.2.9 on Win10 machine. When connecting simulation PLC to Vijeo to test my application everything is good. I go to PLC and check the nodename (see the pic attached) which I put in my Vijeo application and everything works. Issue is, because of my hard drive capacity I am forced to work via VM (but this is my preffered way also because of number of PLC softwares used). When I installed from the same installer (everything same as my local Win10) on Win7 VM when I run simulation I get empty space where the PC simulator should be visible which nodename I should type in Vijeo. Also I noticed when going to gateway management console in VM the process is active, same parameters as in host machine. Turning off the gateway on the VM turns it off as well on the host. Is there a known problem of connecting to simulator on VM? Or win10? Unfortunately I don't have Win10 VM to try right now.. Anyone can help? Much appreciated!
  17. Hello,   Target:  I'm looking to make an excel macro that will take an IP address and pull the components on that specific backplane. Pretty much how RSLinx Classic OEM does it, but it will save me a lot of time if I could automatically put the results into excel. Example: Enter IP "111.111.111.111" into excel, run the macro, and have it fill in the components on the backplane below. 111.111.111.111 00, 1756-L73 LOGIX5573 01, 1756-EN2T 02, 1756-DNB 03, ... 04, ... Any help that could get me toward this would be amazing. I'm just not sure of the code that would do this.   Thank you, MalSmith21
  18. Hi! I am using a Ethernet/IP and a Brainbox ED-588 as a gateway to a PLC that has 8 in and 8 out Digital IOs. In order to interface with other types of PLCs I am looking for a gateway that has 16in and 16out digital I/Os I have also been asked to work with NPN output, not PNP. This can be achieved using yet another component, but if possible I would like the gateway to be configurable with NPN/PNP output. N.B. The orignial protocol doesn't even have to be Ethernet/IP, I might be able to work with other protocols as the source. Products that I found do not have enough IOs   Thanks!
  19. Hi Guys, I recently purchased a 1769 L32e off of ebay. I'm able to connect to the processor through the RS232, but when I try bootp the MAC address is not being detected. I opened up RSLinx through RS232 and I noticed that I don't even have the ethernet port in the device tree at all. I also tried adding the MAC address from the processor in bootp through the add relations button, but with no success. When I go to my Local Area Connection, I can see that I have established connection between my computer and the PLC. I've attached a copy of the RSLinx capture below!!!! You guys help is greatly appreciated!!!!!
  20. I'm wanting to get upload the program from a CompactLogix L31 Controller.  I'm using a generic (non Allen Bradley) "C2G brand" usb -->rs232 cable coming directly off of my laptop because I don't have a serial port out.  The rs232 side of the C2G cable is a "pin out" or male end, and as you can see in the picture, the serial port at Channel 1 on the controller is also male.  I'm using a generic (non-Allen Bradley) null modem (female-->female) cable to complete the connection.  Ultimately, I'm not seeing the controller on linx.  But that's a result of me not being able to configure the driver.  When I try to auto configure this driver, Linx gives me an error saying, "Unable to verify settings due to a NAK!" btw, the rs232 cable going into channel 0 is for the HMI on the machine. A pv600 1. How do I get online and upload the program from the controller? 2. What does NAK mean?
  21. Hi, I have a task whereby I have to hook a WonderWare InTouch (2017) HMI, on Windows 10 through to two Allen Bradley PLCs both programmed via RS-Logix 5000. OPC comms between the HMI PC and the PLCs have to go through RSLinx Classic. The RSLinx Classic install has a paid-for OEM license. InTouch to RSLinx has to be through Wonderware OI-Gateway using Suitelink protocol. I can see and interact with PLC-generated data items at the output side of RSLinx using Matrikon OPC Explorer.  I can also see OPC data generated by Matrikon OPC Server for Simulation from within InTouch with comms to the Matrikon OPC server going through OI-Gateway / Suitelink. However, I cannot get OI-Gateway to talk to RSLinx, and so can't connect InTouch to it.  I have now found that this RSLinx Classic OEM license might not support interaction with Wonderware OI-Gateway. However, fruitless searching means I don't know if this is the case, but I still need to find out and be certain of  the facts before broaching the whole "we actually need to buy another RSLinx license" thing with the Powers That Be. There seems to be content on the Rockwell / Allen Bradley / RSLinx website which deals with it but (frustratingly) it declined to show me that content, appearing to suggest that I needed to pay for a Rockwell support contract before I could get access. I'll not get (too far) into the debate about coolness of this - or otherwise - when we've already paid for this RSLinx Classic OEM license and just want to find out if it will actually do what's required... Cuitting to the chase, could anyone tell me please which RSLinx Classic license I need to have in the setup above in order to be able to speak to RSLinx Classic from Wonderware OI-Gateway? There are 2 PLCs which RSLinx communicates with, but the two of them comprise two 'halfs' of the same overall system. I suspect the OEM license might have to be upgraded to a Gateway license, but I just don't know. Input much appreciated please! Incidentally, the OPC server has to be RSLinx - I'm not allowed to swap it out for Wonderware OI-ABCIP or Topserver etc Thanks      
  22. Hi Guys! A have a problem with Excel and RS linx. I belive the communication is good. I just need a few tips, especially with excel. I have about 3000 dint value, and aI dont know how to put them in excel at once. Not one by one. THis is my first question. You can see the link: =RSLINX|MC!'Database_fifo[0].Motor_rpm, L1,C1' the next one is =RSLINX|MC!'Database_fifo[1].Motor_rpm, L1,C1' and =RSLINX|MC!'Database_fifo[2].Motor_rpm, L1,C1' and so on. I dont want to write the numbers like 3, 4 ,5 ...2560... So I hope you guys get it, sorry for the bad explanation. For this problem maybe exsiting some macro or something like that, I dont know. The second: there is some dint what is in decimal style, but acutall they are ascii, I know how solve that, with the char function, but I dont know how to collect it. Like on the picture, there is the numbers what I read from the plc, like 82 equal to R. But I want to see them in one cell. Like RKBF-355, I want them in a same cell. Unfortunaltely I cant solve it. At least until now, and I hope somebody know it by memory.    Thank you in advance!  
  23. Hi Everyone. I need help bad. For some reason the RSLinx Classic on my computer was not working. I decided to re-install it but could not do that. Then I uninstalled it  but would not. I reinstalled all others but RSLinx would not. I cleaned the registry and again did not succeed either to install or uninstall. Does anybody have an idea what is going on? Please help. Thanks.
  24. FinsGateway Help

    First of all, I apologize if there is a simple solution, if there is, I can't seem to find It. I simply want to make and HMI talk to a PLC using Omron's FINSGateway/SYSMAC window's drivers.. Heck, if I can get an example that uses a simple Excel spreadsheet talking via DDE that would help. I have been writing custom drivers in Windows for years to send FINS commands back and forth to the various Omron PLC's, based off of a bit change either on the HMI side or PLC side. Super fast since only the data that has changed is written back and forth... Lately I have tried using DDE (polling type) communications as some jobs require this and not custom drivers. We use Wonderware Intouch for the most part and have found their DA and OI servers for Omron to be terrible at communications on large IO installations. Their IO servers essentially send 1 packet per bit or word every x msecs over the network according to a wireshark capture instead of blocks of word ranges. I was told FINSGateway / Sysmac Gateway could be installed on a machine and map via datalink( or the sorts) PLC memory to  psedo PLC memory on the windows computer; that the local computer mimics a PLC. The third party application can then read the local memory many times faster than going across the network to get it packet by packet. I can't seem to find a simple 'DDE' type interface with FINSgateway whether trying to use it locally or to a remote PLC. Usually a Topic name and an Item / Tagname....  I have used these DDE interfaces with other brand PLC controllers and their local driver, but can't find squat with the Omron Driver.  Usually you specify in the HMI a tagname and it is pointed to a 'TOPIC' and 'ITEM' that relates to an address in the PLC. Anyone have any type of info on this? I see posts in forums about doing this, but can't find any specifics. Again, I would think this would be basic beginner stuff, but can't seem to find any info on FINS/SYSMAC gateway  and how to make a third party app talk to it. It's been around for many years so I find this odd. Thanks for your time..  
  25. I am trying to setup communications between RSlinx and Softlogix on Windows 7 PC. I open SoftLogix and configure a CPU and Ethernet module. I then cannot open RSLinx GUI since RSLinx is already running as a service. I stop the service, which automatically removes my CPU from SoftLogix but does allow me to open RSLinx GUI. However I cannot connect to the Softlogix now since it has no PLC. When I try and add a CPU I get a message that RSLogix must be run as a service. However in that situation I cannot open the GUI.