Search the Community

Showing results for tags 'rs485 to ethernet'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Found 212 results

  1. Kinetix 300 Ethernet/IP Locks Up

    I am trying to use an Automation Direct Productivity P2000 to control a Kinetix 300 servo drive using Ethernet/IP.  I got the EIP working fine using Explicit Messaging.  The hardware enable and overtravel limits are hardwired ON.  The drive doesn't show any faults.  When I turn on the software ENABLE bit (bit 7 of byte 0 in the Output Assembly), the Ethernet communication stops.  Motionview continues to work, but if I disconnect and reconnect, it can't find the drive.  I have to physically power down the drive to reestablish Ethernet communication.  Once I power back up, EIP communication resumes with no issues. Any thoughts?  What am I missing?
  2. modbus_fb_11.pdfHello to everybody. I'm new I download from Omron France the FB to read form one or more instrument some register by Mod Bus RTU Every things is working well, but some register from the Instrument are on REAL. How i can get a REAL word with the FB on the attachment? Thank you   Modbus_03_Read_Holding_Regs.cxf
  3. Hi all, after my complaing about my lack of network access in the workshop ive been tasked with fixing this so ive have some general questions about networking and concerning Ewons so this network will be used for connecting ewons to test products as well as general computer access the plan is to have 7 computer access points as well as 2 points to connect to product lines for testing my intial thoughts were to run 2 cables from our network to 2 routers, 4 computer access points and one line testing connection on 1 and 3 computer access points and one line testing connection on the other so first question is what type of ethernet cable should i use? i assume cat5 is fine, is it worth going for cat6 or is it just a waste of money? and should i be running crossover cable or straight through? do i need any specific routers or will anything do? will i be able to add splitters later down the line and be fine? or should i future proof a bit with more robust routers? my years of avoiding networking at uni has come back to haunt me i know the basics but thats all really thanks to anyone who can offer some usefull information i mention the Ewon units because ive been told that they need to be the only one on their connection to the network, although i dont know how true this is  
  4. Hello all, I'm trying to control a robot over EtherNet/IP using Omron NX1P2. I have some experience in programming in EtherCAT with Sysmac studio for this robot but no prior experience in EtherNet/IP. I have the EDS file and based on this article I was able to develop the tags. However when I transfer the program to the controller I'm getting the following error and I'm unable to proceed any further. I do not know what I'm doing right or  wrong. If some one can guide me through the steps needed to setup an EtherNet/IP device and building a program with it, it will be of great help. I have set up the Task settings same as the way I do for my EtherCAT program. Is that the correct way to go ? Any help from this community is deeply appreciated. EtherNetIP_Demo.smc2
  5. Hi, I'm trying to communicate with a Keyence Laser Marker MD-X1500 through an RS232 IO module ( QJ71C24N-R2) , and i'm using the GP.OUTPUT command to send the request , and the G.INPUT to receive the Reply from the Laser !!!  No success .    ANY help will be really appreciated       Thanks, 
  6. Hello, Can anyone tell me what types of Ethernet/IP device the  QJ71EIP71 can be configured as? Explicit message server, explicit message client, I/O adapter and/or I/O scanner? I'm having trouble finding this information in the manual: https://eu3a.mitsubishielectric.com/fa/en/dl/12484/SH(NA)-081157ENG-B.pdf
  7. Hi all,  I am trying to configure an Fx3ge-24M PLC using GX-works 2. I can successfully connect to the PLC using the USB cable, however i am having trouble getting a connection via ethernet. I have attached a photo that contains the only ethernet configuration that i can find, what am i missing here? I'm new to GX works & mitsubishi PLCs.  
  8. We have an application using a Mitsubishi L02CPU-P with a built in ethernet module. At one time the TCP/IP interface became irresponsive and a hard reset was required. The device is configured for binary communication and works fine using a GOT therminal and also operates fine when queried from a GX Works application. During debugging of a custom MELSEC application the TCP/IP interface stopped responding and could no longer be located using GX Works and the GOT terminal also lost contact. The L02CPU-P continued running the control application, but could no longer be contacted. The only way to recover was using the L02CPU-P reset button. I have heard developers being restrictive using the TCP/IP interface remotely over VPN and unstable connection due to the risk of hanging the device and not being able to recover without a personal visit to the device. Any experience from L02CPU-P devices requiring hard reset to come "online" again? Or does it enter some default state due to some internal exception handling?
  9. Omron rs485 communication

    I am using OMRON CJ2M-CPU15 with SCU41-V1 communication module I want to establish communication (rs485 modbus) between omron and Schneider device for reading out electrical parameters. How I can do this? I could not find any manuals and this is becoming very hard for me. I want simply to read few registers from Schneider. Where do I set unit number, starting register, ending register, number of data? I was recently using Siemens and Unitronix and started working with Omron recenlty. Do you have any examples or manuals for this? Thanks in advance
  10. Hey all, I am having some issues with a Keyence IV2 camera which has Ethernet/IP functionality.  To summarize briefly, it has been configured and reading the data into my PLC (NJ501) into a structure data type.  The issue I'm having is that I cannot control this on a bit level for triggering the camera, etc.  I was reading that a Union type is the way to go, but unfortunately, I stopped getting data into the PLC when setting it up that way.  According to the configuration guide for Rockwell and setting it up in the Network Configurator, I needed to go with the SINT type.  When registering the device, the 8-bit option was necessary since the Input/Output sizes needed to match.  This was predetermined by the EDS file for the IV2. I am stumped as to how to get the data to read into the Union Type, and any suggestions would be greatly appreciated. Thanks, -K  
  11. Hi to everybody. I'm beginner on Beckhoff so I'm having issues with connecting Beckhoff CX8090 and Weintek EMT3070a. I'm trying to use Beckhoff TwinCAT PLC Free Tag names to get data from CX8090.  I have followed instructions in EasyBuilderPro which are pretty straightforward. On side of HMI I need to select proper settings which should be: IP: 192.168.1.2, Port no.: 48898, ADS port: 801, AMS NetID: 192.168.1.2.1.1 I have succesfully imported all variables from my PLC program into the EasyBuilderPro. For testing I tried to create HMI just to see status of few inputs. I have no issues uploading program to HMI, but after startup I get message Device no response and communication is not working. On side of Beckhoff I have settings like this: AMS NetID: 192.168.1.2.1.1 Ethernet port X001: DHCP Ethernet port X101/102: IP: 192.168.1.2   I can access to CX using input ports X101/102 and also access to HMI through same connection. I have also tried to log on to windows CE on CX and tried to ping HMI and that also went ok. Also I have tried to add static route on TwinCAT to HMI with settings AMS NetID:192.168.1.3, IP:192.168.1.3 but again no connection. So physical connections are CX8090 X101 - > HMI, CX8090 X102 -> PC. From PC I can access both devices. I'm using TwinCAT 2. Can you tell me what I'm doing wrong?   Thank you
  12. My project is to read an RFID tag (ascii) with a Micrologix 1400, send the string to a PC using Ethernet/IP, lookup and compare in an Excel spreadsheet, and send back data (probably an integer) for the plc to use to control direction. I have to scan and compare an RFID tag to a list of 1400 possible part numbers, at different locations (more than 1 plc). I want the several PLCs to go to a single PC to make it easy to update when changes occur (on a weekly basis). Has anyone done anything like this? I'm assuming there will have to be some kind of vb or c+ application involved.   Thanks,  CK
  13. HI all,   I was trying to connect my compass with PLC via SCU32 RS485 (2 wire ) in protocol macros.[ Unit 1 port2]  My send command is   " 01 03 00 01 00 03 54 0B'  &  Expected reply is '01 03 06 XX XX YY YY ZZ ZZ ZZ ZZ" I created a new protocol using CX protocol and created  a send message & a receive message command  and added to sequence 000. (refer pics) Also added PMCR instrcution in cx programmer (refer pic). I can transmit the data , but i cant see any recieve data in D2000. I am not sure what had done wrong, or am i missing something?   Any help is much appreciated!! compass_macro2.psw Compass_TEST.cxp
  14. Hi everyone. I have project to use PLC Mitsubishi Q03UDECPU with QJ71EIP71 to connect with SICK FLEXI soft Ethernet/IP (FX0-GENT00030). I have check both manual but when I turn on Y0 (communication start) there are error code F100h on my QJ71EIP71 and I check that it can only use with produce/consume tag from PLC (such as OMRON, Allen Bradley) but for SICK device it can use only for assembly instance. Then I have use Ethernet/IP scanner (Molex) to read attribute (service code 72h) then I can read status from SICK but as I told before QJ71EIP71 can only communicate with tag-based. Then I have to ask everyone that 1. Are there method that can use QJ71EIP71 to communicate by use Assembly Instance? 2. Could I set consume tag name on FLEXI soft Designer? 3. Are there any protocol gateway device that match with these solutions?
  15. Please could you assist with the software required to download data tables from 4 off DIRIS A10 Multifunction Meters into TM221CE40R Logic Controller via TMC2SL1 Comms Cartridge using Modbus Protocol over RS485. I have downloaded the Modbus tables from Socomec but not sure how to get these into the PLC. I would really appreciate your help in achieving this. I am using EcoStruxure Machine Expert - Basic to program the PLC & DAQ Factory Developer Release for my Touchscreen. Link to Socomec Modbus tables: https://www.socomec.com/files/live/sites/systemsite/files/SCP/6_gestion_energie/diris/diris_a10/DIRIS-A-10_COMMUNICATION-TABLE_2018-01_DCG01013_MULTI.html#General
  16. hi all,  I am using SCU32 ( unit1, port2, 2wire and termination OFF)  to get the RS485 data strings from the compass with setting 19200bps, 8 databit, 1 stop bit &  No parity. I can send the TX string ( 01 03 00 01 00 03 54 0B)  from D100 memory and  write the Rx data to D2000 (01 03 06 xx xx yy yy zz zz CC CC). But the whenever the there is no RX data, The TXdata bounce back to RX. (refer to video, d100 is TX, D2000 is RX). I also tried wth SCU32 termination resistance ON. Same thing. I am not sure what is missing. Should i use different logical Port for TX and RX ?    EDITED: Just tried another scenarios  1) removed the connector and tried , D2000 - was written the TX values  2) Disable the RX  changing  LD from P_On to P_Off. D2000 - was written to #0000 0000 0000 0000  I am not sure what is  happening., Open connection also TX data bounce back to RX   Appreciate all help Thanks a lot  video1.mp4
  17. Hello! I have a problem with Allen-Bradley High Speed Counter card 1734-VHSC24/C. I need to make changes to the configuration parameter .OnValue1 (DINT) during the system is running. Now, for changing the parameter value, I need to switch off the module and this can not be done during the line is running. I think that maybe this can be done using the explicit messaging. I could not find information for this from internet, so now I ask you to help me with this item. If anyone have experience or knowledge of this, please help me. I do no have experience using explicit messaging. My configuration: Studio 5000 Logix Designer V24.00, 1756-L71S V24.11, Ethernet/IP, 1734AENTR, 1734-VHSC24/C countermodule.
  18. Hello, I have been so many days trying to comunicate the multiway software trought a serial usb converter with the SCU31 device, using a omron function block to read a holding register, but I can't achieved it. Now Im receiving some frames on multiway, but there is always some errors. I was wondering if somebody in here that have worked previously with modbus and omron can be able to help me in how to configure everything corectly to be able to read the value from multiway, on the plc, and where is this value saved.  I'll upload some captures to show what I have done till now.    
  19. Heavy Ethernet Problem

    Hi Dears, I have one heavy ethernet network I have 21 station PLC (S7 300) that each station have one server & I have one server that connected to all of this PLC in center. all servers are in one ethernet network I want to know that this configuration is ok? ethernet network can support these number of servers? or may be network fail?
  20. RS232 converter to RS485

    Hi dears i have one cp340 (340-1AH02) that is modbus RS232 RTU master and one RS485 RTU slave. i want to use RS232 to RS485 converter is it ok? can i do this without any problem?
  21. Nachi to Proface over ethernet/IP

    Hi I am trying to connect a Nachi MZ01 robot to a proface (LT400M) HMI/PLC, I cannot seem to get the communications fully working as I have a response error on the proface and a I/O error on the robot pendant, I also cannot find the assembly instance in the manual for the robot to set in the proface device setup, I am using 256 Bytes in inputs and outputs, I have attached the proface software below. J2204 - Welding Cell V2.prx
  22. RS485 to Scale

    Hi guys, I'm trying to communicate with a scale controller (Rice Lake ACT20-AN) to read gross weight. Scale controller: RS485, ASCII bidirectional protocol, Baud 9600, Address 1, Delay 0, Parity None, Stop 1 PLC: Channel 1, Data Bit 7 (unclear if it should be 7/8), Parity None, Stop 1, Sum check code Exist, 9600bps, Non procedural protocol (should this be bidirectional?), Station number 2 (should this be different than scale?) I am using $Movp "$01t75CR" D6050, Movp K1 D6000, Movp K4 D6002, G.Output U8 D6000 D6050 M7000 which seems to work okay since M7001 does not turn on? I do not get any data, however, when running Movp K1 D6100, Movp k7 D6102, G.Input U8 D6100 D6150 M7100 at the same time as the G.Output instruction. I have attached the PLC program. Also, for wiring I wired the RS485+ to SDB and RDB, then RS485- to SDA and RDA as suggested by the scale controller manual. I then grounded the cable shielding along with SG and both FG connections.   Any help would be appreciated in figuring this out, thank you!  Scale_111219.gxw
  23. CJ1W-ETN21 Detection

    To all the gurus. We have a project now that is using CJ2M PLC. However some hardware is using 1 piece of ETN21 card while some machines are using 2 cards. Programs sequence is quite similar. However Customer wants us to be able from program side able to detect if there is 1 card presence or 2 cards presence.   Not sure if there is certain bits or memory in PLC that program can tap to "detect" number of cards that is presence.
  24. CIF41 Connection Problem

    Hi Dears I have one CP1H with CIF41 in its option port1. Firstly I connected to CIF41 ( ON DIP Switch 4,5) and I could download to CPU with ethernet FINS and I connected my HMI to this network and every thins be OK. after one week I power ON the panel and now CIF41 not working. every setting is ok (DIP switches and other settings). now when I connected to CIF41 no LED is on and my laptop network dont recognize the CIF41. can you help me? what is the problem?  
  25. GE ENET station manager

    HiI am just starting out at a new job full of GE systems.I have a IC695ETM001 ethernet card which has a RS232 port for Station manager access.I can currently see some info (such as IP, firmware version etc.) from the card when I connect with Putty and cycle the power but I cannot send commands to the card. I've tried Putty, hyper-terminal and a standalone Station manager terminal from GE but nothing works.Anyone know whether I'm missing something?