Search the Community

Showing results for tags 'program issue'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Found 58 results

  1. I am looking for how others have set up vertical axis motions using the Kinetix 5700 servo system. I have a 2 axis pick/place unit with a horizontal axis (X @ 2500mm) and vertical axis (Z @ 1200mm) that works as designed during normal operation. X axis has no holding brake and Z axis has a factory installed 24vdc to unlock brake. There is a GuardLogix L81ES control system that handles the safety and control. On pressing E-stop/opening Gates the vertical axis will stop the motion, apply the brake and hold with no problems. (2198-D032-ERS3 Drive, 2198-P031 Bus Power, MPL-B430P-MJ72AA X Axis, MPL-B330P-MJ74AA Z axis) The issue that I ran into was an accidental download of the program without activating the e-stop and the vertical axis dropped unexpectedly when entering program mode on the processor. I am aware that this instance was my fault as the programmer, however I am also concerned that this might occur again in the future if the controller ever enters fault mode or someone else completes a download. I have done some investigation with the "ProgrammedStopMode" parameter on this single motion axis and attempted all 5 options and the vertical axis still has a free fall drop for a second before the brake grabs hold - so evidently this is not working for me. (Page 24 of Vertical Load/Holding Brake manual - https://literature.rockwellautomatio...t003_-en-p.pdf) I am curious if there needs to be something done elsewhere as the X and Z axis are set up as coordinated axis? I also am unaware if I need to preform some action/parameter with the bus power supply for this? The current state of the machine as it sits now is preforming a MSF in manual mode after 5 seconds of inactivity or 30 seconds in auto mode. This axis is usually in demand every ~22 seconds. This will shut down the axis after preforming a brake test on the vertical load and seems to function OK, however it is still in the back of my mind the issues mentioned previously if we ever enter a controller fault while indexing. Thanks for your insight
  2. Allen Bradley 1747-UIC DH485 Issues

    Hi there, I am having issues connecting my computer to our SLC 5/02. We have a genuine Allen Bradley 1747-UIC USB to DH485 adaptor, I have read into it a fair bit and have tried many different things. I have removed pin 3 configurations from the ethernet (DH485) as advised previously.. I have tried many drivers to get it to work to no prevail. I cant even change the CPU over to a 5/03 as I cant guarantee the program we have a copy of is the exact one in the CPU, therefore I cant just change to a different unit and establish comms that way. Does anyone have a step by step guide to connecting the 1747-UIC to the PLC? Many youtube clips dont seem to work for me like they do in the videos.   Thanks a lot in advance if you can help!
  3. What Is a PLC Communication Error?

    PLC doesn't respond to communication requests or responds negatively to such requests. A PLC communication error can occur between the programmable computer and the devices it controls or when the technician attempts to program the device. If anybody have idea then share i am fresher now i learn it from CETPA INFOTECH. I think this is the best place to ask.
  4. hello every body.  I want to upload program from  HMIGXU3500 . I have  Vijeo Designer Basic v1.0   software Is it possible to upload program from this HMI.? I want to have back up file 
  5. Program lost after battery replace

    We think so we lost the program after a battery replace, because the program isn´t loaded on GOT. Is it possible restore it by the PLC?
  6. This course is designed to equip the novice with no prior PLC programming experience with the basic tools necessary to create a complete PLC program using ladder logic common to most current platforms. Use Software : - Somachine EcoStruxure Machine Expert Basic - Free - Vijeo Designer Basic Full Articel About Lear PLC Schneider  Video Tutorial Learn PLC Training Free
  7. Gentlemen, I'm new to Siemens and now working on a project for my client. I have a S7 1241 cpu,  CM1243-5 com module, a KTP700 hmi prifibus dp. The hmi is connected to the CM1243-5 via profibus cable. My problem: I'm not able to detect the hmi. My plc is connected to my router and I'm able to get online with it.  I've attached some diagrams..just in case. Appreciate any help. thanks, Moorthy.   
  8. Granite Line Polisher Machine

    Hello friends, I have been working on Granite Line polisher machine. I have completed the program but there is a requirement for polishing the Uneven shape of granite slab. Has anyone worked on logic of this machine? Can anyone give some idea for the logic or the Plc program. I have seen Chinese machine manufacturers giving this feature. 
  9. Cannot Connect to CP1L-E

    Hi guys,     I was programming my CP1L-E over ethernet with no issues at all. I did get an error when uploading my program regarding cycle time, so I went into PLC->Settings->Timings and changed both values to maximum (4000*10ms watch cycle time and 32000ms constant cycle time). Once I restarted the plc it just wouldn't connect. I've tried option cards CP1W-DAM01, CP1W-CIF41, CP1W-EIP21 and i just cannot get comms with the PLC. I can see the CP1W-EIP21 card on my computer, however,, in its own IP address. From what ive figured, the plc is getting stuck somewhere in its boot cycle as I am unable to ping it either. The POWER and RUN lights are both green, and the LNK/ACT light flashes when i connect an ethernet cable to the inbuilt ethernet port. Any help is appreciated, thank you! Any way to factory reset the whole plc or even just the settings? I've disconnected the battery for 30 minutes before plugging it back in aswell but that did not help me.
  10. Hello,, I have motion controller A series A172SHCPUN,, I have written the program ladder into the CPU, but I can't write the motion program.. i dont have the program to open file the program motion and I want to ask if I have the software SW3RNC-GSVE, my os computer is window XP, Can it be installed? and is the cable transfer used the same as the ladder transfer program cable (SC09)?
  11. Mitsubishi GT DESİGNER GOT1000

    Hi,  I need this program Please help me  R.lotfi@gmx.com
  12. Hello folks,   I am a rookie, self-training in PLC programming. I have written an SFC exercise (attached ACD file). I also try to call STL written subroutines and add-on instructions, from within the SFC main program. Calling the created subroutine works fine, but calling the add-on instruction fails from a reason which is above my level. I tried, tried and tried different solutions, with no avail. I am either wrong in writing the add-on (perhaps some missing but missing tag ?), or wrong is calling it. Can someone please give me a hint on what I do wrong ?   Thank you, Radu PS . I use Studio 5000 v24, combined with RSLogix 5000 Emulator.     SFC_trial.ACD
  13. PLC trainee

    Version 1.0.0

    57 downloads

    SFC test file; cant call an STL written add-on from SFC main program
  14. PLC trainee View File SFC test file; cant call an STL written add-on from SFC main program Submitter Radu Babau Submitted 02/04/19 Category PLC Sample Code
  15. Hello I would like to first let everyone know I am new to the world of troubleshooting or programming plc's . What we have is a SLC500 system that is connected to a Panelview 1000 HMI via the DH+ network. The issue we have is the panelview displays a gate that is suppose to be closed at as gate fault. When i connect to the plc the ladder rung shows that the gate is closed. To show various positions of the gate the programmer used N13:70 as gate opened and N13:71 as gate faulted and N13:72 as gate closed. When i checked the logic it showed the bit N13:72 as engaged or true if you will. This logic is in the ladder rung that is labeled PV Status which i take is the status the HMI reads so my question is why does it show GF when it should be reading GC. Ive searched all through the logic and it doesnt appear to be wrong here is the logic the best I can simulate it  ladder 6 rung  53  instruction is  XIC O:13.0/11 and OTE N13:76/0 (Gate Open ) and the branch is XIC I:5.0/11and OTE N13:76/1 (Gate Fault) next branch is XIC N13:3/11 and OTE N13:76/2 (Gate Closed which this section is green or highlighted or true which ever you like) when i looked at the input XIC N13:3/11 this is what I found is that this XIC is on ladder four rung10 and has the following XIC T4:154/DN and branchoff that is XIC I:5.0/11(gate opened)XIC I:6.0/11(gate closed) which these two inputs are false or not lighted the output is OTL N13:3/11 and it is true which makes the previous rung true showing the gate closed. So why is the panelview showing the wrong position. I even went as far as resetting the HMI and the PLC so if anyone has a helpful hint I would greatly appreciate it.
  16. Panasonic FP0 C14RS

    Hi All, I am new to the forum and new to programming PLC and like every newbie I have a lot of questions - Brief History of me - I had been a Manufacturing Technician for 20 years and recently got my BS on Electrical Engineering and now working as an Equipment Engineer. The main reason that got me interested in PLC's is my degree,  the field that I would like to get into and a recent problem that arise at work. My experience with PLC is very small in programming, some in TS I/O- However I had been studying by my self to the point that I built a test bench to understand it better and in the future create different project for learning purposes Currently I am putting together a tool Alarm delay program - Basically my exhaust sensors trigger an alarm (input signal turns OFF) before its send  the signal to my tool for abort, I want to create a different Alarm which will cause a different response from my tool and delay the original Alarm by 10 min and then trigger the original Alarm - PLC = Panasonic FP0C14RS  Reasons: Create a different Alarm: The response from my tool to this alarm will allow me to return my material back from the tool and put it in a safe spot. Delay the Alarm: Use a timer to perform this tasks - This the time that approx. it takes the to return the material. Trigger the original Alarm: I need to know which sensor was the problem in order to properly TS- So after my timer is complete - I want to know which sensor created the original Alarm My Current problem: I created the LD program, and while the original alarm stays OFF the program works fine - but since my exhaust sensor are always on - If my original alarm is trigger for  a few seconds, just enough to start my Delay Alarm: I dont have a way to know which sensor trigger after my Delay(Timer)is complete,  I reset my relays in order to be ready for new alarm.   Please provide feedback to my program - I know currently is not the best way or efficient way to do this and there are better ways, but my plan is to get it to work and then later revisions improve the way the program can be written   Thanks in advanced for your feedback and help Exh_delay_inv_rev1.pro
  17. ladder program

    Hello everyone, I want to know why the Y172 coil is ON / logic 1? whereas contact SM1 is worth OFF / logic 0? can anyone explain it to me ?
  18. Hello.. I have hmi Proface GP-4301TW, USB type B cable and ethernet cable. I want to transfer the program to the hmi but I cant. When I turn on the power of hmi,  a series of test appears and finally it looks like the photo below and I cant enter the offline menu.. can anybody help me to solve the problem?
  19. HI All, i am new to this site, if anyone can help me out for below topic. I am trying to communicate E1101 hmi with Q06UDEH PLC but its giving me continuous communication error. i am using e designer for hmi and gxworks2 for programming. i am attaching the communication screen shots for both,i am quite stuck at this point as i have used all options still not able to solve it. if anyone can help me out with this,help is much appreciated. Thanks in advance  
  20. Please,if anyone has a working program (.stx).I need it to test a PL7 JUNIOR software
  21. Hi, In conception phase we currently use GXWorks to upload programs to PLC (L-Series). In production mode, for different security reasons we would like to automate this transfer so that the operator does not access directly to the program. Do you know any tool allowing this by using command lines and not GXWorks UI ? (GXWorks does not seem to be "command line" friendly As a POC I  have automated the GXWorks UI in C#  (by simulating menu or buttons clicks) but I don't find it reliable (what if an unexpected popup "pops" ? ). PS : I am a totally noob in this PLC world so maybe I missed stg in the docs ... 
  22. recover program from plc-5/15

    A machine was bought at auction which included PLC-5/15 module.  It did not come with a backup of the program.  Our maintenance technician said the program would not load and turned the module over to me (IT).  I notice the battery was installed in '92 so am assuming the program is lost.  Is their any internal memory or last ditch effort i can attempt to recover the program from this module?
  23. Multiple branch

    Hi Guys! You can read my problem below, if anybody can help, please do it. Thank you. So, I have 4 knife. You can set the cutting width for each knife separately. The problem is, there is a lot of size. There is an example: No1 size:  #1: 20 mm, #2: 25mm, #3: 30mm, #4: 25mm   (#1=Knife1.......)                                       No2 size: #1: 22mm, #2:24mm, #3: 32mm, #4: 27mm What is make the problem more difficult is There are plenty of type code too. Like X1, X2, X3, Y1, Y2, Y3 ..... This is the main material code. and you can choose the belogging size. So you can select for X1 to No1 or No2 ... but you can select for X2 to No1 or No2 or any sizegroup you want. I can solve it with a lot programming, like deal every possible situation ... but there is a lot time .... :S  There is a touch panel where you can set the values.  Anybody have another idea for this problem ?    
  24. We have a QSeries PLC. Q25HCPU. We also have a PLC program. We found that the address registers (also known as device addresses) attain a z-value added next to it - automatically over time. We are not sure why this is the case. Nonetheless, when these values get added (by the PLC - not the engineering software), some of the functions in the PLC doesn't work. We found that by formatting the CPU, and reloading the program, allows for the system to work again (temporarily) for a few weeks, up until this problem occurs again. This problem occurs across various CPUs (eliminating the potential for hardware problems. These z values can be seen when a program comparison is done. (see attached file). The questions become; 1. What is the function of these values? (why does the PLC add them? 2. How can they be permanently removed?