Search the Community

Showing results for tags 'output status'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Found 37 results

  1. Evening, I struggle with simple task... I need to activate PLC Output at the specific time of a day. I`m using GSV to obtain PLC time, data is being moved to DIN[7] registers. Then I have three EQU (Hour / Minute / Second) and at the end of rung there is OTL for output. Rung below I have two EQU (Hour / Minute) to disable output at different time - OTU. However every time OTL is energised , OTU on rung below is fired too. What am I doing wrong here ?
  2. Hello, I need to control a stepper motor(have stepper driver) using NX-PG0232-5 with NJ301 PLC. The function is simple, i need to run the stepper motor continuously at a specified velocity. So, in NX-PG module I've made the settings (Ch1 output mode as "Velocity continuous pulse output") and given the tags to IO (as shown below, sorry i'm not able to attach image). I've also added the initialization program to switch on the vfd. Now to move continuously i should should just give speed in pps in "PG_Ch1_Command_Velocity" right?      Ch1 Controlword    Control word 1    W    WORD                 Ch1 Switch On    Switch ON for pulse output 1    W    BOOL    PG_Ch1_SwitchOn        Global Variables     Ch1 Enable Voltage    Start turning on the power for pulse output 1.    W    BOOL    PG_Ch1_Enable_Voltage        Global Variables     Ch1 Quick Stop    Immediate stop for pulse output 1    W    BOOL    PG_Ch1_QuickStop        Global Variables     Ch1 Enable Operation    Start operation for pulse output 1    W    BOOL    PG_Ch1_EnableOperation        Global Variables     Ch1 Fault Reset    Reset errors for pulse output 1    W    BOOL                 Ch1 External Output    Aggregated data of external outputs for pulse output 1    W    BYTE                 Ch1 Command Position    Command position of pulse output 1    W    DINT    PG_Ch1_Command_Position        Global Variables     Ch1 Command Velocity    Command velocity of pulse output 1    W    DINT    PG_Ch1_Command_Velocity        Global Variables  
  3. I have a Base tag of BOOL logic that will not activate the MOV output.  The Base tag is paralleled with an Alias tag for a NO pushbutton.  When the pushbutton is actuated it produces the desired output.  Has anyone encountered this issue from a togglebit base tag before?  Why would a base tag produce a different outcome from that of an alias tag that function properly?
  4. rc01cpu and r60da4 help needed

    Hi every body, could you please help me; i have a mitsubishi plc serie iq-rwith the followings modules:powersupply r61p, r01cpu , rx40c7 inputs , ry10r2 outputs , r60adv8 analoginputs and r60da4 analog outputs. i am newbe with mitsubishi plc ;i would like to learn using the analog output of the R60DA4.for exemple i would send a digital value to the ch1 and convert it a voltage that i can mesure on the output of channel1.i have tried but i didn't succeed.i am using gxwork3.i have configured channel1 as +10v -10v output, normal mode , normal output;then i made a simple program in sfc to try this conversion but i get nothing in the output of channel1. i found that the digital value should be sent to the adress D11 wich is the adress of channel1.here you will find the file i made with gxworks3.could you please help me. ANALOGOUTPUTSCF.gx3
  5. Hello. I can't find any related bits wich would indicate PLC offline / online status. I'm using two PLC's. PLC0 Modbus TCP (Ethernet) PLC1 Modbus RTU (Serial) Please help me to get online status. BR, Andrej. 
  6. Hi all,  I am in the process of doing a project for some school work and need to do a SWOT analysis of the latest modular PLCs from Mitsubishi (R series), Siemens (S7-1500) and Allen Bradley (ControlLogix).  So I thought what better way than to ask the people on what they think are the pros and cons of each! Thanks for your responses in advance!
  7. b&R 4PP015 Error

    I have a 4PP015.0420 panel with the led error that stays between green and red, and it doesn't work.The sequence of the LEDs at power:       Yellow   Red       Green   Red       Green   Green       Green   Green&RedAnd on the display :          Version    1.1          Status     400041000I think there is a Status Register that indicates the errors.How can I see it to know why the PLC is not put in RUN?Thank you in for your help.Sorry for my english
  8. I have IPC and need to detect status of IPC and PLC communication . I need help with the same that how can in detect it ? Is it possible with message instruction ? if it is then how ?
  9. Best Practice Rack 0

    Is there any reason not to have input and output modules on the same rack as the processor and Ethernet cards? We have RIO’s and sometimes have networking outages, I want to move critical IO to Rack0 the same rack as the processor, is this bad practice?  I've seen architecture for BMS that only have Ethernet cards and processors in Rack 0... 
  10. Control Panel

    Is it possible to view the values / states of all inputs, outputs and workbits (e.g. 64.00 through 64.15 on Omron CQM1 PLC) on a single screen or control panel within CX-Programmer software?  I'm trying to troubleshoot some ladder logic that I wrote and need to know the values of 5 or 6 inputs/outputs/workbits simultaneously.  Having to scroll up and down through my ladder logic repeatedly does not work well with code that changes state every 5-10 seconds or so. Any help is welcome.
  11. Using a AD041 and DA041

    Hi, I'm using a CJ2M CPU 33, and also a CJ1m Ad-041-V1 Analog Input and DA-041 Analog Output card.  I am using the Analog input to measure my current in my one heating application and  Ihave that reading and scaled correctly, but now  I want to use my Analog output to replace the Rheostat  we have in the system. I'm having some issues setting the range and getting voltage to vary. I also am a little new to Analog Outputs and don't know what I'm doing wrong. I have attached my program here. Any help would be greatly appreciated. Analog Heat.cxp
  12. Omron Hardware

    Please let me know if it is allowed to sell PLC hardware on your forum. I accumulated lots of Omron hardware  that I want to get rid off. Here is the list, I have several of each type, asking $12 each plus shipping. All in working condition.  Base Unit C200HW-BI051 Base Unit C200HW-BC101 16 Point DC Input Module C200H-ID212 16 Point Digital Output Module 24VDC C200H-OD212 Power Supply Module C200-PA204    
  13. OD212 Card Outputs not powered

    Hello! I'm running into a problem with a malfunctioning OD212 output card on my PLC.  I figure the problem has something to do with my wiring, because I've put 2 different cards in with the same results. The card is unable to switch any of the relays I have as outputs although the indicator lights on it are functioning as expected. The setup it is in is: A PA202 power supply, followed by a CJ1M CPU13 CPU, 2 ID211 input cards, and 3 OD212 output cards. The bad card is the second OD212. All of the other cards work fine, it's just this one that's been having problems.  8 of the terminals on the bad card are hooked up to relays that each draw 0.02A and two more are attached to relays that draw 0.05A. So in total that's 0.26A if all the outputs are on at the same time (which they never will be.) I saw someone was having a similar problem to me on the forum, which was solved by switching out the PA202 supply, but that didn't work in my case. I don't think the problem lies with the PLC or the card's placement in the rack because I switched the card's position with the one next to it (output card 2 switched with output card 3) and tested that card (output card 3 in output card 2's place) without hooking it up to the original wiring and it worked just fine. However, I was still getting the same issue with the bad card even though it was in a different position, leading me to believe that I fried it somehow. Some other quirks of the bad card are that its outputs do not turn on and off with the indicator lights like how the other OD212s do. Below is a link to a video that shows this. The bad card has already been switched with the one next to it in the video - so it's on the end, but it's original position was second to last. https://youtu.be/wTvvGCHFpsc ( you may want to watch it at half speed ) So what I'm wondering is: how am I frying these cards / Is the problem easy to fix or will I have to send them to Omron? Thanks in advance!  
  14. Hi there, is somebody experience whereby the output of the 1769-OF4Ci is not responding on the value entered?.  Setting: 4-20mA Res: 0- 32767 - PID set whatever value I key in the output current remained.  please help. Ganie
  15. I am new to Automation Direct software and how the programs are written. Can anyone explain how they handle the analog outputs? My processor does not support the IBox that makes life easier, so I am having to do it the old hard way. I understand most of the logic of how its done for sending data to one channel but I don't understand how the channel selecting works. Can someone give me a programming example or explain how that works? I am looking at the online manual that Automation Direct provides for you for the analog module but I am having a difficult time trying to wrap my brain around how they do their analog stuff ><
  16. Hello I have a scenario that's been bugging me for some time now. The scenario consists of a Micrologix 1400 that I need to control it's output from modbus/tcp. In detail what I really need is to be able to manipulate the O0:0 through modbus/tcp. The PLC would be the master and I would be the slave that triggers the connection to the master. I'm using a Modbus-Client on my PC and that should be the slave. Any idea as to how I can manage that? Currently I can send data to the master but everything is "stored" on B10 and I have no idea how I could write directly on O0. Thanks a bunch guys. PS: I'm borderline noob. 
  17. ANALOGIC BIPOLAR OUTPUT - HELP

    Hello everyone,   I'm a student who recently started programming, and I could really use some help.  I have a CPU-31 CJ2M OMRON PLC and a ADO41-v1 analogic card. I need help programming an analogic scale with a bipolar signal -10V to +10V to then control a drive, which will then control the motor. If anyone could help me out of give me some examples I'd be really thankfull.   Thanks!
  18. Gang, Hooking up an Automation Direct P2-32TD2P to an AC/DC LED and noticed the LED is always "on" a little bit. When the output is on, the LED is certainly on, but when the output is off the LED is still on by a fractional amount, not much but it's plainly noticeable the room lights are off. The CPU can be in Stop, no matter, power just has to be on. I think this has to do with the card's load disconnected error functionality. +24V and some fraction of amps is always present at the output whether the output is on or off. I talked with automation people at work who noted there is an Allen Bradley system that does the same thing, it caused them a problem, they had to use a relay or etc to make an off output actually be off. Has anyone dealt with this? I'm new to the Productivity software, but there doesn't seem to be a way to just turn it off in the IDE. It seems ridiculous to have to wire up transistors or relays just to have off be off. Thanks for any ideas.
  19. I want to unify my programs and select only configuration words (the same program for many applications) . My problem is with the assigned outputs by the high-speed pulse output like PLS2, ACC, ORG ... I thing that the instructions JMP/JME may allows to use these outputs as normal outputs when HSPO functions is not required. Is it right ?
  20. Good afternoon Mr.PLC forum members.   We recently had a fuse blow on the wiring between a 1756-OF6CI analog out card and a control valve (which we have no feedback for - only the 0-100% output). Took a little longer to troubleshoot since we have no feedback and we also don't monitor individual channel status of the card. For input cards (1756-IF8H or IF16H), it's easy enough to use the under-range/over-range or broken wire signal to troubleshoot a blown fuse or bad connection, and activate an alarm. I have been told by our local consultant-technician that there is an equivalent monitoring bit for output cards. Reading the instruction manual for the 1756-I/O cards, the fault channel bits do not seem to have this type of function for the 1756-OF6CI. The fault bits only seem to look at the requested output values, and at the connection between card and PLC itself as far as I can tell.  Am I missing something?   thanks for your help
  21. I'm looking for some general information about different types of vibration/temperature sensors. What type, brand, model number, etc. will best fit my application.  Scenario: I want to monitor the vibration and temperature of multiple motors and gearboxes for a large overhead conveyor system. If an oil leak occurs and temperature increases, I want to see a temp. alert via a HMI. If a something mechanical fails, I want to see a vibration alert via a HMI.  I've looked into sensors that stick to the outside housing of the motors or gearboxes via a magnet. My concern is justifying the temperature readings. How accurate would a sensor that reads an "ambient" temperature be (compared to a thermocouple on the motor coil itself or some sort of probe)? Also, would the location of the magnet  on the motor or gearbox drastically affect the temp. or vib. readings? Has anyone had success with a similar setup? If so, what devices did you utilize? Are these systems truly beneficial?  I'm currently considering Banner's wireless products...
  22. I hate to start a new topic on such an old processor but I forced to keep this thing working until I can upgrade it.  We are having funny issues with outputs.  At first they were on a PLC5/60.  We suspected a bad processor so we changed to a PLC5/40 we had in our tool crib and the problem didn't go away.  Some of our outputs in the ladder are being evaluated to true but not turning on.  We can force the output on and it will come on and when we remove the force it will turn back off.  I've never seen this problem before on any processor.  All the logic leading up to the output is true but the output is not turning on and is there not green. I've already checked all the obvious causes.  The instruction is an OTE.  The output is not duplicated somewhere else in the logic that is turning it off.  The ladder file is being scanned.  I replaced the output with a B3 bit and on the next line had the B3 bit turn on the ouput.  The B3 output bit turned on but the output did not.  This output is on a remote I/O rack and other outputs on that rack are working. Any ideas would be greatly appreciated.
  23. Hi I am searching for plc having negative analog input and output. i.e. 0 to -10v analog i/p and Analog o/p.  Can any one help me in finding plc which has this feature .  Thank You  
  24. Hi, Iam new to schneider electric PLC drive programming and also to canOpen communication. I have an LMC058 PLC and there are three Lexium 32A drives connected via canOpen which inturn controls three servomotors. My question is how to find/ read hardware limit status of the axis in which limit is connected to a digital input pin of the drive. Even though the axis is properly working by configuring the digital input pins we are unable to get the digital input status of the drive. In the drive manual its given that the digital input status can be read from canOpen address 3008:F(hex) we dont know how to read the status during run time in the program . Can any one advise me how to read that address. I tried SDO_read function but its giving me error(canOpen network id Unknown). Thanks in advance.
  25. Fx3g Binary bit Output

    Hello, Need your advice. I am trying decimal number convert to binary and do output. for example If inside  D90 I have 11 decimal number then for me need active output Y0, Y1 and Y3. I tried make this code below, but it is not work, don't active output . Maybe fx3g PLC have function how need to do it?