Search the Community

Showing results for tags 'omron cp1h'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Found 477 results

  1. Hello everyone I'm trying to measure the size of an object 20mm long with an error of +-0.05mm. then which camera of omron should i choose and how to calibrate it to get the most accurate measurement. What is the formula for calculating the measurement error of the camera? Thanks
  2. robot omron i4

    hi everyone i am wanting to connect PLC to I4L via tcp/ip. However, the documentation was not found. If someone has already done it please guide me.
  3. Hi there This attached pic I got from Omron motion control manual. I am trying to wrap my head around it. Does it mean that the slave servo axis is gonna follow master encoder axis using GearIn FB?? If so, then Can we executive Move FB on encoder axis? Looking forward to your responses.  
  4. Hi all:   Hope somebody will help me with the below error encounter on the NA. I mapped a external device (NJ PLC) variable (which is a structure) to a NA Global variable and the structure is automatically created in the NA data type as expected. I then create a new NA global variable and defined its data type as the auto created structure. However i observe the created new NA global variable is highlighted with an error "a data type cannot be used by both mapped and unmapped variable ....." ( pls refer to the attached screen).  I have found and view on the Youtube this video :"Introduction To The NA DataTypes" (link: https://www.youtube.com/watch?v=VZxWnVn1CSY). that clearly show the "imported" structure can be used for unmapped NA global variable even there is some variable already mapped to external device variable (starting from the 3:50minutes mark of the video). In my NA program i would need to create such unmapped variable for my logic use. Also i observe that i was unable to delete the auto created structure from the NA Data Types even after i deleted all variables that are defined with that specific structure. How can i delete such auto created structure in case i want to clear off some of those unused data types. I am using Sysmac Studio version 1.30.0.17. The HMI Device created is the NA5-9W00 (version 1.11)          
  5. Remote Omron and Yaskawa control

    Information : On the websites - https://abrysshost.web.app (and https://abrysshost .firebaseapp.com ) detailed information about the construction of remote diagnostics and control (Iot) systems for control systems of objects based on OMRON and Yaskawa controllers. The information is presented in Russian and English.
  6. Hi everyone, I'm new here. Thank you all in advance for the help you can give me. I have one machine with PLC Omron NJ101-9000, and this is Server in the Modbus communication. In the attachments, you can find the function block I used to communicate with 1 client. This work OK and I don't have problems, but I need to communicate with 2 clients at the same time. This block only admits one connection at a time. How I can connect 2 at a time? If I create 2 of these blocks, does each client need to connect to a different port? Do I need "open" this port in PLC configuration?   Thanks!
  7. Here is a step by step tutorial... Utilizing the CX Server DDE Manager will allow us to provide a link to the information in the Omron PLC. This link can be placed on an Excel spreadsheet. Charts, graphs, etc. can be made from the data. We will create links on an excel spread sheet from a CQM1H and a CP1L PLC. The information will then be displayed as a bar graph comparing the first ten memory areas. Here is a step by step tutorial... Watch on YouTube : Implementing the Omron CX Server DDE and Excel Let me know what you think. Regards, Garry
  8. Hi. I have this project where we read out data from temp sensors and vaccuum stuff. We use Pfeiffer vaccum cpt 200 for the vaccuum, and we create a frame to send to the modbus unit to pull a value from example '306'. With all the current items we pull data, all the values are only updated every 5 seconds, is there a way to perhaps pull several frame/addresses in one request per device? Current codes we read, some are in sequence of each others, but more has a bit of gap like 00, 02, 306, 307, 398, 330 and so on.    
  9. C# - Compolet missing

    Hi.  I have the CD with SYSMAC Gateway Runtime V1.6 and installed the full CD. I still cannot add a reference to Omron.Compolet in Visual Studio 2019. And the project i am trying to open, complains about OMRON.Compolet is missing. Any idea whats missing to get the OMRON.Compolet to show up in VS.Net 2019?
  10. Hello every one in this video, you will learn about AccumulationTimer in Omron Sysmac Studio. The AccumulationTimer instruction accumulates time during which the timer input In is TRUE. The time is set in nanoseconds. If reset Reset is FALSE, the timer starts when In changes to TRUE. Total time ET is incremented as time elapses. The timer stops when In changes to FALSE. The value of ET is held.  https://www.youtube.com/watch?v=KSSmApnKHR0  
  11. Dear all. I have the issued with Sysmac Studio 1.30. it can not show the Library setting and Library create. just show the reference only. can you pls help me this issued. Many thanks.
  12. Hello Everyone, I am writing one logic and need some help regarding that logic.   CURRENT LOGIC -  -There are two timers TON_1 and TON_2. -TON_1 timer will start as soon as PLC turns on. -After the done bit of TON_1 timer, the TON_2 timer goes on. -After the done bit of TON_2 timer, again the TON_1 timer will start. -This logic cycle will run continuously, both timers will run turn by turn. Code (Codesys/Schneider Eco Structure Machine Expert)- PROGRAM POU_1 VAR      TON_1: TON;     TON_2: TON; END_VAR TON_1(IN:=(NOT(TON_2.Q)) , PT:= T#100S); TON_2(IN:=(TON_1.Q) AND (NOT(TON_2.Q)) , PT:= T#20S);   Actual Requirement -  -There is a BOOL tag. -If the BOOL tag gets high during the TON_1 running, the logic should move to the TON_2 immediately. -If the BOOL tag does not get high during the TON_1 running, the logic should move to the TON_2 after completion of TON_1. -after the completion of TON_2, again restart TON_1. -Logic Runs continuously in a cyclic mode.   Give me your valuable idea to fulfill the logic requirement.
  13. Hi everyone, To explain the problem a little bit: I have 2 systems that are equal, they have 1 PLC, 1 Inverter and 1 Servo Axis (Image01). The devices are connected via EtherCat. The thing here is tht in these systems the PLC and Servo Axis is the same but the inverter is different. My goal is to have the same project on both systems and depending on the inverter detected use the correct program. What worked: If I add the 2 Inverters and 2 Servo Axis on the project on different nodes (Image02), I can detect which is present using the variable _EC_EntrySlavTb[n]. My issue is that if I want to make more replicas of the systems using different inverters I will eventually hit the Axis Number limit for the PLC while in reality I am only using on Servo Axis at a time. What I wanted: I would like to be able to control 1 Servo Axis with 2 different inverters (only one active per PLC) (Image03). What I tried: The axis parameters can be set using a variable of the type _sAXIS_PARAM, however it seems that the option to change the axis basic settings is not available (Manual: NJ/NX-series Motion Control Instructions Reference Manual (W508) page 5-58) (Image04). The axis basic settings is where the definition of the output device plus control words are set (Image05). Is there a work around to solve this issue? I would really like to avoid having to manually change the output device for the Servo Axis every time I make an update on all the systems.   Best Regards, BR  
  14. Hi All,  I am trying to limit the number of character for user to key in data edit . However, I put numbers inside it shows me invalid number of character. Anyone know how to solve it ? Note; My variable is in String Type   
  15. "PLC No Response" NB HMI Omron

    Hello Everybody, I continued to work on project this morning but I seem to be plagued with the "PLC No Response" error. This error will only come up when I assign a PLC address to a particular object.  I have followed the steps in the post(https://forums.mrplc.com/index.php?/topic/39885-nb-designer-hmi-plc-no-response-error-solved/) to try and clear the error but am having no luck. In the screenshot I have assigned the large "Start Process" as a bit button with the write address being W50.00. When the button is pressed it should trigger a bit in the PLC but this is when the error appears. During this test I am connected to the PLC and in run mode with the PLC and HMI address assigned correctly. I have read and followed the section in the manual regarding "PLC No Response" but still no positive results.  I just want to check that there is nothing I have done at a programmer end that could cause these issues. I am happy to provide files. Thanks, Ryan  
  16. Hi there I am working on a project where Omron servo drags a part to a certain position using belt mechanism, But to avoid any slippage we decided to put an external encoder directly on the part. I was wondering what is the best to approach to drive the servo using the position of this external encoder. Is there any way that it can be configured directly with the servo? I am fairly new to coordinated motions, any help will be appreciated. Thanks
  17. Good Afternoon, I am wanting to do two things with and ORMON PLC and HMI with CX-Programmer and NB-Designer. 1. I want to display the current time from PLC on HMI with the real time clock. 2. I want to be able to enter a time on the HMI which will be compared to the PLC time and will stop a process when when the entered time is equal to the actual PLC time.  If I can have some help with this that would be a great help. Thanks,
  18. How to use NB Data Logging

    Good Afternoon All, Just wondering if anyone would have any example code of using the Data Logging on NB designer? I am wanting to use a PID controller and display set point and process variable etc. I have looked in the manual but a coded example would be extremely helpful.    Hope you have a good weekend. Thanks
  19. hello Every one,    I am using a CP1-L PLC and want to communicate to domino ax350i printer over TCP/IP socket programming. For socket programming, I used Omron Function Block CPU012_SendCommand.  I defined network ID and node address. However, I am getting 0502 error which means routing table is not set yes. So, how can I set routing table for both devices?. my PLC on 192.168.250.1 and Printer is on 192.168.250.123 node 7000.    Can any one suggest me best way to do.  Thank you   attached file is for what I did in setting and program for the communication.      
  20. Good Afternoon, I am new to CX-Programmer so excuse this question.  I have written a FB in ST to trigger BOOL and Integer variables. Within the FB I have written ST with a case statement which is working correctly. The issue I am having is that It seems the integer variables in the FB (HMI_Q_FAN_STATUS) are not being passed to the assigned global variable (assigned to D register) on the output of the FB.  In the attached screen shot, the FB is in case 3 therefore the integer variable should display HMI_Q_FAN_STATUS=3, however is still displaying 0. Any help with this would be great. Thanks and have a good day.  
  21. Hi all, currently I'm using NX1P2 PLC for my project. So I'm just using it to transfer data from PLC to my PC but I faced 1 major problem right now which is the connection. I have few experience working on PLC but this time I faced an issue which I don't know how to solve it. So the problem here is, my NX1P2 can't connect stable to my my PLC, initially I thought it was the cable problem, after I changed several cable it's still the same, so I thought it was my ethernet port problem but I can connect it to the internet and also Delta PLC, at last I thought it was PLC problem so I connected it to my colleague PC, they got a stable connection and able to program it. My ethernet keep on displaying "Enabled > Identifying > Unplugged", I check my Ethernet port, it using Intel(R) Ethernet Connection (6) I219-V. Tried to solve it for few days already, anyone faced this problem before? 
  22. Hello everyone! I am quite new to communications between different brands of PLC's. As I have mentioned in the title, machine has a siemens s7-300 series pn/dp PLC with no CP modules (programmed in Simatic Manager). And they are adding an another machine with an OMRON NX102-9000 model PLC (Sysmac Studio). Siemens side also has PC connection over winCC flexible. Somehow i need to communicate between these two devices. Now, I have been looking into this for a while. There are mentions of sockets, but i have no prior experience with them. From what i ve researched omron has "Send" and "Rcv" blocks, but i cant find my way through on how to use them. For example, i dont know "where" to write in the siemens plc. I feel lost to be honest. Can anyone point me to the right direction? Sample program snippets, documents ?
  23. Hello guys, I experience interesting behavior on NX102 PLC. I have an application with NX102-1200 v1.41 and 7 R88*-1S servos in total. All axes were added as a single-axis position. During servo set-up and tuning we periodically experience a communication error. Connection between laptop and PLC over ethernet. Did anybody have similar problem?  Error message #1: -MC Test Mode was interrupted in the controller. The MC test run is terminated. Error message #2 following error: -A communication error has occurred. 
  24. CP1L-EM40DT-D

    Hi there... I'm working on my final project using PLC CP1L-EM40DT-D. I want to set the stepper motor output pulse to match the 3 types of height I want. I used the PLS2 instruction but the simulation results showed the stepper motor rotation did not match the number of pulses and also the frequency I entered. Has anyone here ever used a stepper motor before? If yes, please help by sharing the exact pulse calculation formula on a stepper motor with a load. I really had a hard time finishing my final project because of this. I beg your help. Thank you
  25. plc-plc via internet

    Hello all, I wonder that is it possible to communicate 2 CJ2M plcs or 2 NJ controllers via internet? Those are far from each other. There is WE70 wirelles unit however distance between them more than 5 km. Any idea how can i solve this issue? Thanks in advance. Have a nice day.