Search the Community

Showing results for tags 'nx102'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Found 15 results

  1. I've setup an Omron NX102 PLC with two CIF105 cards communicating with about 40 MX2 VSD's (20 on each card). Generally it works pretty well. I used the attached document to set up the devices. The links on the document to the examples don't work, so I'm unsure if I missed anything. My problem is that every day, sometimes multiple times a day the communication seems to die. i.e I either loose the output to the VSD and nothing will run. Or it all runs but I loose the feedback, as in I get no running signal even though the drives are running causing a fault in my program. I'm at a bit of a loss as to what might be causing the issue. To resolve it, I put the PLC into program mode and back into run mode and everything is happy again.    Has anyone had a similar issue or offer any advise? MX2_Control_Serial.pdf
  2. NX102 SSI encoder problem

    hi have a good time i have a nx102-1200 and a nx-ecs212 module. I connected an SSI encoder to the card and read the position value in the software. The encoder counts 360 pulses in each round and then it goes to zero. I want to use GearIn function and have the encoder as the master and a servo motor as the slave. In each revolution, the encoder pulse becomes zero, and as a result, the servo motor movement is not continuous!!! I want the servo motor to be continuous! In fact, I don't want the encoder pulse to zero every time. What should I do? Is there a solution? please help me thank you so much
  3. Has anyone setup comms between an Omron NX range PLC and a Sick Flexisoft GENT module. Trying to figure this out. Should be doable, but struggling to get InDataSet1 to update in the PLC. I have a comms error on the Flexisoft module. Assume it's something to do with the size of my tag arrays    
  4. Hi, currently I'm facing a problem between  NB10W-TW01B and NX102-1200 PLC. The problem is after I assign the area/variable using W/H/D and Download it to HMI, The HMI will Pop up PLC Response Error, anyone knows how to fix it ?? I have experience using NB HMI with NX1P2 and NJ PLC, didn't have this error before  
  5. Hello everyone,   I was wondering if anyone could assist me as to why my G5 servo resets and goes into a ready state. but when I issue a MC_power it goes busy and doesn't complete.   I am using a Omron Nx102 controller and NB HMI with FINS protocol via port 2 FYI   LINK to screenshot: https://freeimage.host/i/H7gJRXn
  6. View File NJ/NX Get IP Address A Library containing a function Block that can be run on any Omron NJ or NX PLC. The Function Block will retrieve the host PLC's IP address, Subnet Mask, Gateway, and MAC Address. The Port Details are presented through 2 structures , 1 per-port. In the event the PLC only has one port the structure for Port 2 will be blank. Submitter photovoltaic Submitted 12/12/22 Category PLC Sample Code
  7. NJ/NX Get IP Address

    Version 1.0.0

    81 downloads

    A Library containing a function Block that can be run on any Omron NJ or NX PLC. The Function Block will retrieve the host PLC's IP address, Subnet Mask, Gateway, and MAC Address. The Port Details are displayed through 2 structures , 1 per-port. In the event you only have 1 Ethernet port then the structure for the 2nd port will contain all 0s. Data Format: IP Address - USINT[4] Subnet - USINT[4] Gateway - USINT[4] MAC - BYTE[6]  (hex value) Access the retrieved details by the typical parent-child tag structure. ex. Port_1_Detals.IP_Address[0] will get the first octet of Port 1's IP. Tested on: NX1P2, NX102, NX502, NX7, and NJ301 IMPORTANT: This Function Block should not be run immediately after startup. Allow the PLC a few seconds to establish a connection with the Ethernet network.
  8. Hi, I am having trouble with the following hopefully someone can help. Equipment Omron NX102-1220 PLC, SEW MDX61B MoviDrive B with DFE24B EtherCat Card. I am trying to control an SEW Servo Motor via the Omron Ethercat connection. I have connected and configured as below image, at this stage there is no errors with the PLC When I try to add a Motion control axis I can set it up as below but when I download it to the PLC I get the following error I have then reversed all of this and added an R88D-KN drive and this downloads fine.. Any ideas what I'm doing wrong? Thanks
  9. Hello , I am trying to run and parameters settings of several Q2V inverters +SI-ES3+JOHB-Q2V (option board for Ethercat), I managed to install the xml file for the settings , but I dont see as much settings as with the MX2 , and I cant find any related FB's as with the MX2, maybe someone has set this inverters before ? Thanks! 
  10. Hi. I have this project where we read out data from temp sensors and vaccuum stuff. We use Pfeiffer vaccum cpt 200 for the vaccuum, and we create a frame to send to the modbus unit to pull a value from example '306'. With all the current items we pull data, all the values are only updated every 5 seconds, is there a way to perhaps pull several frame/addresses in one request per device? Current codes we read, some are in sequence of each others, but more has a bit of gap like 00, 02, 306, 307, 398, 330 and so on.    
  11. Hello everyone! I am quite new to communications between different brands of PLC's. As I have mentioned in the title, machine has a siemens s7-300 series pn/dp PLC with no CP modules (programmed in Simatic Manager). And they are adding an another machine with an OMRON NX102-9000 model PLC (Sysmac Studio). Siemens side also has PC connection over winCC flexible. Somehow i need to communicate between these two devices. Now, I have been looking into this for a while. There are mentions of sockets, but i have no prior experience with them. From what i ve researched omron has "Send" and "Rcv" blocks, but i cant find my way through on how to use them. For example, i dont know "where" to write in the siemens plc. I feel lost to be honest. Can anyone point me to the right direction? Sample program snippets, documents ?
  12. We have a customer insisting on communicating with our NX102-9000 over EtherCAT, we have explained multiple times that EtherCAT is not intended as a facility communication protocol and recommended that instead they use Ethernet/IP, but after a year of pushing back they are still insisting and willing to pay for the Engineering work to get this to happen. Has anyone successfully configured two EtherCAT masters to communicate with each other? In the past I have used the PN-PN Master Coupler from Siemens to get two ProfiNet Masters to communicate with each other so I am hopeful that a similar device exists for EtherCAT, but I have not had any luck searching the web for such a device. Does anyone have experience with or know of such a device? Thank you!!
  13. Omron NX102 / NX1P2 cannot trigger MOXA ioLogik E1212 Outputs through Ethernet/IP connection, But I can read the Inputs Status All the time.   Just CANNOT trigger the Outputs signal through Omron PLC. Moxa claim that they can use AB PLC trigger E1212 outputs and no problem at all, but now OMRON PLC cannot.   Steps I am doing... Define the custom Data Type Structure. Create a variables with custom data type. Mapping with MOXA eds file setting. Inputs - 67 bytes, Outputs - 1 bytes. I had Install the MOXA EDS file I do contact MOXA Support channel, they claim that Omron PLC  not response to port 2222 . Can anybody help ? because same Omron PLC using for test also tested with other EIP device with no problem at all. I have no idea which party are problem now... T.T  
  14. Is it possible to setup Ethercat parameters from within the PLC program?  I am facing a situation where a machine is going to have changeable tooling fixtures and each fixture is going to have an EtherCAT device on it.  I am guessing they will need to be setup to look like the same node to the PLC, but they will have different physical IDs and different settings for some of the parameter fields.  They will be the same device so they will have the same parameter fields, just different values in those fields. I can also get these devices with EthernetIP as the fieldbus option.  In that case I would always have a network error because the PLC would always see one of the devices missing from the network.  is it possible to enable/disable Ethernet connections from within the program logic to avoid the error?
  15. Hi. We are struggling a bit with the analog IO on the EIC202 coupler. Have tried tag sets, and gotten the digital IO to work without problems, but not the analog. Any tips here? We are using 2x NX102 with 1x ID4442, 1x OD4256,  and 2x EIC202 with 1x ID4442, 1x OD4256, 1x AD2603, 1x DA2603 on each, for a redundancy-system. Software is Sysmac Studio. EIP connection.