Search the Community

Showing results for tags 'motor control'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Found 102 results

  1. I searched FX5 manuals and it appears that with the high speed inputs I can run a stepper motor without a motor controller. I have little experience setting up a new system with any motor but have made changes with servo issues. I sent a request for info from my supplier but I still have some questions/requests.   1. Can an FX5U control stepper motors without a motor controller? 2. If not then what Q/R series setup is required 3. Are there any document to help understand? (program examples are welcome)   Main objective is to run a sensor head to 3 or 4 specific points using a belt driven linear actuator with a nema motor.
  2. Hello Everyone. We have Schneider TM241 PLC Along with Citect SCADA System at 100MWp Solar Power Plant to monitor and control various equipments like Inverters, Switch-Yard, MFMs, Weather Monitoring Systems etc... Government Authority here asked every solar plant to control the generation as per the instructions by Load Dispatch Center, for that we need to implement logic to control Generation as per requirement. For that we are controlling generation from inverters by giving them generation setpoints calculated by PLC using PID function.   But we are facing one problem while using PID. (FB_PID of Toolbox Library)   Suppose we need to generate only 60MW out of 100MW. So we set PID setpoint to 60MW and according to that we get PID output and according to that PID output value we provide generation setpoint to every inverters.   This system works very fine until the clouds comes into the picture.   Now suppose Setpoint of PID is 60MW and PV is also near about 60MW, and suddenly large cloud comes over plant and block solar radiation.   In this case generation comes down to 10MWp(or any value below 60MW), So output of PID will Increase and keep increasing and settle at the Maximum value. but without solar radiation generation value stays very down then Setpoint.   Now suddenly Cloud moves and again solar radiation increase, but the PID output is maximum at that time so, Suddenly Generation goes from 10MW to near about maximum capacity (100MW) instead of 60MW, and then it will slowly comes down to 60MW.   We need to rectify this generation shoot up when cloud moves. Anyone have idea how can we solve this problem or anyone have programmed PID in this kind of situation.   Is there any function block available to do this correctly like function block of PID with two Reference or something like that...   We are using TM241 which is CoDeSys based PLC.
  3. Hello everyone, I have a Kinetix 6000 CIP drive (unwind) and I need to control its speed by a PID controller. I have everything working except the MCD instruction doesn't pick up on the PID output value change. It changes the JOG speed, which I use to control the unwind, if I set the speed manually, which is slow. The PID changes the speed almost continuously. Any suggestions are welcome. This is how I'm attempting to control the speed: A1_r_JogSpeed = PID output value   Thank you    
  4. PLC Panasonic FP0R Motion Control

    Hi, I am using FP0R C32T, i use FPWIN GR to make plc program using jog operation instructions F172. I used the program exactly like manual, but still got error code 45? Did anyone know about this thing?
  5. Constant Web Tension Control

    So I'm having trouble writing a FBD within my current program for a slitting line. I need to keep a constant tension on my web as it is being recoiled onto our recoiler. I wrote a simple program using a sensor to read the growing rate of the coil to get a radius and I have feedback on my torque on the recoiler motor. The simplest math for this application without getting into anything too fancy should be Tension(lbs)= Torque(ftlbs)/coil radius. only problem is when its less than a foot then my calculation is thrown off and it actually shows tension goes up until it reaches the one foot mark then it seems to scale correctly. Do I need to scale something else? Any help on this would be appreciated.
  6. Good Afternoon  im a complete newbie when it comes to PLCs but have done plenty of PIC programming in the past. I've been gifted a couple of FX0s 20mr units to try to repair something I made with PICs years ago. It got damaged during a move and I can’t see well enough now to make PCBs anymore so thought that this might be a solution. The basic operation is  1. switched on 2. motor A moves till hits limit switch (X000) 3. Wait 2 seconds 4. motor reverses till hits second limit switch (X001) then once this has been completed then the following  5. Motor B turns clockwise for 30 seconds then stops  And while Motor B is turning I need Motor C to turn until hitting limit switch (X002) I then need to get it to repeat on the press of a button but I need to reverse operation of Motors B and C I am using double position relays to drive the motors so motor A is on Y000 and Y001 if I power either relay the the motor turns in that direction. Same with Motor B and C Y002 to Y005 is this something that’s possible with one of these controllers or am i going to be programming a PIC to control the PLC ?   All the various COM and powers are connected up, I can individually make every motor do what I want, but the program doesn't flow from one item to the next. but this is probably just me      
  7. Can someone please suggest a Control Panel Builder that is located in Germany?   I work for a company in Australia and due to Covid 19, we are struggling to meet an onsite date for a project in Germany.   This project uses Siemens PLC gear, Danfoss drives, and mostly Schneider electrical gear. The enclosures are custom and stainless steal.    I have electrical schematics and enclosure drawings for quoting.
  8. Mitsubishi FX5-4LC

    Hello Guys,                      can anyone help me programming of FX5-4LC temperature control module with FX-5U80MT PLC. I want to Read present temperature value of each channel and want to set Temperature Set value from PLC.
  9. Is there a way to monitor the Temperature of a Servo Motor on Allen Bradley Servo motors... MPL? PLC: CompactLogix 1769-L30ERM Drive: Kinetix 6500   Motors: MPL-B310P-MJ72AA, and  MPL-B560F-MJ72AA I would like to be able to monitor the temperature, and flash a warning screen on the HMI if the Motor gets too hot, or perhaps shut down the operation before the Motor overload trips. The drive and PLC are connected through Ethernet IP What I don’t know is if that Motor heatsink temperature information is available to the PLC.
  10. Hello, Have this error come up constantly and can't be reset. Motor hasn't tried to drive at all. Second motor showing same problem. This is a new configuration on new machine. Other inverters configured without any problems. Anyone seen this before or any ideas what could be the issue.
  11. Hi Every one, I have two 2198-P070 bus power supplies for that I’m using for four Kinetix drives, 2 drives per power supply, all controlled by one processor (5069-L350ERMS2). I have an enable contactor setup for each power supply for each set of drives. I have them configured as DC bus groups 1 and 2 respectively. I had the first set of drives working, setup inside the motion group, with no issues. When I added the second power supply and drives. I found that when I added them to the motion group I couldn’t get the enable contactor to close for the first set of drives. I f I took them out of the motion group and made them ungrouped then the first contactor would close but then I couldn’t get the contactor on the second set to close. Do you have any thoughts as to what I might be missing to get these to work? See the screen shots for more detail. Let me know what you think.  Also, I have heard that only one motion group is allowed per PLC, but my question is : Can I use  sevral axes and Power units in the same motion group? 
  12. Getting this error while adding MC_TorqueControl. I want to control torque from HMI value. Using R88D-1SN08H-ECT drive and R88M-1M75030T-S2 Ac servo motor with NX1P2 PLC. Newbie Here. Please support. Error    1    The Axis parameter of the MC_TorqueControl instruction does not support single-axis position control axes.    Program1 Section0    Row 6  
  13. Control Panel

    Is it possible to view the values / states of all inputs, outputs and workbits (e.g. 64.00 through 64.15 on Omron CQM1 PLC) on a single screen or control panel within CX-Programmer software?  I'm trying to troubleshoot some ladder logic that I wrote and need to know the values of 5 or 6 inputs/outputs/workbits simultaneously.  Having to scroll up and down through my ladder logic repeatedly does not work well with code that changes state every 5-10 seconds or so. Any help is welcome.
  14. Control Logix 5561

    Hello  We have just purchased some equipment with a Control Logix 5561 (1756-L61/B Rev 13.40). The compact flash card is missing from the unit but the seller says the unit was running in his facility prior to shipping. Does the 5561 have internal memory where a program is stored? Is the Compact Flash used only for recipes and persistent data? Thank you
  15. Logic to control many motors

    Hi everyone, I trying to develop a logic to control 6 motors. Two motors needs to working and four motor will be in stand by. When one of the two motors fail, one of the four motors will start to work. Another rule is, when one of the motors that is working reach the preset time of working, the controller will stop that motor and start another motor with low working time, and so on. I'm have difficult to solve this problem. Can someone help me, please? Best, R.  
  16. stepper motor position control

    Hello, I need to have a cx-programmer code which I can control my linear actuator position by setting 3 positions with timer, I am using a CP1L pro'skit
  17. Sample blocks for S7 1200 plc's

    Hi experts, please share the sample blocks for the EDITABLE TIMER block it should be editable from HMI(Siemens). And also motor run hour block. Actually i am having all blocks in tia v12 version and sadly i dont have the old software to convert it again. So please share the blocks that it shoud be work in TIA V14 for s7 1200 plc's. Please note that the blocks should use add instructions to calculate the time because i don't have much memory.
  18. Control Panel Drawings

    Gentlemen and Ladies,                             This post might come off as generally lazy but this is purely in the interest of saving time. Our company has been building control panels for quite some time. I have been doing the design for about 10 years or so. We typically build Allen Bradley type control panels. Our main customers are water/wastewater so they are typically Compactlogix with basic IO. (AI, AO, DI, DO) modules. Recently i've been using the IO Wiring System modules. These save an incredible amount of time. However, they are quite big and require a decent amount of space. Our smallest control panel size is usually 36x36 and that is pretty tight. My question to all is, does anyone have a set of control panel drawings for an Allen Bradley compact logix system without these wiring modules? I am looking to create a smaller control panel, and I just haven't had much time lately to sit down and do the design. This is indeed a shortcut, but time has been limited on my end as of late. I apologize if this is out of line.   Thank you,  
  19. Stepper Motor Control

    can anybody Know how to control stepper motor using PLC
  20. GX Works 3 - PID control

    Hi, I am using PID function (PID operation instruction) from GX Works 3 library but it doesn't work. I set all necessary parameters (sampling time, direction and upper/lower limit values + KP, TI). My input PID_Par is array of 25 points (in manual is written: "*1When auto tuning is not used, the same number of points are occupied as when the step response method is used."). For example, in GX Works 2, PID function works ok. Did someone have similar problem? Does someone have mitsubishi library (GW Works 3) with PID function that works correctly?   Regards Luka  
  21. Hello,I am sizing a feeder circuit for a panel according to UL 508A and came into a question:My input current is of 76.5 A (considering all the loads), thus, it is fine for me to use a cable of 4 AWG (max. 85A @ 75 c).For the circuit breaker I did 76.5 A x 1.25 = 96 A and then I selected a breaker of 100A.My question is: Is it ok for me to keep this configuration according to UL 508A? 100A breaker + 4 AWG load side cableOr do I need to level up the cables?Thank you very much in advance!
  22. Mitsubishi FX2N, Servo Output problem

    Hello guys, I am facing a problem that our Servo is generating output for only reverse direction, when we give forward command from HMI the output Y0 is active but when we give reverse command same outut Y0 is high, other output which is Y4 is not high, what could be te possible reasion.
  23. Mitsubishi FX2N, Servo Output problem

    Hello guys, I am facing a problem that our Servo is generating output for only reverse direction, when we give forward command from HMI the output Y0 is active but when we give reverse command same outut Y0 is high, other output which is Y4 is not high, what could be te possible reasion.
  24. Hi all. I have a Kinetix 350 and an AB TLY servo motor. I'm using the drive's STO function. AC power is supplied into the drive, passing through an "M1" contactor. It makes sense to m e to keep that contactor open, preventing AC power to the drive, until the drive is fully awake.  Is that what you guys do? Someone suggested to me in another forum ( http://www.plctalk.net/qanda/showthread.php?t=121021&highlight=drive+awake ) that there is no reason not to supply power to the drive right away because the STO function is inhibiting power to the motor anyway. 
  25. Hi All, I have an AB servo TLY-A110T and 2097-V31PR0-LM Kinetix 350 drive. I thought that it was fully configured and ready for tuning, but when I issue a MSO it immediately starts to spin the shaft (no load yet). This lasts about a second until a Physical Axis Fault, Excessive Velocity Error occurs. I've double and triple checked the feedback and power wiring, and everything looks right. Is there anything else I can check? What can I do to trouble shoot this if I can't even give an MSO? Any insight is greatly appreciated.