Search the Community

Showing results for tags 'modbus communication'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Found 324 results

  1. MPI Connection problem

    Hi there. Recently I've experienced problems when connecting to a S7-300 PLC via MPI/PROFIBUS. I use a PG with CP5711 processor. The thing is that I'm able to connect when I plug the 6ES7901-0BF00-0AA0 cable (male to male) directly to the PLC connector, but when I try to do connect to a PLC that has any device connected to the DP port (let´s say an inverter or HMI) I get 33:17075 error. PG/PC Interface it's correct, in fact another PG with the same configuration is able to connect through the already connected DP device's cable. Station number and transmission rate is all correct.  So I tried the Simatic NET Diagnostics Test and I got error 0x0313 and since the mentioned parameters are correct I refered to this link:  How do Diagnostics and Remedy work in STEP 7 when an online connection with the CP... - ID: 11492532 - Industry Support Siemens Where they say the following:    I've searched for this readme file but can't find it, and there are no useful results when looking for it on internet.  Why am I able to connect directly to the PLC but not when another device is connected and I have to use the female connector of the DP connector itself? Should I try to reinstall CP5711 drivers? According to Windows, I got the last drivers for the CP.    Thanks in advance and I hope you can help me!
  2. Hello,   Any one  have idea how to read and write variable for Schneider tm221 plc with Modbus function codes 3,6,16. I attached file for power supply communicator with registers, I need to adjust power supply from 25% up to 100. Please need help. Best regards,   Chyngyz   Modbus OPERATING INSTRUCTIONS.pdf
  3. FX-2NC-32MT Battery & Communication Cable

    Hi, FX-2NC-32MT PLC need to change Battery, Can you please tell me the battery model no? Which communication cable require  for FX-2NC-32MT PLC upload or download program? Thanks & Regards Sohel Ahmed
  4. Hi all, I'm having an issue with EcoStructure Control Expert where when using DTM browser I try to connect but I get a message "No Ethernet/IP device at specified address...." My issue is that I had a device communicating using modbus but it has stopped and I cannot diagnosis the issue. I can ping the address and run a modbus poll from a PC on the network and everything performs correctly. Any help would be greatly appreciated. 
  5. CompactLogixL24ER

    Dear Experts Request to let me know in case it is possible to get communication software to communicate with CompactLogixL24ER. As per my understanding Rs Logix Studio 5000 is needed , version number required is V21.000 Thanks and Regards
  6. Hi there! I've been working with NB HMIs with good result. But today I loaded a project to a NB7-TW01B and it feels slow, both offline and online. Switching screens and reading/writing take around 1sec or more. It first had some bmp images created with .bmp and .png files, so I tried using vector graphics instead, but didn't get any better. I don't have another NB to try it right now so I'd like to ask you if you've been in this same situation before or what could be causing this. PLC is CP1L and communication it's via Ethernet. Both devices are actually pretty close (cable is less than 3m) and the previous HMI (Pro-face GP) felt a lot faster. Thanks in advance!
  7. Need help in table scrolling

    Hi all, We have a DOP 107CV HMI we interface this HMI with microcontroller through RS485 Modbus protocol. I'm new to HMI and PLC's although we are successful in interfacing HMI with Controller(Communication Established successfully) We made a table in HMI and allotted some registers to Modbus address and data is transferred from controller to HMI up to this we are good in communicating Since the table created is static and we cannot scroll down from that table so, to overcome this problem we found History buffer and made PLC trigger and allotted address. In that History Buffer we created 7 rows and the data is sample whenever we triggered the PLC in that case scrolling is working fine, but the problem we are facing is whenever we update 3 rows out of 7 and triggered the PLC only 3 samples are updated in first column and in the next step we updated the other 4 rows and triggered the PLC the data is sampled on next column but we required it to be sample on first column instead of second.  
  8. Delta plc Communication Issue

    Dear allI have DVP14SS211R series Delta PLC Which is having 24V DC supply voltage. I am using PLC as master and My end device as slave. My slave device set device_iD=1I am using Modbus RTU protocol for Function code1baud rate =9600parity =noneStop bit=1data length=8I would like to know how to send request with Function code 1(Read coil Register). i have attached code reference. Communication block it wont give error it shows 0 .means No error
  9. Hey Everyone,   My company decided to purchase a piece of equipment from China, and I have the pleasure of updating its terrible existing controls. We were given the PLC program by the manufacturer, so I was able to make my changes pretty easily - or at least that would be the case if I could actually connect to the dang thing. The source program is indeed openable and editable via GX developer (the original configuration shows it as an FX3). I figured connecting should be straightforward, but I was wrong.    I initially used a serial/usb converter that I've used on some older Allen Bradley equipment (which worked fine for that). However, after no luck using it on the "Mitsubishi", I purchased a different cable that I found recommended on this forum (Tripp Lite USA-19HS - https://www.alliedelec.com/product/tripp-lite/usa-19hs/70101537/?gclid=Cj0KCQiAj9iBBhCJARIsAE9qRtB_n8TVAnJdFyYokoEu42W6H6LaT4kVsgJQI1qvPUsUF3rFviKpbt0aApLHEALw_wcB&gclsrc=aw.ds). Still, no luck. I've tried 7E1 and every baud rate possible, as well as some other bit/parity configurations (and yes, I've verified that I'm using the right com port, as well as tried moving the converter to different ports and trying those). Nothing seems to go through.  I have almost no experience with Mitsubishi beyond a couple of FX5s (which have worked fine, but I connect to those via ethernet). Any help would be greatly appreciated; if I can't make these changes, I'm going to end up rebuilding the whole cabinet with a PLC I can rely on.   Thanks in advance.
  10. modbus rs232 communication error

    hi I am traying to connect 10 plc's FX3U to a scada system, on the plc's there are a rs232db and FX3U-232ADP-MB cards. i have devices transmit the rs232 by lan or any thing I need (rut955) my problem is when i download the program on plc same times the communication go right , but if i powering pls off then on the communication fail down. I initialized the plc  like photo https://drive.google.com/file/d/1Tr367wfVCRG6vvKcsOFyTKG_FExAsnVy/view can any one help me? sorry for my English
  11. CJ1M+ETN21 Modbus TCP

    Hello. I'm trying to use Omron ETN21 as master for ModbusTCP protocol. I can communicate with 1 SLAVE UNIT (standard modbusTCP slave) using FB MTCP_ETN_Client.zip  from https://www.myomron.com/index.php?action=kb&article=1245. It works perfectly. But I have three SLAVE UNITS to communicate to. I'm trying to do this using [524]Modbus_TCP_FB.zip sample. I have copied SECTION1 to SECTION2 and changed IP number and SOCKET number. But this doesn't work. I would realy appriciate a working sample where OMRON PLC is MASTER for THREE (or more) SLAVES. I'm attaching code file... Thanks. Best regards, Andrej. Modbus_TCP_FB.cxp Modbus_TCP_FB.opt
  12. Hello out there   I've searched for quite some time but unable to find any information helping me through this. I got a Omron PLC NX1P2 where im supposed to setup modbus communication over TCP/IP but so far i've only been able to find information regarding RTU setup. But seen forums mention its possible to setup via TCP/IP Anybody who can help. A program sample would be helpfull aswell. Im a trainee as automationengineer and this is my first encounter with Omron PLC and Modbus so quite new to the field.   kind regards Ivan T.
  13. I am currently trying to connect my OMRON NX1P2 1040DT1 (Using CIF-105) to my Unitronics V570 PLC, With my OMRON PLC as Master. It seems as if Unitonics Rs485 only wants a six-wire connection type but my OMRON PLC wants a 2-wire or 4-wire connection, Wondering if anyone has a solution to my problem and can assist me.  
  14. Hello, I'm trying to connect a CJ1M-ETN21 as slave Modbus TCP with a Modbus/Dali Gateway. I download from Omron website some FB with ones should be possible.   https://www.myomron.com/index.php?action=kb&article=1245 The FB only can be used with the direction unit 0, but we can change some directions inside the FB and can be adjusted to other units. In the download I found this FB: MTCP_ETN_Connect, MTCP_ETN_Fn01, MTCP_ETN_Fn02, MTCP_ETN_Fn03 .... Supposed with connect we can establish the connection with the master, but the FB never make nothing. Should I make some special configurations to use this FB? I appreciate any help. Thanks
  15. Indusoft Web Studio

    i am using indusoft web studio for the modbus logging. program runs successfully but after a half day or a day it shows error " error initializing the driver modbu 10.10: invalid serial port "any suggestion will be appreciated.RegardsZubair Ahmed
  16. Modbus with CJ1W SCU31-V1

    Hi every one, I want communication Inverter mitsubishi D700 with module CJ1W SCU31-V1,  any one give me a correct solution and send any sample program. Thanks
  17. I'm trying to communicate with INVT PLC and DGM8002(grain moisture analyzer) via mobus RTU.   Can anyone explain about these Modbus address ? Please kindly see in picture . example working mode address K0 (0-stop ,1-manual,  2-Auto) Actual Moisture Address K6 What is meaning of K0,K1,K3,K6.  https://drive.google.com/file/d/1-mGzpEvw4UlewWhR9k3wOd1mO-uhsklL/view?usp=drivesdk Is that K0= 0000 K2 = 2000. K3=3000 ? Any suggestion please. I'm really appreciated your comments.❤️  
  18. Error Indicator on FX3U-ENET-ADP

    Hi all, I have finished installing ethernet adapter module FX3U-ENET-ADP on the FX3U-48M PLC. From the ethernet module, i connected it to a wireless router and then i am planning of connecting to the ethernet module using GXWorks 2 on my laptop through wireless router. On the ethernet module, the error indicator LED is on (red). From the FX3U-ENET-ADP, it means that there might be setting or hardware errors.  I am asking if i have missed some steps on the installation process and if any of you have experience with similar problems. Thanks in advance for the answers.
  19. - i'm from VietNam, Who can help me?? - I cannot communicate the RFID card reader with the FX3U PLC using the FX3U-485ADP-MB module; - register error D8438 = 3821; D8423 = 1025; D8422 = 212. - Here is the connection picture and my PLC code thanks !!!!
  20. Hi all,  I want to ask some questions regarding Ethernet Communication with FX3U PLC series. I have 2 PLCs of FX3U series (FX3U-48M and FX3U-64M) and I want to monitor its data (input and output) using ethernet communication in real time. My questions are: 1. Does FX3U PLC have ethernet port so I can connect it directly to my Laptop/PC? 2. If no, do I need to use FX3U-ENET-ADP and can it be used for 2 PLC or only 1? 3. What software do I need to use to configure the communication between PLC and FX3U-ENET-ADP? 4. Does this configuration change the existing PLC program? 5. Can i transmit the data wireless-ly using some kind of ethernet to wifi adapter and what additional hardware do i need for that?  
  21. Check serial connection to Omron PLC

    Hello, I am building an application in CitectSCADA and I want to communicate with an Omron Sysmac CS1G. The connection between the plc and the Citect computer is through an ethernet to serial adapter (the computer doesn't have com ports on board). I'm having some difficulty establishing the communication and I want to make sure that I can actually reach the plc. Is there a way to check that the computer can reach the plc over the serial connection without using CX programmer? Maybe using Hyper Terminal, Putty or something similar. Thank you, Liron
  22. Q03UDVCPU Modbus Setup

    Hi Guys, I need help to set up modbus tcp/ip parameter for Q03UDVCPU, i want to use the predifined protocol and built in ethernet port. do you guys have some usefull references how to setup modbus tcp/ip, or is there any example program from mitsubishi? Thanks
  23. Dear Engineerds,   My Master (non siemens) doesn't see the Holding Registers of the Slave (S7-1200) plc. However the Q coils are fine and all Diagnostics don't show errors. The Hardware: S7-1200 – CPU 1215C CM PtP – CB1241 RS485 (6ES7 241-1CH30-1XB0) - Half Duplex RS584   Firmware: Modbus_Comm_Load (V3.1) Modbus_Slave (V4.0)   I've tried with various DB, UDTs and manipulating HR_Start_offset parameter with no success. Could you advise what am I possibly missing? Modbus_Comm_Load_DB_Snapshot.xlsx Modbus_Slave_DB_Snapshot.xlsx
  24. From DM:   Hi; my name is Metin , I live in turkey. unfortunately I have a problem that I could not reach a conclusion here. I hope you can help. I need to communicate with CJ1W-ETN21 with a device via modbus tcp and read information. I downloaded ready-made protocols on omron site, connection is established but I cannot read. I tried the attached protocols. the device I am trying to communicate with :  https://www.gmweighing.com/products/weighing-indicator-m02  I will get the weight information from the weighing device. Thank you in advance for your help. MTCP_ETN_Client.zip
  25. Hi there, Im having issues controlling ATV 320 VSDs over Modbus RTU with a M221 plc, does anyone have any pointers for me to look at? I believe I Have set everything up correctly but when I run the program on the plc the atv's just stay in 'NST' state I have included screenshots if they are any use   My speed reference in this example is taken from the memory word %MW0 which I am inputting via a HMI   I have addressed all my ATVs accordingly in there setting with the correct Modbus parameters and selected Modbus under the FR1 configuration, am I missing anything?? Any help is appreciated as I am really struggling   Tom