Search the Community

Showing results for tags 'micrologix 1200 fault led blinking'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Found 112 results

  1. codebar reader

    hey can someone please help me with programming the plc to test on a code transmitted by a barcode reader thank you
  2. I am working on a project with Micrologix 1400 and PanelView C600 I am not able to communicate over Ethernet with any device and my computer. I was not able to load the HMI screens so I don't know if they are communicating between themselves. The RSLinx does not see any device connected via Ethernet. I am using EtherNet/IP driver for this, not sure if that is right. I have tried connecting directly to each device from PC over ethernet and also connecting to them through switch. I can however ping each device and the packets are coming back. The IP assignments are as follows: 192.168.0.1 Router 192.168.0.2 PLC 192.168.0.3 HMI 192.168.0.25 PC Would anyone have any suggestions what I need to try to get this resolved? I was able to communicate with the MicroLogix via serial port but was not able to communicate with the PanelView through serial port at all. I have tried using the USB-2711-NC13 cable for the PanelView connection. Thank you.
  3. S7-1200 firmware load on the CPU once we have it inside the card. What is the process and sequence of LEDs indicating which CPU is running at all times. Have a look and red amore at... http://www.tecnoplc.com/cargar-firmware-s7-1200-en-una-cpu-6es7-214-1be30-0xb0/ You can find some more inforamtion about how to update firmware at... http://www.tecnoplc.com/actualizar-firmware-s7-1200-de-una-cpu-6es7-214-xxx-0xb0/ ------------------------------------------------------------------------------ www.tecnoplc.com
  4. I want use the panel view 800 with micrologix 1100 but  i can't add the controller in connected component workbench. Exist another program to program the panel view???
  5. Excel Add-in for Siemens S7 Data Logging

    Version 3.6.8.1

    314 downloads

    ASComm Excel Add-in is a simple to use, non-programmatic way to populate Excel 2007 - 2016 spreadsheets with data from PLCs, instrumentation, and other process hardware. ASComm Excel Add-in uses built-in drivers for Siemens S7-200, S7-300, S7-400, S7-1200, and S7-1500 communications. No OPC, DDE, external drivers, or programming required.  
  6. View File Excel Add-in for Siemens S7 Data Logging ASComm Excel Add-in is a simple to use, non-programmatic way to populate Excel 2007 - 2016 spreadsheets with data from PLCs, instrumentation, and other process hardware. ASComm Excel Add-in uses built-in drivers for Siemens S7-200, S7-300, S7-400, S7-1200, and S7-1500 communications. No OPC, DDE, external drivers, or programming required.   Submitter Automated Solutions Submitted 03/01/16 Category Demo Software
  7. Excel Add-in for Allen-Bradley Data Logging

    Version 3.9.0.0

    426 downloads

    ASComm Excel Add-in is a simple to use, non-programmatic way to populate Excel 2007 - 2016 spreadsheets with data from PLCs, instrumentation, and other process hardware. ASComm Excel Add-in uses built-in drivers for Allen-Bradley ControlLogix, CompactLogix, MicroLogix, Micro800, PLC5, and SLC500 communications. No OPC, DDE, external drivers, or programming required.  
  8. View File Excel Add-in for Allen-Bradley Data Logging ASComm Excel Add-in is a simple to use, non-programmatic way to populate Excel 2007 - 2016 spreadsheets with data from PLCs, instrumentation, and other process hardware. ASComm Excel Add-in uses built-in drivers for Allen-Bradley ControlLogix, CompactLogix, MicroLogix, Micro800, PLC5, and SLC500 communications. No OPC, DDE, external drivers, or programming required.   Submitter Automated Solutions Submitted 03/01/16 Category Demo Software
  9. DATAMN 60S

    hey can someone help me i dont understand how to communicate a DATAMAN60 with a PLC s7-1200 through an RS-232 communication the problem is with programming the module that contains the RS-232 port i dont know if the DATAMAN60 send data automatically or i have some programming to do thank you
  10. Hi: I know how to update the S7-1200 by this link: http://www.tecnoplc.com/actualizar-firmware-s7-1200-de-una-cpu-6es7-214-xxx-0xb0/ , but anyone knows about update the Firmware with other type of Memory Cards??? Is it available with 12MB or 4MB card??? Thank you a lot.
  11. Dear colleagues and siemens experts, I''m new in siemens. As all I make my program for PLC, but I need help with PID autotunig (pretuning) I use : 1.CPU 1214C DC/DC/DC (6ES7214-1AG40-0XB0) 2. 6ES7214-1AG40-0XB02. 16IN/16 OUT DC/DC/DC (6ES7-223-1BL32-0XB0) 3. 2x 6ES7231-5PD32-0XB0 ( 4 channel RTD analog module - PT100) We use 7(seven) Pt100 points with 7(seven) heaters ... so I need 7 additional outputs..... [you can see example of wiring in attached pic 6es7231-5pd32-0xb0-modules.jpg] Maximum heating point is around 220 degrees. I make my configuration for PID_Compact : 1. Basic settings 1.1 Controller type : Temperature : °C Set mode to : Pretuning ( sometimes I make it Automatic mode) 1.2 Input_Per(analog) -----> Output_PWM 2.Process value setting: 2.1 Process value limits: Process value high limit : 220.0 °C 2.2 Process value limits: Default 3. Advance setting 3.1Process value monitor : Default 3.2 PWM limits Minimum ON time : 0.5 sec Minimum OFF time : 0.5 sec 3.3 Output value : Default 3.4 PID parameters : Default I start Commissioning with these steps : 1. Measurement : Sampling time 0.5 Start 2. Start PID_Compact 3.Tuning mode : Start When I try first time my setpoint was 90 degrees , second time I try with 120 degrees. After 4-5 hours it stop more in Progress bar it stop when I reach a little more then 50%, and I stop PID. For heaters it is not normal to process to be 4-5 hours, there have some wrong. Example with 120 degrees : During process I make : When Input_PER reach 120[1200] degrees I stop physical access to heaters. When Input_PER reach 100[1000] degrees I start physical access to heaters So 4-5 hours is soo long time for this type process. Time to reach 120 degrees from 100 degrees is around 2-3 min. Time to fall from 120 degrees to 100 degrees is around 4-5 min. Total time for one whole cycle around : 8min. Sometimes when I set setpoint to 140, 150 degrees it writes me that output set value is to high after I give Start Pretuning ? Even sometimes when try for 120 degrees .... As all I want to start PID pretuning (autotuning) with setpoint 140 - 150 degrees. Which are minimum requirement to start PID autotuning with PID_Compact ? Could you send me some very simple example and steps that I must make or only steps ? I attached files in dropbox with images and program example, because I can't attached nothing here. This form don't give me access to attached something. So link is here : Even program is there. Thanks in advance Best regards : Altan
  12. Hello! I have a PLC S7-1200 (1212C DC/DC/DC) and a few question about programming S7-1200 in TIA Portal v13. 1. I want to make "upload station", because I am not surre whichone project is the last. But, when I start upload data, the error hapens, and the decription of error is: The name of the station "S7-1200 Station_1" is already in use in the project. How and where can I change it? 2. And the last question: I try to connect my S7-1200 and Weintek simualtion. There is all time :"PLC not connected". I have chceck everything: PLC is OK, communication PC-PLC ok (ping ok), windows firewall off, administrator rights ok, configuration made with manuals, (CPU - Siemens S7-1200, IP: 192.168.1.100, port 102, tags import - ok.) I have read the manual many times, and check settings - nothing change. Maybe have someone problems like this, and found a solution? PLC: 6ES7212-1AE40-0XB0 WIndows: 7 Proffessional 32 bit Program: TIA Portal V13 Basics Weintek: EasyBuilder Pro V5.02.01 Best Regards! Andrzej.
  13. I'm using AuthSmtp as my mail provider and I need to be able to specify the port number. I can't find a place in the rslogix 500 channel setup to put the port id. Currently I'm giving just giving it the host name 'authsmtp.com. I did try the ip address with the port number xxx.xxx.xxx.xxx:xxxx but that didn't work either. Any thoughts are appreciated.
  14. Hi All Was wondering if anyone could help i've setup an OPC Server ok and can read all the tags from my PLC. Now i need to write to some of the tags so the warehouse can input production requirements. Has anyone done this or any idea on how to do this. Any help would be great. Cheers Chris
  15. help with NOT and OR instructions

    I've been programming PLC's for about 2 months but working with other types of control systems for a few years. I'm currently building a program to control a water storage tank for the farm that will interface with advanced HMI. my issue right now is with my fault light stack and fault logic. im trying to use a NOT instruction so that the green light is always on unless the Red light comes on... so i thought i'd use NOT so that if N7:30 is not true or 1 then the green light is on but if it is true then its off or 0 ...but i keep ending up with -1 or -2 in the interger file. also, my OR logic of the yellow light that should trigger if any of my 4 tank level switches fault only works on one of the rungs... if either of the N22 or 23 come true then N7:31 comes true but it doesnt seem to work the same way on the rung for N7:20 or N7:21 to trigger N7:31... if either of them come true N7:31 doesnt come true. im submitting my logic for your review... thanks so much in advance. WaterSystem.RSS
  16. Hello A-B Guru's, I have a small station with a Micrologix 1000 controller in it. Keep getting a "Major Halt Error S:1/13, Invalid STI interrupt set point. Refer to S:30." It is a very simple program, not using the STI instruction. Have a filter on the processor power. Nothing crazy going on, on the station, no big coils, etc. What can I do to prevent this fault from occurring? Can I add a line of code to always unlatch S:30? What should I do? Please help.
  17. Hello Everyone, I want to have a serial communication using Siemens S7-1200 with CM 1241 (RS-232) and communicate with my Arduino. Here is the setup of the communication. I have 2 temperature sensor and one Led connected to my Arduino, and on the PLC side I have S7-1200 from Siemens and CM-1241. Arduino and my PLC are connected just by using Tx and Rx pin no handshake is done. I am sending the temperature data from both the sensor to the PLC. on the PLC side i decide when to turn on the Led connected to my arduino depending on the different temperature values. I have assigning a ID to both the sensors before sending out the data. This is how the transmitted data from Arduino looks like $AOPT_TEMP1_20_TEMP2_21 . So far its good, I am receiving serial data on my PLC using RCV_PTP (received data are placed on the buffer) and sending data using SEND_PTP. I have also implement a filter on the PLC which will only accepts the serial data starting with '$AOPT_'. Now, I want to receive the temperature value from two temperature sensor TEMP1 & TEMP2 and then control the Led. For instance if (TEMP1>TEMP2 ) then turn ON the Led else turn OFF. I am able to receive the data on the PLC from Arduino but now I don't know how to proceed with comparing the received information. How do i extract the only required data from the received buffer? Any suggestions will be highly appreciated. Thanks in advance....
  18. S7 Schedule program block (HVAC)

    Hi, Lately I've been working with Siemens S7 1200 for HVAC applications and I was wondering if anyone has a working schedule program. I need to be able to set weekly schedules and exception schedules. Also its supposed to be controlled from a SCADA so there needs to be a DB. I've heard some rumors that siemens have made something like this but I can't seem to find it anywhere.
  19. Micrologix 1500 PLC tripping /stopping periodically with red led indication . It is showing error 679H It is also showing error on Analog Output Card which is at slot 6 . After clearing error it starts and stops again after some time . Requested to suggest me any solutions for eliminating the problem
  20. HELP S7-1200 tia portal

    Hi I m new and I need some help in programmin an actuator with S7-1200 on TIA PORTAL Here is the topic: program an actuator which move between two position located by thwo limit switch END_FWD_SW and END_BCK_SW To do that I have : Hardware: S7-1200 CPU 1212C AC/DC/RLY 6ES7 212-1BD30-0XB0 1 REVERSING CONTACTOR WITH LED 1 STARTER 1 POWER SUPPLY the list of inputs I have : 1 FWD_BUTTON to send the actuator forward until it reach the limit switch END_FWD_SW 1 BCK_BUTTON to send the actuator backward until it reach the limit switch END_BCK_SW 1 ESTOP_BUTTON to stop the actuator at any time 1 AUTO_BUTTON to set the system in auto mode so that the actuator could move itself from one position to another and so on go and come automatically 1 MANUAL_BUTTON to set the system in manual mode 1 INPUT_FWD_SWITCH this is the limit switch for the END FORWARD POSITION 1 INPUT_BCK_SWITCH this is the limit switch for the END BACKWARD POSITION The list of outputs I have 1 OUT_FWD to send the actuator forward 1 OUT_FWD to send the actuator Backward I do not know if I have to put the coil of the reversing contactor as OUTPUT too ??? because the reversing contactor has two coils : one that i used to go Forward and the other that I use to go backward the reversing contactor has an mechanical interlock of course. The actuator connection has two switch to send it Extended or Retracted. Of course the actuator is connected to a motor as you can see in the file attached showing it with his drawing connection. I also have to count the number of thime the actuator is used for the history. Any help please ???? Thanks you ! i HAVE ALSO ATTACGED THE PROGRAM I HAVE WRITE, I WANTED TO USED DB AND DB INSTANCE TO DO THAT CAN SOMEONE HELP ME IN MY PROGRAM ????
  21. Hello all, I have been trying to get my first C-more application to work and am pulling my hair out. I have an AB micrologix 1400 and am trying to connect it to a C-More EA9 with ethernet. I am using a cable directly from the panel to the plc. I can ping the PLC, and works well with RSlogix via the Ethernet cable. Nothing I do to the EA9 CMORE has worked yet. I have changed the ip settings several times. I can load the program with a USB and I can see it using the CMore software but I cannot transfer. AutomationDirect seems to be out of town this week and I can't get anyone to speak/talk with. There is no section on troubleshooting this as far as I have found. I have set the PC to : IP 10.0.0.65 Mask of 255.255.255.0 I have set the EA9 Panel to : IP 10.0.0.21 Mask of 255.255.255.0 I have set the Micrologix to : IP 10.0.0.10 Mask of 255.255.255.0 Thanks, Hutch07
  22. Hello, I am trying to communicate with MicroLogix 1100 from CompactLogix. But I keep getting an error and It says connection failure. This is what I have done so far. Can anyone tell me what I am missing? Regards,
  23. Good day to all, Please i need your support. I am new to world of Plc. I just bought a micrologix 1500(1764-24BWA) Plc for my training program. I have a question with respect to the Input terminal 24V DC. I connected L1,L2 and the ground at the Output terminal to a 230VAC and power On the Equipment, everything was okay. My question is do I still need to connect the -DC and + DC at the Input terminal to a 24VDC external power supply to get the needed 24VDC for the Input terminal or the 24VDC comes from the internal voltage conversion of the PLC. Once again thank you for the support. Best regards
  24. ML1400 and C400 Resetting Values

    At work we have been having a slightly increasing number of instances where the Micrologix 1400 that is paired with a Panelview C400 resets values when we cycle the power. Originally we thought the solution was a bad battery in the ML1400. This was the case the first few times that it happened. However, we recently had one doing the same thing and when the program was loaded onto another PLC and HMI combo it had the same issue. So either the battery for both just happen to be bad, or there is something in the program that is forcing the values to automatically reset when the power is cycled. I cannot post the program on here but I can tell you that the tags that are being reset are only used in the PLC program once. There are six total that are being reset and they are the high and low range in an SCP function that is used to scale inputs. I will be testing the program myself in house on a bench setup, but I wanted to get this question out there as soon as possible in case it is not an obvious problem. Has anyone seen this before? Any suggestions? If I come up with an answer I will post it. Thanks.
  25. All CPU led falshing

    Hi, I have S7 300 CPU all its leds falshing in same frequency this happen while it running and can't access to it online if we make power reset and selctor on stop it start normal and when try to go online all leds flash if we make power reset and the selctor in run position it start and after a few second start flashing can any one advice me what i do ? what is the possible causes of that