Search the Community

Showing results for tags 'micrologix 1200 fault led blinking'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Found 117 results

  1. 1756-RM2 allen bradley

    Hello everyone, my name ia alif from indonesia i have redundancy module 1756-RM2 controllogix5000 Allen bradley. On the module, fault codes appear as EG12. What is it means ?   I have already search in the user manu but there is no explanation about this fault codes.     Thank you
  2. Hello All,   I hope this post is not against any forum's rules. If so please delete.   I would like to invite everyone interested to have a look at my website, which is purely about TIA Portal and everything related: TIA Portal how to   There you can find articles, tutorials, tips and videos.   Hopefully someone will find it helpful. There are more materials coming so be sure to subscribe to Newsletter   There is also: Facebook Fanpage                          Facebook Group                         Twitter                         YouTube   Regards, Robert Jankowski
  3. Hello,  As the title indicates, we have a micrologix 1400 that has been installed for a long time.  Recently it faulted out on 71h and was in Remote Mode.  Do these PLCs revert to Remote Mode when in a fault condition?  We placed it back in Run Mode and everything worked fine, but how did it get to Remote Mode in the first place? Thanks,  J 
  4. I have a "paddle wheel" style flow meter that I am trying to wire to my Micrologix 1400. It is a three wire device and there is a tag on it that says it can run at 6-36VDC. So, naturally, I thought to wire this to one of the HSC inputs of the Micrologix directly. I hooked the ( + ) on the meter to 24V, ( - ) on the meter to common, signal to the oscilloscope, and ground on the scope went to common. I see a small 60Hz sine wave @ like 5mv when the wheel is not turning. When the wheel is turning I get a small square wave but in the same mV range. It is not a nice smooth square wave either its all jumbled up with the 60Hz sine wave.  I hooked this thing up to a transmitter and scoped the signal and ( - ) in parallel with the wheel - I get a nice smooth square wave signal when the wheel turns. It is only at 4.5V though. My questions are? Why does't the paddle wheel give me what I am expecting directly? Also, what is the voltage range on the pulse that a micrologix will see? I am assuming that it will not count a wave with a 4.8V amplitude.... Thanks for your help in advanced! neech   
  5. Hi all, I will be starting on my MSc in automation in a couple of days so for that reason i have obtained a S7-1200 series 1211AC/DC/RLY PLC. This is a new area for me as i have been working in offshore since i graduated from my BSc a couple of years ago. I watched some Youtube tutorials on how the programming is done and i am ready to try it out for myself, but i have encountered a little problem.   Problem: I am using the X1 P1 PROFINET (LAN) port as a connection to my PC, this turns the Green Link light on and the Rx/Tx lights blinks orange. Now to the problem, i cannot connect to the PLC through the TIA portal, no matter what settings and connection types i use in the PG/PC interface box. I have had no luck finding leturature adressing how to configure the PC/software and get a connection to the PLC. Do any of you have a PDF or link which can help me through this problem?  Hardware: S7-1200 series 1211AC/DC/RLY 6ES7 211-BE40-0XB0 S C-J5PN 1614 2017 FS:05 Software: TIA Portal Version 13 STEP 7 Professional V13 WinCC Basic V13   Thanks   Best regards   Dennis    
  6. Encoder Interrupt Help

    Hey guys, I am working on an application that tracks irregularly spaced PET bottles on a conveyor line and then blows them into boxes waiting on the side of the conveyor. I believe I have working logic, but I am having issues with the encoder at operating conveyor speeds. I believe the best logic for my project is to use a photoeye to detect the presence of a bottle (a one-shot makes sure it is only detected once), and then "store" the "presence" of the bottle in a binary file using an encoder pulse to trigger a BSL function. Using this logic, the bits in the file are analogous to a real, physical location on the conveyor, and I can just monitor specific addresses in the file where my real-world air nozzles are located. My current problem is that as my conveyor speeds increase, the PLC begins to miss pulses from the encoder. During my initial set-up, I took data at very slow speeds to experimentally determine how many pulses were between the photoeye and each air valve, but when I run at full speed, I only detect about 70% of the pulses detected at slow speeds. Not good. Althought the "skipped pulses" seem to be proportional to the detected pulses at slow speeds. I am using an encoder that only runs at 60ppr, so I would think that my PLC (MicroLogix 1200) can handle this...I did the math before I purchased the encoder and thought I found the pulses to be infrequent enough that the PLC wouldn't miss any. My 2 trains of thought: 1) I need to use an interrupt for each encoder pulse since they occur so quickly (utilizing an EII), which I am not fluent in. I can find instructions to intitially configure the EII file, but I am unsure of how you are supposed to correctly set up the ladder logic to utilize the interrupt. 2) There is an electrical issue. The encoder I bought uses pull-up resistors. The resistor value I selected only drops the detected voltage to 14V from 24V. Is it possible that the encoder does not spend enough time in the "off" state at high speeds because of this high voltage value? OR does the usage of a resistor introduce a time-lag into the system which further complicates the issue? Any help would be appreciated, Thanks!
  7. need help for TIA V13

    Hello Everyone,  Our machine with PLC CPU 1214c, was program last year using TIA V13 professional. Now i need to add some Expansion module for additional sequence, but i only have here a TIA V13 basic. When i tried to search the hardware; yes it can be searched, but it will not upload the existing hardware (CPU+ other modules).  My question is, if the s7-1200 PLc was programmed by TIA v13 professional , does it can only  be edit  by TIA v13 professional? is there any chance that  the basic version can edit the programmed.    Thank you all in advance for your answers...
  8. Hello all, I am still fairly new to this forum and PLC's in general. I am trying to connect a EA9 touch panel via Ethernet to an Allen Bradley Micro Logix 1400 PLC. I am using Ethernet over serial because I need the serial connection to program while using the touch panel. I have given the Panel the IP Address 192.168.1.20 with a subnet mask 255.255.255.0 and I have given the PLC the IP address 192.168.1.10 with a subnet mask 255.255.255.0. The panel is not communicating with the PLC and I have very little knowledge on the subject, anyone's help would be greatly appreciated. The picture on the top is from the PLC and the picture on the bottom is from the C-More program for the panel.
  9. I'm trying to ramp up from zero to enable a NJ calculated random curve to never produce a negative position point:                                                     Calling the move "Offset", and using a MC_MoveAbsolute fb, the idea is to trigger the curve generating ST to start when the move reached 50mm.  (Wanted the variable "Ready" to go TRUE at the end of the ramp to 50mm)  .. Then, MC_SyncMoveAbsolute fb would continue from there, sending streaming position data to the LinMot Linear motor. As seen above. But, there's a problem.  Initially, I used the MCMoveAbsolute.Done to start the ST curve move sequence, which also ramps amplitude from zero, over a period of 3 seconds: Offset + [(a number that goes from 0 to 1.0 in 3 seconds) * (the mathematically generated position curve)]   The result is a "clunk" at the transition of the end of the ramp and the start of the curve. Not sure when "Done" happens... started to think perhaps it's when the fb is finished making the command to move, and not when the move has actually finished. So I tried an IF_THAN:                    That was kinda silly, because the ramp final position never reached 50mm ... "Ready" never set to TRUE ...  close, but no cigar. So the next step was use a Round instruction that actually monitors the position of the slider: and a EQ instruction that compares the two, and issues a "Ready" command to start curve the curve program:                  This produced the Minor Fault:  Axis 0x543B0000 Motion Control Instruction Re-Exicution Disabled Now I'm thinking this can't work because "Ready" will only be TRUE when the the curve hits 50mm (which is quite often, after it starts running ... 50mm being the new zero) However, It did start the curve sequence.. but nothing moved because of the fault... Soooo.. The question is: How can I do a smooth transition from the end of an Offset move to the start of the curve?  Or.. better still...How is an "Offset" normally done to any curve generating routine? Thanks much, Regards, Michael PS:   Here's a look at what's happening when I tried using State Tracker... and something to compare actual position at the end of the Offset move, and the start of the random sea curve: https://www.youtube.com/embed/BdpvC1yyKxU?rel=0&controls=0&showinfo=0      RSStart is the variable that powers the Random Sea ST program, and the SyncMoveAbsolute fb that drives the motor.  Cycle time is 1ms.  Probably would be quieter if I could 500us .. but the NJ is only a 101-1000               FYI... Delta Motion's RMC75E Motion Controller can make the Random Sea using LinMot's B1100-VF drive .. as quiet as a mouse.  But then, I think that controller has a cycle time of 1us!   Wondering if there's a problem with Direction or BufferMode:    _emc_Direction#_mcNoDirection or _eMC_Buffer_Mode#_mcAborting ????  Thanks for any ideas on the "Clunk" ... I may have to live with the "singing" ... sniff!  .... or use a Delta Motion Motion Controller ..      
  10. I have a c-more HMI and an Allen-Bradley 1200, is it possible to set them up with two AB 1764-NET-IAC+ to have my computer monitoring the PLC at the same time, I have established communication from my computer to the PLC through the IAC, but I haven’t been able to integrate the HMI, is it even possible?. This is been setup for training purposes, any help would be appreciated.
  11. I have been searching on how to import logic 500 tags to connected component workbench for panel view 800 project and striking out is there a way to do it? Project is to replace optimate  OM440  HMI connected to MicroLogix 1500 with a panel view 2711R-T7T. Replacing the controler is out of the question at this point. Tom
  12. Hello, I am currently installing a PLC control panel and due to space constraints, we will need to install the Panelview 600 HMI separate from the Micrologix. We purchased a 50ft Allen Bradley communication cable, but 50ft will not be long enough. We have about 70 to 75ft of conduit between the panel and the HMI. I would like to know what options we have for this connection. I read that for serial connection, we shouldn't go past 50ft. I understand the Micrologix 1100 has an ethernet connection and the Panelview does as well, but I'm not sure what changes would be needed in order to communicate through the ethernet port, instead of the RS-232 port. Any suggestions will be greatly appreciated.   Thanks, JCG
  13. Have a red lion HMI G306A connected to a micrologix 1500 plc. Communication working. I want to be able to change screen through plc as well as have plc be able to read what acreen is active. Had an old panel view hooked up and can use an integer to do this one for active screen and one for screen change called for from plc. Thanks for the help on this.
  14. Ethernet Global Data Comms Fault

    Hi All, We have a 4X Rx3i PLCs that use Ethernet Global Data (EGD) to talk to each other. At the moment we a facing EDG communication fault being generated and it trips the entire pumps What the likely causes of EDG faults: We have replaced PLC Ethernet Interface Modules-no fix We have tested the fiber optic cable-the readings show its OK Also,can someone explain what PLC heartbeat is?
  15. I'm having problems with some explicit messages between the 1100 and the power flex 525, the message that send the commands to the 525 has the error code e6 and according to what I read the error describes Target node cannot respond because requested function is not available. Thank you for your help.Vinicius Galvão
  16. Implement IEC 61499 Micrologix 1500

    Hello all I want to know if is possible implement the standard IEC 61499, for distributed control, in a PLC Micrologix 1500, this standard proposes use function blocks, but this blocks are different to the blocks proposes for the IEC 61499
  17. You can buy books programming Modbus TCP / IP with C# language on Google's Play Store Link: https://www.youtube.com/watch?v=gC2Y...OgG_veiieCTor6
  18. I'm designing a PLC system in which a Micrologix 1400 talks Modbus TCP/IP with three Modbus TCP-capable SCR controllers. I've never done Ethernet/Modbus TCP communication using the 1400, so I'm asking the following questions: 1. Can I connect the 1400 PLC and the three devices to an Ethernet switch and configure Modbus TCP communication from the devices to the PLC (data collection only) ? The switch will also be connected to the customer's DCS, receiving the data from the PLC and the three devices. 2. Can I connect the Ethernet port on the1400 PLC to the Ethernet switch directly, or do I need some kind of Ethernet interface, like the 1761-NET-ENI ? 3. The system also includes an HMI, connected to the 1400 PLC by RS-232 communication. Any issues with communicating with the HMI and doing Modbus at the same time? Your help in this matter would be highly appreciated. Thanks. Ron
  19. SCL Powerup Fault

    Need a little help here - I am trying to re-purpose some old hardware.  I have 2 old SLC5/04 B processors (+15 yrs?), that are giving me the same problem.  After a power cycle, they boot to a solid fault light - no comms.  Cycling the keyswitch has no effect.  Popping the processor from the rack and reseating it, powers up in a default state - it will not reload automatically from the EEPROM (when I establish comms, I can reload from the EEPROM or download the program from RSLogix).  I can't read the processor fault.  The battery is good.  The rack was scavenged, I have no idea its history.  Also in the 4-slot rack are DI, DO and RIO Scanner cards. I would consider my self a competent programmer, but no A-B expert.  Any ideas here would be appreciated.
  20. Micrologix 1400 Post mortem

    Hi everyone, I have a Micrologix 1400 that went out over the weekend.  First thing that happened was a contact went out on it forcing us to move the wire and change the program to a different location, but then the next day it provided full voltage to a solenoid even when it was supposed to cut out via timer.  We switched the processor out, but now I want to find out why it went bad, and if there is something I can do to make the next one last longer.  I don't have techconnect through AB (That I know of), so how and where do I send my processor out to get a post-mortem analysis on it?
  21. As I am a noob this is probably a noob question. I have a machine with a micro 1400 and if the machine has a fault or jams it lights it's "machine fault" lamp. The fault can be triggered by one of 8 prox switches not getting made within a certain time span. There is nothing to indicate which one. I'd like to program the lamp to, rather than stay on steady, have a blink pattern to indicate which prox caused the fault condition. 3 blinks and a pause, then repeat for PROX 3 for example. I have searched for this with no joy. Thanks - Jon
  22. Micrologix 1000

    Im having some trouble with a PLC and looking for a some help. Whats happening is output number 3 is stuck on. I thought maybe it was just the PLC. I pulled the program tried it on a new PLC with no luck. I checked for faults and the handheld shows no major faults. The output that is stuck on is for a door, its telling it that the door is open. Any help would be great.
  23. Software for Siemens s7-1200

    Hi guys, i have siemens s7-1200 that i need to communicate with. Meanwhile i have programming software Simatic Manager ver.5.3. Can i use this Simatic manager to communicate with s7-1200, and how to configure its connection. Thanks and best regards, Harianta
  24. Micrologix 1200

    I have a micrologix 1200 series module which goes on fault mode after providing it in run mode and it shows an error of 81h whenever i clear the fault nd go to run mode i get faulted again. Please help guys  
  25. Siemens structured language SCL

    Introduction to leguaje SCL senior siemens. When I use it for better optimization tasks, how to handle it and what its structure to be known as a language PLC Open. See more at   http://www.tecnoplc.com/scl-lenguaje-estructurado/   PLC and HMI programming http://www.tecnoplc.com