Search the Community

Showing results for tags 'micro flex'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Found 37 results

  1. Motion Control

    Hi Everyone.   I have been tasked with changing out an older Flex Drive servo drive to a more modern Micro Flex drive in a machine that has an Omron CQM1H-CPU51 PLC.  I'm having a few issues but hope that i can gain some clarity around at least one of the hurdles Im facing from here. Biggest issue for me at this moment is My work hasn't yet purchased a programming lead for this PLC (or even the bits required to make one myself) but i have a feeling the control for the Servo is done via motion control in the PLC.  Question here is, if changing from one servo drive to another type, will the motion control code need to be updated to work with the new servo drive?  I have very limited experience with motion control itself at this stage so I'm a bit lost when it comes to these sort of details. Regards Kiwi_man82
  2. PLC is old one, but I need to add one feature, Signal can be very short and when I get it I want to stop auto mode. I am afraid that signal can be so short and skipped by normal input. How I can set input as an interrupt input. I read that PLC has events processing and it can be triggered by " inputs 0 - 3 of position 1 module, on rising or falling edge"  - in first slot I have card TSX DMZ 64DTK. ( 32 inputs and 32 outputs) is it true ? -  and how I associate it. Maybe I create new Events and as an input I use f.e %I1.0  or I configure it somewhere?   thanks for help     
  3. power flex 525 multi speed

    Hi guys! I need some help with a powerflex 525 multi speed configuring. I know I have to set the P046 parameter for 2 “DigIn TrmBlk” (source) and  P047 parameter for 7 which means present frequency. This is the speed reference. I need 3 speed, so I will use Terminal 5 and Terminal 6. When both terminal is zero then 10 Hz, when terminal 5 is 1 but terminal 6 is 0 then 20 Hz and lastly if both terminal is 1 then it will be 30 Hz. I will adjust the speed with the parameters: A410, A411 and A412. Terminal 2 would be the forward and terminal 3 would be the reverse direction. I think these two can be two PLC digital output trough one-one relay. It will be counted the distance by an encoder. When it reach the target the run command will be released and the motor will be stopped with the decel time1. Also I will connect the S1 and S2 for safety.   My question is do I have to connect other wires ? Also do I have to remove the jumper between terminal 11 and 1 ? Am I forget something ? Any comment would be highly appreciated. Thanks ahead.  
  4. Hi,  We have 2 x 1756-L71 Processors joined together with a pair of 1756-RM2/A redundancy modules. The rack also has 1756-EN2T and 1756-CN2R modules.    I was called to the site after a power outage and found that the link between the 2 CPUs had failed with one displaying no program and the link modules with error lights. The ControlNet cards also had red lights on both channels and all of the FlexIO devices were red Xed in RSLinx. I went down the path of trying to get the CPUs up, and running but this was a red herring as I was informed that if the CPU's get out of Sync and have any faults on the cards the secondary one will lose its project. The ControlNet cards were giving a no Active Keeper fault? So we went down the path of the ControlNet cards, I initially thought that it was that the cards had lost their configuration files but we isolated the coax network to just the 2 cards, and the CP's and ControlNet cards came back up online. We joined the network back onto the ControlNet cards and found a faulty 1794-ACNR15/CFlexIO module. Once we replaced this the other devices (48 devices on the network) were not being discovered on the network. We went around and power cycled the IO units and then they started to Auto discover and the site came back up - Note CPUs were in Program mode at the time and I flicked them to Run and the site came back online. Does anyone have any information on why they needed to be power cycled and is there likely to be an underlying issue other than the single failed module pulling the network down?
  5. Hi! I'm using RSLinx Classic, RSLogix Micro English and RSLogix Emulate 500 to emulate a Micrologix 1100 Series B. I'm able to run, program and simulate different input and output with the emulated PLC. Everything works fine. My problem is that I'm writing a program using the nodePCCC library (https://github.com/plcpeople/nodepccc) and I'm not able to connect to the emulated PLC using the address 127.0.0.1 and the port 44818. I tried  running 'netstat -a' on Power Shell and I found out that the port 44818 is not being used.  Could someone help me identify what I'm doing wrong?
  6. Hello all, I am working on a project where I am communicating with a Mensor CPT6100 pressure transducer using a Micro-850 PLC. For this, I have used an AWA instruction to write some ASCII characters to the sensor. The sensor then responds to the write instruction by sending ASCII characters to the RX buffer and I used ACB and ARD instructions to read the ASCII characters. Now, I have set the ACB trigger type to 0 (msg triggered only once) and it successfully reads from the sensor. However, when I set the ACB trigger type to 1 (msg triggered multiple times), I do not get any reading in the ARD block. As a matter of fact, the ACB Q bit switches off every time the program is executed when the trigger type is set to 1. I am trying to get continuous readings from the sensor, but when the trigger type is set to 0, the program latches on to the first and only reading and it won't change. My question is, how can I change my program so that it can continuously and autonomously read from the sensor without me having to manually trigger the AWA and ACB instructions every time. I am attaching the program to this thread for your reference.  ASCII_Test_Copy.ccwarc
  7. Good day all. I have an application which is running an Allen-Bradley SMC-Flex and the client would like to get the monitor the current of the soft-starter via an HMI connected to a Delta DVP-12SE. Is the SMC able to output a current and with what communications medium would I use?   Thanks.
  8. I want to offer my industrial surpluses for your projects! All details are verifiable. Excess surpluses often occur. Sending to any country in the world. The price is low. I can pick something up for you personally. Sending can be made, both expedited, and economy air delivery. Ukrposhta or EMS Ukraine. Siemens Simatic, Wieland,  Wago 750, BECKHOFF, Schneider electric, Schneider Automation, Yaskawa Omron, KEYENCE, Pepperl+Fuchs, Telemecanique, ABB, FESTO,  DUNKERMOTOREN, Eaton, Micro Innovation, Jumo, Phoenix contact, Bruel & Kjaer, Unitronics, Samson, Danfoss, OMRON, Rexroth Indramat, Fanuc.  https://www.ebay.com/usr/vitalij6131   All parcels are sent by Airmail, are processed with disinfectants and sent with a large number of bubbles before being sent. For safe delivery of the parcel to you! I am worried about your safety, in this difficult time for you!
  9. Hello - we run a car wash that is controlled by a Modicon TSX Micro 3721001. It is indicating a CPU fault. I've attached a picture of the unit in place, with the LEDs lit. I have ordered a new base unit (2nd picture). I haven't tried it out yet, but it is tested working. I am hoping a base unit replacement will solve the problem, but wondering if it it possible the problem could be in the modules? I did not order those but now wondering if I should have... If the issue could be with the modules, is there a way to test which one it would be so I won't need to order all 4? If it coult be a module, I might order that now as I am in a rush to get back in service. Thanks for any guidance! Andy
  10. We have a carwash automatic controller board with an Eagle Signal Micro 190 PLC.  The program has been reloaded after power outages from a MX207l1 EEPROM Memory Transport Module for over 20 years.  Suddenly the reload isn't working -- either the MTM lost it's program or the socket has worn out over the years.  Anyway, the program can also be loaded via a 9-pin serial cable from a PC.  In trying that, we've found that the program the vendor gave us on the PC doesn't match that on the MTM.  Testing shows that only one output is incorrect.  We simply need to change output on O22 (broken trace on the board 20 years ago) to O20 (which would then match the MTM code).  I am a software engineer, but have never used ladder logic in a PLC.  I *think* I have changed the output, but maybe I just changed a comment.  [Testing requires powering off the carwash, with loss of $$ if we can't get it back up, and $80K expense for total failure, so trial-n-error isn't feasible.]  (1) Can anyone discuss what I did with me so I have a better idea if it will work or not?  (2) Is there anyone in the Atlanta area willing to look at this?  Thanks for reading!
  11. I have a devicenet network with slc 05 module 1747 sdn and two flex io systems with 1794adn adapters.  After a thunderstorm where lightning struck us near the facility The 1747sdn module had an indicator LED flashing in red and error code 91. I connected to the network through 1784 u2dn to be able to configure from RSnetworks, but the program only saw the Flex io, not the 1747sdn module. According to the manual, a resistance of 60 ohms must be measured between the blue and white wire, when measuring with the instrument it gave me 120 ohms, which seems to indicate that a resistance was missing at one of the ends, so I placed a resistance of 120 ohms in the end of the devicenet module, to get the 60 recommended measure. The module was kept with an error code 91 So I decided to change it for another card, when changing the card the module indicator LED was no longer in red but it was impossible for me to communicate with the card through Rsnetworx. The other two nodes of the devicenet network had to be disconnected so that I could see the module in the RS networks. I loaded the configuration of a similar network previously saved in the computer, but when connecting the other nodes of the network to load the scan list the network fell and I could not continue with the configuration of the module and now i can not see any node from Rsnetworx.
  12. Flex I/O Rack

    I am in the middle of doing a retrofit for a old PLC5 and i decided to upgrade it to a Control Logix. With how much I/O I was needing the price of the system was going to be very pricey. So I decided to use my main rack as a control logix and use Flex I/O for my remote racks. I have never put together a Flex I/O rack so I am unsure of what I need for this rack other than my I/O modules and a communication module. Could someone give me a list of what is needed for these systems? 
  13. Micro 850 to Logix5000 comms.

    I am trying to read data from a Micro 850 into my L18 (V 30.11). I have never set up an ethernet bridge between these 2 components and i have been up against a wall since starting. I have the MSG blocks in my routine but i am obviously configuring either the bridge, MSG instruction or something wrong. Any help will be GREATLY appreciated!!!
  14. Flex i/o outputs shorting

    Hello everyone! Im hoping someone could shed some light on a issue im having. Im having issues with a 1794 ow8 output module. This module is used to control 8 hydraulic cylinders that push biomass into a burner. The overall problem is that roughly once every couple months a output will short in the on state and force a coil on, activating the vavle full time and burning out the coil. Each seperate output is fused on the module with a 2a fuse and each modules incoming power is also fused at 2a. The output that is shorted did not blow its fuse. The 'ON' light is not activated but 120v still runs through it. Since each valve has 2 coils and one is forced 'on' the main fuse will blow once the second half of the valve is activated because the valve is fighting itself. It is not just this one module, this happens on other modules that serve the same funtion as well. This is a contractor installed system but they have been no help so im left trying to figure it out. Could my seperate inputs be fused too high at 2a for this type of card. These are parker valves 120v 60hz with a max 1500psi pushing wet hog/chips. Any suggestions would be really appreciated!
  15. Is it possible to communicate from a PC program to PLC program for reading inputs and setting outputs? How can it be made ? is it possible to do from TER connector or AUX connector , without special comm module?
  16. Trouble Wiring a Simple LED with a Micro820 Controller

    Hi everyone, Recently, I started working with the Micro820 Controller Embedded I/O. My project is simple : when the output _IO_EM_DO_00 is set to true, an LED light turns on. But, even though it's super simple, I can't make it work. Here's my setup. If you need more information, feel free to ask anything !
  17. Socket communication with Micro820

    Hi everyone ! I have a little project wich involves communication between two Micro820 controllers via TCP/IP. To do that, I started to work with TCP/IP socket. Within CCW (Connected Components Workbench), I tried to create a new socket instance using the instruction SOCKET_CREATE and set the socket address to 127.0.0.1:21. Basically, my computer through the FTP port. The problem was that it couldn't create a new socket instance (error variable is set to TRUE and status is set to 4, wich I don't know the meaning) because I didn't have a server-side application that listens to TCP/IP socket requests. That said, I found an open source application called SocketTest that listens for TCP/IP socket requests on a specified IP address and port. So, I started a listener on the following address : 127.0.0.1:21, but the error variable is still set to TRUE and status is still set to 4. So, my questions are : Is my IP address OK ? Is my port number OK ? What means the status code 4 ? Is SocketTest doing what I think it does ? Do I need to do something else before using the SOCKET_CREATE instruction ? Thank you in advance for your help !
  18. Can't connect to Micro820 controller via CCW

    Hi everybody, Recently, I started working on a project. I want to develop a program for a Micro820 controller (2080-LC20-20AWB) using CCW (Connected Components Workbench). I built a little motor circuit for testing purpose. However, after building the program and downloading it to the controller, I tried to connect to my controller via CCW, but I can't. When I click the button "Connect", CWW crashes OR a window saying : "The controller has unnacepted changes" appears and asks me if I want to "Download current project to the controller" (wich I already did) or "Upload the project in the controller to overwrite current project content" (wich is grayed out). When I choose to "Download current project to the controller", CCW starts downloading the resource, but fails. In the "Output" window, there's a line saying : "Download failed for Device:Micro820: An error occured while reading from GETACTIVERESOURCELIST.". The problem is that there's no documentation at all concerning this error. I even tried to reinstall CCW, but it didn't fix the problem. I joined some images so you guys can see what I'm talking about. Don't mind asking for more details !
  19. Good morning i want to know how i can recognize into the compactlogix 1769-L24 ER the micro 850 (2080-LC50-24QBB), because i want to communicate this two devices with MSG, i already i can see these two equipments into RSlinx but when i start Studio 5000 i don't know whick module i have to use it to recognize the micro 850, please help me
  20. Greetings, I'm here in my home lab trying to acquire a working knowledge of UDT's.  I've had to work with them in the past in large existing programs and they were a pain to track down and find out what IO they were really controlling.  I have a decent understanding of what they are and I've created several to play with here using my softlogix processor and a digital flex IO rack. My issue starts when i'm trying connect my UDT's to the physical IO.  it looks like I cant use a simple move instruction (which would be way too easy and exactly what I need)  I have a flex IO 8 point output.  Local:1:O.Data[0] I have a UDT consisting of (see attachment) Valve001  Valve001.Out     Valve001.Out.OPEN     Valve001.Out.CLOSE   Valve001.In     Valve001.In.OPEN     Valve001.In.CLOSED I have a copy instruction set to copy Valve001    to Local:1:O.Data[0]     Length 2 that allows the Out.Open and Out.Close UDT's to control bits 0 and 1 of the 8 bit output . .... great. Now I have another UDT setup to control lighting... Door   Door.Out.OPEN   Door.Out.CLOSE I want to control bits 2 and 3 I make another copy instruction in a line before the original copy instruction that states Copy Door to Local:1:O.Data[0] Length 4 but i'm really just fighting for the same 2 bits that the valve controls.... how can I control bits 2 and 3 for the door/lighting logic using these UDT's?   and that's not yet getting into having physical inputs moved/copied to the UDT input bits. thanks!!    
  21. Hello, I have AB PV 300 micro HMI and AB ML 1000 PLC . i want to configure it so how i can do it ? is it possible to configure both without AIC ? Which cable is required please help me.   Thanks in advance
  22. Macro Burned by the Micro 850

    I'll try and keep this neutral and not degenerate into a rant, but my recent experiences with the AB Micro 850 have been less than heart-warming and encouraging.  We recently purchased a production line for my place of employment from a trio of OEM Equipment builders.  All were supposed to use AB ControlLogix or CompactLogix PLCs.  However, two of the vendors called purchasing and said "let us save you some money, by using the Micro-850 PLC Rockwell's latest and greatest offering".  And our purchasing bought it.  So this week we brought in a Rockwell Premier System Integrator to add 9300-ENA units to these machine so we could collect SCADA Data from them. Now in full disclosure these were CCW version 6 not the latest and greatest 9.1,  So we came to machine 1 a micro 850 and uploaded, saved a copy for safety, then changed the Gateway  from blank to the NAT device IP and downloaded.  Machines on our SCADA Net could now see the Micro 850, but the machine it was in wouldn't start or communicate with the Component Panelview.  Turns out that thing was in remote and came up in program.  Chose run and all appears well.  Go on and do machine 2 another Micro - 850 and it went equally flawlessly.  Our downtime window was up so we started making product.  Only one problem the previous maximum speed was unattainable.  As a matter of fact several configured variables were at their Initial Factory State rather than the state they were when we shut down.  SO HERE COMES BURN NUMBER ONE.  Upload and Save only gets the logic not the variables or the values.  You must export the Controller and each programs variables to a separate excel file to have them around to restore.  That means 1 upload and 15 exports per machine backup and no word of this "FEATURE" in the tech database.  Now today we got a window to do the third machine also a Micro-850. This time we went to program and changed the Gateway without downloading.  Went back to run and all was well in CCW, except the NAT couldn't find the Micro-850.  Blowing the project totally away and doing an upload we learned that the Gateway was not there.  So we did the 1 upload, 15 exports, 1 download and 15 imports and this time all worked fine.  SO HERE COMES BURN NUMBER TWO.  So now we try and place message instructions from Machine 1 to Machine 2 in place and nothing will communicate.  Now before you think we're total fools we had to Micro-850's talking to a Compact Logix on the shop bench just fine when they were all in the same subnet.  But when we placed NATs between them nothing works.  Hopefully our SI will sort this out over the weekend and I'll post that answer later.  SO HERE COMES BURN NUMBER THREE.  We've decided it is in our best interest to flash our Micro-850's to version 9.1, but given the Micro's track record we decided to flash a spare first and swap it in.  Only one problem, the Micro-850 is either such a hot commodity or poor unit that you can't get one for at least 2-3 weeks.  ANd FINALLY BURN NUMBER FOUR.  Trying to troubleshoot this week I wanted to force an INPUT on; only there is no right click and force option.  It is called variable monitoring and you must lock and un-lock.  It has been FORCE for two decades, why change what we call it.  Really did we need to make this more complicated.   OK I am done.  I will not knowingly spec or buy another 850 in my Plant.  Enough said.  Control and Compact Logix only.
  23. Micrologix 1000

    Hello,  I am getting this fault when I am trying to load one of my program and set to run mode.  I have the same plc and I have not had this problem again. 1761-L16BWA Any suggestions ? I think this plc is older than the other I have. 
  24. Panelbuilder 32

    I am in the learning phase of HMI and PLC programing and am trying to use some of the hardware that has been donated to me. I have an AB panelview 300 micro terminal and a Micrologix 1000 Plc (they are not tethered yet). I have constructed a small test board with everything mounted to it and have successfully written and downloaded a simple project to the plc with timers, etc.   Now I need to find a way to program the terminal to make changes to the program.   I am looking for some free panelbuilder 32 or anything that will allow me to program the terminal and use it.   Can anyone help me? All help will be greatly appreciated!
  25. Gentleman…   Does Rockwell have any simulation PLC code that mimics an SMC-Flex soft starter?  Since we are using those (as well as the E3+ and E300) I would like to develop a model environment for starting of several drives.  In a specific case, we may have 3 or 4 drives in a pool of drives in which only a subset must be running at any one time.  Development of ladder logic for starting and maintaining those drives running while considering various fault conditions and startup issues would be very helpful in our environment.  I would like to be consistent among various areas within our plant that we incorporate pools of drives, from 4 to 2.  Having the ability to test in the lab would be very beneficial.  Thank you, David