Search the Community

Showing results for tags 'kinetix 300 ethernet/ip enable'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Found 217 results

  1. I'm trying to understand the basics of using a serial to ethernet converter such as this Comtrol DM-EIP-2101, with Studio5000 code. Basically I have a weighing machine that only outputs data via RS-232 and I need to send that data to a PC that will process it through a Studio5000 program and have the data displayed on an HMI using FTview SE. Is it as simple as just connecting the serial and ethernet to the converter and it does all the work? Obviously checking ip addresses and firmware will need to be verified. The main thing I am unsure of is the process of passing the individual data packets from the machine to the Logix code on the PC,  things like what the weight of the item was, was it over weight or under, etc....  Would there be an AOI or tags built into the software for a machine like this Checkweigher? I've worked with much smaller items like Cognex Dataman cameras and I know you can just use their AOI that allows you to simply call a tag if you want to display information like if a scanned barcode was correct or whatever. If anyone has done something similar I'd appreciate any guidance. It can be difficult getting the information from the manufactures so I'm looking for answers anywhere I can. EDIT: I guess I should also clarify that only using one or the other (serial or E/IP) is not an option. It will be a serial connection from the Weighing machine to the converter and then Ethernet to the PC.
  2. Hi All, I am new with PLCs. Currently I have a project that required me to send a 12 alphanumeric (2D code scanned) from multiple CP1Hs to NJ101. Then NJ101 will directly send the data into a SQL (haven't made yet). So basically, there are a few hurdle that I face. 1) How send data from CP1H to NJ101.  - I have tried using _CPU010_SendData from CP1H but I'm not sure how to do the ladder or what to use on sysmac (NJ101) side. Btw, I really not familiar with sysmac.  This is the first project that I use sysmac.  - I have read about TCP IP, Fins/UDP and Fins/TCP but I'm not familiar with those method. 2) How to confirm that NJ101 has received the data from CP1H 3) How to arrange the data received from CP1H into SQL - This one I have a sample program that I can follow from my colleague. 4) Setting up a dummy SQL server just for the sake of testing. - I don't have any idea on this. I anyone have an application or software that can used to test the database function, please let me know.   Your helps are greatly appreciated!   Thank you! Bob
  3. All, I have been trying for days to find a way to control a yaskawa v1000 over Ethernet. I have been trying to use explicit messaging but I cannot find the instance class  etc in any of the yaskawa literature. All I can find is to use EDS files with RS5000 but I have a micrologix 1400 and I don't have that capability. If anyone has any recommendations let me know. Thank You, Liam M.     
  4. I am needing some guidance on an application I'm working on. I'm trying to obtain data from a profinet slave device to an Allen Bradley compactlogix PLC. I am using a Prosoft PLX82-EIP-PNC profinet-/ethernet-ip gateway as a median to allow me to access the profinet data. In RSlogix5000, I have created an EIP Class 1 connection for the profinet controller and AB PLC (248 words of input data, 248 words of output data). The same structure is created in the profinet controller (248 words of input data, 248 words of output data). The profinet gateway and PLC are communicating properly. From my profinet slave device, I have a specification that the data is structured within a 23 byte format. Connecting to my profinet gateway, I can see this data. I have attached an image that shows the specification of the profinet data and the data values displayed inside the profinet controller. From the PLC side, I'm needing to be able to see this data and put it in meaningful values. I am using the profinet slave device's internal temperature as an example to work towards. I'm not sure the best way to be able to handle this data and structure it to a meaningful value inside the PLC. (I am using the device's internal temperature as an example to try and get into the PLC).   Thanks,
  5. I am needing some guidance on an application I'm working on. I'm trying to obtain data from a profinet slave device to an Allen Bradley compactlogix PLC. I am using a Prosoft PLX82-EIP-PNC profinet-/ethernet-ip gateway as a median to allow me to access the profinet data. In RSlogix5000, I have created an EIP Class 1 connection for the profinet controller and AB PLC (248 words of input data, 248 words of output data). The same structure is created in the profinet controller (248 words of input data, 248 words of output data). The profinet gateway and PLC are communicating properly. From my profinet slave device, I have a specification that the data is structured within a 23 byte format. Connecting to my profinet gateway, I can see this data. I have attached an image that shows the specification of the profinet data and the data values displayed inside the profinet controller. From the PLC side, I'm needing to be able to see this data and put it in meaningful values. I am using the profinet slave device's internal temperature as an example to work towards. I'm not sure the best way to be able to handle this data and structure it to a meaningful value inside the PLC. (I am using the device's internal temperature as an example to try and get into the PLC).   Thanks,
  6. Hello I have a problem with dl-ep1 ethernet modul. I connected the module to a IL-1000 sensor amplifier. There is some problem with the communication. How should I adjust ? I made some pic about the trouble. The sensor is a IL-600 laser distance sensor. I dont know yet how can I get the actual value.  Anybody knows how to set this modul ? If I think correctly after the right setting, if I check the sensor output:0 then, I can see the actual value of the IL-600 sensor. But unfortunatelly this part also not so clear for me, because I can connect about 15 sensor this ethernet modul.  Thank you so much if anybody help.
  7. Hi Guys, I need your various suggestion and helps on this issues. Past few days we facing an issues whereby the gantry of Z-axis which using the Kinetix 5500 servo drive straight crash down on the conveyor. The fault was Excessive Velocity Error and the first thing we took a look was the teaching and the speed. Somehow the teaching value of the motor and the speed was alright, we are running the axis on 100% speed. We have no idea the fault might be on the wiring or it might be the acceleration of the motor speed. We use to run this machine onsite at various customer, and this happens past few days. We run out of idea and we will be very much appreciated if there is any helpful idea could be bring up to. Steps taken so far; - Verify encoder value - Checked teaching position - Verify speed,acceleration and deceleration value was correct - Power motor connector was shielded  
  8. I have a cpu33 that I had issues with a bad battery and it loaded from memory card.  The version on the card was old so I decided to download the latest version from 2 days ago to it.  When I did, I lost communication through ethernet.   Can't connect through usb either.   The thing that baffles me is that I can ping the plc at the address and I get a reply.   Any help/suggestions would be greatly appreciated as I am not familiar with omron plc's at all.  Also on the display it cycles through Er HE 1P 07.
  9. I've got a 300 with Motionview that I'm going to run using the IOD connector with discrete signals.  First time to touch one of these.  I see the pin 29 is enable/inhibit.  I've tried +24VDC, 0v, and nothing and the drive will never 'enable'.  What am I missing?  I've got the the STO where the safety1 & 2 inputs are tied to +24VDC and the commons shorted together.  I tried unshorting the commons.  I tried removing the connector altogether.  I've read the manual, there nothing mentioning 'enabling' other than that pin 29 being high, which obviously doesn't work for me.  Any help?
  10. Hi everyone,  I am trying to use Kepware to communicate with my PLC setup which is the iQ-R Series R08PCPU.  I read the documentation which is available at https://www.kepware.com/getattachment/3daf1ac3-5c76-49ce-bbfe-f0fb1015f6cc/mitsubishi-ethernet-manual.pdf I read through the setup for Kepware and the setup procedure for iQ-R series but it still didn't work.  From the documentation, it said something about "using special ladder logic to enable ethernet communications is required.", I couldn't find anything about this online.  Here what I did in addition to the documentation: - Enabled IP Packet Transfer - Ping the PLC's IP Address which was successful Does anyone have any idea what I didn't do to establish that communication between Kepware and R08PCPU?  Thank you in advance. 
  11. Kinetix 300 servo drive

    Is there a real-time help resource for this thing other than the worthless AB site, on which the support page has been giving an error message for 2 weeks?
  12. I have a AB CompactLogix L43S with 1768 ENBT Ethernet/IP module. I would like to talk to a TCP/IP device (such as my laptop) from the PLC. How can I do this without using RSLinx? 
  13. I have a line that I'm integrating that requires the main machine (Q13UDVCPU) to communicate via the built in Ethernet port with 3 different up and downstream machines using FX3G controllers with FX3U-ENET modules.    We are using GX Works 2 software. So far I'm having no luck with the Mitsubishi documentation, or online.  Some (old) sources say it is not possible, I hope that is not the case. What I could really use is a working example program to look at and dissect.  But any help would be appreciated.
  14. Hello all. I have been working with an SLC 5/04 system, which houses various Digital and Analog INs and OUTs, up to Slot 29. I am currently mainly working with Slot 25, an Analog Input: 1746-NI16I. This is a system which has already been set up and has been running for the best part of 8-10 years. This particular card has had some spare inputs, one of which I am trying to connect to. In the Advanced Configuration, only a few Channels are actually "Enabled", and each channel is pretty much slightly different from another in terms of Input Type, Filter Frequency and Data Format. I am trying to set up Input 14, which is Channel 15, to "Enable" it, 4-20mA Input Type, Filter Frequency of 6 Hz and Data Format of either Raw/Proportional or Engineering Units. Now, after I have made my choices, I click apply, and then OK. I am then confronted by a pop-up which states: "Configuration Rung and Data Integer Data File Number: 25 Integer Data Element: 100 Rung to be inserted: XIC S2:1/15 COP #N25:100 #O0:25.0 24 At Program File Number: 4 82" I have the options of OK or Cancel. If I click OK, I now have LAD 4, Rung 82 Highlighted. This First Scan Bit and COP function were already here, but does that mean I have now altered what is being written to "#O:25.0"? I now Download the Changes. However, after all this, I am not getting any Analog input reading coming in from the Live PLC. What is this COP function? What does it do? How do I properly set up this Analog Card?   Thanks for your time, -Jame
  15. Anyone know any free libary to communication with FX3u-enet-adp, please help me ? Note: I've used mx Component , it work very well but it is too expensive and I dont even know it can work in windows server 2012/2016 or not.  one more question, Is there otherway to make program run in other computer without install mx compoment, it is very huge to install in every client computer Thank for reading and sorry for my bad english  
  16. Communication error

    Hey Guys,    This is my first time on a forum like this! but i need a hand with something if someone could point me in the right direction.   I have a Powerflex 40 drive communicating over Ethernet/IP to a switch, That drive has four Powerflex 4's connected to it thru DSI connection. They seemed to be wired correctly and seem to be sound connections but when someone on the production hits an E-Stop it removes power from this bank of drives. (Which is standard here) . However, when they power back up i get an F081 Error (Comms lost) on the master drive and one slave. Also, the port light on the 20-comm-e(Powerflex 40) is faintly flashing about every 5 seconds and is the only light on. In this state, none of them communicate. However, when i unplug the DSI cable, the 20-comm-e powers back up to normal operation. I then plug the DSI back in and everything works fine.  Should i start replacing parts or is there some parameters/other wiring i could check?   Thanks guys.
  17. I recently had an issue where a system shipped to a customer's site with a mismatch between the IP address loaded into the CJ1W-ETN21 card and the node dials on the card itself.  We had been testing the settings of the card by pinging the address and had assumed if the node dials were wrong we would not be able to ping the card.  As we just found out that is not the case! Both our quality department and our customer's end user were able to ping the Ethernet card, but the end user could not establish FINS communications because the node dials were not correctly set. Is there a way to test that the dials are correctly set?    Thank you!!!
  18. Is it possible to add another AB Rockwell PLC to the network tree as a Generic Ethernet Module and use it as IO? Any idea where I would find information regarding assembly instance and size of I/O/C for AB Rockwell products? If possible, what are the pros and cons when compared to produce/consume and MSG instructions? Don't need to use it real world, just curious. Many thanks in advance.
  19. Hi all !    I need a help about connection between mitsubishi GOT Simple series (gs2110) to kawasaki robot via crossed ethernet cable on tcp/ip protocol. I actually have a fx3g for main unit of my project, and also i have a kawasaki robot for slave unit. My purpose is basically to control both with HMI. I used RS422 between plc and got gs2112 and I want to use a crossed ethernet cable between robot and got but i did not communicate with ethernet even between pc and got. There is a manuel which I found on internet about GOT2000  Connection Manual (Microcomputers, MODBUS/Fieldbus Products, Peripherals) I think i need to work on  microcomputer connection (ethernet) subject, what do you think about that ? I need all advices and ideas which come from you.   [ROBOT]--------Ethernet--------[HMI]--------RS422--------[PLC] https://electrobit.ee/web/file_bank/Manuals/operaatorpaneelid/mitsubishi/GOT2000/GOT2000-connection-manual-ENG.pdf
  20. Zebra ZT230 Ethernet/IP

    Does anyone have an .eds file for the Zebra printers. I need to use ethernet/IP from a CJ2MCPU31
  21. SUPERVISION OF A CHAIN

    I have 6 PLCs CPM2A and 4 PLCs CP1LM I'm going to network them to do the supervision and data acquisition from each PLC and connects them to a pc via an ethernet port So what are the hardware and software used?
  22. What am I doing wrong? I have an FX3GE PLC. I have set up the IP address 192.168.3.254 and I am able to connect with my laptop running GX Works2 version 1.501X. I also have a GS2107 that I have set up with IP address 192.168.3.18 (Default). I can communicate with my laptop running GT Designer3 version 1.151H. The HMI is still failing to communicate with the PLC. I have followed different threads on this forum, tried different port settings on the HMI. I have attached my settings. Is there anything else I need to set?
  23. We have been successful using the EIP4CCPU module in communicating Ethernet IP between Compact Logix And Mits Q PLC's. Always with the Allen Bradley as the master. However, we are presently trying to control a 520 PowerFlex VFD from the Q series as master.  Has anyone attempted this?
  24. Any tool to simulate Ethernet/IP for omron PLcs? I need to know the complete packate structure for Omron Ethernet/IP over Omron PLCs. I have read that we can use FINS command inside Ethernet/Ip packet . But how to get full pacakte structure.   Please help , it is urgent.
  25. I am looking to replace a SIC Hiperface encoder with a standard 1024 encoder. I see how to change the protocol here but am wondering what else I would have to change. Thanks for your help!