Search the Community

Showing results for tags 'inverter servo drive syncrhonization speed position'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Found 191 results

  1. How can i limit MRJ4 servo load?

    Hello, I am beginner at servo and its driver. i am using MRJ4A driver and HG SR102 servo motor. i want to make my servo stop or alarm when the load is over the maximum load that i set by my self. what parameter should i set to limiting servo load even if the servo motor strength enough to lift the load.?  
  2. Can anyone tell me how to check fault history in Allen Bradley powerflex 40 drive?  
  3. Hello Experts We have a machine with Mitsubishi Servo MR-JE-2008 With PLC Fx 5U & HMI GS2107 Yesterday we altered PLC by adding a row with input and timer & used this Input in next rung for weld start Although we did not  find any linkage but found "'Screen error Ok"' on HMI and after pressing Ok, HMI screen getting blank. We restored original PLC backup - PLC in Run Mode still ""Screen error Ok"" on HMI Via GT designer 3, we have loaded HMI backup, now HMI screen is OK and normal Getting Ab on Mitsubishi drive - we feel it is not an error but due to this we are unable to rotate motor although other functions like door open/close etc Ok In PLC, online mode, we are finding Servo in ON but unable to understand Ab on Drive and may be due to this, unable to rotate motor Please refer to attached HMI, PLC & Servo Backup Request advice HMI BACK UP.GTX PLC BACKUP.gx3 Flange Welding_Tag Line Servo Backup.mrc2
  4. Dear all, I have an Omron inverter 3G3TC-AB004, which apparently there is not much information about it online. I have successfully connected this inverter with Modbus, and able to change some of its parameters from Modbus Poll, yet I still haven't found the address for the Start and Speed Command. I've tried to set the frequency from modbus but unfortunately it's a read only register. Is it possible to control this inverter from modbus or it's only useful for monitoring the inverter status? Thanks in advance.  
  5. Motion Control

    Hi Everyone.   I have been tasked with changing out an older Flex Drive servo drive to a more modern Micro Flex drive in a machine that has an Omron CQM1H-CPU51 PLC.  I'm having a few issues but hope that i can gain some clarity around at least one of the hurdles Im facing from here. Biggest issue for me at this moment is My work hasn't yet purchased a programming lead for this PLC (or even the bits required to make one myself) but i have a feeling the control for the Servo is done via motion control in the PLC.  Question here is, if changing from one servo drive to another type, will the motion control code need to be updated to work with the new servo drive?  I have very limited experience with motion control itself at this stage so I'm a bit lost when it comes to these sort of details. Regards Kiwi_man82
  6. QD77GF Error D304

    Hi. I am using PLC Q06UDV wit QD77GF to operate 11 servos, it is my first time using QD77GF and CC-Link IE Field. I've done the parameter setting. but the qd77gf error lamp started to blinking. i try to check it in cc link ie field diagnostic and didn't find anything except the error lamp blinking in monitor view. then i checked system diagnostic , no error showing up but, only historical error when i started the power of plc. it show D304 error.  in manual book the solution are lengthen the operation cycle qd77gf, check the cable, and shorten plc scan time. where can i find this setting sir?  
  7. question about ABB ACS800 control

    I am not a drive person (far from it...),  but I am working on a project using a number of ACS800 drives.  On one drive (only seeing this issue on one drive,  as far as I can determine) - when I specify a target speed and also specify maximum acceleration - there is a (significant) difference in terms of the accel time whether I have the drive set to internal speed control vs. external (encoder) control.  It takes almost exactly twice as long to get up to speed when set to external vs. internal.  (And problem with keeping it set to internal is that we lose accuracy at higher speeds,  and also at very low speeds...).  The most obvious issue would be a bad or improperly set encoder module,  but speed of motor is correct (as measured by tach) whether using internal or external.  Encoder module was also swapped for new one,  with no difference.   The only parameter that I am changing is speed by external encoder vs. internal  (I think that it is parameter 98.01).  Would anyone have any idea as to what could be causing this?   Thanks for any ideas!
  8. Hello all,    I have 3 kinetix 5500 drives connected in series but some how the 3rd drive lost power. all the fuses in the cabinet look good. nothing else is tripped either.    any advice is appreciated.  thank you   
  9. Hello All, I'm a newbie to Omron programing  I have a program where I want to control a stepper motor with 1 plc output "pulse output0"  in my program I used PLS2 instruction but when I execute the instruction the motor won't rotate and the plc outputs are off, My wiring is fine, and my plc is CP1E-N40S1DR-A MY 1st output is pulse output 0 Q100.0 and also the driver wiring with the stepper motor is good ( I did a test with siemens plc the motor does work fine ) , what could be the problem? thanks, PLC OUPUT 0 SETTING
  10. Hi everyone,  I am new to Mitsubishi PLC. I am trying to see from where Run or speed commands goes to Servo. I have MELSEC FX2M-32MT with FX2N-1PG cards for the Servo and I am using GX Developer 8.91v  Also, I would like to mention that initially I found out that BATT V light was lit so here what I didi. >I replaced the battery within 20 second while powered ON. Before changing the battery I took upload of the program successfully.  >I have cleared PLC memory and re downloaded the program.  > Checked Memory addresses M8005 8006 both are Low.  Now, when I am trying to run  my machine it is not giving output to two Servos while a conveyor operates when started from the HMI so it means program is inside PLC, right ? Program is attached if someone wants to have a look.  labeling mc 300322.rar
  11. MX2 Modbus doubt

    Hi there! I'm programming a CP1L-E CPU to control 3 3G3MX2 inverters via Modbus. It got some things right, like the INV002_Refresh_X31 block and its parameters. The thing is, I also want to read some parameters from the inverter using the INV206_ReadParameter block. My doubt is, do I need to be careful so both blocks don't execute at the same time and use the serial port at the same time? Is it better to use one INV206_ReadParameter block for each parameter I want to read? Thanks in advance!
  12. Omron 1S Servo

    Hello:           Does anyone know the details explanation of the Homing Settings for the Axis? Set the homing operation. 0: Proximity reverse turn/home proximity input OFF 1: Proximity reverse turn/home proximity input ON 4: Home proximity input OFF 5: Home proximity input ON 8: Limit input OFF 9: Proximity reverse turn/home input mask distance 11: Limit inputs only 12: Proximity reverse turn/holding time 13: No home proximity input/holding home input   Limit Input referring to Input (I/O) ? How about Proximity Input ? It is confusing with the terms. The manual has no explanation for each of the above selection.   Any one?   Simon
  13. Hello everyone    I am working on modbus TCP protocols to communicate between SEW drive and Omron PLC CP1L-EM. I am following modbus TCP function block from Omron, But i have updated that block because of is not fit to SEW modbus communication. Currently, I am sending a control work to SEW but I am getting error on Modbus TCP from SEW drive, which is invalid data. So I am looking your help is you work with SEW drive before and communicate over modbus, then please let me know how to make a data string for read and write (SEW Drive function 23). I am using 3PD data structure.    Thank you
  14. Hi, I need help with my program. How do I include the fractional part of the position I set for encoder? I have an Omron PLC and using cx programmer.  I need to command my servo (from HMI number input) to move to a certain position. Now using a manual computation, my servo is supposed to move 95.65mm, however, using my plc program, the resulting position doesn't include the 0.65. I used the FIXL instruction to convert my result from float to 32 bit and it removed the fractional part of the value.   Thank you!
  15. VHSC5/C

    Hey all. Wondering if anyone has an example program they'd be willing to share? Specifically I'm using the 1734-VHSC5/C with a 1769-L18ER-BB1B PLC. All of Rockwell's wonderful information only refers to SLC-500 platform. I'm not trying to do anything terribly fancy, just have a quadrature encoder attached to Channels A & B, then using an output to turn on a valve at 8.0" and turn off at 10.0" Any help would be appreciated.
  16. Hi, I have to implement an axis control in a NX1P2 PLC using an inverter (3G3MX2) and an encoder cabled on a EC0122 board. I found something similar implemented  on a CJ2M PLC, but I have no idea how to set up the axis in the configuration of sysmac studio and how to implement the control. Can someone help me? Some sample to catch out the configuration?   Thanks a lot Andrea
  17. Dear forumers, It started on ISPsoft end nov. 2021. I have to program a MS300 drive. It is a very interesting software. And even if it is a bit rigid, in ladder for example, I begin to like it. I would need some help though, especially on the APIs properties. Indeed, the F1 help doesn't work well. Sometimes it doesn't open (can bypass), sometimes the APIs I’m looking for is not in it.  In the different pdf's I have gathered, the APIs, especially those concerning the MS300 variator, are not all explained. Does anyone have precise literature, official or personal, on these APIs?  It is difficult to program by having to guess/test. The doc. I currently have: Delta Standard Compact Drive MS300 Series User Manual (2 PDF : one with 688 pages, one with 510) 2 Quick guid, probably done by my seller (Word format) ISPSoft User Manueal (2 PDF : 2017/06/14 with 840 pages; 2021/03/29 with 1160 pages) A few DVP PLC PDF : DVP-28SS2; SA2; SS2… I also had trouble installing the last 2 versions of ISPsoft on a Windows 7 pro 64 bits PC. The V3-14-0 version refused to install, displaying an inability to write to a temporary folder. The V3-13 version (SW_20210420) just froze during installation. No info. I didn't look further (the client is coming netxt week), I stayed at 3.12.01 (beta) Has anyone ever had this? I will try insall V3-14 on a windows 10, and also try a monitored install on my one personal PC at home with w7 pro 64b. Thank you in advance to anyone who can help me. I have contacted DELTA support in Europe and am waiting for answers. As well as my seller, who has technical competence, has already used this software, but is far from having answered all my questions. Best regards, KsioP  
  18. Hi guys! I need some help with a powerflex 525 multi speed configuring. I know I have to set the P046 parameter for 2 “DigIn TrmBlk” (source) and  P047 parameter for 7 which means present frequency. This is the speed reference. I need 3 speed, so I will use Terminal 5 and Terminal 6. When both terminal is zero then 10 Hz, when terminal 5 is 1 but terminal 6 is 0 then 20 Hz and lastly if both terminal is 1 then it will be 30 Hz. I will adjust the speed with the parameters: A410, A411 and A412. Terminal 2 would be the forward and terminal 3 would be the reverse direction. I think these two can be two PLC digital output trough one-one relay. It will be counted the distance by an encoder. When it reach the target the run command will be released and the motor will be stopped with the decel time1. Also I will connect the S1 and S2 for safety.   My question is do I have to connect other wires ? Also do I have to remove the jumper between terminal 11 and 1 ? Am I forget something ? Any comment would be highly appreciated. Thanks ahead.  
  19. Hey y'all- I have an application that uses an Allen Bradley servo with a brake and a linear actuator to lift a plate vertically. While maintaining a position, the servo drive (Kinetix 5500) will occasionally fault due to over-torque.  I'm thinking it could possibly be due to mechanical issues i.e. bearings in the actuator but my initial thought would be that it would fault while moving up/down as well, so far I've only ever seen it fault while holding a position. This leads me to suspect that there may be something off in the control loop. I'm not involved in the setup but I know we use load observer and I reckon we use auto-tune. Other than that, I wonder if it's something to do with the brake. I also read about mechanical resonance in the manual which seems like a stretch but it could be contributing, the frame that the actuator/motor is attached to does vibrate a fair bit.  I'm familiar enough with basic motion control using Allen-Bradley and understand the basic concepts behind the servo/control loop. However I'm at a loss for why the servo/drive would spontaneously over-torque while maintaining a position.  How would you guys approach troubleshooting this further/solving this issue?  Many thanks!
  20. Hello, I wonder who can help me out here. I am new to the CX programmer. I want to communicate to selema drive through CX programmer. The drive is IPS plus Selema. The company was gone in 2017. There is no manuals regards to the drive. Here is the issue, in the program. The SPED block show port specifier is 10, the INI blcok show Port specifier is 0. Refer to the PLC picture, my first questions which one is port 10? I think port 0 is the left bottom cable from the second picture. So port 10 is the last module?  Second, Do anyone have manual or knowledge with the selema drive? Is there another one to communicate with the drive not using CX programmer?   thanks
  21. Problem during tuning

    Hi! I would like to do some tuning on our machine, but the problem is that the machine stops and drops origin positions. I selected User Command method with Basic setting. After 5sec I started the tuning, the machine stops with the roblem of that axis. Is there a parameter bit that goes high (or low) during tuning? There're no strange sounds nor movements..even the amplifier doesn't give error code. Is there something else that i should check? In the Servo-Adjustments parameters, One Touch Tuning setting I found the Permissible Overshoot Amount Level is set to 0.  Can it be the problem? 
  22. hi everyone, I'm using 3g3mx2-a4022-v1 inverter, and to control the inverter, I decided to use the 3-wire input function & control the inverter from touch screen nb7w-tw01b, connected to cp2e-n60dr-a. now i already followed the manual on how to set it up. however, the inverter didn't run as expected. have i missing any step in setting up the 3-wire input function? currently i've set the c001 => 20, c002 => 21, c003 => 22, a002 => 01. is there any setting that i've missed? thanks in advance 
  23. Hi there I was reading this thread: And trying to create 3 axes. 1 virtual axis and 2 real axis, I would like to use MC_GearIn for each real axes so both real ones follow  the virtual axis (so both can move in sync motion). But my question is: If I give Move cmd(Absolute or relative)to master virtual axis and since it's virtual, it is not going to move then how can the other real ones follow the master(assuming that it's literally electronic gearing).  Any help will be appreciated!
  24. Anyone know what could be missing to be able to import this stepper motor to sysmac? This is one of the supplied xml files for the stepper motor.     FASTECH_Ezi-SERVO2_EtherCAT - OMRON.xml
  25. Hi there This attached pic I got from Omron motion control manual. I am trying to wrap my head around it. Does it mean that the slave servo axis is gonna follow master encoder axis using GearIn FB?? If so, then Can we executive Move FB on encoder axis? Looking forward to your responses.