Search the Community

Showing results for tags 'intelligent position servo drives'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Found 124 results

  1. MR-J2S- Servo Driver to PLC

    I have a test station to test MR-J2S Servo drivers,  I am looking for something unique in the drivers to be able to save data about that test.  First thought was the SN, but i am not seeing any way to pull serial number from the driver. Only found it on the side of driver and really don't want people having to type it in , cause usually they type in the wrong numbers.  Does anyone know of a way to get the serial number out of the driver? or at least where it could be found?  Or any other unique identifier in these drivers?  
  2. How can i limit MRJ4 servo load?

    Hello, I am beginner at servo and its driver. i am using MRJ4A driver and HG SR102 servo motor. i want to make my servo stop or alarm when the load is over the maximum load that i set by my self. what parameter should i set to limiting servo load even if the servo motor strength enough to lift the load.?  
  3. Motion Control

    Hi Everyone.   I have been tasked with changing out an older Flex Drive servo drive to a more modern Micro Flex drive in a machine that has an Omron CQM1H-CPU51 PLC.  I'm having a few issues but hope that i can gain some clarity around at least one of the hurdles Im facing from here. Biggest issue for me at this moment is My work hasn't yet purchased a programming lead for this PLC (or even the bits required to make one myself) but i have a feeling the control for the Servo is done via motion control in the PLC.  Question here is, if changing from one servo drive to another type, will the motion control code need to be updated to work with the new servo drive?  I have very limited experience with motion control itself at this stage so I'm a bit lost when it comes to these sort of details. Regards Kiwi_man82
  4. QD77GF Error D304

    Hi. I am using PLC Q06UDV wit QD77GF to operate 11 servos, it is my first time using QD77GF and CC-Link IE Field. I've done the parameter setting. but the qd77gf error lamp started to blinking. i try to check it in cc link ie field diagnostic and didn't find anything except the error lamp blinking in monitor view. then i checked system diagnostic , no error showing up but, only historical error when i started the power of plc. it show D304 error.  in manual book the solution are lengthen the operation cycle qd77gf, check the cable, and shorten plc scan time. where can i find this setting sir?  
  5. Hello all,    I have 3 kinetix 5500 drives connected in series but some how the 3rd drive lost power. all the fuses in the cabinet look good. nothing else is tripped either.    any advice is appreciated.  thank you   
  6. Hi everyone,  I am new to Mitsubishi PLC. I am trying to see from where Run or speed commands goes to Servo. I have MELSEC FX2M-32MT with FX2N-1PG cards for the Servo and I am using GX Developer 8.91v  Also, I would like to mention that initially I found out that BATT V light was lit so here what I didi. >I replaced the battery within 20 second while powered ON. Before changing the battery I took upload of the program successfully.  >I have cleared PLC memory and re downloaded the program.  > Checked Memory addresses M8005 8006 both are Low.  Now, when I am trying to run  my machine it is not giving output to two Servos while a conveyor operates when started from the HMI so it means program is inside PLC, right ? Program is attached if someone wants to have a look.  labeling mc 300322.rar
  7. Omron 1S Servo

    Hello:           Does anyone know the details explanation of the Homing Settings for the Axis? Set the homing operation. 0: Proximity reverse turn/home proximity input OFF 1: Proximity reverse turn/home proximity input ON 4: Home proximity input OFF 5: Home proximity input ON 8: Limit input OFF 9: Proximity reverse turn/home input mask distance 11: Limit inputs only 12: Proximity reverse turn/holding time 13: No home proximity input/holding home input   Limit Input referring to Input (I/O) ? How about Proximity Input ? It is confusing with the terms. The manual has no explanation for each of the above selection.   Any one?   Simon
  8. Hi, I need help with my program. How do I include the fractional part of the position I set for encoder? I have an Omron PLC and using cx programmer.  I need to command my servo (from HMI number input) to move to a certain position. Now using a manual computation, my servo is supposed to move 95.65mm, however, using my plc program, the resulting position doesn't include the 0.65. I used the FIXL instruction to convert my result from float to 32 bit and it removed the fractional part of the value.   Thank you!
  9. Hi, I have to implement an axis control in a NX1P2 PLC using an inverter (3G3MX2) and an encoder cabled on a EC0122 board. I found something similar implemented  on a CJ2M PLC, but I have no idea how to set up the axis in the configuration of sysmac studio and how to implement the control. Can someone help me? Some sample to catch out the configuration?   Thanks a lot Andrea
  10. Lenze i950

    Hello everybody. We have situation when trying to control a Lenze i950 drive from the Omron CPU NX102 using the CIA 402 CSP protocol with one motion axis configured on a 2ms task. On the drive is it a motor + resolver connected to lenze drive. EtherCAT communication is up and running and we are enable to run the motor with bad results.  behaviors we see is wrong actual speed from drive, hard stopping in the drive, oscillation when the drive is standing still, overshooting the target. running better when send lower velocity to the drive. First the scaling is off at least regarding velocity, As we do the scaling in the omron cpu 65536/Work travel distance per motor rotation and I am 100% sure it is correct. First time I am in contact with this drive, is there any out here that has experience with this Lenze I950 drive and their software's and able to give any idea what can be wrong ?  I have one feeling that there is some scaling being done inside the lenze drive aswell or wrong resolution somewhere. Have been in contact with the local lenze support without any progress  /Best regards  i950 BS-STO - TA CiA402_192_168_200_14_C01_TC2.gdc
  11. Hey y'all- I have an application that uses an Allen Bradley servo with a brake and a linear actuator to lift a plate vertically. While maintaining a position, the servo drive (Kinetix 5500) will occasionally fault due to over-torque.  I'm thinking it could possibly be due to mechanical issues i.e. bearings in the actuator but my initial thought would be that it would fault while moving up/down as well, so far I've only ever seen it fault while holding a position. This leads me to suspect that there may be something off in the control loop. I'm not involved in the setup but I know we use load observer and I reckon we use auto-tune. Other than that, I wonder if it's something to do with the brake. I also read about mechanical resonance in the manual which seems like a stretch but it could be contributing, the frame that the actuator/motor is attached to does vibrate a fair bit.  I'm familiar enough with basic motion control using Allen-Bradley and understand the basic concepts behind the servo/control loop. However I'm at a loss for why the servo/drive would spontaneously over-torque while maintaining a position.  How would you guys approach troubleshooting this further/solving this issue?  Many thanks!
  12. Problem during tuning

    Hi! I would like to do some tuning on our machine, but the problem is that the machine stops and drops origin positions. I selected User Command method with Basic setting. After 5sec I started the tuning, the machine stops with the roblem of that axis. Is there a parameter bit that goes high (or low) during tuning? There're no strange sounds nor movements..even the amplifier doesn't give error code. Is there something else that i should check? In the Servo-Adjustments parameters, One Touch Tuning setting I found the Permissible Overshoot Amount Level is set to 0.  Can it be the problem? 
  13. Hi there I was reading this thread: And trying to create 3 axes. 1 virtual axis and 2 real axis, I would like to use MC_GearIn for each real axes so both real ones follow  the virtual axis (so both can move in sync motion). But my question is: If I give Move cmd(Absolute or relative)to master virtual axis and since it's virtual, it is not going to move then how can the other real ones follow the master(assuming that it's literally electronic gearing).  Any help will be appreciated!
  14. Anyone know what could be missing to be able to import this stepper motor to sysmac? This is one of the supplied xml files for the stepper motor.     FASTECH_Ezi-SERVO2_EtherCAT - OMRON.xml
  15. Hi there This attached pic I got from Omron motion control manual. I am trying to wrap my head around it. Does it mean that the slave servo axis is gonna follow master encoder axis using GearIn FB?? If so, then Can we executive Move FB on encoder axis? Looking forward to your responses.  
  16. Axis Permanent Control

    Hi Guys, How can I bring an axis into permanent control? that as soon as a value changes, the axis reacts. My Hardware FX5U, FX5SSC MR-JE-20B. Thanks a lot.
  17. Servo tuning

    Hi.  I am planning to do a full scale servo tuning on our producting machine. Is it possible to do it while the servos are in, assambled? I mean no production, no disassembling, servos stay where they are, just tuning them one by one with their empty load..
  18. HELLO EVERYONE THERE IS THIS PROJECT WHERE I CHANGED THE OLD SERVO SETUP WITH NEW SERVO DRIVE MRJ4200A-RJ SERIES. OLD SERVO HAS A REVOLUTION OF 15 BITS BUT NEW SERVO HAS 22 BITS RESOLUTION. PROGRAMMING IS SAME BUT MY DISTANCE CALCULATION IS DIFFERENT NOW AND MACHINE DOES NOT GIVE CORRECT DISTANCE. PLEASE HELP ME
  19. servo training

    Hello . Does anyone from the forum have such a program as on flimik, and he could share a program for f3x and the got1000 panel regards
  20. Hi there I am working on a project where Omron servo drags a part to a certain position using belt mechanism, But to avoid any slippage we decided to put an external encoder directly on the part. I was wondering what is the best to approach to drive the servo using the position of this external encoder. Is there any way that it can be configured directly with the servo? I am fairly new to coordinated motions, any help will be appreciated. Thanks
  21. I'm sure many of you are in the same boat with supply issues and elongating lead times with the Logix 5500 and 5700 servo drives. Are there any decent alternatives that are easily integrated into a 5380 controlled system, maybe with an AOI? I've looked at Beckoff and Parker systems, but Parker only seem to line CoDeSys as far as I can tell. Do any of you clever clogs have any suggestions for a well stocked alternative? As a side note, I'm not new to PLC programming, but I am only 6 months in to using motion and servo systems so be kind :)
  22. Hello! I'm trying to connect my QD75M2 with a MR-J2S40B1 Servo amplifier with an SSCNET cable. The problem is when I try to turn on the Servo ON/OFF on the Intelligent function in GxWorks2, an error occurs saying the servo amplifier is disconnected with my QD75M2. I'm confident that I've wired it properly. What could be the problem? Hoping you might help. Thank you.
  23. Is it possible to reset " Motor replacement detected error" ( Error code 95.01) using code without connecting to PLC through sysmac studio? If yes please suggest how to do it... Thanks in advance...
  24. All of the ethercat servos I have installed are Omron. I have used many many brands in the past - over analog, pulse train, but not ethercat. I have one of the Yaskawa servopacks that can control two servos independently. The drive is all wired (POT, NOT, safety), autotuned, it's in RUN OK state, I have installed the ESI file, set up the axis, mapped the PDOs.. it's all working, but they do not move. I made a test program just with MC_POWER and MC_MOVEJOG/MC_MOVERELATIVE/MC_MOVEABSOLUTE along with the resetting of MC and EC and the servos do turn on, but ignore any movement command. They do not flare up with an error, and they give me their actual position, so the network is working. If I send the movement command the command position starts to differ, so the plc is/should be sending the command. I feel like there's something missing in the PDO mapping screen, but I didn't need to do all of this with Omron so I have no idea. I thought at first the servos needed huge units of movement and speed but the actual position value confirms this is not the case since it doesn't ever change.
  25.  What is the difference between Active Immediate homing and passive immediate homing ?   Does Motion servo axis have to be turned ON for active immediate and turned OFF for passive immediate homing ?.