Search the Community

Showing results for tags 'how to use encoder with micrologix 1400'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Found 103 results

  1. NX1P2 Motion Control

    Hi:       I need to change an old PLC  with NX1p2  to control 3 servo motor by means of Analog Outputs couple with encoders, My job is to change the PLC only. So the servo drives and drivers are untouchable (No budget and involve too much mechanical works).   I observed that Sysmac Sttudio Axes setting has this: Servo Axes, Encoder axes, Virtual Servo Axis and Virtual Encoder Axes.   I believe the Encoder Axes couple with Analog Output is able to to do the Job? If so, what function block should i use? If no, do any body have a suggestion of any function block i can use? Thanks  
  2. Hi: I am trying to determine if I should use the RS 5000 or RS 500 to start a micrologix 1400 project that will include a Maple Systems HMI. I have never used the RS 5000 software so I am aware there will be a learning curve, however I am certain that it could be useful in the future.  However, my work schedule is nights so I am limited in how much tech support I will get here at my facility when no one is using RS 5000 here at this time? Your input and feedback will be greatly appreciated. Thanks in advance.  
  3. Hi:         I am planning to use NX with Encoder Card  couple with Omron Rotary Encoder for measuring product length. ( GX-EC0211 /EC0241) or may be (NX-EC0112, I read there is proble with this card , here https://forums.mrplc.com/index.php?/topic/34896-problem-pulse-reading-with-fast-counter-card-in-nx2/ ), but whatever it is I need to know is there any specific Instruction in Sysmac Studio that is tailored for Fast Counter or Encoder (something Like PRV in CX Programmer or special function in CJ-CT021 where start/stop counter and changeable preset counter are available).  The Length measurement is straight forward and is only a small part of the overall program.  Basically is Start ---> measure to length----> Cut --->Repeat again.  I read through the Instruction Reference Manual and I am unable to find one.   Anyone have any idea or any sample program (Sysmac Studio only ) that I can refer to ?    Thanks     
  4. communication

    i want to communicate ml1400/compact logix L24ER to simatic s7200 via ethernet.Please help me with it i am new to it and dont know how to do it.
  5. SLC 500 and SMC Ex260

    I'm trying to connect a SMC EX-260 to a Allen Bradley Micrologix 1400 PLC so  I can run some valves with it. However, RsLogix 500 doesn't allow me to just setup a generic ethernet device like I would on RsLogix 5000. Is there a way I can communicate these devices together so I can use the SMC Valve system with my Micrologix?
  6. Hi everyone, I have an annoying fault on my Kinetix 5700 drive: M01-Safety Feedback. I know this fault is generated by  the SFX instruction in my Safety program that sets tag: "Axis.SFXFault" to 1. The problem is that the instruction is NOT in Fault (Fault code 1 = no fault). This error occurred after Safety encoder 843ES lost it's IP address. I used Bootp to set it gain. And reset the SFX instruction. I can see the encoder in studio 5000 rev 32.12 running and ok.  Does anyone encountered this problem? How can I clear the fault?   Thanks
  7. I have a machine with NJ501-1400 controller. I have some NX-ECS212 SSI encoder input cards. I use Encoder axis with that SSI encoders. I need to change the encoder axis value with the real value of the machine. I tried to use "MC_HomeWithParameter" instruction but I cannot do it because must'nt be used with encoder axis. If I put it at a virtual encoder axis I cannot change actual axis position. I tried to use "MC_SetPosition" instruction but it isnt retentive area and when I lost power I lost reference value too. How can I do it? Thanks! Josep Torres.
  8. Square Wave Problem With Micrologix

    Hello all, this is my first post. I am using an AB Micrologix 1400 (1766-L32BXB Ser C FW 21). I was trying to generate a pulse train using the PTO instruction. I have modified PTOX funct. file. The ladder is just a simple XIO followed by PTO, (The Quick Start ladder from 1766-RM001). When I looked at the output waveform on my oscilloscope, I noticed that it wasn't a square wave. I decided to run it at several different frequencies to see how the wave form would change. At 10Hz i got a square wave. As I increased the frequency the falling edge became sloped and almost horizontal. Is this how the output should behave? The data sheet indicates a max frequency of 100kHz, but at frequencies over 150 Hz. The wave form looks like the output of SMPS. 
  9. How to connect + Program wire encoder

    Hi all, I am not a PLC expert but can find my way within the program and would like to develop much more. For work (We sell industrial bandsaws) we have purchased a Posital Fraba wire encoder, and we would like to hook it up to our Mitsubishi FX3G PLCs to measure at what height the saw bow of the bandsaw is at that moment. Unfortunately I have little experience with connecting these things, as other encoders used in our machines are pre-installed by our factory. Below is described what functions the wires have. What I thought was the following: Pin 1 goes to an input of the PLC Pin 2 goes to + (or 24V) Pin 3 doesn't go to "Ground" as they describe, but instead to - (or 0V), which is technically ground Pin 4 and 5 we don't use, correct me if I am wrong. The saw bow goes up and down only, and I thought we don't need to use these wires.   I connected it like this, connected wire 1 to X0 on PLC and just to test I made the program read:   M8000 ------------------------------ C235 k99999   But the value stays 0, whether I pull the wire or not. So something is wrong, but what, I really can't figure out. Hope someone can help!  
  10. Hello Everyone, I am struggling with interfacing Incremental encoder with FX5U PLC, Does anyone have parameter setting and sample program for same. i am unable to fetch counts...   Encoder: 500ppr, 24V line drive, A-B phase,  PFA datasheet
  11. Hi all, I have my own driver to communicate with a MicroLogix 1400. Please refer to the attached screenshot from Wireshark. 10.10.21.10 is my driver's host, and 192.168.1.192 is the ML1400. The startup sequence to establish a connection & session with the PLC is correct I believe: - In the grey highlight, client requests a connection to .192 via SYN and this is ack'd - A session is registered, and forward open is successful - There's a lot of stuff in green simply because I've also got an HTTP browser session open to the PLC to monitor its session table - In between, spaced 8 seconds apart, are my two attempts to keep the connection alive by sending a List Identity request (as a ping, if you like). These are highlighted in pale blue. - However, 16.5 seconds from the start of the grey highlight, and 16.4 seconds after sequence=115 ack=99, the controller sends back a [RST, ACK] and a callback from my socket code tells me that the session has been dropped. The connection timeout for the PLC is configured as either 30 or 60 seconds, so I don't see how that's relevant here when the reset is happening only 17 seconds after it was established ? However, presumably the PLC doesn't see the application-level "List Identity" request as a valid means of keeping the connection alive. What is the correct mechanism to use that the PLC will accept as a keep-alive ?
  12. Signal Tower Error Code(s)

    Hi, got a mental block lol.  Got a machine we are modifying, currently got most of the code in place. Working on a fault routine now. This machine doesn't have an HMI or wide array of PL. Nothing major just a simple vision system check. Currently have 6 faults that will stop the cycle running. I'm wanting to have the beacon light (Red light) blink for the cause of the fault. For example: Scenario 1- Fault stop for bottle check NG:  (two) .5 sec blinks -  2 sec red light off -  (two) .5 sec blinks ..... repeat  Scenario 2- Fault stop for bottle check NG and reject sensor blocked:  (two) .5 sec blinks -2 sec red light off - (three) .5 sec blinks - 2 sec red light off....... repeat I have the code a few different ways but it looks "dirty". Any suggestions? Thanks in advance  
  13. Hi there, As a software engineer, but a newbie to the Allen-Bradley world, sorry if this question doesn't make sense. I'm enhancing an existing driver by trying to add the ability to read/write structured and array data types - rather than just the elementary data types it supports right now. This following question is only in the context of SLC/500 & MicroLogix 1400. And I'm currently working on a Counter as a test case, but any solution obviously needs to take into account other structured (and array) data types. One of the requirements is that the user should be able to select a specific atomic item within a parent structure/array that they want to read/write. So, using the Counter as an example, they might want to define a field which holds just the value of the accumulator. I know that I can achieve this with a CIP command. I specify file type 87 for counter, file number as 5 (my test example happens to be the standard C5 data file of counters), and element is 0 (for the first counter in C5). Bit number is irrelevant so remains as zero. I ask CIP to return me 2 bytes of data (to hold just the accumulator word). Finally, I tell CIP that I want sub-element 2 (because the accumulator is Word 2 of the whole structure). Sure enough, the CIP response gives me exactly the 2-byte accumulator value I was expecting, nothing more, nothing less. Success. My question is this: I knew I had to specify the sub-element as 2; this happens to work for a Counter because of the way it is structured as 3 words. However, it implies that the value I specify for sub-element is ALWAYS measured in units of 16-bit words. Is this a universal truth (i.e. works for other structured types too ?), or does the size of a sub-element depend on other factors, such as the file type ?   Thank you in anticipation.
  14. EEPROM PLC's

    I thought only PLC5's had EEPROM, but I was told MicroLogix PLC's also have an EEPROM that need to be burned to... What are all the PLC's that have EEPROM and require an EEPROM burn to prevent the program from being wiped in a power cycle?
  15. My project is to read an RFID tag (ascii) with a Micrologix 1400, send the string to a PC using Ethernet/IP, lookup and compare in an Excel spreadsheet, and send back data (probably an integer) for the plc to use to control direction. I have to scan and compare an RFID tag to a list of 1400 possible part numbers, at different locations (more than 1 plc). I want the several PLCs to go to a single PC to make it easy to update when changes occur (on a weekly basis). Has anyone done anything like this? I'm assuming there will have to be some kind of vb or c+ application involved.   Thanks,  CK
  16. Hi All, Am trying to communicate and make In-Sight bar code reader to trigger through MicroLogix 1100 with RSLogix 500.  Does any have any info as to the steps to follow. Most of the info I saw and have tried were for SLC processor In fact, I created the String file ST10:0  for the target device as was mentioned in one of the posts but when I complied it there was error saying that St10:0 was not supported by the module. Please see attached file. Any insight will be appreciated  
  17. Hello guys, I am running an application for packaging measurement using a sick DFS60B incremental encoder (programmable from 1 to 10000 PPR). In more detail, it passes packaging on a conveyor belt and we have created an inspection station and an expulsion station (defective packaging), so we use the encoder to check at specific points of the packaging for defects (we use special sensors to check defects). ) (there are four in total). However, the problem we are having is the following: When reading the encoder in the PLC, the same means that performs "jumps" and does not enter the windows (GRT and LES) created on the ladder, ie, as if it were not continuous. . I understand that because the VHSC24 card works at 1 MHz in counter mode, this type of problem should not occur according to our application is not even 100 KHz. For example, our case: Using 1000 PPR and the motor speed (coupling output) is 3600 RPM (in practice it is around 1750 RPM) the frequency is calculated as follows: F = (PPR X RPM) / 60. : F = (1000x3600) / 60 = 60 KHz, ie 60 KHz is much less than 1 MHz, I think this kind of problem does not occur. Application Info: . Studio 5000 V31 . PLC Model: Rockwell 1769 - L19ER-BB1B CompactLogix 5370 . Encoder Card: 1734-VHSC24 / C . Incremental Encoder: Sick, DFS60 up to 10,000 PPR and HTL Electrical Interface. Using a 200 mm circumference / perimeter wheel. . Motor Nameplate Data: 1670 RPM, 0.37 kW / 0.5 HP, 60 Hz . Inverter: Weg CFW500, Output Frequency 62 Hz. Card Settings we use RPI: 2 ms Type: Counter, but we already use it as Encoder X1 Store Count Mode: Disabled Filter: No Filter, but we use 50 KHz and 5 Khz filters in our tests. Counter Attenuator: 1 Wiring Diagram VHSC24 We turn on encoder A at input 0 and encoder Aret at input 1 In logic (Structured Text) Using the PMUL instruction to convert encoder (Pulse) data to mm scale. (Ladder) The window comparisons part (GRT and Les) and other part of the process. We emphasize that we performed the tests also only with the reading and comparison part of the data, excluding the other parts, precisely to verify the issue of Scan, but the problem persisted. If anyone here in the forum has some information that can help us, I would appreciate it.
  18. Trying connect baumer EAL 580... Ethhercat absolute encoder with Beckhoff C6015. Ethercat connection is From PLC to EL6695 module(This module is connected to KUKA robot for mater to master communication) and from Out port of EL6695 to In port of Baumer Encoder. It is not getting scanned nor manually appended. But when i connect it directly to PLC it works fine(gets scanned). Any solution?
  19. Hi all, I am taking a Kubler draw wire encoder back to a 1734-VHSC24 and having a little bit of an issue with the rollover.  With the draw wire untouched the output value seems to be fluctuating over time and appears to be drifting backwards to the rollover value making our distance measurements completely useless.  Does anyone have any insight as to why that might be?
  20. I know nothing about HMI's or Crimson software.  I'm in I.T. and we had to change the third octet in the IP address and gateway on all devices at our warehouse.  I extracted the file on one HMI, changed the ethernet info, and clicked send.  That HMI that runs a carpet machine works perfectly.  I went to the second carpet machine.  Extracted the file changed it's ethernet info, clicked send.  It came back with all ---- (dash's) instead of zeros, the carpet machine won't work.  I kept messing with the file trying different things, and inadvertently saved over the original extracted file!!!!!  So I thought I'd extract the file from the working carpet machine and loaded it on the second carpet machine.  I get the same issue, all ---- (dash's) on the HMI and you push any of the buttons on the front of the HMI and nothing works.  These are Allen Bradley MicroLogix 1500 running Crimson 2.0 HELP I don't know how to resolve this issue.  I would have thought both HMI's would have been the same!  HMI all dashes.eml HMI all dashes2.eml
  21. Hi, I can’t find an answer to the following and I was advised to ask it here.I’m programming an Omron CJ2M with an MD212 high speed I/O card. I usually do all my programming in Structured text, simply because I like it a lot over ladder or sft.Now, if I want to read the hight speed counter (incremental encoder), I have to make a ladder section and use the PRV instruction to store the present value in a chosen location.The manual says the current PV is stored in A271, but I can’t get a readout there. Apparently the only way to read it is through this instruction.Does anyone know if there is an equivalent to the PRV instruction for Structured text? or another way perhaps? Again, when I check the actual memory adress, there’s no value there withouth the use of the PRV instr.
  22. MicroLogix 1100 IP Addressing

    I have a micrologix 1100 PLC as well as a weintek HMI all connected through a network switch for them to communicate between each other, however I'm having an issue where the Micrologix Controller will not retain its IP address once I set it through Allen Bradleys BootP tool. I can set it through the tool and then go into RSlogix 500 and communicate with it and all that, but once the controller is turned off the IP address goes back to its factory setting of not showing an IP at all. Any suggestions/ ideas as to what I'm doing wrong?
  23. s7 214

    Dear All ,  I need to connect two encoder to S7 214 PLC  any one have information about 1-If it applicable to connect encoder  2-How adjust it on S/W and H/W to work good  thanks in advance
  24. Stepper Motor Control

    can anybody Know how to control stepper motor using PLC
  25. Cp1h-y - encoder issues.

    My issue and goal. - Trying to get an encoder (Automation Direct TRD-N30-RZVWD) connected to a cp1h-y to read wheel position(coupling) and have a pulse trigger at certain positions is this possible? I currently have the encoder wired up to highspeed counter 1 and am using PRV(881) port #0010 control data #0 with an P_On always on flag.  wanting to see  values change but nothing is being changed in the watch window. I'm reading the programming in section  3-20-2 HIGH-SPEED COUNTER PV READ: PRV(881), but I'm struggling.  any help is much appreciated.