Search the Community

Showing results for tags 'factorytalk view studio'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Found 171 results

  1. Union

    Hello! I am trying to get hold of the bits in a word, i have read that union is the way to go. My problem is that i cant figure out how union works. I have made a union between a word (16bit) and an array(0...15). The way I understood this was that the word now automaticly updates the array so that when the least significant bit in the word should update array[00] and so on. This is not happening. When I monitor the variables I can see the word change, but nothing happens with the array. Have I misunderstood the consept and what should I do to get hold of the bits?
  2. Our IT department is on their annual crack down on administrator access and 'unauthorized' software. This year they are demanding to know why I need to run my laptop with administrator access. Besides the Simulator, what other functions will I not be able to use without administrator access? 
  3. Hi guys, I just starting to use Sysmac Studio. Its a bit confusing as I am currently used to CJ series PLC. Usually, we can use P_1sec, P_0_2s and so on to create a simple clock pulse timer function. However, I couldn't find the command or FB to do that in Sysmac Studio. Anybody could explain on how to do that in Sysmac? Thanks 
  4. VBA issue on FTViewSE Clients

    I am having a very weird issue that Rockwell was not able to help with.  I have a new SE application that I converted from RSView32 and I re-wrote some VBA code associated with the project.  The code works fine on the server while the screen is running in studio.  Once I deploy a Client it no longer works.  It just sits there like its waiting for my trigger to go off, but I am seeing it sit there with a 1 so i know it should be executing the code because as soon as i open the screen in studio and press play the code executes and my data is there.  Does anyone have any ideas for me?   Thanks
  5. Ok so I recently got the Factory i/o software to practice plc programming more in depth.  I got it working easily enough with the siemens TIA software and I am now trying to get it to work with the Omron Sysmac Studio software.  I am not sure if it is possible or not.  I have access to the hardware but I was really hoping to use the simulation like I can in TIA.  Any insight would be appreciated on the subject.
  6. Hi:         I am planning to use NX with Encoder Card  couple with Omron Rotary Encoder for measuring product length. ( GX-EC0211 /EC0241) or may be (NX-EC0112, I read there is proble with this card , here https://forums.mrplc.com/index.php?/topic/34896-problem-pulse-reading-with-fast-counter-card-in-nx2/ ), but whatever it is I need to know is there any specific Instruction in Sysmac Studio that is tailored for Fast Counter or Encoder (something Like PRV in CX Programmer or special function in CJ-CT021 where start/stop counter and changeable preset counter are available).  The Length measurement is straight forward and is only a small part of the overall program.  Basically is Start ---> measure to length----> Cut --->Repeat again.  I read through the Instruction Reference Manual and I am unable to find one.   Anyone have any idea or any sample program (Sysmac Studio only ) that I can refer to ?    Thanks     
  7. Good day, We are running FactoryTalk View SE (Network Distributed) version 7.00 (CPR 9 SR 6). We have 5 machines: Engineering Station, HMI/Data Server A, HMI/Data Server B, Operator station A and B. The FT Directory is located on Server A. Server A is Primary and Server B secondary. I made some changes to one of the HMI Display's and added a HMI Tag with an alarm.  Tested the changes, everything worked as predicted. I then checked the status of the RSLinx, HMI and Data servers using FT Administration Console, everything was running with full redundancy. I then selected Replicate to Secondary, the replication was successful and Server B rebooted. After Server B finished rebooting, I check the status again. I found that the RSLinx and Data servers started up and was again fully redundant but the HMI Server showed that Server A was active and Server B was Ready to provide service, left it for about 10 minutes but it never changed to Standby.  I rebooted Server B again to see if it will help but it did not. I then stopped the services on Server B, deleted the HMI Project, restored the project from a backup of Server A, but still had the same issue. I am suspecting that there might be an issue on server A because if I open FT View Studio on the engineering station, I get an error stating: Unable to open HMI Server. I have checked all network connections and everything looks fine. Is there someone that may be able to assist me? 
  8. Sysmac Studio 1.31.0.10 crash sometimes, often when copying things like color palettes, string in the Output Window, etc. It's always with NA not NX. I have a corrupted project because Sysmac Studio crash and save the project. NEVER use this file, restarts with the old file is better. The text fields does not appear on all objects on the HMI and it's never the same object each time your download to HMI! Check images below. Font is "No Value". Do you know how to resolve this problem?
  9. Bad quality alarms ( FT View SE v8.0)

    Dear Experts!!! I am facing one problem in ALARMs configured in SCADA ( FT View SE v8.0) There are some unnecessary alarms like "acknowledgement status" are coming. Alarm bad quality alarms are coming all the time, I dont have any clue about them. Please help!!!
  10. I am trying to display the time from an Accumulation timer. Using a data display object I am able to see the time in the following format 00:00:00.0000000. Is there a way to format the time without the decimal seconds I just want to see 00:00:00 (hours:minutes:seconds)
  11. As the title says, Studio 1.40 crashes if I try to run it in VMWare Workstation (version 14.1.8). I had to disable the "Accelerate 3D graphics" option in VMWare in order to install this upgrade, this has never been an issue before on earlier versions of Studio. I thought I could then re-enable it but this causes Studio to crash as soon as you start it up. I've not spent any time running it with 3D graphics disabled to know if it can run stable. Or if having it disabled causes problems with Studio or other software on my Omron VM. Has anyone else experienced this issue or have any insight?  
  12. Hello all,   My coworker is running into an issue where his version of Sysmac Studio has been updated, but this is causing a version mismatch from an existing project.  He has called Omron, and they are saying that there's no way to downgrade the OS.    Project operating system version = 7.4.0 Device Operating System version =  7.3.0   So the OS on the NA5 would need to be upgraded to match the version of Sysmac.  Does anyone have any suggestions to revert the automatic upgrade that has occurred? Any help would be appreciated!
  13. Friends kindly help me I need to create ton and counter macro function in factorytalk view studio 
  14. Axis Attribute Error

    Hello All, First time working with PLC. Get the hang of it from stuff I researched. Having an issue with an axis setup for a servo motor.  When I try to do an auto tune it gives me an error that axis is not configured.  Source: Config Fault    Condition: MotorDeviceCode- INvalid attribute      ACtion: Immediate Stop Fault Entry: Type 8, code 9 subcode: 1314 stopaction: 4 Statechange: 3   I was wondering what am I doing wrong? Any leads or source information I can use to solve this. 
  15. Hi, I'm fairly new to motion applications and I have an interesting (to me) problem to solve. I'm using Kinetix 5700 with MPL motors to drive a pick&place carousel and a conveyor belt. I have a virtual master that driver the carousel in 1:10 ratio. The virtual master also drives the conveyor belt, the ratio is given by the carousel diameter and the conveyor driving cylinder diameter +  2x the belt thickness. And I'm using MAJ to drive the master and the MAG instruction to drive the carousel and the conveyor. This all works well. BUT: the carousel does not pick the product in the same place every time. That creates irregular gaps, or pitch, between the product on the conveyor which causes some issues down the line. Is there a way how to superimpose a value to the conveyor axis to ensure the pitch is regular at all times. Something like the ADDAX instruction it Trio motion controller for example? I'd want to have a sensor that detects the edge of the product and compares he encoder value to an expected value and slows downs or speeds up the conveyor accordingly. Thanks a milion.
  16. AVE instruction Error

    A little background information here, I am trying to create a moving average so I accomplished it with the code (imaged attached) The problem i am having is the AVE instruction error bit goes true. it leaved me with a result of 1.#QAN  I did some googling and it said this is typically done when dividing by zero?? so i added a NEQ to 0 prior to loading the array. then it happened again. so i put the error bit in front of the FFL so it will stop loading the array when i get the error bit so i can see what values are in the array when it errors out. Has anyone else had this issue and what could you do to resolve it? I haven't had any luck find something that points me in the right direction. Thanks in advance for your help.
  17. Hello there, I am using a Kinetix 5700 drives to control bunch of axis. HW used : 5069-L320ERMS2 GurdsLogix, 2198-S086-ERS4 Servo Drive with MPM-B2152M-M motor and the 843ES-SIP12BA6 safety encoder. All is working fine except I can't figure out how to dynamically change an axis velocity  controlled by a MAG instruction. I have a virtual master axis controlling the velocity and each physical axis is controlled by a MAG instruction with a gear ratio. In my safety program I have SFX and SLS function block used to determine the safe speed limit. The  SLSLimit output of the SLS function block is linked to a SS1 Request of my servo drive. This causes the axis to stop when safe speed limit acceded.  What I'd like to be able to do is to dynamically change velocity (limit it to safe speed if SLS instruction is active) of each axis without having to change the gearing ratios and thus avoid the SS1 safe stop action.  I know how to do that using JOG or MOVE but is it even possible to do that using the MAG instruction? Regards Martin
  18. Hello, In my ladder program I have 7 different arrays (containing REAL values) all members of a structure and I wish to extract certain values from the arrays and put them on another structure consisting of REAL values (not arrays). Which is the best way to do that ? I tried AryMove command but I get an error "Conversion from REAL to ANY_ELEMENTARY[], ENUM[], STRUCT[] is impossible. To get a better understanding of my structures and arrays here is an example: Struct wheel_data Global variable SWheel of wheel_data rad[1...10] of real, vary[1...10] of real, varx[1...10] of real struct. 2 wheel Global variable Wheel1, .... , wheel10 of wheel rad REAL, vary REAL, varx REAL what I wish to do is to copy Swheel.rad[1]  to wheel1.rad,  Swheel.vary[1] to wheel1.vary, Swheel.varx[1] to wheel1.varx 2nd structure Swheel.rad[2]  to wheel2.rad,  Swheel.vary[2] to wheel2.vary, Swheel.varx[2] to wheel2.varx until I fill all 10 wheel structure instances with values Thanks in advance.
  19. Is it possible to reset " Motor replacement detected error" ( Error code 95.01) using code without connecting to PLC through sysmac studio? If yes please suggest how to do it... Thanks in advance...
  20. Hi all, I've ran into an unusual situation where I could use some suggestions.  I have an AB PLC working in the field, and an existing fixture that needs to be transferred from an Omron PLC into our AB.  I have an integrator who did some offline development with a welder that uses Anybus communication.  He sent a .ACD file to implement the logic from.  The file has an Ethernet module configured but more importantly, it's showing EDS not registered.  I've asked for the EDS he used, and none of them work when trying to register it via right-click and register.  I can export the module, but it won't import into the current PLC program because there's no EDS (shows EDS error after the import).  If I try to take the program that was sent to me online with the PLC, it will automatically upload and overwrite the build.  I can't even open the properties of the module to see what the integrator did. The end goal is to have the offline developed module implemented into the current program, but it seems like everything I've tried to do has me against a wall.  Is there a way to go online without uploading?  Maybe there's a way to implement this I haven't learned yet?  Any suggestions would be much appreciated, and if more information is needed, I'll be glad to provide it. More info:    PLC Type: 1756-L82E ControlLogix 5580    Rev: 30.014    Studio 5000 Version 30.01.00 - Standard Thanks, K
  21. Sorry if this is covered elsewhere, but my search hasn't revealed anything yet.  I have a number of PanelView graphics created with FactoryTalk View ME and some use a lot of Parameter Files, which link to popup faceplates. So a large number tags are represented with parameter files, which, when clicked on screen, then pop-up an appropriate faceplate, based on tag type or category etc.  I am still digging into the very elaborate FT View ME manual, but at 500 pages, that's quite a deep study.  But I don't see the linkage between the tag's parameter file and how it specifies which faceplate to pop up, and I've not yet found a good article other than keep digging into that FT manual. There does not appear to be a linkage entry in the parameter file itself, where I would have expected it.  Nor do I see any "hot spot" click type event code in the display itself, which would also make sense.  Is it in the PLC code itself?  I would not have expected that, since they seem to be keeping the FT environment self-contained. But there must be some sort of table or linkage somewhere that I'm over looking. Thanks in advance for anyone's thoughts & guidance on this.  Other parts of FT HMI screen development does seem intuitive, just not this dynamic linking.
  22. Hi, Could anyone help me out on how to extract the digits present in a string in sysmac studio... Thanks in advance !!!
  23. Anyone know of a guide about programming a balluff io master device into Sysmac Studio?
  24. Version 4

    21 downloads

    MX Component manual for programming PC - PLC software solutions.   Details MX Component library functions and examples. 
  25. MX Component Programming Manual View File MX Component manual for programming PC - PLC software solutions.   Details MX Component library functions and examples.  Submitter WattUp Submitted 03/13/20 Category Manuals, Tutorials