Search the Community

Showing results for tags 'factorytalk view me'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Found 82 results

  1. Expressions

    Hi forum members!   I am spinning the wheels on trying to get my expression to validate.  I am new to expressions so after trying for a bit I have thrown in the towel and am looking to the experts here to help me out. As you can see with attachment I am trying to change the color of the valve top hat.  I am needing 3 colors: Gray when closed, Green when open and in Auto, and Yellow when open and in Manual. I was asked to not change the PLC logic as this could be done from the SCADA level.. After looking at my application and attempt do you have any suggestions on what I am doing wrong?    My Expression:  If {::[Process]Program:Boilers_Main.LV_36101_New} < 3  Then 0  Else  If {::[Process]Program:Boilers_Main.LV_36101_New} >= 3  AND {[Process]LIC_36101A_PIDE.Auto}  Then 1  Else  Then  If {[Process]LIC_36101A_PIDE.manual}  Then 2
  2. Hi all I am setting up a batch tank system, I have 1 pump which can pump to six different tanks(via pneumatic actuated valves). This is my first go with a HMI, usually I would use a multiple position switch. Is it possible to make a six position selector switch with a HMI? I am using a AB Panel-View 800, has anyone done this before? Any help would be appreciated.
  3. I have this panel view 1000 plus with accounts enabled but customer forgot the app password. I have both the executable and source file. Can I retrieve the password from any of both files? Can accessing configuration mode help disabling security to enter new passwords? Having the files, what is the best way of retake control over this application?    I am not experienced on AB equipment, but have general experience on automation. I have access to Factory Talk View.
  4. Folder in FactoryTalk View Studio

    Hallo my Allen Bradley friends, is there any way to create a folder in FactoryTalk View Studio? I mean at Graphics/Displays. The clarity of a bigger projekt is affected by that.     Mit freundlichen Grüßen, Best regards   Adrian Düringer
  5. Hi everyone, I was wondering if anyone knows why we cant change the date on an application using the system tags? I was able to use the system tags for time and that works fine. however, year,day and month are giving me a write error. (Basically made a screen for the user to change the datae/time instead of going through the terminal settings. Using RS500 controller: Micrologix 1400 HMI: PV+700 Factory talk studio ME.
  6. I have an SE program that i would like to add ME programs into. I want to view the ME apps as seamlessly as possible. i need to maintain the security and alarms from the ME systems into the SE system. What would be the best way to do this? I want to duplicate as little effort as possible. Thanks, ALex
  7. So here's the problem I'm facing. I've recently started working for a company that has two facilities. They have lots of old equipment/PLCs, plus some new stuff. We undertook a project to upgrade the network infrastructure, and replace all the old programming terminals (Some had Windows 2000!) with a new standardized programming terminal, all sharing a common image. We've installed these new computers, and they were working great. Recently, we switched all the licensing to a Hyper-V based server, using FactoryTalk Activation Manager. Right off the hop, there was issues with one of the sites (let's call it site B). Site A is working fine. When you open FactoryTalk Activation manager, it populates the activations from the server in about 1s. The wait times for opening software are pretty normal (For RSLogix 5000, "normal" isn't exactly rapid, but like I said, that's normal). For Site B, the activations take forever to refresh in Activation Manager when opened on a programming terminal. The software takes even longer to open (we're talking about 2-3 minutes). Network wise, Site B is further along than Site A. We've implemented a Stratix layer 3 switch at the top of the network and use area specific VLANs to reduce multicast noise across the network (much of the multicast noise comes from vendor equipment, not PLCs, so I can't control it). This works fine. I can remote in and use TeamViewer/VNC with acceptable performance across the network, so it's not being bogged down to unacceptable levels. However, connection to the activation server is unacceptable. I'm not sure of the culprit (yet). We are continuing network improvements, removing some older 10/100 links and installing Gigabit equipment between the Hyper-V server and the above mentioned Stratix, hopefully that might help. However, that same 10/100 link is the one I use to remote in and use Teamviewer currently, so I can't see how much improvement it will give us for activations (which really should take almost no network traffic). To get activations, I'm just adding the IP address of the Activation Server into FTActivation Manager on the programming terminals. Any ideas, people? Thanks
  8. Hi, I'm trying to use a parameter pass a literal string (eg. "Tank Temperature") in a global object, but when it displays in the pop-up I'm passing it to, it shows up as all caps (eg. "TANK TEMPERATURE"). How do I fix this?  Thanks in advance PS. It's not showing up with quotation marks, I used the alt0160 to replace the spaces.  Is there something similar to fix the capitalization?
  9. I hope I am posting this in the right location, I did not see any sub forums specific to Rockwell or Factorytalk. We are finally converting from XP to Windows 7! WOO-Hoo! It has gone fairly well but I see one issue that has me concerned and I would like to resolve it now; my application converted fine except my translations did not come across. We have two base applications we build off of that correspond to the type of machine they are used for; both support multiple languages which are selectable with an on screen VBA based button that does a bit and language change in the background. One application supports English and Russian while the other is English and Spanish. I have tried doing the import on Windows 7 in both languages related to the application I am working with and the alternate language (in this case it is Russian) never comes across. I have tried both the direct copy and .apa methods with the conversion and the results are the same. Is there a step I am missing during the conversion process or will I have to export my languages from 6.0 and import them to 8.0 separately after conversion? I am not thrilled about this process as it never seems to keep the proper layout of the text when imported. I assume the issue is the conversion process as I can load the .apa on a fresh XP build and the languages are both present.
  10. I believe I have found a bug in FactoryTalk View ME version 8.10. I have a trend object that uses parameter file placeholders on the connections tab. These are direct-addressed to the shortcut ie {[PLC]...}. The historical data from the datalog does not show. (The pens write lines, but when I navigate away from the screen and come back, the lines are gone and begin drawing again from the right side.) The current data does show. This tells me that the placeholders are correct syntax. When the screen loads, the placeholders are being replaced by a string which yields a correct tag path, or else the pens would not be writing correct data. When I replace the placeholders manually and directly address the tag, the historical data does show correctly. This tells me that the datalog is set up correctly and is logging data. I have verified that a previous project of mine, using I believe version 6.0, successfully used this method of using one screen and one trend to plot various tags using parameter placeholders, and the historical data did show correctly.
  11. I want use the panel view 800 with micrologix 1100 but  i can't add the controller in connected component workbench. Exist another program to program the panel view???
  12. Hi Guys  I keep getting this error, when using Factory Talk View Point    But when I download to the HMI, there are no warnings or errors.  By searching the internet, I can't get ant clue of what EaseljsVisualContainer are....    Any experience ?     Cheers
  13. Popup windows on the FT View SE v8

    Dear Experts, I want to pop up a window automatically when a tag value becomes high. Please tell me how can i do it??? Eagerly waiting.
  14. Dear All!!! Please tell me the way how can i delete recipe from Runtime. There are only save and restore options in the inbuild recipe function. I am using inbuild recipe function. Factory Talk View SE v8.0 (all the patches till date are installed) I have RSView32 VBA code but i am not able to use it in FTV SE Please help me with it!!! Private Sub Display_AnymationStart() Dim sRecipes As StringList Dim vRecipe As Variant On Error GoTo ErrHandler Set sRecipes = gProject.GetComponents("recipe;files") For Each vRecipe In sRecipes LstRecipeNames.AddItem vRecipe Next vRecipe ErrHandler: If Err.Number Then gActivity.Log Err.Description Err.Clear End If Set sRecipes = Nothing Set vEachRecipe = Nothing End Sub 'user selects the recipe name in the list box, and then presses delete button Private Sub cmdDeleteRcp_Click() On Error GoTo ErrHandler If LstRecipeNames.ListIndex = -1 Then MsgBox "Select a recipe to delete" Else 'delete the recipe file, and remove from the project gProject.DeleteComponent "Recipe;files", LstRecipeNames.Text 'remove the item from the listbox LstRecipeNames.RemoveItem LstRecipeNames.ListIndex End If ErrHandler: If Err.Number Then gActivity.Log Err.Description Err.Clear End If End Sub The bolded points are problem, Bypased the error handler , but please lemme know how can use use this commands in FTV SE, as VBA in SE is client based blah blah... gProject.DeleteComponent "Recipe;files", LstRecipeNames.Text
  15. Finding FTV version?

    I’ve got a quick question regarding programs that get loaded onto the PanelView Plus products. Let’s say I download a Runtime app from a PanelView, convert it into an .apa, and then need to recompile it into a Runtime app and downloaded it back to the HMI. Is there anyway, either through the PanelView or the program which I convert, to find out what its particular software compile version is? I’m trying to figure this out to put into a quick guide for myself and our company field service techs to avoid the pitfall of accidentally compiling a program with the wrong version. Any advice from the group is much appreciated!
  16. I have a button on my HMI that I only want visible under two conditions. One of them is a numerical value and the other is if a bit is on. English translation If Variable 1 = 0 OR BooleanBit is TRUE, then show the button I tried entering the expression in the button's Visibility parameter in Animation as such: {[Program]Variable} = 0 OR {[Program]} However, it does not work on both conditions. It will work if I just use one of them but not as shown above, even if the order is reversed. There must be a trick of how to write an expression that uses multiple values...... any suggestions?
  17. Dear  Experts!!! I want to log each and every tag if its value changes from the SCADA. Please help me. Please be clear about all the things. I don't wan to write all the tags in the event server in deviation tab. Its a very long time taking process.   Is there any other way to do it efficiently.
  18. I have a FactoryTalk 8 application that exhibits some weird symptoms when I run it. I have buttons whose "visible" state and "enabled" state are based on HMI tags. The states of these buttons don't update. I have screens that fail to close when the "abort" command is issued. I have vba that connects to a tag group, which fails to retrieve the value and produces an error. Some tag values from the PLC (always direct-addressed, I think) show up correctly, even when other symptoms above are happening. These issues randomly go away sometimes after a restart and the entire application runs fine. Does anybody have a clue what could be doing this? (Using Windows 7 Professional 6.1.7601 Service Pack 1 Build 7601, SE version 8.10.00 (CPR 9 SR 7.4), Internet Explorer 11.0.9600.17633)
  19. Hello! I am programming with FT view studio version 8. In the program, when I make numeric display, I can not input values for this tag I am using in the display. Then I decided to make 'invisible button' for enabling the input for this tag which is shown in the numeric display. This is okey for me, only if there is other ways to do this please tell me. Now when I have created this numeric display with input enabling -'group', I have a problem, how can I use security levels for this group, so that only logging in values can be set? I have found that there is security code selection for this in the screen displays, but not for the buttons.
  20. FactoryTalk View Studio Error !

    Hello I am having a difficult time with opening FactortyTalk Studio. It was working fine yesterday, but when I tried to open it today. I got an error and it says " SQL Server 2008 Express Instance 'FTVIEWx64TagDB' which is required for FactoryTalk View v6.1 or later cannot be found' Unfortunately, I do not have a contract with Allen-Bradley so I can not get help from them I have attached the error too. Can anyone help me out with this issue? Thanks for reading. Have a good day :)
  21. FactortyTalk Trend Issue

    Hi all, I have built trend for a pressure transducer. It is working fine when the trend is open. However, When I go to different pages and come back to the trend, It loses all the data it was showing before. The HMI is panelview plus 700. What is this path?? Can anyone help me with this Any help would be great. Thanks
  22. Good Morning guys, I've been working on the last months in a complex project in Pharmochemical Industry, in this project the customers will need run FactoryTalk SE Client in a Data Collector(Motorola MC3190 with Windows CE and resolution 320x320), so because FT doesn't run in 3rd party Microsoft Windows CE devices/platforms, i will use Remote Desktop Connection from Windows to acess FT in a PC. Until here i didn't have problem, i created one script that detect the resolution of screen and open graphics developed in 320x320. And here comes the problem: FactoryTalk use one ActiveX developed by Rockwell to make Digital Signature, and this pop-up is too big for the resolution of Data Collector(320x320). I couldn't find a way to resize it.... I attached a picture from screen of MC3190. Anyone knows one way to resize the pop-up? If not's possible, have a way to send as a parameter the information to Digital Signature function? Thanks.
  23. Hi all, So this is more of a theory / how would you attack this problem, question: I'm creating my first HMI and while playing around in FactoryTalk View Studio I noticed I can add objects to a screen. I can add a browser and with some work I can get it to display an HMTL file directly in the screen. So the browser in this case is opening a file stored locally, not something served up from the internet. Which opens up the question, could I write most of my HMI in HTML and Javascript? As a previous developer having the ability to control more of the UI would be amazing and perhaps easier to use/maintain. The only pitfall that I haven't been able to figure out is how to get real time values from the PLC. I'd welcome anyone's input on the idea in general or if someone knows a good method for getting/setting values from the PLC. Thanks!
  24. Hi there I have a panelview in plant and when I try to buy, it tells me this obsolete, someone will know what is the recommended replacement for this equipment Rockwell, part number is 27711P-T7C4D1 or when i can found this number replacement part thanks a lot guys for the help Angel Leiva Project Manager Ingenieria Autintrol CA 584242608153
  25. Hi, i tried everything i know and what i saw in all forums possible, and i can't resolve that problem. So i came here hoping have anyone can make this "miracle" rsrs This is the problem... Have one application operating with FactoryTalk SE 5.00.00 (CPR 9) in plant made by other enterprise and we will insert a new area on system. So we backup the application coppying this 3 itens: - The file: C:\Documents and Settings\All Users\ApplicationData\Rockwell\RNAServer\Global\Application.RNAD - And the folders: C:\Documents and Settings\All Users\ApplicationData\Rockwell\RNAServer\Global\RnaStore\Application C:\Documents and Settings\All Users\Documents\RSView Enterprise\SE\HMI Projects\Application After i create a VM with Windows XP Professional and same name of existent server, install FactoryTalk SE and replace the file and folders in respectives locals. So i open FT and all most of things restored, but the graphics didn't. I tried add them manually, It appears that is loading, but in the end, no screen was added. Sorry for my english errors... I hope someone can help me.