Search the Community

Showing results for tags 'factorytalk view'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Found 92 results

  1. Hi! I hope you could help me with the problem I've been having with this HMI. Usually I use the Instruction-based alarms (ALMD) in the program of my PLC Controller (ControlLogix 5580) to be able to send Alarm Messages to my View Designer Panel View. However, on this new HMI I'm getting the alarm trigger on the Panelview (I get the prompt on the Alarm Summary, and get the Alarm TAG of the ALMD Instruction associated with the alarm), but for some reason the Alarm Message is on blank. It´s the same for all the alarms on the controller. I checked again and the "Message" parameter of the ALMD is configurated, and even test just typing "a" as an Alarm Message to see if it was that the string was too long, but even with that the message didn't show up. Can you help me understand what I'm doing wrong?
  2. Is there a work around for using ActiveX controls when the FactoryTalk View ME edition does not match the Panelview firmware revision? I have FactoryTalk version 13 and the Panelview is 10 (Panelview Plus 7 Perf 1500). Trying to use the Microsoft Date and Time Picker Control.  Thanks
  3. Unable to delete a screen

    Hello AB professionals, I am using FactoryTalk View Studio v11. I am basing on an old project to build my application. I restored the project from a .mer file. I deleted or renamed some old screens, saved and closed the project. But when I open the project next time the screens I deleted still show up. When I click on it it will show an error message "Component does not exist".  In the FactoryTalk ME application, I right click a screen name on the left tree under the Graphics, and then click "Delete" or "Remove", the display would disappear at that time. But it persists on coming back next time I open the project. If you know the solution to resolve please reply. It is much appreciated.   Thank you. Lei
  4. Hey guys,   I am looking to query a database through FactoryTalk SE.  I will be scanning packages, and using that bar code to find a lane assignment from the database.     My question has to do with where the VB script will reside in the FactoryTalke SE program.  I want this script to run at all times.  I see that each screen has a "VBA Code" but I am assuming that these will only run when the screen is visible.   Where does this have to be stored in order to run all the time?   Thanks In Advance!
  5. Hello! I have been working with a Factory Talk Studio V8.0 and my computer was crashed, "blue screen". After this, I can not open my panel project anymore, I only get information Failed to open factory talk private directory for the application. How to save my project?  
  6. I am starting an upgrade process for all my SLC50* PLCs and working out the communication of my machines for the upgrade. I ran into this complication I don't understand. I have 2 machines that work together using 1 HMI. Both machines have their own PLCs. Both are running SLC5/02 to 1747-AIC link coupler then to the 2711P-RN6 interface with the DH-485 communications running parallel. I don't understand how this works, or how I might possibly upgrade the communications from 2 PLC's into 1 HMI without linking the PLC's programming first. (Also, a complication I am working on, I only have the Runtime file, not the ME file for the HMI program). 
  7. Hi all, I have an application where two buttons are created: End Batch: "Momentary Push Button" that modifies the value of a tag. Print Report: "Display Print Button" that generates PDF with a screenshot of the current screen. I would like to mix both buttons into one single button that does this functionality at once. I have been reviewing forums and it seems that the only way to do that would be by using VBA code but I believe that this is not available on FactoryTalk View ME but only on SE. Would anyone know a way of printing a PDF screenshot + modifying a tag at the same time and with a single button on FactoryTalk View ME? Thank you!
  8. I had FactoryTalk ME and SE Studio V12 on my Windows 10 machine. A few days ago I needed to use to V10 for some alarm functions and because FT will not let you have multiple versions on one laptop, I had to downgrade to V10. Everything had been working fine until the uninstall of V12 and the install of V10. Whether in ME or SE, and even in a newly created project, opening any display crashes Studio. I have attempted two clean installs and can't seem to get it fixed. It feels more like a Windows OS issue but we're a bit stumped. Anyone else run into this?
  9. Dear Experts, We are facing one issue to get a ASCII serial pump data into FactoryTalk SCADA tags. Though, we get to communicate with Pump with VBA form and able to control the pump and get its flow status, can set the flow as well. Now our requirement is to fetch the pump flow and set the flow from FactoryTalk SCADA screen (using tags) How to get the data received in VB script into tag??? Any sample code for the same will be more helpful. Thanks in advance.
  10. I have a global sidebar that has all of my page navigation buttons.  Is there a way to hide a certain button based on the current page that is displayed (i.e. "Manual" button is invisible when the Manual screen is displayed)?  I know how to make a button visible/invisible based on a tag or expression, but I don't know how to do it based on the current page.
  11. Dear friends.. I want HMI panel view 300 software.. Is this available in net or free of cost in web sites
  12. Friends kindly help me I need to create ton and counter macro function in factorytalk view studio 
  13. Hello All   I have 6 x SLC5/03s that I am trying to connect to a windows PC that is running FactoryTalk View Studio Enterprise. To do this I have connected Serial to Ethernet gateways (MGATE EIP3170) to each CH0 serial port of the SLC5/03s. The EIP3170s are connected to a switch that has the windows PC connected to it . The EIP3170s and the PCs are all on the same subnet. In FT View SE I have added 6 x Serial DF-1 drivers for each SLC5/03. When I add the drivers, I can see three of the SLC5/03s. If I try to add any more Serial DF-1 drivers I loose communication with all of the SLC5/03s and the diagnostic window in FT View SE I see the following error message: DF1: Failed to open '\\.\COMx', error = 0x000005AA. When I phoned Rockwell Automation what this error message means they told me it is a "Fatal access error" which means that the EIP3170s are incompatible with FT Linx.  Does anyone know if it is actually possible to connect more than 3 EIP3170s to FT Linx? I am sure I have seen an article on how to do this but I can't seem to find it again
  14. HI guys,now i have " unable to determine the size of the file C:\users\public\document\RSVIEW ENTERPRISE\ME\HMI\PROJECTS\abc\tag\abc\.mdf. " this error shows...please give some help
  15. Hi guys, I am trying to open an application and i keep getting this error. Failed to initialize the service: {3F883B87-2208-11D4-B0E7-001083022E04} Does anyone know how to get rid of this error? Regards,
  16. Here is my setup - Factorytalk view SE V 7.0 with Primary and secondary servers. System gets replicated from primary to secondary once in a week. After the primary server was restarted due to some issue, all the HMI tags lost their values. 'Retentive' checkbox was checked on all HMI tags, initial value field is blank. According to the description of 'Retentive' field in the help file, the HMI tag should hold its value even after the server is restarted if the box is checked. Also, secondary server should have held those same values while primary was rebooting, but as of now all my HMI tags field are blanks. Am I looking at a patch roll up here?
  17. I have a display I use to show overviews on several big tvs in our plant.  Up to now I have used a single display and change which display is visible based on tag that increments based on a timer.  This has worked great but as my system grows I keep adding additional "blocks".  I have now ran into the issue that you can only have 3000 tags on one display.  While i only display one block at a time all of them load so that pushes me over the limit.  I am guessing I need a vba script to accomplish this .  If someone has done this I would love to see some VBA examples of what you did.  Or other ideas...
  18. Ok, so I was tasked with setting up a virtual for our development team to be able to use to quickly deploy projects hmi, emulated plc, and studio 5000 project together on one virtual.  The main reason for this is when we get a project, many times we have to wait for an available plc.  We have plc’s in our rack but they can’t be used because they are being used for other projects.  I’ve used the compatibility matrix that Rockwell has but my boss wants to stick with Windows 10 Professional like we do in most our projects but according to the matrix, it looks like having FactoryTalk View SE Enterprise version 10, Studio 5000 Logix version 33 and Studio 5000 Logix Emulate version 33, FactoryTalk Gateway 6.11 and RSLinx 4.11 (mainly for communication to the emulated plc) but in the matrix says Windows 7 and Windows Server 2012  is the best choice.  I’ve ran into issues with Emulate opening, it takes up to 20 minutes to open.  Our licenses are on a server and accessed using FactoryTalk Activation Manager and all the activations are there.  Any suggestions would be appreciated.
  19. My Compact Logix PLC is connected to my computer by USB. When I try to create a new view designer file, I can not connect my view designer with my controller. "OK" button of the HMI to controller path remains INACTIVE. Please see the attached.  How can i solve this issue?
  20. This is my first post so let me know if there is anything wrong with my post. I am learning Studio 5000 right now for an internship and created a simple project involving a pushbutton and some LEDs. Now I am trying to create an HMI for it in View Designer. My problem now is that I cannot establish a connection to the project because I do not have a physical HMI connected to my plc (Logix 5380). I can't find any way to emulate an HMI module so that I can get it to run. When I emulate my HMI project it tells me "Unable to reach controller TEST" where test is the name of my plc program. I added a module that matched the model in my HMI program (panelview 5510 2715p-t7wd) which I arbitrarily picked at random. But when I go into references and try to add HMI to Controller Path it does not show up (I'm assuming it's because it is faulting in the plc program since it doesn't actually exist). Is there not a way to emulate an HMI or add a virtual HMI to my studio 5000 program that I could connect to from View Designer?
  21. I'm a young Controls Engineer at an integration company, and I need assistance.   I have a client that has about 330 different alphanumeric product numbers broken down by length and width. The operator must be able to select the product number at the HMI to pass along to the robot we are integrating. Is there a way to be able to have the operator select the product number simply, without having to scroll over 300 items in a single control list. The HMI is not chosen yet, so it can be GE, Rockwell/AB, or Automation Direct, but we are using a AB ControlLogix Processor. Racking my brain and I have little VBA/Scripting experience.
  22. I am having a very weird issue that Rockwell was not able to help with.  I have a new SE application that I converted from RSView32 and I re-wrote some VBA code associated with the project.  The code works fine on the server while the screen is running in studio.  Once I deploy a Client it no longer works.  It just sits there like its waiting for my trigger to go off, but I am seeing it sit there with a 1 so i know it should be executing the code because as soon as i open the screen in studio and press play the code executes and my data is there.  Does anyone have any ideas for me?   Thanks
  23. Good day, We are running FactoryTalk View SE (Network Distributed) version 7.00 (CPR 9 SR 6). We have 5 machines: Engineering Station, HMI/Data Server A, HMI/Data Server B, Operator station A and B. The FT Directory is located on Server A. Server A is Primary and Server B secondary. I made some changes to one of the HMI Display's and added a HMI Tag with an alarm.  Tested the changes, everything worked as predicted. I then checked the status of the RSLinx, HMI and Data servers using FT Administration Console, everything was running with full redundancy. I then selected Replicate to Secondary, the replication was successful and Server B rebooted. After Server B finished rebooting, I check the status again. I found that the RSLinx and Data servers started up and was again fully redundant but the HMI Server showed that Server A was active and Server B was Ready to provide service, left it for about 10 minutes but it never changed to Standby.  I rebooted Server B again to see if it will help but it did not. I then stopped the services on Server B, deleted the HMI Project, restored the project from a backup of Server A, but still had the same issue. I am suspecting that there might be an issue on server A because if I open FT View Studio on the engineering station, I get an error stating: Unable to open HMI Server. I have checked all network connections and everything looks fine. Is there someone that may be able to assist me? 
  24. Dear Experts!!! I am facing one problem in ALARMs configured in SCADA ( FT View SE v8.0) There are some unnecessary alarms like "acknowledgement status" are coming. Alarm bad quality alarms are coming all the time, I dont have any clue about them. Please help!!!
  25. Sorry if this is covered elsewhere, but my search hasn't revealed anything yet.  I have a number of PanelView graphics created with FactoryTalk View ME and some use a lot of Parameter Files, which link to popup faceplates. So a large number tags are represented with parameter files, which, when clicked on screen, then pop-up an appropriate faceplate, based on tag type or category etc.  I am still digging into the very elaborate FT View ME manual, but at 500 pages, that's quite a deep study.  But I don't see the linkage between the tag's parameter file and how it specifies which faceplate to pop up, and I've not yet found a good article other than keep digging into that FT manual. There does not appear to be a linkage entry in the parameter file itself, where I would have expected it.  Nor do I see any "hot spot" click type event code in the display itself, which would also make sense.  Is it in the PLC code itself?  I would not have expected that, since they seem to be keeping the FT environment self-contained. But there must be some sort of table or linkage somewhere that I'm over looking. Thanks in advance for anyone's thoughts & guidance on this.  Other parts of FT HMI screen development does seem intuitive, just not this dynamic linking.