Search the Community

Showing results for tags 'factory talk view studio'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Found 150 results

  1. Bad quality alarms ( FT View SE v8.0)

    Dear Experts!!! I am facing one problem in ALARMs configured in SCADA ( FT View SE v8.0) There are some unnecessary alarms like "acknowledgement status" are coming. Alarm bad quality alarms are coming all the time, I dont have any clue about them. Please help!!!
  2. I am trying to display the time from an Accumulation timer. Using a data display object I am able to see the time in the following format 00:00:00.0000000. Is there a way to format the time without the decimal seconds I just want to see 00:00:00 (hours:minutes:seconds)
  3. As the title says, Studio 1.40 crashes if I try to run it in VMWare Workstation (version 14.1.8). I had to disable the "Accelerate 3D graphics" option in VMWare in order to install this upgrade, this has never been an issue before on earlier versions of Studio. I thought I could then re-enable it but this causes Studio to crash as soon as you start it up. I've not spent any time running it with 3D graphics disabled to know if it can run stable. Or if having it disabled causes problems with Studio or other software on my Omron VM. Has anyone else experienced this issue or have any insight?  
  4. Hello all,   My coworker is running into an issue where his version of Sysmac Studio has been updated, but this is causing a version mismatch from an existing project.  He has called Omron, and they are saying that there's no way to downgrade the OS.    Project operating system version = 7.4.0 Device Operating System version =  7.3.0   So the OS on the NA5 would need to be upgraded to match the version of Sysmac.  Does anyone have any suggestions to revert the automatic upgrade that has occurred? Any help would be appreciated!
  5. Friends kindly help me I need to create ton and counter macro function in factorytalk view studio 
  6. Axis Attribute Error

    Hello All, First time working with PLC. Get the hang of it from stuff I researched. Having an issue with an axis setup for a servo motor.  When I try to do an auto tune it gives me an error that axis is not configured.  Source: Config Fault    Condition: MotorDeviceCode- INvalid attribute      ACtion: Immediate Stop Fault Entry: Type 8, code 9 subcode: 1314 stopaction: 4 Statechange: 3   I was wondering what am I doing wrong? Any leads or source information I can use to solve this. 
  7. Hi, I'm fairly new to motion applications and I have an interesting (to me) problem to solve. I'm using Kinetix 5700 with MPL motors to drive a pick&place carousel and a conveyor belt. I have a virtual master that driver the carousel in 1:10 ratio. The virtual master also drives the conveyor belt, the ratio is given by the carousel diameter and the conveyor driving cylinder diameter +  2x the belt thickness. And I'm using MAJ to drive the master and the MAG instruction to drive the carousel and the conveyor. This all works well. BUT: the carousel does not pick the product in the same place every time. That creates irregular gaps, or pitch, between the product on the conveyor which causes some issues down the line. Is there a way how to superimpose a value to the conveyor axis to ensure the pitch is regular at all times. Something like the ADDAX instruction it Trio motion controller for example? I'd want to have a sensor that detects the edge of the product and compares he encoder value to an expected value and slows downs or speeds up the conveyor accordingly. Thanks a milion.
  8. AVE instruction Error

    A little background information here, I am trying to create a moving average so I accomplished it with the code (imaged attached) The problem i am having is the AVE instruction error bit goes true. it leaved me with a result of 1.#QAN  I did some googling and it said this is typically done when dividing by zero?? so i added a NEQ to 0 prior to loading the array. then it happened again. so i put the error bit in front of the FFL so it will stop loading the array when i get the error bit so i can see what values are in the array when it errors out. Has anyone else had this issue and what could you do to resolve it? I haven't had any luck find something that points me in the right direction. Thanks in advance for your help.
  9. Hello there, I am using a Kinetix 5700 drives to control bunch of axis. HW used : 5069-L320ERMS2 GurdsLogix, 2198-S086-ERS4 Servo Drive with MPM-B2152M-M motor and the 843ES-SIP12BA6 safety encoder. All is working fine except I can't figure out how to dynamically change an axis velocity  controlled by a MAG instruction. I have a virtual master axis controlling the velocity and each physical axis is controlled by a MAG instruction with a gear ratio. In my safety program I have SFX and SLS function block used to determine the safe speed limit. The  SLSLimit output of the SLS function block is linked to a SS1 Request of my servo drive. This causes the axis to stop when safe speed limit acceded.  What I'd like to be able to do is to dynamically change velocity (limit it to safe speed if SLS instruction is active) of each axis without having to change the gearing ratios and thus avoid the SS1 safe stop action.  I know how to do that using JOG or MOVE but is it even possible to do that using the MAG instruction? Regards Martin
  10. Hello, In my ladder program I have 7 different arrays (containing REAL values) all members of a structure and I wish to extract certain values from the arrays and put them on another structure consisting of REAL values (not arrays). Which is the best way to do that ? I tried AryMove command but I get an error "Conversion from REAL to ANY_ELEMENTARY[], ENUM[], STRUCT[] is impossible. To get a better understanding of my structures and arrays here is an example: Struct wheel_data Global variable SWheel of wheel_data rad[1...10] of real, vary[1...10] of real, varx[1...10] of real struct. 2 wheel Global variable Wheel1, .... , wheel10 of wheel rad REAL, vary REAL, varx REAL what I wish to do is to copy Swheel.rad[1]  to wheel1.rad,  Swheel.vary[1] to wheel1.vary, Swheel.varx[1] to wheel1.varx 2nd structure Swheel.rad[2]  to wheel2.rad,  Swheel.vary[2] to wheel2.vary, Swheel.varx[2] to wheel2.varx until I fill all 10 wheel structure instances with values Thanks in advance.
  11. Is it possible to reset " Motor replacement detected error" ( Error code 95.01) using code without connecting to PLC through sysmac studio? If yes please suggest how to do it... Thanks in advance...
  12. Hello all, I'm trying to control a robot over EtherNet/IP using Omron NX1P2. I have some experience in programming in EtherCAT with Sysmac studio for this robot but no prior experience in EtherNet/IP. I have the EDS file and based on this article I was able to develop the tags. However when I transfer the program to the controller I'm getting the following error and I'm unable to proceed any further. I do not know what I'm doing right or  wrong. If some one can guide me through the steps needed to setup an EtherNet/IP device and building a program with it, it will be of great help. I have set up the Task settings same as the way I do for my EtherCAT program. Is that the correct way to go ? Any help from this community is deeply appreciated. EtherNetIP_Demo.smc2
  13. Hi all, I've ran into an unusual situation where I could use some suggestions.  I have an AB PLC working in the field, and an existing fixture that needs to be transferred from an Omron PLC into our AB.  I have an integrator who did some offline development with a welder that uses Anybus communication.  He sent a .ACD file to implement the logic from.  The file has an Ethernet module configured but more importantly, it's showing EDS not registered.  I've asked for the EDS he used, and none of them work when trying to register it via right-click and register.  I can export the module, but it won't import into the current PLC program because there's no EDS (shows EDS error after the import).  If I try to take the program that was sent to me online with the PLC, it will automatically upload and overwrite the build.  I can't even open the properties of the module to see what the integrator did. The end goal is to have the offline developed module implemented into the current program, but it seems like everything I've tried to do has me against a wall.  Is there a way to go online without uploading?  Maybe there's a way to implement this I haven't learned yet?  Any suggestions would be much appreciated, and if more information is needed, I'll be glad to provide it. More info:    PLC Type: 1756-L82E ControlLogix 5580    Rev: 30.014    Studio 5000 Version 30.01.00 - Standard Thanks, K
  14. Sorry if this is covered elsewhere, but my search hasn't revealed anything yet.  I have a number of PanelView graphics created with FactoryTalk View ME and some use a lot of Parameter Files, which link to popup faceplates. So a large number tags are represented with parameter files, which, when clicked on screen, then pop-up an appropriate faceplate, based on tag type or category etc.  I am still digging into the very elaborate FT View ME manual, but at 500 pages, that's quite a deep study.  But I don't see the linkage between the tag's parameter file and how it specifies which faceplate to pop up, and I've not yet found a good article other than keep digging into that FT manual. There does not appear to be a linkage entry in the parameter file itself, where I would have expected it.  Nor do I see any "hot spot" click type event code in the display itself, which would also make sense.  Is it in the PLC code itself?  I would not have expected that, since they seem to be keeping the FT environment self-contained. But there must be some sort of table or linkage somewhere that I'm over looking. Thanks in advance for anyone's thoughts & guidance on this.  Other parts of FT HMI screen development does seem intuitive, just not this dynamic linking.
  15. Hi, Could anyone help me out on how to extract the digits present in a string in sysmac studio... Thanks in advance !!!
  16. Anyone know of a guide about programming a balluff io master device into Sysmac Studio?
  17. Version 4

    8 downloads

    MX Component manual for programming PC - PLC software solutions.   Details MX Component library functions and examples. 
  18. MX Component Programming Manual View File MX Component manual for programming PC - PLC software solutions.   Details MX Component library functions and examples.  Submitter WattUp Submitted 03/13/20 Category Manuals, Tutorials
  19. In CX-Programmer software, we have the ability to make a bunch of copies of the same rung with the "Address Incrememntial Copy" Function. Does Sysmac Studio have a similar function?
  20. A simple request for an Omron novice.  I know Timer values in Sysmac Studio are classified as TIME variables.  How can I modify the Preset of a TON block from my NA HMI since the TON Preset is of a TIME data type? Thanks,
  21. PWM

    Hi  In CX-programmer there is a PWM(891) function. Is there a similar same function block in sysmac studio ?  
  22. Hello, Have this error come up constantly and can't be reset. Motor hasn't tried to drive at all. Second motor showing same problem. This is a new configuration on new machine. Other inverters configured without any problems. Anyone seen this before or any ideas what could be the issue.
  23. Is there any instruction in Sysmac Studio Structure text to detect rising Edge (DIFU/DIFD) ?
  24. Task Priority 16

    I have made a fat bloated program that runs too slow. I tried working under the philosophy that "Premature Optimization" is the biggest time waste in developing programs. Now my program takes to long to run and throws a task error. I am attempt to cut the primary task's cycle time down I tried to move programs that use IO to other tasks. Task 16 is supposed to be able  to handle IO but it doesn't come up as a selection choice of priorities for me. I can do 17 but I get errors trying to use IO variables at that priority level. NX102-1200 controller, Sysmac Studio 1.30.1. Should I be able make a task at priority 16? I have some analog IO that I don't need to update every millisecond and I have some data and loop intensive FB's that only need to run once hour and I'd like to get them off my primary task's to-do list. I'll be busy re-writing my program FB's to accept specific variables instead of bloated structured variables and converting and changing Lreal's to real's and some other Premature Optimization tasks so I can run the sucker. 
  25. I am using Studio 5000 View Designer v4.3 to create an HMI on Panel View.  I'm having a weird issue where every time I open up my project, the windows are displaying only in the lower right hand corner.  This wasn't happening earlier.  Undocking the window, expanding the window, uninstalling and re-installing View Designer have not helped.  Trying to open View Designer as an administrator has not helped either.  I know there are better HMI platforms, but I am basically complete with the construction of this HMI using Studio 5000 View Designer and now it is too late.  I just want to add a few more buttons and I can't do it because I can't see the bottom of any of my windows.  Since Studio 5000 View Designer is based in Visual Studio, maybe someone would know how I can fix this via Windows registry files?