Search the Community

Showing results for tags 'explicit'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Found 6 results

  1. Hi Everyone,   I'm having an issue with getting an OMRON CP1H with an EIP21 module using explicit messaging back and forth with an AB PLC.  I'm using a CompactLogix L16ER to test the setup in place of the future Micro850 that will be used.  I've used the Network configurator to set up tag sets with instance IDs for the consume/produced tags.  The data being transmitted is 240bytes in the form of an array of DINTs.  On the AB side I've setup a get and set attribute message with the setup as follows; Get Attribute (Read):  Service Code: 10 Class ID: 4 Instance ID: 111 (Matches Network Config) Attribute ID: 3  Set Attribute (Write) Service Code: E Class ID: 4 Instance ID: 101 (Matches Network Config) Attribute ID: 3 The MSG command executes as expected on the AB without error.  The get attribute works beautifully, but the set attribute completes with no response on the OMRON (no write).   Am I missing something here?  Thanks!
  2. Hello Guys, I am using a nx102-9000 CPU and trying to communicate explicitly to a Telsonic Mag Generator. I have done this on a CJ2M & an Allen Bradley Processor successfully before but am struggling with sysmac. I will attach some screen shots of the AB message instruction because it is much more simple then the CJ2M (required pretty much a full function block made). If anyone wants to see the CJ2M block let me know. I am working right from the sysmac manual using the CIP OPEN, READ, SEND, & CLOSE. Once it is working I will write as well.  I am getting stuck right on the first part "CIP OPEN" I am using a route of '02\10.203.21.40' I am unsure what the 02\ means. I am just copying it from the example. The IP Is correct. Below is the picture of my 1C05 Error. Which in the manual is confusing because they have a 1C error and an 05 error separately.  Another question (once i can open a connection) is in the CIPRead the 'srcdat' I am not really sure what this is? Everything i've used before is an instance number, class, and attribute number (used in the CIPSend Logic From Allen Bradley MSG Instruction & Current Sysmac logic shown in pictures as well. Please let me know if you have any suggestions or need any additional information. Thanks, Kevin
  3. Hey Guys, I am using CJ2M plc and all I want to do is read some parameters from MURR IO-Link connected to Master block. I have all the information required to read the data and I am also able to do that with the network configurator but having hard time doing it with PLC instructions. I have attached the image of how my network configurator file looks like. It has details related to service number, class id, instance id, attribute id and data.    I have tried using EGATR, CMND and EXPLT instructions but have no success reading data from the MURR block. It will be really appreciated if some one can help me find out where I am missing something in PLC to implement any of this instructions. 
  4. Hello, I try to have a communication between a device in Ethernet/IP with my NX1P2. I use the CIP_Open block before the CIP_Send block but I have an error 1C05, "connection not established". However my communication is ok because I can drive my device in implicit messaging. My IP address is ok. I don't understand. Somebody can help me please ? Pascal.
  5. Hello, I am a beginner in PLC world trying to find my way through LADDER programming, ST, protocols etc etc and I am slowly getting the hang on it but now I have come accross a troublesome implementation. We have 3 Robotic Cells in my plant each of them consisting of a Fanuc robot communicating via Ethernet IP protocol to NX1P2 PLC controller. The setup of communications is implemented and working as intended but I want to use explicit messaging to manipulate certain Robot Position Registers, Registers and string Registers. I have the needed Fanuc documentation and Omron documentation but I am a little lost. Are there any guidelines I could use to start ?
  6. Hello! I have a problem with Allen-Bradley High Speed Counter card 1734-VHSC24/C. I need to make changes to the configuration parameter .OnValue1 (DINT) during the system is running. Now, for changing the parameter value, I need to switch off the module and this can not be done during the line is running. I think that maybe this can be done using the explicit messaging. I could not find information for this from internet, so now I ask you to help me with this item. If anyone have experience or knowledge of this, please help me. I do no have experience using explicit messaging. My configuration: Studio 5000 Logix Designer V24.00, 1756-L71S V24.11, Ethernet/IP, 1734AENTR, 1734-VHSC24/C countermodule.