Search the Community

Showing results for tags 'example programm for encoder read in sysmac studio'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Found 298 results

  1. Has anyone found Omron NX IO to be unreliable? I have 2 racks of various NX analogue and digital IO where connections between the IO modules appear to fail when modules are prodded with a finger. System will be running fine without error, then prodding/pushing IO modules will cause TS lamp to flash red on module and cause CPU to throw various errors such as image below. After cycling power, system will start up and run fine with no errors present. Doesn't appear to be related to any particular module and where a particular module looks suspect, fault symptoms will not follow suspected faulty module when swapping with other modules of same type in the rack. Contacts on sides of modules are clean with no dirt or corrosion visible. System has been installed for 24 months and these issues started appearing at around 12 months and seems like it is getting worse. Local Omron tech support are saying solution is to "re-seat" the modules by sliding modules in and out of the rack 10 times. Strangely enough, this actually improves situation for a while and then modules will start playing up again. I am wondering if this is typical of NX IO modules? The connector arrangement on sides of the modules on close inspection looks like it may be prone to spring/wire side of connection jumping out of shallow grove in mating module.  
  2. Hi,   I'm developing an application in C# and need to communicate with a plc omron NX1P2. How can i do it? With cx-compolet? Or is there another way?  
  3. Hi and thanks for youre time  I am a newbie trying to connect to a 1769-L30ERMS using an Ethernet cable. I am using Studio 5000 and RSLinx Classic lite for programming and communication. However Studio 5000 and RSLinx Classic lite are installed on av virtual machine using VMware.  So my problem is two fold. Connect the VM so that it reads from the real computers ethernet port Find and communicate with the PLC from the VM There are guides on how these problems are addressed seperatly. For example https://www.youtube.com/watch?v=JdArYVceO1I and https://www.youtube.com/watch?v=ERLTvcBBK_w however I have not been able to get them to work together. So I was wondering if you, the sages of PLC programming might have some tips or trix that I could test or perhaps even a guide for how to do? Mvh Eric
  4. GX Developer project does not open

    Hello All, I have a GX Developer project folder file sent by the client. I am not able to open. It opens the GX Developer and says Failed to read the project file. The screen shot is attached. Also the  the project is attached. Please help me to open the project. I am using GX Developer version 8.91V 显示器 综合测试.rar
  5. Hi, Does anybody know if its possible to access the "Inhibit Module" tick box within the Hardware Device Connection tab from the PLC code? I'm hoping to turn this on / off depending on whether certain modules of machine are physically installed.  e.g. A Kinetix Drive / Point IO etc. Thanks
  6. Hi All,Cx-Supervisor, NJ501-1340, Sysmac Gateway.I have been writing an update for a project and converting to this new controller.It's a pretty big project.Using a combination of Ladder and ST.Using Cx-Supervisor 3.5.I created some new Variables in Studio and made them Publish only.Started to create Points in Supervisor and made them I/O connected to the variables in Studio. No problems everything was connecting and working just fine.Then one of the points would not update. I could change it in the PLC and it would not change On the HMI.I deleted it and recreated it and it did the same thing. (sometimes points in Supervisor just stop working and recreating them fixes it).I then copied the control and pasted the old point into it and it did the same. Then other started to fail. Showing no reaction.I stopped the gateway and restarted, no help, I rebuilt the HMI, nope.The can check the tags in Sysmac gateway and they always change when the PLC changes but not the HMI.I checked the point maintenance in Supervisor and it would not change.I dumped all the affected variable in the PLC and in the HMI and recreated them. Then it got stranger.I could change some on the HMI and it would show in the PLC but not the other way.This is on Bools and UINTS.Stopped CX-server, tried using it with Win8 compatibility. nope.Pulling my hair out now. I should be coding but I'm trying to get the apps to work.Any ideas will be used with thanks.Peter
  7. Hey group! I am working on a project that has a machine that forms cartons that will drop the cartons into a cleated conveyor after they are formed. The forming machine needs to be synchronized with the cleated conveyor so that the formed cartons will drop in between the cleats as they pass under the forming machine. So, in essence, the conveyor will be the master and the forming machine will be a slave to the conveyor and match its position accordingly. Initially, it was proposed that the conveyor utilize a CIP encoder so it could be set up as a motion axis, but the customer declined that option as they didn't care for using CIP encoders (can't really blame them!). So, a slightly cruder proposal of using two 1024 count encoders was proposed, which they accepted. However, your friendly programmer here isn't quite sure how to make that work! I think the basic concept is encoder following but but I can't seem to find anything online that really describes the actual process or logic for this. The RA Sample Code site doesn't seem to have anything on there but maybe I just haven't entered the right search keywords. The forming machine has the following notable components: 5069-L310ER 5069-HSC2xOB4 PowerFlex 525 drive 1024 count incremental encoder As noted, the idea is to have a 1024 count encoder mounted on the conveyor with some sort of ratio so that the counts will run the pitch of the cleats 508 mm). Some trickery will have to worked in to get them to sync at the right time but for the time being, I'm just looking for a method to do the encoder following and asking the group if anyone has some ideas, or better yet, a method, of how to accomplish that.
  8. Hello, I guess everyone knows the current availability situation with electronic parts. Due to this reason I'am looking for alternatives for the Omron NA-Panel series. I'am curious if you guys already made some good or bad experiences with third party HMIs in combination with NJ/NX PLCs. It would be a pleasure if you could indicate some brands that will work.   Thank you in advance.
  9. I'm editing a dual language project for an NA5 HMI. It's working fine except for the message at startup. To modify the project I've had to update the firmware on the HMI. I'm using Sysmac Studio 1.15. Startup language seems to be set correctly. Any ideas?
  10. Sysmac studio not installing

    Hi, I am currently trying to install sysmac studio v1.43 on my computer and I'm getting an error at the beginning of the installation process (see picture) From what I have seen on this forum I am not the first person living this situation and it seem that the user asking for help on this forum had his issue resolved with the use of a previous version, V1.25 I believe, and I was wondering if it anyone could help me with this problem to either patch it or get a compatible version for my computer.      
  11. Hello, I am working on a project currently that uses a windows application on a PC to communicate with an NX1P2 controller to read and write variables data. I found a course on Udemy which has a Visual Studio project with OMRON DLLs that are used for these communications. I confirmed with OMRON that they do have official DLLs for this, but the technical support guy has told me he is trying to find them himself.   I have attached a screenshot of the DLL references.  I am really looking for the DLL libraries, aswell as the documentation on their functionality to I can use them to communicate. Any help would be greatly appreciated!  
  12. Unable to delete a screen

    Hello AB professionals, I am using FactoryTalk View Studio v11. I am basing on an old project to build my application. I restored the project from a .mer file. I deleted or renamed some old screens, saved and closed the project. But when I open the project next time the screens I deleted still show up. When I click on it it will show an error message "Component does not exist".  In the FactoryTalk ME application, I right click a screen name on the left tree under the Graphics, and then click "Delete" or "Remove", the display would disappear at that time. But it persists on coming back next time I open the project. If you know the solution to resolve please reply. It is much appreciated.   Thank you. Lei
  13. I'm working on a program where I manipulate REAL numbers in Sysmac studio using an NX1029020 PLC. My problem is I am new to automation and I don´t know how to display those numbers when connecting to an NB HMI. I´m trying to send the data to a bar picture and a number display. My question is which AT Specification Attribute should I assign to my variables in Sysmac Studio and their corresponding Area in NB-Designer? I tried using the DM area but it didn't show numbers on the displays, only shows *****. Should I convert my real variables in Sysmac first? Or how can I keep decimal numbers and then display them? My current configuration in Sysmac: Name Data type AT Network publish ST1 REAL %D5 Publish Only ST2 REAL %D3 Publish Only My current configuration in NB-Designer Bar Picture Addr. Type D Address 3 Code type BIN Number Display Addr. Type D Address 3 Code type BIN Data type Float Integer 4 Decimal 2
  14. Hi all, Can i rename the master of numbered project (#1, #2... create used "save as new number" function)? Actually i can only open preferences window of the last number, and only edit Author and Comment. If i edit one on these two it only change it on the last number. Are there a method to change preferences for the "master" project and all the sub-number? If i would rename a project now i have to save as different project, and loose basic version control that numbered projetc provide (enought for me) and generate more confusion. In the single project i have no problem edit all Preferences include name. Versione: Sysmac Studio Standard Edition 1.47 Thanks, Andrea.  
  15. LOGO For Excel

    Version 1.0.0

    6 downloads

    LOGO For Excel allows you to retrieve, view, log and write data to one or more Siemens LAN connected LOGO! 8 basic modules using Microsoft Excel without the need of a touchpanel or any other hardware or driver. Configure in no time Excel spreadsheets that contains live LOGO! data.
  16. View File LOGO For Excel LOGO For Excel allows you to retrieve, view, log and write data to one or more Siemens LAN connected LOGO! 8 basic modules using Microsoft Excel without the need of a touchpanel or any other hardware or driver. Configure in no time Excel spreadsheets that contains live LOGO! data. Submitter progpro Submitted 03/25/22 Category Demo Software
  17. Hi!   I am new to plc-programming and i need few tips to finish my first project   question 1: What is best way to convert bool's, lint, time and real into array?     question 2: What i need to have for transferring that array into company's Http/web and how to do it? modem?   Thanks for helping!    
  18. Currently have NX PLC setup as an OPC UA server and an OPC client setup and communicating.  The issue is only tags that do not have a Data Type are showing up in the OPC client.  I have 2 separate OPC softwares connected to this plc through OPC UA and both are having same issue.  If I setup the OPC as a polling service, then all the tags show up as expected.  Does anyone know if this is a known issue with Omron and their OPC UA server, or is there something that I am doing incorrectly (possibly a setting within Omron that I am not aware of)?
  19. Hi. I use the email block on few of our NJ101-9020 controllers to send out daily reports or any status updates. Recently the PLC's started an unknown issue and fails to send email out anymore. I use the Mail_Send function block from Omron to send emails. The only Error ID i can get is 2005, with status being "Connection to SMTP" failed. Looking at the troubleshooting guide, i cannot find anything to do with error id 2005, in fact its missing. There is 2004 and 2006 but no 2005. I've tried all the obvious thing like, power cycle, redownload the whole project, create a new instance of Mail_Send function block etc. Nothing seems to have fixed this unknown issue. Our IT department did a full check on their side and nothing seems to be out of order. I can still remote into the PLC, so i dont know what exactly is the problem. Has anyone came across this error ID before? Any ideas why this might have been happening? It was working well until few weeks ago and nothing changed and this suddenly started. Any input is really appreciated. Thank you.
  20. OS: Windows 7 on VMware virtual machine. Sysmac Studio V 1.13. What works: Ping to PLC. Sysmac Studio -> Controller -> Controller Communications -> Ethernet via hub -> Test -> "OK". What doesn't work: Starting with new project for NX701-1600 (correct PLC): Sysmac Studio -> Controller -> Online. -> Controller -> Transfer ... -> From Controller. The task seems to run to about 90% before stopping with the error:  I can't find any reference to this error in the manuals. Has anyone got any suggestions to fix this?   Many thanks.
  21. Hello! I have been working with a Factory Talk Studio V8.0 and my computer was crashed, "blue screen". After this, I can not open my panel project anymore, I only get information Failed to open factory talk private directory for the application. How to save my project?  
  22. View File Sysmac Studio Simple PID Example A simple test program and starting values for the PIDAT instruction in Sysmac Studio. Simply run the simulator (Simulation-> Run) and toggle the Test_PID bit. Simulated feedback will allow the loop to operate normally. The setpoint can be adjusted by modifying the PID_SP variable. There is a pre-programmed data trace that traces the SP, MV, and PV. To use the data trace navigate to DataTrace0 and start the trace, flip the Test_PID bit true and the trace will log 10k samples. Submitter photovoltaic Submitted 02/13/22 Category PLC Sample Code
  23. Sysmac Studio Simple PID Example

    Version 1.0.0

    20 downloads

    A simple test program and starting values for the PIDAT instruction in Sysmac Studio. Simply run the simulator (Simulation-> Run) and toggle the Test_PID bit. Simulated feedback will allow the loop to operate normally. The setpoint can be adjusted by modifying the PID_SP variable. There is a pre-programmed data trace that traces the SP, MV, and PV. To use the data trace navigate to DataTrace0 and start the trace, flip the Test_PID bit true and the trace will log 10k samples.
  24. Encoder for fx1n

    Hi all! How can I use two AB phase encoder at the same time. I use Mitsubishi FX1N PLC, and I would like to use a high speed counter. I think the plc has 6 high speed counter input, but I cant use only one at same time.
  25. The summary of the issue is when attempting to update any hardware file or technology package, the package will hang up in the “copy setup” status. This state will remain indefinitely – no further progress is made past this point. These are the steps that I have used to troubleshoot this thus far: I always run Automation Studio as an administrator I have redownloaded the program a couple of times, storing the downloaded ~8 GB package in C:/temp Temp files are cleared prior to launching Automation Studio I have tested different internet connections. With and without going through the company VPN. Launching the package via local and internet connection to isolate if it is a TCP port blocking issue. At this point I’m curious if there’s different registry key changes which allow for deleting files from temporary directories… but that’s just a theory. I've attached some screenshots.    What the function of the copy setup state? How can I progress past this state?    I'll keep banging on the keyboard to figure this one out but if there is a good Samaritan out there on the web it would be MUCH APPRECIATED!