Search the Community

Showing results for tags 'ethenet port is not showing up in rslinx'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Found 61 results

  1. Hi all, I'm new to Allen Bradley but have some experience with TIA/STEP 7 - not that it relates to this issue! We have 2 side by side systems but running a SLC 5/05 CPU, with the same program but different IP addresses, connected via a network switch. All has been fine until both were power cycled - system 1 CPU program has dropped but not system 2? The IP address for system 1 has been reset and can't be pinged from either the switch (but 2 can) or directly connected to the PLC port. Steps I have carried out as below, so would appreciate anyone skimming over and pointing out where I've gone wrong/something else to try; - Used BOOT P DHCP tool directly connected to system 1 plc, add relation assign original IP address, click Disable BOOT P. - Attempt to ping (after changing laptop IP to same loop but different node) = no connection - same cable used to connect to switch and ping system 2 which worked so cable and adaptor settings good. -not going to help with the immediate problem but battery swapped out for new on CPU. Any assistance and advice appreciated!
  2. Hi and thanks for youre time  I am a newbie trying to connect to a 1769-L30ERMS using an Ethernet cable. I am using Studio 5000 and RSLinx Classic lite for programming and communication. However Studio 5000 and RSLinx Classic lite are installed on av virtual machine using VMware.  So my problem is two fold. Connect the VM so that it reads from the real computers ethernet port Find and communicate with the PLC from the VM There are guides on how these problems are addressed seperatly. For example https://www.youtube.com/watch?v=JdArYVceO1I and https://www.youtube.com/watch?v=ERLTvcBBK_w however I have not been able to get them to work together. So I was wondering if you, the sages of PLC programming might have some tips or trix that I could test or perhaps even a guide for how to do? Mvh Eric
  3. Dear forum, I am facing a trouble at the moment and hoping somebody can assist. I have one HMI software, GT Designer 3, HMI: GS2107 and/or GT2107, the software works so far so fine. The software is used on several products, I dont want to maintain two or even more software versions. Two serial devices are connect: 1x MODBUS RS-485 1x MODBUS RS-232. The data transfer is done via DDT, no direct calls. The DDT transfer the MODBUS address to the internal GD-Registers. The GD-Registers are used within the HMI. My trouble is that in some cases, there is no RS-232 device connected. This creates time outs, slows down the HMI and its just not nice looking (I have a warning implemented "WARNING NO CONNECTION TO SERIAL DEVICE RS-232". Is there a way, that I can select (retained) that the RS-232 is connected / or not? Once the software is configured "NO RS-232 CONNECTED" I can handle the rest of the software.   Anybody an idea how to do this? Many thanks.
  4. Hello everyone, I am a newbie with PLC. I have a Micrologix 1000. The last time I connected with RSLinx easy, however, I change it to DH485 (I do not remember exactly). And now I can not connect it to RSLinx, I tried many times for all types of drivers. Please help me. Thank you very much.
  5. We have an SLC 5/05 on our automation network, one of several SLC 5/05 processors on site.  It functions perfectly well and no ethernet messaging issues or SCADA drop outs.  The difficulty I am experiencing with it is when I am required to fault diagnose it takes a very long time to get online to it with our laptop running RSLogix500.  It sometimes takes as long as 10 minutes.  It makes no difference whether I use the Ethernet devices or the EtherNet/IP Driver in RSLinx, it nearly always takes an age which is frustrating in a breakdown situation.  I don't ever experience these long wait times connecting to any other of the SLC 5/05 controllers or any other controllers for that matter.  Once I am connected to the problematic controller I don't experience any issues, it's just the initial time getting online.  I try to leave the laptop permanently connected to it to avoid the long wait time to connect.  When I open RSLogix500, select Comms, Who Active Go Online, Ethernet devices driver, I can see that the problematic 5/05 has Active as its Status whereas the other 5/05 processors have Remote Run as their status.  Please can anyone advise as to any possible program parameters, RSLinx settings or hardware faults I should be looking for?  I have considered it could be a network problem but I'm unsure about this given how the processor performs well in every other regard. Neil
  6. Hi! I'm using RSLinx Classic, RSLogix Micro English and RSLogix Emulate 500 to emulate a Micrologix 1100 Series B. I'm able to run, program and simulate different input and output with the emulated PLC. Everything works fine. My problem is that I'm writing a program using the nodePCCC library (https://github.com/plcpeople/nodepccc) and I'm not able to connect to the emulated PLC using the address 127.0.0.1 and the port 44818. I tried  running 'netstat -a' on Power Shell and I found out that the port 44818 is not being used.  Could someone help me identify what I'm doing wrong?
  7. Fatek PLC Communication Problem

    hy all. i am having an error while communicating with fatek plc. when i communicate it gives an error. " Com port open fail, plz check if this port is used by other programme when we online the PLC (Fatek/ WinProLadder). kindly Guide me   as it looks like port is already used by another program . and i dont know how to kill that program ..       
  8. Hi All, How can I collect the information provided through RSLinx in a ControlNet network, specifically on the Station Diagnostics Contronet devices? My idea is to generate some statistics errors and avoid some network errors failures.
  9. Hi all,   Is it possible to simulate LMC058 PLC with ethernet in soMachine software. I want to test the logic written in PLC which uses tcpudp library.
  10. Hello all, I am working on a project where I am communicating with a Mensor CPT6100 pressure transducer using a Micro-850 PLC. For this, I have used an AWA instruction to write some ASCII characters to the sensor. The sensor then responds to the write instruction by sending ASCII characters to the RX buffer and I used ACB and ARD instructions to read the ASCII characters. Now, I have set the ACB trigger type to 0 (msg triggered only once) and it successfully reads from the sensor. However, when I set the ACB trigger type to 1 (msg triggered multiple times), I do not get any reading in the ARD block. As a matter of fact, the ACB Q bit switches off every time the program is executed when the trigger type is set to 1. I am trying to get continuous readings from the sensor, but when the trigger type is set to 0, the program latches on to the first and only reading and it won't change. My question is, how can I change my program so that it can continuously and autonomously read from the sensor without me having to manually trigger the AWA and ACB instructions every time. I am attaching the program to this thread for your reference.  ASCII_Test_Copy.ccwarc
  11. Hi, I am very inexperienced with Omron hardware so apologies if this is a daft question. I am trying to use Kepware to retrieve data from a CJ1M-22 PLC via the peripheral port using RS-232 and the Toolbus Kepware Driver. The RS-232 is provided by a Brainbox ES-246 Ethernet to RS-232 convertor. I have no problem accessing the PLC using this peripheral port via the programming lead but I wanted to know if anyone had successfully pulled PLC data through this port? Many thanks John
  12. Hello everyone! This is the first time I use Micro850 controller (2080-LC50-48QWB) and after I made a really simple programme (just for testing) I wanted to download it to my controller (which I was able to see and connect to via Ethernet and USB normally) and I got a message saying that firmware version didn't match (programme - v9, and PLC - v4). So I found some datasheet where was explained how to upgrade device firmware with ControlFLASH. I started the mentioned software, choose the right controller, and I choose the version 9 and the process started, but near the end I got the ERROR message, and the update wasn't finished successfully. So my controller went to fault (FAULT red light flashes) and now I can not see it in RSLinx nor via Ethernet nor USB. Does anyone have any idea what could I do to try to establish connection with my controller? I have tried to change from prog mode to run, and back to prog, but the fault remains. I really hope that I didn't make some serious mistake, because we need this PLC very soon for work. Thanks  in advance!
  13. Currently I am using DDE links in Excel to run a live "dashboard" with our cycle times and faults/downtime. I was wondering what the best solution would be if I wanted to display a dashboard with this information on a TV within the plant but I only have 1 license of RSLinx Gateway. OPC perhaps? SQL? I attached a picture describing what I need
  14. Hello PLC expert i need your help. i want to use OPC communication and Matlab to read and write data from/to a Logix5561. A Topic is already configured on RSLinx. On my PC i installed MATLAB and i can connect to the OPC Server using Simulink opc Toolbox. My Problem occurs when i want to add Items, i receive a Simulink error saying Name space Browsing not avaible. and Matlab says could not retrieve name space for Server. Error was: StartItemId is not a branch in the Server Namespace Additionaly i have RSView32 as an OPC Client too and although it is working fine, there is an error saying: OPC Error :Server the item is no longer available. could the error in RSView32 be the root cause of my Problem ? edit: I forgot to mention, that on Simulink opc read and opc wirte box have the Mention disabled in brace .
  15. The BOOTP/DHCP is unable to function because port 67 is being used by another process Throwing this in here because I have a plethora of problems with BootP since Win10. It is rare that I use Boot/P, we don't need to install a lot of new devices, as we are an OOM. Had an old 5/05 that should of had an IP address but did not and was not immediately discoverable by other means. Could not read through the serial port because it was set up as half duplex and apparently RSlinx and/or my cable would not work on half duplex (auto find could not see any PLC's). We tested the serial port of an identical 5/05 and see the same issue, moving that to Full duplex would allow a connection. We looked at the last program back up we had and found that it was indeed set to half duplex. So, suspecting that PLC did not have an IP address, I received an error which is the first line above. It also said it was a service host with PID 10262 that was using it. I opened my services and looked for PID 10262, it was being used by a "Shared Services" function, which I stopped. Then BootP opened and worked fine. Reality is, that if I reboot, this service will likely restart and cause the same issue and I don't think I can keep it off all the time. If I can find a way to reassign this service, I'll post more here.   Good luck
  16. Hello,   Target:  I'm looking to make an excel macro that will take an IP address and pull the components on that specific backplane. Pretty much how RSLinx Classic OEM does it, but it will save me a lot of time if I could automatically put the results into excel. Example: Enter IP "111.111.111.111" into excel, run the macro, and have it fill in the components on the backplane below. 111.111.111.111 00, 1756-L73 LOGIX5573 01, 1756-EN2T 02, 1756-DNB 03, ... 04, ... Any help that could get me toward this would be amazing. I'm just not sure of the code that would do this.   Thank you, MalSmith21
  17. Hi Guys, I recently purchased a 1769 L32e off of ebay. I'm able to connect to the processor through the RS232, but when I try bootp the MAC address is not being detected. I opened up RSLinx through RS232 and I noticed that I don't even have the ethernet port in the device tree at all. I also tried adding the MAC address from the processor in bootp through the add relations button, but with no success. When I go to my Local Area Connection, I can see that I have established connection between my computer and the PLC. I've attached a copy of the RSLinx capture below!!!! You guys help is greatly appreciated!!!!!
  18. CJ1M serial communication

    Hi! I would like to know how I could send information throw serial RS232 communication. I mean, I have CJ1M-CPU11 connected with ID232 and OC201 modules, and I have an optic sensor (digital input). When the sensor turn on, I would like to be able to read the information (on/off) with an application like Putty (I have the PLC connected by RS232) to develop an application and show the information on another framework. I don't know if I have explained very well. Thank you!
  19. I'm wanting to get upload the program from a CompactLogix L31 Controller.  I'm using a generic (non Allen Bradley) "C2G brand" usb -->rs232 cable coming directly off of my laptop because I don't have a serial port out.  The rs232 side of the C2G cable is a "pin out" or male end, and as you can see in the picture, the serial port at Channel 1 on the controller is also male.  I'm using a generic (non-Allen Bradley) null modem (female-->female) cable to complete the connection.  Ultimately, I'm not seeing the controller on linx.  But that's a result of me not being able to configure the driver.  When I try to auto configure this driver, Linx gives me an error saying, "Unable to verify settings due to a NAK!" btw, the rs232 cable going into channel 0 is for the HMI on the machine. A pv600 1. How do I get online and upload the program from the controller? 2. What does NAK mean?
  20. Hi, I have a task whereby I have to hook a WonderWare InTouch (2017) HMI, on Windows 10 through to two Allen Bradley PLCs both programmed via RS-Logix 5000. OPC comms between the HMI PC and the PLCs have to go through RSLinx Classic. The RSLinx Classic install has a paid-for OEM license. InTouch to RSLinx has to be through Wonderware OI-Gateway using Suitelink protocol. I can see and interact with PLC-generated data items at the output side of RSLinx using Matrikon OPC Explorer.  I can also see OPC data generated by Matrikon OPC Server for Simulation from within InTouch with comms to the Matrikon OPC server going through OI-Gateway / Suitelink. However, I cannot get OI-Gateway to talk to RSLinx, and so can't connect InTouch to it.  I have now found that this RSLinx Classic OEM license might not support interaction with Wonderware OI-Gateway. However, fruitless searching means I don't know if this is the case, but I still need to find out and be certain of  the facts before broaching the whole "we actually need to buy another RSLinx license" thing with the Powers That Be. There seems to be content on the Rockwell / Allen Bradley / RSLinx website which deals with it but (frustratingly) it declined to show me that content, appearing to suggest that I needed to pay for a Rockwell support contract before I could get access. I'll not get (too far) into the debate about coolness of this - or otherwise - when we've already paid for this RSLinx Classic OEM license and just want to find out if it will actually do what's required... Cuitting to the chase, could anyone tell me please which RSLinx Classic license I need to have in the setup above in order to be able to speak to RSLinx Classic from Wonderware OI-Gateway? There are 2 PLCs which RSLinx communicates with, but the two of them comprise two 'halfs' of the same overall system. I suspect the OEM license might have to be upgraded to a Gateway license, but I just don't know. Input much appreciated please! Incidentally, the OPC server has to be RSLinx - I'm not allowed to swap it out for Wonderware OI-ABCIP or Topserver etc Thanks      
  21. Hi Guys! A have a problem with Excel and RS linx. I belive the communication is good. I just need a few tips, especially with excel. I have about 3000 dint value, and aI dont know how to put them in excel at once. Not one by one. THis is my first question. You can see the link: =RSLINX|MC!'Database_fifo[0].Motor_rpm, L1,C1' the next one is =RSLINX|MC!'Database_fifo[1].Motor_rpm, L1,C1' and =RSLINX|MC!'Database_fifo[2].Motor_rpm, L1,C1' and so on. I dont want to write the numbers like 3, 4 ,5 ...2560... So I hope you guys get it, sorry for the bad explanation. For this problem maybe exsiting some macro or something like that, I dont know. The second: there is some dint what is in decimal style, but acutall they are ascii, I know how solve that, with the char function, but I dont know how to collect it. Like on the picture, there is the numbers what I read from the plc, like 82 equal to R. But I want to see them in one cell. Like RKBF-355, I want them in a same cell. Unfortunaltely I cant solve it. At least until now, and I hope somebody know it by memory.    Thank you in advance!  
  22. 90 30 CPU350 serial connection

    ok running into a issue here, so we were able to communicate with the processor to download a program. transfer went fine. upon cycling power, we can no longer connect to processor. we used LM90 for the software. i've tried removing the battery and shorting out the "mem clear" points on the board, however we can no longer communicate with the CPU. we have a POWER and OK light solid on the power supply. kinda stumped here if anyone has any insight.
  23. Hi Everyone. I need help bad. For some reason the RSLinx Classic on my computer was not working. I decided to re-install it but could not do that. Then I uninstalled it  but would not. I reinstalled all others but RSLinx would not. I cleaned the registry and again did not succeed either to install or uninstall. Does anybody have an idea what is going on? Please help. Thanks.
  24. BECKHOFF CX-9020

    Hello PLC experts, I am master student currently writing thesis. For this, I have a initial task of making some changes to PLC program (Just started getting to know about PLCs- complete beginner). I have a BECKHOFF cx 9020 PLC connected to my notebook using ethernet. I am using TWINCAT 3.1 (VS) as IDE. Firstly, I cannot find my PLC IP address connected to my notebook . I added the route in the Twincat and it shows the PLC is connected. When, I am trying to run a program (activate boot project), I am unable to login to the PLC. It gives an error "login failed for application port 851". What I undertood from BECKHOFF scripts,  there is something wrong with the ADS ams net ID which I am trying to figure it out. I appreciate all the help. Thank you.
  25. I am trying to setup communications between RSlinx and Softlogix on Windows 7 PC. I open SoftLogix and configure a CPU and Ethernet module. I then cannot open RSLinx GUI since RSLinx is already running as a service. I stop the service, which automatically removes my CPU from SoftLogix but does allow me to open RSLinx GUI. However I cannot connect to the Softlogix now since it has no PLC. When I try and add a CPU I get a message that RSLogix must be run as a service. However in that situation I cannot open the GUI.