Search the Community

Showing results for tags 'error 95 1s servo'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Found 233 results

  1. TON syntax error

    I am trying to do a TON timer in GX Works2 on a FX2N PLC. If I simulate the code I have done in GX Works it works the way I need it to, but as soon as I upload it to the PLC it goes into error state. When I look up the PLC diagnostic there are two entries in the list.  NO 6502 Error Step 35 Syntax error No 0000 Error Step 35 Unregistration error If I remove the timer from the program, all other things works fine.  This is the code that makes it give the syntax error.  Forward( IN:=%IX004, PT:=eTime); %QX004:=Forward.Q; Also tried this Forward( IN:=%IX004, PT:=T#5S); %QX004:=Forward.Q; I have also set up the same in ladder, but get the exact same syntax error from the PLC once it's uploaded.  Does anyone have an idea of what the problem can be?   
  2. FX3U Stop Reading Channel Data

    Hello Everyone,  Need help with reading channel data of FX2N-4AD with FX3U Cpu. I have added all the logic and it works also. Problem is that, FROM function stop reading/fetching data from FX2N-4AD after some time i.e couple of hours and value just hang. Like 502 or something, untill you reset the whole PLC. What could be the problem. For the further info, -I have connected the FX2N-4AD on the right of fX3U-64M. -There are two extension blocks FX2N-16EX and FX2N-16EYR also added to the right of FX3U-64M -Order of mounting....FX3U-64M > FX2N-16EX > FX2N-16EYR > FX2N-4AD > FX2N-4AD   I have tried using the 2nd special module connected at the end, but It showed similar problem after few hours of running. THis shows that both Special blocks fx2n-4ad are okay. There is something wrong with PLC maybe? Please help
  3. MR-J4-60GF-RJ Programming

    I am new to Mitsubishi (only done Allen Bradley) and Im tasked with programming a MR-J4-60GF-RJ servo drive with a HG-SR motor. I am using GX Works 3 and have a R02CPU and I am wanting to use CC Link IE Field Basic communication with this. Do I have to use the point table to move this motor from "Point A-B" or can I send absolute positions, speed, etc to a given position. Any advice/programming examples would be great. 
  4. Hell PLC World! I have been trying for several weeks in my spare time at work to tune an Allen Bradley Servo Motor.  Below is the list of hardware I am currently using: - CompactLogix Motion Controller (1780-L33ERM) - Kinetix 350 Driver (2097-V34PR5-LM) - MPL Series Rotary Servo Motor (MPL-B310P-MJ74AA) I have been using RSLogix5000 for testing and I plan to use it to develop a simple conveyor type program later.  I have tried a list of things which will be below, but to no avail, I cannot simply jog the motor for any period of time without triggering a position, velocity or bus voltage error.  I have tried changing the motor, driver and feedback cable to no avail.  Here is the process I have used: 1) Add the hardware to RSLogix5000 (PLC, Driver and Motor) 2) Configure the motor 3) Run the hookup test.  This works flawlessly.  The motor will slowly turn independently on the feedback test for as many revolutions as I input.  This is what makes me think I am doing something wrong in the tuning process. 4) Run autotune process with the velocity, acceleration and jerk set well below the limits of the hardware.   5) Attempt manually control motion 6) Recieve error I have tried changing the input from trapezoidal to S-Curve, changed velocity and position limits, manually tuned velocity gains in a myriad of configurations.  I have swapped legs on the 3 phase input (which made matters worse). I suppose it is possible that multiple pieces of hardware are faulty because this equipment was previously used, but I still cannot wrap my head around why the hookup test would work so flawlessly, yet I cannot just get the servo to rotate at an equivalently low speed. If anyone recognizes my mistake, I would be eternally grateful.  I am an intern studying control systems in graduate school and as popular as AB is, I would sure like to get some experience with it.  Thanks in advance!  
  5. Q02HCPU- Unit Verify Error

    Hello to all I have a mitsubishi electric plc Q-series (q02hcpu) with 2 Position card (qd75m4) for controlling 4 servo motor (mr-j2s-350b).  I have a new problem with. PLC after working for a few minutes, The Error light on the CPU  and position card turns on and the PLC STOP Working. Please help me fix the problem VID-20190806-WA0004.mp4
  6. Hello, I have a project where I need to synchronize 2 servos. I use GearIn command to sync this servos. I created 1 virtual axis and attached my 2 physical servos to virtual one. Based on application logic I need to stop sync servos when count from sensor reached max value. To stop the servos I'm using ImmidiateStop command. For some reason stop point for this servos variate based on servos speed.    How I can improve my stop point?      Thanks!
  7. Alice Sales Manager Changsha Zhinian Automation Equipment Co;ltd   Te/whatsapp:+8613341312293 Fax: 0086 0731-82292217   Email: info-zna@zhinianauto.com   Main products: PLC: Mitsubishi, Omron, Panasonic Inverter: Mitsubishi,Fuji, Omron,. HMI: Mitsubishi, Omron,, Proface,FUJI, AC Servo: Mitsubishi, Omron,FUJI Sensor: KEYENCE,OMRON   Air cylinder: SMC Below is our best price product list: MITSUBISHI: 1.MR-J2S/ MR-J3/ MR-ES AC servo pack ( amplifier, motor, cables ,connectors) 2.FR-A700, F700, E700, and D700 inverters 3.GOT1000 and GT1500 Human machine interfaces 4.A, Q and FX series PLC(FX1N/FX2N/FX3U/FX3G/FX1S) plc OMRON: 1.C200H/ CQM1/ CS1W/ CJ1W/ CP1H/ CP1L/ CPM1A/ CPM2A/ CPM2AH plc 2.SYSDRIVE 3G3JZ/3G3MX2/3G3JE/3G3RX Series inverter 3.NS5-V2/ NS8-V2/ NS10-V2/ NS12-V2/ NS15-V2 Human Machine Interface 4.E3JK/ E3JM/ E3Z photoelectric switch 5.TL-Q5/TL-W3/TL-N Proximity switch 6.E6B2/E6C2/E6CP rotary encoder 7.G3NA-205B/G3NA-210B/ G3NB-240B Solid State Relays 8.H3CA/H3CR-A/H3DE/H3DS/H3JA/H3Y-2 Solid-State Timer   Contact me if you are interested, thank you !  
  8. Mitsubishi FX2N, Servo Output problem

    Hello guys, I am facing a problem that our Servo is generating output for only reverse direction, when we give forward command from HMI the output Y0 is active but when we give reverse command same outut Y0 is high, other output which is Y4 is not high, what could be te possible reasion.
  9. Mitsubishi FX2N, Servo Output problem

    Hello guys, I am facing a problem that our Servo is generating output for only reverse direction, when we give forward command from HMI the output Y0 is active but when we give reverse command same outut Y0 is high, other output which is Y4 is not high, what could be te possible reasion.
  10. Hi all. I have a Kinetix 350 and an AB TLY servo motor. I'm using the drive's STO function. AC power is supplied into the drive, passing through an "M1" contactor. It makes sense to m e to keep that contactor open, preventing AC power to the drive, until the drive is fully awake.  Is that what you guys do? Someone suggested to me in another forum ( http://www.plctalk.net/qanda/showthread.php?t=121021&highlight=drive+awake ) that there is no reason not to supply power to the drive right away because the STO function is inhibiting power to the motor anyway. 
  11. Hello  I am currently trying for testing purposes an Mitsubishi Servo Amplifier M4-J4-TM, which has a Servo motor (also from Mitsubishi) controls to integrate in Beckhoff's TwinCat 3. The controller is directly connected to the computer via EtherCat and is also communication between TwinCat and EtherCAT device is detected. But when I switch to online mode and try to control the engine manually, it always comes the following error message:  Error 51 'TCNC' (500): 'Axis 1' (axis ID: 1): The axis or the drive is not ready for positioning (error code: 0x4225)!  Somehow I miss a step to the valid activation of the engine. ?? In the documentation of Beckhoff and Mitsubishi there is no indication. Actually that should work like that. Has anyone ever had a similar problem and knows about advice? Thanks in advance in advance and many greetings
  12. Hey, I have a 1763 L16BBB...when I plug the 1762IF20F2 analog card in, I get a 0189h error code. Any help would be appreciated. Currently looking at doing a bootp on the plc to get online...no ip
  13. Vijeo Citect - write to tag - error

    Hi everyone.  In Vijeo Citect SCADA I created some tags and I try to write to a bit device of MELSEQ Q PLC. But I get this error : Cicode General software error. Note: I can read from PLC.
  14. Hi Guys!   Anybody Can help me ? I have a kinetix 6000 servo, and that axis dont want to go in home position. There is an MSO instruction, but the ER bit is active.  What should I do ? What would be the problem?    Thanks in advance!
  15. Hi All, I have an AB servo TLY-A110T and 2097-V31PR0-LM Kinetix 350 drive. I thought that it was fully configured and ready for tuning, but when I issue a MSO it immediately starts to spin the shaft (no load yet). This lasts about a second until a Physical Axis Fault, Excessive Velocity Error occurs. I've double and triple checked the feedback and power wiring, and everything looks right. Is there anything else I can check? What can I do to trouble shoot this if I can't even give an MSO? Any insight is greatly appreciated.
  16. Hello All I am new to sysmac studio, i am using a NJ301-1200  and R88M-KN10H servo drive , i connected the servo to the NJ using ethercat. I was able to write a program where i was able to activate the servo from the NJ using the mc_Power instruction . My question is , i am not able to run the servo using the mc_movevelocity and mc_moverelative . Do any one have any suggestion to how to go from here ..  
  17. Bonjour, Hello, I use a l33erm automaton and a Kinetix servo motor . This servo motor drives an engine with a chain moving in steps of 100 millimetres (there are 15 steps on the chain ) At each top of a cell this motor advances by 100 millimetre. in reality it advances from about 0 to about 100. Sometimes it is 100,002 times to 99,997 (this is important further) and when I give it a top it goes back to about 100 (100,003 times to 99,996) And so on and so forth up to no problem, I use a MAM with an absolute type of movement. It works.     However, this does not work any more after a rearmament following an emergency shutdown. if it is a 100,002 no problem at the next top the chain advances one step But when the engine is shut down at 99,997 and I give it the order to go to 100 it advances only by 0,003.  This only happens after an emergency stop (or door opening). Thank you for the help you can give me excuse my English this is a machine translation Un séjour sans faille
  18. Hi, I am developing Servomotor Drive Module for Mistubishi servomotor to control its positioning and speed. I have combined two FBs of the RD77MS4 FBs 1. SetPositiiningData FB 2. StartPositioning FB  and defined in Local label as  Label Name: i_stModule , Data Type : M+RD77 Class: VAR_INPUT. I get Error Invalid device or invalid constant is used. Can someone tell me how to define Module Label while combining two  FBs using same Module. Please
  19. Hi, I am developing Servomotor Drive Module for Mistubishi servomotor to control its positioning and speed. I have combined two FBs of the RD77MS4 FBs 1. SetPositiiningData FB 2. StartPositioning FB  and defined in Local label as  Label Name: i_stModule , Data Type : M+RD77 Class: VAR_INPUT. I get Error Invalid device or invalid constant is used. Can someone tell me how to define Module Label while combining two  FBs using same Module. Please
  20. Hi all,  At my work, we are unfortunately still using GX IEC Developer 7.04. All of a sudden I can no longer open any project at all with my GX IEC Developer. I can start the program just fine, but as soon as I choose a project to open I get "cannot initialize communication manager". And after this, I get another 2 "cannot restore parameter file. param.tmp not found" and "cannot restore transfer setup file! cnct.tmp not found!". Doesn't matter which project. And I have opened these earlier with no problem for years. I have tried reinstalling ALL Mitsubishi software on my PC. And restarting PC. I can't find a link to any other changes I have done on my PC either... Does anyone have any idea how to solve this? Best
  21. Omron PLC problem

    Hello, Maybe somebody know why show this error number and that that mean, how solve this problem? I upload video to youtube https://www.youtube.com/watch?v=Leiya_YreeQ
  22. Hey, I recently started trying my hand at creating function blocks. At the moment I'm trying to create a PID function block, however I keep getting this error: "ERROR: Variable does not have enough size." No idea why it does this. Can anyone help?  
  23. State Machine Based PLC Logic Design

    Dear, Folks Greetings of the day                                     I am got very confused in "State Machine" Based Logic design, now am doing Index table based vision inspection system it having 6axis servo, now the major issue is I need to do the better logic with easy error traceability technique. So am chose state machine based system design but the error handling of system is very difficult for me. Any Process automation experts give me the proper solution for this issue or suggest any good book for this state machine error handling concept. Am tried it in web search but I can't get suitable answer < Thanks in advance > 
  24. Hi Everyone, Learning the ropes of SoMachine V4.2 (coming from Arduino and Ucontrollers), I am using a Sequiental step style program and I am receiving 4 error messages. I'm trying to understand why it won't compile.   POU for implicit check is missing. It is recommend to add the POU. C0032: Cannot convert type "IeSFc.SFCStepType(iesfc,3.4.2.0 (systen))'to type BOOL "Same error for a different ladder (the output of ladder rung hits the transition step, the transition is a bool which kicks off the beginning of another ladder rung). C0032: Cannot convert type BOOL to "IeSFc.SFCStepType(iesfc,3.4.2.0 (systen)) Are these two different "data" types?   Thanks in advance!
  25. Hi Everyone,   Learning the ropes of SoMachine V4.2 (coming from Arduino and Ucontrollers), I am using a Sequiental step style program and I am receiving 4 error messages. I'm trying to understand why it won't compile.   POU for implicit check is missing. It is recommend to add the POU. C0032: Cannot convert type "IeSFc.SFCStepType(iesfc,3.4.2.0 (systen))'to type BOOL "Same error for a different ladder (the output of ladder rung hits the transition step, the transition is a bool which kicks off the beginning of another ladder rung). C0032: Cannot convert type BOOL to "IeSFc.SFCStepType(iesfc,3.4.2.0 (systen)) Are these two different "data" types?   Thanks in advance!