Search the Community

Showing results for tags 'data exchange omron nx1p2'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Found 553 results

  1. Hi to everyone!   Our company is planning to build >10 same machines. Some features will be developed later down the road. And here I'm facing a problem where I need to start tracking PLC and HMI program build revisions. Has Omron any internal tools to generate program build revision? Regards, Scotty
  2. Hello every one in this video, you will learn about Omron PLC PID Control (CX-Programmer) you could see it for free by using the below referral link for 5 days. https://www.udemy.com/course/omron-plc-training-course-fa/?couponCode=0384FB604CD8E26CDD09 I hope it will be useful for you.   Regards Mehdi
  3. Omron PLC PID Control (CX-Programmer)

    Hello every one in this video, you will learn about Omron PLC PID Control (CX-Programmer) you could download as free by using the below referral link: Omron PLC PID Control (CX-Programmer) | Udemy I marked free download for 1000 people. I hope it will be useful for you.   Regards Mehdi  
  4. Hi, I have a CP1L and CP1E Omron PLC, and I try to make communication between my PLCs and my system (raspberry pi with Linux OS) using Node-red and specifically using the OMRON-FINS node ( https://flows.nodered.org/node/node-red-contrib-omron-fins) and more detail ( https://github.com/ptrks/node-omron-fins ). So I’m looking for a module to create an Ethernet port for my PLCs. ( both PLCs have RS232 port) . Can you please guide me to find a compatible RS232 to Ethernet module for my PLCs?  Thank you
  5. Hello, I am working on a project currently that uses a windows application on a PC to communicate with an NX1P2 controller to read and write variables data. I found a course on Udemy which has a Visual Studio project with OMRON DLLs that are used for these communications. I confirmed with OMRON that they do have official DLLs for this, but the technical support guy has told me he is trying to find them himself.   I have attached a screenshot of the DLL references.  I am really looking for the DLL libraries, aswell as the documentation on their functionality to I can use them to communicate. Any help would be greatly appreciated!  
  6. Hello! I am working on a quote for a new project that will use EtherCAT but also requires DeviceNet for some legacy components.  Has anyone successfully used the Beckhoff EtherCAT coupler (EK1100) with the DeviceNet Master Terminal (EL6752) and an Omron PLC as the EtherCAT master? My concern is that the coupler will only communicate with the Beckhoff EtherCAT master, but since it is so much more expensive to get the new Omron parts to communicate DeviceNET i am hoping this could be an option.  The equipment is extremely simple and price is a major consideration.   Thank you!!!
  7. CP2E Modbus RTU Slave

    Hi, I would like to know CP2E have any modbus rtu slave function block. CP2E with add on CP1W-CIF12
  8. Hello everyone I'm new to omron plc . I have a system which consists  1. Omron Plc CP2E 2. Two stepper motors and their drivers.  3. 4 Inputs-  one stepper start push button, second stepper go back push button, third stepper 1 home sensor, fourth stepper 2 home sensor 4. 4 Outputs- stepper 1 step(-) Q 100.00, stepper 1 dir(-) Q100. 02, stepper 2 step(-) Q100. 01, stepper 2 dir(-) Q100. 03 Seuence is like that:- Initially both stepper motors are at their home sensor.  When start push button is pressed both stepper move 110 mm distance and then stop.  Now when go back push button is pressed both stepper motors should go back to their home sensors and should stop at reaching their hone sensors.  This is the sequence. Can someone please send me the program by writing in cx - programmer or upload the photos of ladder program and settings also. Please
  9. Bonjour, svp comment résoudre le problème désactivation master
  10. Bonjour svp, qlq me l'aide ,j’ai un problème au niveau automate CJ1M CPU12 via  Erreur de numéro dupliqué 
  11. I recently wrote a simple java driver to communicate with Omron devices (CJ1 and CJ2) via the FINS protocol over UDP. I've installed this software at a number of my client's sites and it works well most of the time. However, I've encountered a number of instances where a CJ1 device will consistently return what looks like a valid response but every memory register I request will return zero. I've deployed the software to 5 sites with identical configurations. The sites have one CJ2 device and one CJ1 device.  The CJ2 devices work exactly as expected. Three of the CJ1 devices work exactly as expected but the other two have this issue where every value is zero all of the time.  This issue is not intermittent at those sites - I have never had it return anything other than a zero for any memory register for a CJ1 device at those two sites. Example: TX: [80, 00, 02, 00, 0a, 00, 00, c9, 00, ff, 01, 01, 98, 00, 00, 00, 00, 64] RX: [c0, 00, 02, 00, c9, 00, 00, 0a, 00, ff, 01, 01, 21, 08, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00]  
  12. HMI Replacement Options

    Hello! We are looking to find a replacement for our Omron NS Screens in what seems like about 20 systems...there are so many third party/other vendor options available, I am honestly overwhelmed, so I thought maybe some of you had great experience with other vendors screens that I could look into using in our equipment.  The screen will have to communicate with an Omron CJ PLC, serial or Ethernet is fine, Ethernet is preferred.  Would also prefer screens that actually have Omron drivers.   Thank you!!
  13. Hi, I have a project including 32 digital outputs, 8 Pt100 probes, 4 thermocouples, and 4 analog inputs so I have to choose an OMRON PLC. The supplier in my country has only CP2E and CP1E PLCs. Is there a way to connect more than three expansion modules to the PLC? On the website is stated that the maximum number of expansion units is 3, if the answer is no, is there a solution to this problem? Thank you
  14. I'm working on a program where I manipulate REAL numbers in Sysmac studio using an NX1029020 PLC. My problem is I am new to automation and I don´t know how to display those numbers when connecting to an NB HMI. I´m trying to send the data to a bar picture and a number display. My question is which AT Specification Attribute should I assign to my variables in Sysmac Studio and their corresponding Area in NB-Designer? I tried using the DM area but it didn't show numbers on the displays, only shows *****. Should I convert my real variables in Sysmac first? Or how can I keep decimal numbers and then display them? My current configuration in Sysmac: Name Data type AT Network publish ST1 REAL %D5 Publish Only ST2 REAL %D3 Publish Only My current configuration in NB-Designer Bar Picture Addr. Type D Address 3 Code type BIN Number Display Addr. Type D Address 3 Code type BIN Data type Float Integer 4 Decimal 2
  15. I have an old Panelview 800 in a system that consists of the PV, a Micro 850 and 10 Powerflex VFd's running conveyor motors. My problems started when one of the motors would not run. It seemed that the PLC was not sending the Run command or the Speed. The problem got worse as I was working on it when two others did the same thing. The current situation is that 8 of the VFD's are getting a Run command and 2 are getting a flickering command. All 10 are getting a 0.0Hz speed command. I connected to the equipment with my laptop and looked at the PLC program and the PV program. I found that in the PV program that all of the user input data, which consists of Motor Speed (Hz), Accel and Decel times and some other timer values for the timing of some conveyor starts and stops, where all gone, set at '0'. this equipment is several years old and predates my presence here. The PLC program seems to be running and passing the commands that it receives to the VFD's. The data is passed to the PLC via Global Variables. I've never encountered this particular problem before. Any ideas?
  16. I am trying to get a G9SP taking over serial to a NX1P2 using a NX1W-CIF01.  I have the details in Manual P545-E1 and it uses a example file which i am unable to locate OMRON_G9SP_SERI232_LD_EV100.SMC I have got the coms working with a CP1L using the example in Manual Z922-E1.  I was wondering if anyone has the example file or a working example they can share for Sysmac Studio. The serial comms will take a little bit to get going but it is the code for the checksum for the sending data that i would rather not have to translate from CX Programer fort he CP1L to Sysmac Studio...... P545-E1-01.pdf.lnk Z922-E1-07.pdf.lnk
  17. Hi, I have a problem with Omron PLC and Beckhoff IO. The IO just disconnects in a few minutes and comes back! I received different errors: Link off error, Illegal slave disconnection, process data reception timeout. When I also check "Display Diagnosis/Statistics information" I see errors on all ports A and B of all nodes.  I have called and talked to both Beckhoff and Omron.  I have two NX1 and one NJ101 to test. And I have three EP2318-0001. I have the same problem with all the PLCs and EP boxes. It does not matter if I have one, two, or three nodes. I have tried different revisions of the EP2xxx from the XML file, different settings for the slave, different task periods, and the error still is persisting.
  18. Im trying to integrate the Omron Nx-ID3444 terminal with the TwinCAT software via EtherCAT, connecting the teminal to a ECC-202 coupler and it to a PC runing TwinCAT, the problems come when using the terminal timestamp whrn the digital input change. The bit input change is detected perfectly but the timestamp corresponding to said bit is always 0, I've been talking to Beckhoff and they tell me that the descriptors on their web might not be in the last version, have you experienced anything similar? I link the files for you to compare https://assets.omron.eu/downloads/ddf/en/v6/omron_nx-ecc20x_ethercat_esi_file_en.zip
  19. This is a machine with a CQM1 PLC and a NT31C HMI. Battery of the HMI run out and the HMI program was lost. I got the PLC program and identified some of the memory locations, can use the machine but not fully. Omron is not my thing so I am looking for some help to identify program functionality. some sequencer functionality and a servo, not many I/O's. The entry from the HMI is converted and has some math maybe to address the 16bit limitation, not sure. Is a home made machine and the original controls contractor cannot be located.
  20. MX2 Modbus doubt

    Hi there! I'm programming a CP1L-E CPU to control 3 3G3MX2 inverters via Modbus. It got some things right, like the INV002_Refresh_X31 block and its parameters. The thing is, I also want to read some parameters from the inverter using the INV206_ReadParameter block. My doubt is, do I need to be careful so both blocks don't execute at the same time and use the serial port at the same time? Is it better to use one INV206_ReadParameter block for each parameter I want to read? Thanks in advance!
  21. Omron 1S Servo

    Hello:           Does anyone know the details explanation of the Homing Settings for the Axis? Set the homing operation. 0: Proximity reverse turn/home proximity input OFF 1: Proximity reverse turn/home proximity input ON 4: Home proximity input OFF 5: Home proximity input ON 8: Limit input OFF 9: Proximity reverse turn/home input mask distance 11: Limit inputs only 12: Proximity reverse turn/holding time 13: No home proximity input/holding home input   Limit Input referring to Input (I/O) ? How about Proximity Input ? It is confusing with the terms. The manual has no explanation for each of the above selection.   Any one?   Simon
  22. NX1P2 SIL

    Hello! I have problem with nx1p2 SIL/pl rating. crane standard says, system have to be atleast (EN ISO 13849) PL D or (IEC 61508-1) SIL 2 rated. Did not found answer from the manual or google. Full Safety rated system is too expensive for this application.  Long story short does anyone know SLI rating for nx1p2? Is there any SIL 2 rated cpu's?
  23. Hi!   I am new to plc-programming and i need few tips to finish my first project   question 1: What is best way to convert bool's, lint, time and real into array?     question 2: What i need to have for transferring that array into company's Http/web and how to do it? modem?   Thanks for helping!    
  24. Currently have NX PLC setup as an OPC UA server and an OPC client setup and communicating.  The issue is only tags that do not have a Data Type are showing up in the OPC client.  I have 2 separate OPC softwares connected to this plc through OPC UA and both are having same issue.  If I setup the OPC as a polling service, then all the tags show up as expected.  Does anyone know if this is a known issue with Omron and their OPC UA server, or is there something that I am doing incorrectly (possibly a setting within Omron that I am not aware of)?
  25. mx2 control with modbus

    Hi all im back to trying to get my inverter to work but this time with modbus, from this post http://forums.mrplc.com/index.php?/topic/38445-controlling-mx2-inverter-without-modbus/ and im stumped, im sure its just one thing somewhere messing it up i have a cp1l-el20 with a cp1w-cif11 and a 3g3mx2 inverter and am attempting to control it via modbus, it is wired up as follows, sp+ to RDB+, sn- to RDA-, common to the plc pin and plc output pin 100.00 to logic input 1. im using 100.00 to put it into run mode the paremeters ive put in are a1=3,a2=1, a4=50, c070=3, c071=5,c072=1, c074=00, c075=1, b27=1. im using MOV to set my speed to d1001 attached is my inv002_refresh x31 fb thanks to any1 who can see my silly mistake