Search the Community

Showing results for tags 'cx designer or sysmac studio'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Found 342 results

  1. "PLC No Response" NB HMI Omron

    Hello Everybody, I continued to work on project this morning but I seem to be plagued with the "PLC No Response" error. This error will only come up when I assign a PLC address to a particular object.  I have followed the steps in the post(https://forums.mrplc.com/index.php?/topic/39885-nb-designer-hmi-plc-no-response-error-solved/) to try and clear the error but am having no luck. In the screenshot I have assigned the large "Start Process" as a bit button with the write address being W50.00. When the button is pressed it should trigger a bit in the PLC but this is when the error appears. During this test I am connected to the PLC and in run mode with the PLC and HMI address assigned correctly. I have read and followed the section in the manual regarding "PLC No Response" but still no positive results.  I just want to check that there is nothing I have done at a programmer end that could cause these issues. I am happy to provide files. Thanks, Ryan  
  2. Has anyone found Omron NX IO to be unreliable? I have 2 racks of various NX analogue and digital IO where connections between the IO modules appear to fail when modules are prodded with a finger. System will be running fine without error, then prodding/pushing IO modules will cause TS lamp to flash red on module and cause CPU to throw various errors such as image below. After cycling power, system will start up and run fine with no errors present. Doesn't appear to be related to any particular module and where a particular module looks suspect, fault symptoms will not follow suspected faulty module when swapping with other modules of same type in the rack. Contacts on sides of modules are clean with no dirt or corrosion visible. System has been installed for 24 months and these issues started appearing at around 12 months and seems like it is getting worse. Local Omron tech support are saying solution is to "re-seat" the modules by sliding modules in and out of the rack 10 times. Strangely enough, this actually improves situation for a while and then modules will start playing up again. I am wondering if this is typical of NX IO modules? The connector arrangement on sides of the modules on close inspection looks like it may be prone to spring/wire side of connection jumping out of shallow grove in mating module.  
  3. Hi,   I'm developing an application in C# and need to communicate with a plc omron NX1P2. How can i do it? With cx-compolet? Or is there another way?  
  4. Hi and thanks for youre time  I am a newbie trying to connect to a 1769-L30ERMS using an Ethernet cable. I am using Studio 5000 and RSLinx Classic lite for programming and communication. However Studio 5000 and RSLinx Classic lite are installed on av virtual machine using VMware.  So my problem is two fold. Connect the VM so that it reads from the real computers ethernet port Find and communicate with the PLC from the VM There are guides on how these problems are addressed seperatly. For example https://www.youtube.com/watch?v=JdArYVceO1I and https://www.youtube.com/watch?v=ERLTvcBBK_w however I have not been able to get them to work together. So I was wondering if you, the sages of PLC programming might have some tips or trix that I could test or perhaps even a guide for how to do? Mvh Eric
  5. Hi,   I am attempting to download a Vijeo designer application to a remotely situated Magelis HMI over the cloud by means of a VPN. Vijeo designer's built-in help indicates that this is possible and has provided an example.  BTW, I am using Vijeo Designer basic v1.1 & the HMI model is GXU3512.   However, I find the fields for router IP and TCP port nos. all deactivated  
  6. Hi, Does anybody know if its possible to access the "Inhibit Module" tick box within the Hardware Device Connection tab from the PLC code? I'm hoping to turn this on / off depending on whether certain modules of machine are physically installed.  e.g. A Kinetix Drive / Point IO etc. Thanks
  7. Hi All,Cx-Supervisor, NJ501-1340, Sysmac Gateway.I have been writing an update for a project and converting to this new controller.It's a pretty big project.Using a combination of Ladder and ST.Using Cx-Supervisor 3.5.I created some new Variables in Studio and made them Publish only.Started to create Points in Supervisor and made them I/O connected to the variables in Studio. No problems everything was connecting and working just fine.Then one of the points would not update. I could change it in the PLC and it would not change On the HMI.I deleted it and recreated it and it did the same thing. (sometimes points in Supervisor just stop working and recreating them fixes it).I then copied the control and pasted the old point into it and it did the same. Then other started to fail. Showing no reaction.I stopped the gateway and restarted, no help, I rebuilt the HMI, nope.The can check the tags in Sysmac gateway and they always change when the PLC changes but not the HMI.I checked the point maintenance in Supervisor and it would not change.I dumped all the affected variable in the PLC and in the HMI and recreated them. Then it got stranger.I could change some on the HMI and it would show in the PLC but not the other way.This is on Bools and UINTS.Stopped CX-server, tried using it with Win8 compatibility. nope.Pulling my hair out now. I should be coding but I'm trying to get the apps to work.Any ideas will be used with thanks.Peter
  8. Hello, I guess everyone knows the current availability situation with electronic parts. Due to this reason I'am looking for alternatives for the Omron NA-Panel series. I'am curious if you guys already made some good or bad experiences with third party HMIs in combination with NJ/NX PLCs. It would be a pleasure if you could indicate some brands that will work.   Thank you in advance.
  9. Hi everybody, in the system information about GT Designer 3, how can i set up that The GOT writes to the PLC to notify it that their communication is active?  
  10. I'm editing a dual language project for an NA5 HMI. It's working fine except for the message at startup. To modify the project I've had to update the firmware on the HMI. I'm using Sysmac Studio 1.15. Startup language seems to be set correctly. Any ideas?
  11. Recipe information Folder's

    Hi experts, i have a problem, i can't delete the Recipe information Folders's in the utility functions. Who can help me please? Many thanks in advance.  
  12. Dear forum, I am facing a trouble at the moment and hoping somebody can assist. I have one HMI software, GT Designer 3, HMI: GS2107 and/or GT2107, the software works so far so fine. The software is used on several products, I dont want to maintain two or even more software versions. Two serial devices are connect: 1x MODBUS RS-485 1x MODBUS RS-232. The data transfer is done via DDT, no direct calls. The DDT transfer the MODBUS address to the internal GD-Registers. The GD-Registers are used within the HMI. My trouble is that in some cases, there is no RS-232 device connected. This creates time outs, slows down the HMI and its just not nice looking (I have a warning implemented "WARNING NO CONNECTION TO SERIAL DEVICE RS-232". Is there a way, that I can select (retained) that the RS-232 is connected / or not? Once the software is configured "NO RS-232 CONNECTED" I can handle the rest of the software.   Anybody an idea how to do this? Many thanks.
  13. Hi experts, i have a problem, i did the upload of my software with GT Desinger 3 on the GOT, but i don't see the PLC variables because my other  software did with GX Works3 isn't linked with the uploading. Is there a way to connect both softwares to the uploading withouth a PLC?
  14. Hi everyone, is there a way to put the numerical input keyboard in a specific position when i click on the numerical input? Thanks a lot.
  15. Sysmac studio not installing

    Hi, I am currently trying to install sysmac studio v1.43 on my computer and I'm getting an error at the beginning of the installation process (see picture) From what I have seen on this forum I am not the first person living this situation and it seem that the user asking for help on this forum had his issue resolved with the use of a previous version, V1.25 I believe, and I was wondering if it anyone could help me with this problem to either patch it or get a compatible version for my computer.      
  16. I have set up a timer in exostructure expert basic and am trying to get the contdown value from the preset of 20 to show in vijeo designer but it tells me the %tm0.v is read only and cant find the variable in Vijeo designer to show it. Does anyone know how to do this?  
  17. Hello, I am working on a project currently that uses a windows application on a PC to communicate with an NX1P2 controller to read and write variables data. I found a course on Udemy which has a Visual Studio project with OMRON DLLs that are used for these communications. I confirmed with OMRON that they do have official DLLs for this, but the technical support guy has told me he is trying to find them himself.   I have attached a screenshot of the DLL references.  I am really looking for the DLL libraries, aswell as the documentation on their functionality to I can use them to communicate. Any help would be greatly appreciated!  
  18. I am attempting to download a Vijeo designer application to a remotely situated Magelis HMI over the cloud by means of a VPN. Vijeo designer's built-in help indicates that this is possible and has provided an example.  BTW, I am using Vijeo Designer basic v1.1 & the HMI model is GXU3512.   However, I find the fields for router IP and TCP port nos. all deactivated. How to get pass this roadblock? I'll appreciate any suggestions.   Thanks a million
  19. Unable to delete a screen

    Hello AB professionals, I am using FactoryTalk View Studio v11. I am basing on an old project to build my application. I restored the project from a .mer file. I deleted or renamed some old screens, saved and closed the project. But when I open the project next time the screens I deleted still show up. When I click on it it will show an error message "Component does not exist".  In the FactoryTalk ME application, I right click a screen name on the left tree under the Graphics, and then click "Delete" or "Remove", the display would disappear at that time. But it persists on coming back next time I open the project. If you know the solution to resolve please reply. It is much appreciated.   Thank you. Lei
  20. I'm working on a program where I manipulate REAL numbers in Sysmac studio using an NX1029020 PLC. My problem is I am new to automation and I don´t know how to display those numbers when connecting to an NB HMI. I´m trying to send the data to a bar picture and a number display. My question is which AT Specification Attribute should I assign to my variables in Sysmac Studio and their corresponding Area in NB-Designer? I tried using the DM area but it didn't show numbers on the displays, only shows *****. Should I convert my real variables in Sysmac first? Or how can I keep decimal numbers and then display them? My current configuration in Sysmac: Name Data type AT Network publish ST1 REAL %D5 Publish Only ST2 REAL %D3 Publish Only My current configuration in NB-Designer Bar Picture Addr. Type D Address 3 Code type BIN Number Display Addr. Type D Address 3 Code type BIN Data type Float Integer 4 Decimal 2
  21. Hi all, Can i rename the master of numbered project (#1, #2... create used "save as new number" function)? Actually i can only open preferences window of the last number, and only edit Author and Comment. If i edit one on these two it only change it on the last number. Are there a method to change preferences for the "master" project and all the sub-number? If i would rename a project now i have to save as different project, and loose basic version control that numbered projetc provide (enought for me) and generate more confusion. In the single project i have no problem edit all Preferences include name. Versione: Sysmac Studio Standard Edition 1.47 Thanks, Andrea.  
  22. Hi Experts,  In GT Designer 3 would there be a progressive number of the active window screen? For example, if I am in the window screen 5, the program retrieves in a variable the value 5. Many thanks in advance.
  23. Hi!   I am new to plc-programming and i need few tips to finish my first project   question 1: What is best way to convert bool's, lint, time and real into array?     question 2: What i need to have for transferring that array into company's Http/web and how to do it? modem?   Thanks for helping!    
  24. Good morning experts, i have a little problem with a Alarm display (user) and i hope with your huge experience you will may help me. Thank you very much in advance  Let me explain best. I would like use a slider to control a Alarm display (user), i tried to do it, but the slider doesn't scroll up/ scroll down like i will want. It doesn't scrolling through the pages and it heighlights just some alarm. Could you give me a bit advice, please? 
  25. Currently have NX PLC setup as an OPC UA server and an OPC client setup and communicating.  The issue is only tags that do not have a Data Type are showing up in the OPC client.  I have 2 separate OPC softwares connected to this plc through OPC UA and both are having same issue.  If I setup the OPC as a polling service, then all the tags show up as expected.  Does anyone know if this is a known issue with Omron and their OPC UA server, or is there something that I am doing incorrectly (possibly a setting within Omron that I am not aware of)?