Search the Community

Showing results for tags 'cp1h-y with encoder.'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Found 74 results

  1. NX1P2 Motion Control

    Hi:       I need to change an old PLC  with NX1p2  to control 3 servo motor by means of Analog Outputs couple with encoders, My job is to change the PLC only. So the servo drives and drivers are untouchable (No budget and involve too much mechanical works).   I observed that Sysmac Sttudio Axes setting has this: Servo Axes, Encoder axes, Virtual Servo Axis and Virtual Encoder Axes.   I believe the Encoder Axes couple with Analog Output is able to to do the Job? If so, what function block should i use? If no, do any body have a suggestion of any function block i can use? Thanks  
  2. DATE Instruction for CP PLCs View File Sample code to set the RTC on a CP PLC. Individual sections can be enabled/disabled. Submitter photovoltaic Submitted 03/12/21 Category PLC Sample Code
  3. DATE Instruction for CP PLCs

    Version 1.0.0

    11 downloads

    Sample code to set the RTC on a CP PLC. Individual sections can be enabled/disabled.
  4. Hi:         I am planning to use NX with Encoder Card  couple with Omron Rotary Encoder for measuring product length. ( GX-EC0211 /EC0241) or may be (NX-EC0112, I read there is proble with this card , here https://forums.mrplc.com/index.php?/topic/34896-problem-pulse-reading-with-fast-counter-card-in-nx2/ ), but whatever it is I need to know is there any specific Instruction in Sysmac Studio that is tailored for Fast Counter or Encoder (something Like PRV in CX Programmer or special function in CJ-CT021 where start/stop counter and changeable preset counter are available).  The Length measurement is straight forward and is only a small part of the overall program.  Basically is Start ---> measure to length----> Cut --->Repeat again.  I read through the Instruction Reference Manual and I am unable to find one.   Anyone have any idea or any sample program (Sysmac Studio only ) that I can refer to ?    Thanks     
  5. Hi everyone, I have an annoying fault on my Kinetix 5700 drive: M01-Safety Feedback. I know this fault is generated by  the SFX instruction in my Safety program that sets tag: "Axis.SFXFault" to 1. The problem is that the instruction is NOT in Fault (Fault code 1 = no fault). This error occurred after Safety encoder 843ES lost it's IP address. I used Bootp to set it gain. And reset the SFX instruction. I can see the encoder in studio 5000 rev 32.12 running and ok.  Does anyone encountered this problem? How can I clear the fault?   Thanks
  6. I have a machine with NJ501-1400 controller. I have some NX-ECS212 SSI encoder input cards. I use Encoder axis with that SSI encoders. I need to change the encoder axis value with the real value of the machine. I tried to use "MC_HomeWithParameter" instruction but I cannot do it because must'nt be used with encoder axis. If I put it at a virtual encoder axis I cannot change actual axis position. I tried to use "MC_SetPosition" instruction but it isnt retentive area and when I lost power I lost reference value too. How can I do it? Thanks! Josep Torres.
  7. How to connect + Program wire encoder

    Hi all, I am not a PLC expert but can find my way within the program and would like to develop much more. For work (We sell industrial bandsaws) we have purchased a Posital Fraba wire encoder, and we would like to hook it up to our Mitsubishi FX3G PLCs to measure at what height the saw bow of the bandsaw is at that moment. Unfortunately I have little experience with connecting these things, as other encoders used in our machines are pre-installed by our factory. Below is described what functions the wires have. What I thought was the following: Pin 1 goes to an input of the PLC Pin 2 goes to + (or 24V) Pin 3 doesn't go to "Ground" as they describe, but instead to - (or 0V), which is technically ground Pin 4 and 5 we don't use, correct me if I am wrong. The saw bow goes up and down only, and I thought we don't need to use these wires.   I connected it like this, connected wire 1 to X0 on PLC and just to test I made the program read:   M8000 ------------------------------ C235 k99999   But the value stays 0, whether I pull the wire or not. So something is wrong, but what, I really can't figure out. Hope someone can help!  
  8. Hello Everyone, I am struggling with interfacing Incremental encoder with FX5U PLC, Does anyone have parameter setting and sample program for same. i am unable to fetch counts...   Encoder: 500ppr, 24V line drive, A-B phase,  PFA datasheet
  9. Hello everyone. I need help setting up a data transfer between a CP1H with a CIF41 module, and a CJ2H. I realize this can't be done with Ethernet/IP, so I figure FINS should do the trick. I've read up a bit on the SEND and RECV instructions, and tried to set up a RECV in the CJ2H (since I know the CIF41 can't act as the sender, it can only receive), but I just can't seem to get it to work... I work at a factory and we're setting up a data collection system. It is mostly CJ2s with EIP tags doing most of the transters, but there are a few machines where EIP tags can't be utilised. Unfortunately I don't really have the freedom of choice what to work with, my budget is already pretty dry, so I kinda have to work with what I have... We need to read 100 WORDs from the CP1H to the CJ2H and send 10 WORDs from the CJ2H to the CP1H, so I figure I'll need to make both SEND and RECV in the CJ2H. CJ2H-CPU64EIP Has two EIP units, built-in and an EIP21. Acts as a relay device to the internal production line network. All the machines on the line network send data via EIP tags to this relay machine. The internal network: Built-in EIP (CPU Unit 0) IP: 10.1.95.80/24 FINS Net 95 FINS Node 80 External network: CJ1W-EIP21 (Unit 2) FINS Node 9 FINS Net 2 IP 10.1.99.9/16 CP1H-X CP1W-CIF41 in the left slot. IP: 10.1.95.180/24 FINS Net 95 FINS Node 180 They are on the same subnet within the line network and the same FINS Network as well. I have successfully set up routing tables and can connect from the external network via the added EIP21 card on the CJ2H to the CP1H PLC and work on it in CX-Programmer and other tools. That should mean the communication works, and I'm just failing to configure the RECV parameter properly... Here's what I have right now: I've pretty much followed the example in the W465 manual from page 235 in combination with the Instruction Help for RECV. (Instructions horizontally are intentional for the purpose of saving vertical space for this screenshot, I normally have them vertically. Also sorry for basically no symbol comments...) In the CP1H in D0 I've input FFFF. I run this by setting on W511.15 and hope that FFFF will appear in E3_3800, but no such luck. A202.00 does blink indicating the logical port did get used and the instruction executed, but didn't work as needed. I'm not sure about the response code. Here's how I understand the control words: D7700 being #0064 means 100 WORDs transmitted. D7701 being #005F means that the FINS Network of the PLC I read from (CP1H) is 95 D7702 being #B4E4 means that the FINS Node of the PLC I read from (CP1H) is 180, and the Unit address on that PLC is the Serial Communications Board Port 1 (I think this thing is what I'm getting wrong, I just can't figure out what to put here... I've tried 00 for the Unit address and that transferred from D0 on the CJ2H which isn't what I wanted, I've also tried #10 to specify a CPU Bus Unit 0, as well as FE to specify "Unit connected to network (not necessary to specify Unit)", but none of these worked) D7703 being #000F means no response needed, use logical port 0, and retry 15 times D7704 being #0 means default timeout Can someone please tell me what I'm doing wrong?
  10. Tank Level Program from PM

    From a PM from @Jason_G I am newbie her  to omron and need some help. I am trying to program a tank level control using a CP1H. What I would like to do is to take a 4-20mA signal from a DP cell located on the bottom of the tank to measure the level (0 to 100%). I would want to take this level and send it to a PID which would then manipulate a VFD pump to control the level base on the set value in the PID as well as the PV from the transmitter. I need help in setting up the PID parameters and also how best to scale the analog input should I use SCL or APR?  Specs: DP Transmitter : 4-20mA on Tank O to 10 feet of water to be displayed in percentage of 0 to 100% VFD pump taking in an analog of 4 to 20mA to drive a 0 to 2000 rpm VFD drive   Tank Level Program.cxp
  11. C+9 on PIDAT Instruction

    Hi, could anyone help? On C+9 PIDAT parameter settings, what's the difference between the values of 0 and 1 in the bit 15 of C + 9? When I try 0 or 1, PID constants remain at the initial values that I made before, the auto tuning doesn't work. Thanks  
  12. CP1H Modbus issues

    From @Janaka Angampitiya: Hello, I have Three CP1H PLC with Cj1w scu31-v1. I need to send a Modbus command SCU unit through Modbus RTU compatible power meter. I use instruction TXDU and CMND but it's not working. My PLC Arrangement CP1H PLC  - CP1H-X40DT1-D    ver. 1.3 Option Board 1 mounted Cp1w-CI41   to NB HMI its work Option Board 2 Mounted CP1W-CIF12-V1 to PLC 1, PLC 2 and PLC 3 between communication Serial gateway mode it is work. CJ1W SCU31-V1  (ver.1.3) and Modbus compatible Power meter it's not working. Please help to how to connected and what is the use of instructions for this case. 
  13. Hi everyone! I got this machine with a CP1H PLC and NS8-TV00B-V2 as PT. I was told that they were working fine, but suddenly, It appeared a communication issue: black screen and "connecting..." at right bottom. I dont know if It is a configuration problem or some hardware damage.  These are the configuration in the PT and the PLC. The communication is through RS232 Serial.  I tried to communicate another PT screen with the same communication settings and IT WORKED!. ' I've been thinking that, perhaps, the serial port A is damaged, I have tried to set port b, but I havent could. How can I configurate PORT B??   THANKS...  
  14. Hello Sir/Ma'am, Hope you and your family are safe in this Covin-19 Pandemic.   One of my client have a machine in their ceramic industry which has Omron PLC System. Here I am describing the PLC Hardware Structure. (CP1H-X40-DT1-D-SC) + (CP1W-40EDT) + (CP1W-DA041) CP1H-X40-DT1-D-SC (Main CPU Unit) CP1W-40EDT (First Expansion Module, on right side of the CPU) CP1W-DA041 (Second Expansion Module on right side of the CP1W-40EDT)   Client shutdown the machine before a month due to Corona Pandemic, and today restarted the machine.   Now the problem at the restart of machine... Analog Output of 0-10V DC are not sourcing from the attached analog output module for any of channels. (Used to control speed of AC Drive) We have checked the program, and verify that the program is moving the value in analog output register address, but still no output signal at the module.(Checked Using Multimeter) We have same machine at another factory so we have tried to replace the all 2 expansion module and observed that the first Digital Module is Working properly but only last analog output module is getting problem again.   I don't know much about OMRON PLC Programming so seeking for the help regarding this.   OEM have moved the data in CIO 106 for generating analog output, as well OEM has move #8099 in CIO 104 and CIO 105 at the first scan of program. I don't know very much about this programming, that's why i refer some manuals but didn't succeed yet.   Kindly help me out if possible... I have attached backup of program as well for reference...   Thanks...   Bobin Feeder.cxp
  15. Hi all, I am having some trouble communicated with a Omron CP1H PLC from CX Programmer.  The CP1H itself comes with two option boards (CP1W-CIF01) to allow for communications via RS232.  The PLC also has standard USB access. When I connect my PC (Windows Server and Windows 10) to the PLC via USB connection I am able to communicate successfully.  The only caveats are: The PLC program appears to be read protected (not related to USB I assume!) The system which I want to integrate the PLC with, Kepware Server, does not appear to support OMRON usb communications. Kepware Server does have support for connections over serial or ethernet so I am looking to make a connection via RS232. After some digging I realised the RS232 cable needed to connect the PLC to a PC is not your standard cable.  I purchased the XW2Z-200S-CV RS232 cable and tried it in both option boards but CX Programmer is not able to make a connection. I used the auto-online, serial port sniffer and manual configuration.  I must have cycled through all possible combinations of settings several times but no joy. I can see an led light on the option boards flicker when CX Programmer is attempting to connect so it appears that something might be happening.  One of the option boards is already occupied by another device (which is working) btw.  I did unplug that device and tried my own cable, again, no success! I also double checked the cable itself to make sure the wiring was working correctly, it appears to be fine. So my question is, does anyone know why the RS232 method is not working?  Are there any options and settings I need to check?  Perhaps I'm missing something obvious. Thanks!  
  16. Hello there, Today i have commissioned my first project with OMRON make PLC. Model: CP1L-EM40DT1D. (CX-Programmer) I have 2 built in 0-10V Analog Inputs on the plc. for analog input no-1 i get the digital value of 0-1000 in specific plc register address corresponding the 0-10V. (Factory setup) But today on site, i have noticed that some miner value of 0 to 50 is always coming and fluctuating very fast in that register, however the transmitter are genetaring 0.0V only (I have checked using digital multimeter with high precision) PLC and Transmitter are already grounded and all the cable connections are tight as well. so how to overcome this high fluctuating value ? is there any setting to filter the input ?
  17. Hola buenos dias quisiera pedirles de su ayuda estoy intentando establecer la comunicacion por el modulo cif11 modbus 485 el plc es omron cp1h con un esclavo que es un variador delta ,pero el tema es que no puedo comuncarme alguien que haya hecho ya, en la configuracion solo me da el puerto de enlace serial HOST LINK y otros pero por el manual te dice que es por el puerto de enlace serial, alguien que lo haya hecho seria de gran ayuda. saludos.  
  18. Hello guys, I am running an application for packaging measurement using a sick DFS60B incremental encoder (programmable from 1 to 10000 PPR). In more detail, it passes packaging on a conveyor belt and we have created an inspection station and an expulsion station (defective packaging), so we use the encoder to check at specific points of the packaging for defects (we use special sensors to check defects). ) (there are four in total). However, the problem we are having is the following: When reading the encoder in the PLC, the same means that performs "jumps" and does not enter the windows (GRT and LES) created on the ladder, ie, as if it were not continuous. . I understand that because the VHSC24 card works at 1 MHz in counter mode, this type of problem should not occur according to our application is not even 100 KHz. For example, our case: Using 1000 PPR and the motor speed (coupling output) is 3600 RPM (in practice it is around 1750 RPM) the frequency is calculated as follows: F = (PPR X RPM) / 60. : F = (1000x3600) / 60 = 60 KHz, ie 60 KHz is much less than 1 MHz, I think this kind of problem does not occur. Application Info: . Studio 5000 V31 . PLC Model: Rockwell 1769 - L19ER-BB1B CompactLogix 5370 . Encoder Card: 1734-VHSC24 / C . Incremental Encoder: Sick, DFS60 up to 10,000 PPR and HTL Electrical Interface. Using a 200 mm circumference / perimeter wheel. . Motor Nameplate Data: 1670 RPM, 0.37 kW / 0.5 HP, 60 Hz . Inverter: Weg CFW500, Output Frequency 62 Hz. Card Settings we use RPI: 2 ms Type: Counter, but we already use it as Encoder X1 Store Count Mode: Disabled Filter: No Filter, but we use 50 KHz and 5 Khz filters in our tests. Counter Attenuator: 1 Wiring Diagram VHSC24 We turn on encoder A at input 0 and encoder Aret at input 1 In logic (Structured Text) Using the PMUL instruction to convert encoder (Pulse) data to mm scale. (Ladder) The window comparisons part (GRT and Les) and other part of the process. We emphasize that we performed the tests also only with the reading and comparison part of the data, excluding the other parts, precisely to verify the issue of Scan, but the problem persisted. If anyone here in the forum has some information that can help us, I would appreciate it.
  19. Trying connect baumer EAL 580... Ethhercat absolute encoder with Beckhoff C6015. Ethercat connection is From PLC to EL6695 module(This module is connected to KUKA robot for mater to master communication) and from Out port of EL6695 to In port of Baumer Encoder. It is not getting scanned nor manually appended. But when i connect it directly to PLC it works fine(gets scanned). Any solution?
  20. Hi all, I am taking a Kubler draw wire encoder back to a 1734-VHSC24 and having a little bit of an issue with the rollover.  With the draw wire untouched the output value seems to be fluctuating over time and appears to be drifting backwards to the rollover value making our distance measurements completely useless.  Does anyone have any insight as to why that might be?
  21. Modbus TCP with CP1H and CP1L from PM

    From @SamuelT Please, I want to know if you know how to communicate two plcs omron CP1H (master) and one CP1L (slave). The master CP1H will send 10 DM memories to slave CP1L. Now I have this configuration: CP1H MASTER PORT: CP1W-MODTCP61 MASTER IP: 10.150.1.5 SLOCK: 1, DIP SWITCH PLC # 4 = OFF CP1L SLAVE PORT: CP1W-MODTCP61 SLAVE IP: 10.150.1.1 SLOCK: 1, DIP SWITCH PLC # 4 = ON I use the modbus RTU function blocks, but the master PLC does not communicate or send the DM memory values to the slave PLC Thank you very much for your reply if you have any example program it helps me a lot MRTU_CP1L SLAVE.cxp MTCP CP1H_MASTER.cxp
  22. Hi, I can’t find an answer to the following and I was advised to ask it here.I’m programming an Omron CJ2M with an MD212 high speed I/O card. I usually do all my programming in Structured text, simply because I like it a lot over ladder or sft.Now, if I want to read the hight speed counter (incremental encoder), I have to make a ladder section and use the PRV instruction to store the present value in a chosen location.The manual says the current PV is stored in A271, but I can’t get a readout there. Apparently the only way to read it is through this instruction.Does anyone know if there is an equivalent to the PRV instruction for Structured text? or another way perhaps? Again, when I check the actual memory adress, there’s no value there withouth the use of the PRV instr.
  23. cx programmer

      I have a problem with CP1H-EX40DT-D-SC unable to connect to cx progrmmer 9.6 in libary, there is no have cpu type. is there a solution in this forum terimakasih
  24. s7 214

    Dear All ,  I need to connect two encoder to S7 214 PLC  any one have information about 1-If it applicable to connect encoder  2-How adjust it on S/W and H/W to work good  thanks in advance
  25. CP1H Communication HElp

    Hi - I had an old lab PC running software made in CX-Supervisor to control equipment attached to a CP1H (I did not make the software).  The CP1H connects to the PC with a RS232.  The PC running the software died, but I have the files copied onto a new PC.  I have installed the latest CX-Supervisor software, when I open my program file from the old PC I have a communication error (attached).  Where do I setup the new PC to communicate with the CP1H? Thank you