Search the Community

Showing results for tags 'communication error'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Found 301 results

  1. Hi, How can I communicate Codesys and Intouch. Can you help me.
  2. i just got my NX1p2-1140DT controller with a R88D-KN04-ECT. i conneted every thing and directy got the 87 message on the display. i found out dat is becous wrong wiring I dont have the I/o cable incallt with omron they where saying that i don't need it and i can controll the motor controller full via ethercat. i already try to change to pdo mapping. what am i doing wrong? can someone help me? is it indeed true i dont need the i/o cable  thanks in advance for helping.
  3. Hi all,  I am trying to modify the date and time of several PLCs from other PLC. Them are all CJ2M, and they are all in the same ethernet network (192.168.100.xx) and in the same FINS network (#1). I am doing it using the FINS command 07 02 ("CLOCK WRITE") with the CMND2 instruction. It is not working entirely: the clock time is being modified at the specified node; however, I do not get the FINS response (expected 07 02 00 00). If I modify the number of retries of the CMND2, the command is repeated all the specified retries though the clock was already written on the first try.  The D+0 and D+1 (response channels) are always #0; nevertheless, the I+1 ("Communication Completion Code" channel) allways receives #205. Acording to the manuals, this code is for "Response Timeout". I have tested it with 10 retries and with 10.0 seconds of monitoring response time, but it is working in the same way: the clock is modified fast enough, but I am not getting the FINS Response and the I+0.00 bit is ON after 100 seconds...  I have been also doing tests with the OMRON's Etherway Software, sending the same FINS command, and here I am getting the response properly. (???) I would say the FINS network was set-up correctly. All the PLC were set in network #1 with Cx-Integrator. In fact, they are currently sharing several channels using the SEND command on this network #1. I don't know what I am not doing right... Any idea?  The ladder is attached as .cxp and as .png. Thanks a lot.  Best regards.  CLOCK_WRITE.cxp
  4. Array A INT[32] Array Index B INT Destination C INT I am trying to move an Array (A) Element (A[2]) using a symbol (B) in ladder into a destination symbol (C) C = A [ B ] Result: ERROR: Array Index of Operand 1 out of range at rung 1 ( 6, 0 ).  The documentation suggests that it is possible, but I am unsure if there is something I am doing incorrectly. Note* Fixed indexing works with no errors Is there another method to accomplish this?   PLC : CJ2M CPU31 CX- Programmer: Verion 9.74 Update 1: If I go online to the PLC It does look like the array look up is working. Is the issue with the mov block? Update 2: I changed the memory locations which has caused a different error to appear. This error is clearer but does not explain the manual excerpt I posted further up ERROR: Only the constant can be specified for the index of the array.  at rung 5 ( 6, 0 ).  Update 3: Solution 1 I managed to hack together a proof of concept using pointers and indirect offsets  Update 4: Solution 2 For some strange reason things work as expected inside of the function blocks so I made one where the array is In-Out and with an input and output respectively. Note* External reference to pointers inside of the function block produced an error. Function block Logic     Update 5: Solution 3 Now I feel like I am going crazy, I tried just the original code again and it works... I have no idea why and if it was not for all the documentation I would be lost as to why it works now... Update 6: Conclusion It seems to have array indexing work the array index must exist in the D Memory Block. The reason it did not work above is because I somehow had a MOVR block when I tested after moving all the variables to the D Memory Block. I hope this journey helps someone else :)
  5. Error **03 Special Parameter Error

    Hello I have a problem whit PLC mitsubishi FX3U thernet communication, we have a module  FX3u-ENET-ADP. and we have the error "**03 Special Parameter Error".  
  6. CP1W TS001

    Hai, I have problem with my CP1W TS001, suddenly reading result always #7FFE.  i use CP1E-N60 and 2 expansion module, AD041 and TS001. I put TS001 after AD041 then my program code as follows : mov #8051 105 mov 7 D20 mov 8 D22 the reasult at D20 & D22 always #7FFE could someone help me to solve this problem?
  7. Communciation Error plc with PC

    Dear All,   Am new to Siemens plc. i have CPU 315-2DP. but when i try to communicate with pc through simatic Manager . i receive the Following Error. " Unable to establish a connection with module ." Sometimes it gives error as attachments. kindly help me out.    Through control panel , i have selected the PG / PC interface to S7 Online with PC adapter Auto 1.   Kindly help me out. you will be a life savoir.   Regards, ZUbair
  8. I am trying to POST API to a meter in Maximo using a socket in a 5069-L320 controller. I am able to successfully create and open the socket. The write and read instructions get the DN bit but I do not see the meter updating in Maximo. I was able POST successfully using Postman, so I know I am sending the correct information. Do I need to be formatting the POST differently? I'm not getting errors so don't have a direction to go from here. (I will fix the obvious username and password vulnerability, one step at a time) Thanks
  9. Hello. I am writing a function block and i am getting the following error: ERROR: STRING type or an Input Output variable is not supported by the PLC of this unit version. Check the unit version in program check options. When i try to remove the string i get error: instruction is not available for current plc Is there somewhere where i can see which instructions i can use? Or is it not the string or one of my in or outputs I am doing something wrong with?   Kind regards, Ralf  
  10. Q02CPU Error 2200

    Hi All; Trying to make a backup of a Q02CPU.  Used GXWorks2 to get the program and parameter files from the working CPU.  The System is on an 8-slot rack with mixed IO including a ProfiBus module (QJ71). Got a new CPU, powered down the system and installed it after setting the DIP switches the same as the working one (2 and 3 both on, others off). Power on system. Download the program and parameters to the unit, have the ERR LED blinking and the CPU will not run.  PLC Diagnostics show this 2200 error, which when I look it up in the book starts talking about 'drives', which I find out have something to do with the DIP switches.  The combination of switches 2 and 3 indicate the parameters are to be stored in Standard ROM (Drive 4), but apparently this is not happening when I do the download of the program and parameters.   Is there a specific procedure I need to follow to put the parameters into Standard ROM (Drive 4)? Or, did I get a replacement CPU that is either A)Bad or B)does not have this Standard ROM? Or...?   Any assistance would be appreciated.   CPRenaud
  11. Hi all,I'm completely new to ASCII and trying to figure out where I'm going wrong here.Application: I need to send 2d barcode data to a KGK Jet model CCS3000L Inkjet printer. Only protocol possibility is ASCII. PLC I have is a Micro850, and the only port option for ASCII is the serial port. I modified one end of a 2707-NC11 cable to connect PLC TxD to printer RxD, PLC RxD to Printer TxD, and PLC SG to Printer SG. I jumpered CTS and RTS at the printer connector, and the 2707 cable I'm using doesn't have wires on the Micro850 CTS or RTS pins.Printer company verified that I can just jumper RTS and CTS on their side and not connect their DTR and DSR pins (since I'm not using hardware handshaking). I don't really need any flow control for the application ( I don't think...again, ASCII noob here).Do the CTS and RTS on the PLC side need to be jumpered? Does the DCD pin need to be jumpered or connected to something if I'm not using handshaking?I downloaded the Micro800 ASCII read and write functions and function blocks from Rockwell library, and they seem to be working, except that I keep getting ABL error id "7". This error states, "Cannot complete ASCII send or receive because channel configuration has been shut down using the channel configuration dialog box." I have the serial port enabled and configured to ASCII, no handshaking, baud 9600 same as printer, no parity check, 1 stop bit, character length of 8.Any help in pointing out what I'm doing wrong or things to try would be greatly appreciated!   ASCII_TEST.ccwsln
  12. Trying to log into NA HMI, NA5-7U001B  Direct, using USB or Ethernet.  All attempts failed .. tho, it was easy to log into the NJ Controller, direct, with USB or Ethernet using the same PC. Then a window popped up.. saying the firmware needed updating in the HMI, and suggested launching the "update" from the same window... Then, after a few minutes.  a "update failed" was displayed on the window.. and the HMI screen changed to this: ..and the green LED went RED ... aaaaagh!   HMI no longer works... any idea why this happened, or the failure to log in happened.. or, what it will take to fix it? Please tell me it was something Omron did .... Thanks Much, Regards, ,Michael PS:  additional info..  I was using Sysmac Studio Version 1.1 .. because I could log in to the CPU (USB and Ethernet) and not the HMI.. I changed to another PC with Sysmac Studio Version 1.17 .. Now I was only able to log into the CPU with Ethernet.. USB login failed. .. and, so did any attempt to log in to the HMI (USB or Ethernet) It looks like if you use a new version of Sysmac.. better not have a device with  "old firmware" ..  I think it was the V1.17 that presented the window suggesting the Firmware Update ...  sigh!
  13. CP1E won't connect or run program

    Hi there! Today a CP1E-E10DR-D suddenly stopped working. RUN led was off and I couldn't connect to it via USB getting this error: "Selected port does not exist. Select proper port number from Change PLC dialog and press OK button", and automatic online function didn't work as well(it's not a cable/driver problem since I successfully connected to a CJ2 CPU using same cable and PC). Since I also tried to connect with the CPU outside the control cabinet with no success, I asume there is something wrong at hardware level.  My question is, have you ever faced something like this? My plan is to try to revive it somehow (maybe trying to locate any defective component in the PCBs or something). So I was just wondering if you have any advice in order to achieve it.  Thanks in advance!
  14. Hmi modbus TCP/IP device communication

    Hi all; I have Delta DOP110 IS hmi and i have a modbus tcp device. I want to communicate hmi and device with modbus tcp/ip but i didnt understand device's register address. For example, input bytes 0,1 analogue control word, What is the register address? 40.000 or 40.001 can you help me ?  
  15. Omron NB Software

    I am facing the error while compiling the program , there is only 1 error , but not able to figure what is the actual error. Please suggest and support.
  16. Q-Series - Operation Error 4100

    Hi guys. I found error on PLC and from PLC diagnostic I found this Operation Error 4100 as per attach picture. FYI, there is no SD card mount onto this PLC. I wonder what is ATA card. This error wont affect the operation. Any advise on what to check?   This ladder is pop up when I clicked, error jump.   Thanks.
  17. Hello, has anyone noticed that plenty (not all) forum posts are changed to quotes from TWControls? What is happening here?  Hopefully only a momentary breakdown  
  18. Hi guys. I was getting Coordinates error popped up everytime I tried to go the page. If click OK, everything is normal and can operate as usual. Just wondering how to eliminate and what causing this error. Thanks!  
  19. j’ai un probléme au niveau Unité DRM21 via Network Device Net et aussi l’un des paramétré(température, Résistivité) qui n’est pas affiché dans la partie supervision(Remote), mais il s’affiche localement.
  20. HOSTLink read multiple DMs

      Hello,    I am using Hostlink protocol to read data from PLC units. for example @00RD22220001..., will return DM2222's value. But I want to know, if I could read multiple DM values at the same time. for example: DM2222, DM3000, DM4000, reading these DMs with one communication. Please note that these are not continuous DM areas. I know a sequence of DMs can be read by specifying starting address and count.   Many thanks in advance.   Ting              
  21. Here is a post that we recently completed on the Automation Direct USB to RS485 Adapter.  The USB-485M is a 2-wire USB to RS-485 serial communication adapter for RS485 use. It does not require an external power supply or complicated configuration. It has a Type A (plug) USB connector for the computer side and a universal female RJ45/RJ12 modular connector. This will accept RJ12 and RJ45 plugs.  The USB-485M supports multiple baud rates and is USB V2.0 Compliant. Read the rest of the post... YouTube Video on the installation and communication to a Solo Process Temperature Controller via Modbus RTU. https://www.youtube.com/watch?v=aWE05ZNZNXw Let me know what you think, Garry www.accautomation.ca  
  22. Panasonic FPG-C32T2H - E45

    Hi, I have PLC with Error E45. I am not very familiar with Panasonic and in manual, explanation is not very clear for me. Any help appreciated    
  23. RS485 COmmunication

    Hi all, i am looking for a solution to connect 7 plc with a single scada. is it possible according to my topology diagram ?   Kindly make me suggestion and if you have any information regarding the solution then share .   Thanks in advance. 
  24. Good Morning,   My name is Joseph Rhodes, I work as an electronic technician for the City of Tuscaloosa at the wastewater treatment plant. I work to keep the plant up and running as well as 64 lift stations spread out around Tuscaloosa, Alabama. A majority of our lift stations utilize Verizon Cell Modems, RV50s to be exact. It's rather easy connecting remotely to these lift stations as I can configure a driver as an ethernet / ip driver then associate an IP of that lift station (ex. 10.181.3.104 is lift station 104, 10.181.3.105 is lift station 105, etc). However, for the lift stations that do not utilize cell modems. We use GE MDS 9710 and 9810 radios. It is these lift stations that I have yet to figure out a way to connect remotely to the LS RTU PLC. All of our lift stations use Allen Bradley MicroLogix 1200s or 1400s. These lift stations that use the MDS radios communicate information to water tanks then that information is sent back through other channels. I was wondering is there a way to associate these lift stations on RSLinx that use GE MDS radios ?   
  25. Hi. I use the email block on few of our NJ101-9020 controllers to send out daily reports or any status updates. Recently the PLC's started an unknown issue and fails to send email out anymore. I use the Mail_Send function block from Omron to send emails. The only Error ID i can get is 2005, with status being "Connection to SMTP" failed. Looking at the troubleshooting guide, i cannot find anything to do with error id 2005, in fact its missing. There is 2004 and 2006 but no 2005. I've tried all the obvious thing like, power cycle, redownload the whole project, create a new instance of Mail_Send function block etc. Nothing seems to have fixed this unknown issue. Our IT department did a full check on their side and nothing seems to be out of order. I can still remote into the PLC, so i dont know what exactly is the problem. Has anyone came across this error ID before? Any ideas why this might have been happening? It was working well until few weeks ago and nothing changed and this suddenly started. Any input is really appreciated. Thank you.