Search the Community

Showing results for tags 'b&r automation studio'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Found 190 results

  1. Kinetix 5500 lost power

    Hello all,    I have 3 kinetix 5500 drives connected in series but some how the 3rd drive lost power. all the fuses in the cabinet look good. nothing else is tripped either.    any advice is appreciated.  thank you   
  2. Hello, I am working on a project currently that uses a windows application on a PC to communicate with an NX1P2 controller to read and write variables data. I found a course on Udemy which has a Visual Studio project with OMRON DLLs that are used for these communications. I confirmed with OMRON that they do have official DLLs for this, but the technical support guy has told me he is trying to find them himself.   I have attached a screenshot of the DLL references.  I am really looking for the DLL libraries, aswell as the documentation on their functionality to I can use them to communicate. Any help would be greatly appreciated!  
  3. Unable to delete a screen

    Hello AB professionals, I am using FactoryTalk View Studio v11. I am basing on an old project to build my application. I restored the project from a .mer file. I deleted or renamed some old screens, saved and closed the project. But when I open the project next time the screens I deleted still show up. When I click on it it will show an error message "Component does not exist".  In the FactoryTalk ME application, I right click a screen name on the left tree under the Graphics, and then click "Delete" or "Remove", the display would disappear at that time. But it persists on coming back next time I open the project. If you know the solution to resolve please reply. It is much appreciated.   Thank you. Lei
  4. I'm working on a program where I manipulate REAL numbers in Sysmac studio using an NX1029020 PLC. My problem is I am new to automation and I don´t know how to display those numbers when connecting to an NB HMI. I´m trying to send the data to a bar picture and a number display. My question is which AT Specification Attribute should I assign to my variables in Sysmac Studio and their corresponding Area in NB-Designer? I tried using the DM area but it didn't show numbers on the displays, only shows *****. Should I convert my real variables in Sysmac first? Or how can I keep decimal numbers and then display them? My current configuration in Sysmac: Name Data type AT Network publish ST1 REAL %D5 Publish Only ST2 REAL %D3 Publish Only My current configuration in NB-Designer Bar Picture Addr. Type D Address 3 Code type BIN Number Display Addr. Type D Address 3 Code type BIN Data type Float Integer 4 Decimal 2
  5. Hi all, Can i rename the master of numbered project (#1, #2... create used "save as new number" function)? Actually i can only open preferences window of the last number, and only edit Author and Comment. If i edit one on these two it only change it on the last number. Are there a method to change preferences for the "master" project and all the sub-number? If i would rename a project now i have to save as different project, and loose basic version control that numbered projetc provide (enought for me) and generate more confusion. In the single project i have no problem edit all Preferences include name. Versione: Sysmac Studio Standard Edition 1.47 Thanks, Andrea.  
  6. I'm looking for a serial device server, which will be a cheaper equivalent of moxa. Does anyone recommend anything?
  7. Currently have NX PLC setup as an OPC UA server and an OPC client setup and communicating.  The issue is only tags that do not have a Data Type are showing up in the OPC client.  I have 2 separate OPC softwares connected to this plc through OPC UA and both are having same issue.  If I setup the OPC as a polling service, then all the tags show up as expected.  Does anyone know if this is a known issue with Omron and their OPC UA server, or is there something that I am doing incorrectly (possibly a setting within Omron that I am not aware of)?
  8. Hello all,   I am working on a batch computer for a concrete mixer, and the computer that was running the plant before has stopped functioning. It was an old PC running MS DOS. The code is encrypted and replacing it is not a cost effective option.   I therefore am looking into using a PLC to control this batch plant. I have a setup that was in progress by another employee who no longer works for us, it is a CLICK PLC from Automation Direct, and it is supposed to be paired with a EA9 T8CL touch screen HMI from the same company. I would like some advice on just some basics, I would greatly appreciate some input.   I essentially only have one input, and that is an analog scale, 0-20mA input. I have digital outputs for sand, gravel, cement powder, and a water meter for adding water to the mixture. I have one final output, an additive for reducing the required water in the concrete.   What I would like to create is a program that when it is told to start, looks at the scale, and if the scale is less than say 100 pounds, opens sand until it hits 1700 pounds (as an example), then turns it off. Then it turns on the gravel and adds that for another 1700 (again for example, all these are variable), turning the gravel off after. Next the cement, and so on. I don’t need someone to write the program for me, but can someone point me in the right direction on using an analog input to turn digital outputs on and off? Again, your help would be greatly appreciated.   Thanks for taking the time to read this long post.
  9. OS: Windows 7 on VMware virtual machine. Sysmac Studio V 1.13. What works: Ping to PLC. Sysmac Studio -> Controller -> Controller Communications -> Ethernet via hub -> Test -> "OK". What doesn't work: Starting with new project for NX701-1600 (correct PLC): Sysmac Studio -> Controller -> Online. -> Controller -> Transfer ... -> From Controller. The task seems to run to about 90% before stopping with the error:  I can't find any reference to this error in the manuals. Has anyone got any suggestions to fix this?   Many thanks.
  10. Hello! I have been working with a Factory Talk Studio V8.0 and my computer was crashed, "blue screen". After this, I can not open my panel project anymore, I only get information Failed to open factory talk private directory for the application. How to save my project?  
  11. I hear a lot of people talking about the annoyance of price estimates (meaning they don't get a clear, transparent price from the beginning) and the costly engineering that seems to never end. Do you think that a step-by-step, clear process and course of action from A to Z would be beneficial for companies? And I'm not talking here about SCADA software, like Ignition. I'm talking about using Ignition to build and implement a fully working SCADA solution, customized to your company BUT you know exactly the price and the methods/processes that will be used (it's a replicable framework to get similar results for multiple companies - and the results would be a SCADA solution without the headaches of the unknown prices and engineering characteristics). Basically, a clear project-based approach rather than an hourly approach where things can get confusing.    Do you think the industrial space could use something like that?
  12. View File Sysmac Studio Simple PID Example A simple test program and starting values for the PIDAT instruction in Sysmac Studio. Simply run the simulator (Simulation-> Run) and toggle the Test_PID bit. Simulated feedback will allow the loop to operate normally. The setpoint can be adjusted by modifying the PID_SP variable. There is a pre-programmed data trace that traces the SP, MV, and PV. To use the data trace navigate to DataTrace0 and start the trace, flip the Test_PID bit true and the trace will log 10k samples. Submitter photovoltaic Submitted 02/13/22 Category PLC Sample Code
  13. Sysmac Studio Simple PID Example

    Version 1.0.0

    17 downloads

    A simple test program and starting values for the PIDAT instruction in Sysmac Studio. Simply run the simulator (Simulation-> Run) and toggle the Test_PID bit. Simulated feedback will allow the loop to operate normally. The setpoint can be adjusted by modifying the PID_SP variable. There is a pre-programmed data trace that traces the SP, MV, and PV. To use the data trace navigate to DataTrace0 and start the trace, flip the Test_PID bit true and the trace will log 10k samples.
  14. The summary of the issue is when attempting to update any hardware file or technology package, the package will hang up in the “copy setup” status. This state will remain indefinitely – no further progress is made past this point. These are the steps that I have used to troubleshoot this thus far: I always run Automation Studio as an administrator I have redownloaded the program a couple of times, storing the downloaded ~8 GB package in C:/temp Temp files are cleared prior to launching Automation Studio I have tested different internet connections. With and without going through the company VPN. Launching the package via local and internet connection to isolate if it is a TCP port blocking issue. At this point I’m curious if there’s different registry key changes which allow for deleting files from temporary directories… but that’s just a theory. I've attached some screenshots.    What the function of the copy setup state? How can I progress past this state?    I'll keep banging on the keyboard to figure this one out but if there is a good Samaritan out there on the web it would be MUCH APPRECIATED!
  15. I am new to automation systems and devices and I just want to know how to connect two HMI's (each one would control different things) to one PLC using Sysmac Studio and NB-Designer via Ethernet. The model of the PLC is NX1029020 and the HMI's are one NB10W-TW01B and an NB7W-TW01B. I searched for info about this topic online but I couldn't find anything that worked for me, I saw an article from OMRON where they connect two NB's to the CP series, but in my case, NB designer doesn't allow me to insert more than one HMI in the same project, I also found something similar on a youtube video that gave me an idea about how to connect multiple HMIs exporting the pks file and importing it to another HMI project but I still can´t figure out how to add both to my PLC. I would thank you a lot if you could help me with this because I know it's not a rare implementation, just I haven´t found the right way to do it. I also leave the links to the Omron article and the youtube video I found. https://www.myomron.com/index.php?action=kb&article=1554 https://www.youtube.com/watch?v=rXx5lut7G9I
  16. Hi, Could anyone help me out on how to extract the digits present in a string in sysmac studio... Thanks in advance !!!
  17. Hi, I have quite a noobie question. I want to create a function block to do some simple operations on 2 variables. Both variables are In/Outs (see picture attached). How can I make this function accept variables regardless of the data type? Given these is just simple math I am able to use the same instructions in REAL, INT, UINT, etc. But, the function block only lets me assign one Data Type to the In/Out variables.
  18. Good day everybody!    I am having issues troubleshooting a machine which is controlled by a VIPA PLC. I must admit that I am not very knowledgeable with this brand so I am a bit hesitant to touch anything. From the machine's supplier I got a .wld file which I could load into an SD card and load into the VIPA PLC itself through a Master Reset procedure. Still, our issue persists so I was wondering if I could somehow extract this .wld file into Speed7 Studio (or another program) to visualize it and try to troubleshoot the issue. Or in another case, if there was a way to directly read the currently loaded program from the PLC.    As I said, I had never worked with this brand before so I am being a little overly cautious with what I touch in this PLC.    Thanks for your help! 
  19. Productivity 2000

    Has anyone had the opportunity to work with Automation Direct's new "Productivity 2000" PLC? I have personally had the opportunity to use their "Click" PLCs which are, as advertised, very cheap, but effective. These little plcs are similar to Allen Bradley's micrologix line of processors, but definitely are not as well made. The software is free (a nice bonus) but definitely lack in features that you would get from the Rockwell folks. Still, for a simply job on a tight budget they work well. As for the new Productivity line, it looks (from a software side only) like many of the features you would find on the Contrologix and Compactlogix systems are now available. The user interface looks relatively clean and easy to use (Coming from an Allen Bradley background). So...any thoughts on the Productivity 2000?
  20. Is it possible to give a physical proximity switch or photo eye input a value to change a vfd's speed. Speed up or slow down when it has been triggered. 
  21. connect encoder to nx1p2

    hi everyone i have a question about nx ec0122 i connected an encoder to ec0122. now i want creat a programm for read the pulse and reset pulse. Then write a program to measure the length of a roll. How should I do this? Thank you for your help
  22. I encountered an issue that technical support was not exactly able to help me out with, and I wanted to share what I learned here for the next guy. Specifications: Omron NA5 HMI v1.10 connected to NJ PLC via Ethernet Issue: Made a change to a screen where I copied and pasted a button from a different screen.  The screen where the button was copied to had some sort of issue, but it was still able to compile and transfer to the HMI.  It worked for several days until the HMI was power cycled by maintenance, and it was stuck in a black loading screen saying "Initialising Variable System" with a scrolling wheel and green LED on the HMI panel.  It stayed in this loop indefinitely.  The HMI still had a ping, could be connected to from Sysmac Studio, and could be transferred to and from.  Troubleshooting section of the HMI mentions something about initializing failure with a red LED which required a system recovery, but no description for this state. Troubleshooting: Power cycled the HMI, but this resulted it getting stuck back in the same loop. Connected with Sysmac Studio with most recent backup and transferred from the HMI to get the current program.  Before transferring in this synchronize step, I could see a page that was on the target device that wasn't in the source.  I'm not exactly sure how it got there as it wasn't in my backup, but I had green in the comparison list when I shouldn't have.   Reverted program changes, downloaded to the HMI, and power cycled.  Still stuck in black screen with same message. After several other modifications, I eventually had a heavily stripped down program of the backup and downloaded to HMI.  Power cycled with same message. Resolution: In Sysmac Studio under HMI View, select HMI from ribbon, select Clear All Memory, confirm the target device, and select OK.  Once this has factory reset, I made sure the IP address was configured as necessary, connected, transferred backup, and all is well with the HMI now.  Even after loading a backup from several months ago, I could not clear this issue without a factory reset. Hope this helps!
  23. I have 23 Micrologix 1400s and I want to take the same register, N100:99, out of each one and put in a single array in a CompactLogix L18ER. From what I have tried, it only seems like I can only map a range of integers, N100:77-N100:100, to the array and not an individual register to a particular element. (For example, mapping N100:99 from machine 16 to Selected_Model[15]) Can you map to individual elements in an array? If so, are there any instructions on how to do so? Thank you in advance for reading my post!
  24. GLX Safety Question

    So im looking for recommendations on a safety PLC application, and I'd like some advice. So the addiction is zero motion detection, were using a 5069-L306ERMS2, 5069-IB8S, 5069-OBV8S. What id like to know if its feasible and safe. Can a zero speed detection code be written and safe in a PLC? I mean you can buy a zero speed detection safety relay, and two generic sensors , one PNP, and one NPN, and its just watching the pulses to happen in a predetermined manor and that both transition in the correct manor and that they both stop. So why or why not do this in a PLC? Any advice on how to do it, and considerations or advice?  What are peoples thoughts and or advice?
  25. Hello Guys, I am using a nx102-9000 CPU and trying to communicate explicitly to a Telsonic Mag Generator. I have done this on a CJ2M & an Allen Bradley Processor successfully before but am struggling with sysmac. I will attach some screen shots of the AB message instruction because it is much more simple then the CJ2M (required pretty much a full function block made). If anyone wants to see the CJ2M block let me know. I am working right from the sysmac manual using the CIP OPEN, READ, SEND, & CLOSE. Once it is working I will write as well.  I am getting stuck right on the first part "CIP OPEN" I am using a route of '02\10.203.21.40' I am unsure what the 02\ means. I am just copying it from the example. The IP Is correct. Below is the picture of my 1C05 Error. Which in the manual is confusing because they have a 1C error and an 05 error separately.  Another question (once i can open a connection) is in the CIPRead the 'srcdat' I am not really sure what this is? Everything i've used before is an instance number, class, and attribute number (used in the CIPSend Logic From Allen Bradley MSG Instruction & Current Sysmac logic shown in pictures as well. Please let me know if you have any suggestions or need any additional information. Thanks, Kevin