Search the Community

Showing results for tags 'System Date/Time'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Found 87 results

  1. GX Works 3

    Hi everybody! Recently I've got problem with installation of GXW3 on my PC There is a message "Any of the MELSOFT products or other software may not be installed normally. Please restart computer before installing this product" during installation. Of course I restarted PC)), delete all Melsoft products from my PC,  please i need your Help here ver 2.7 IQWORKS  I have Windows 10 64bit .  
  2. Hello. I'm using OMRON NB Display Did someone already made time adjustment from NB to OMRON PLC? What I'm trying to do is to adjust time  from HMI to PLC. Since now I have done time sync from PLC to HMI using timer and data transfer. Now I would like to adjust current time in PLC using NB HMI. I know how to do it, but I'm some kind a lazy person. In our country there is a saying: " Don't reinvent things that already exists" Thanks.   BR, Andrej.
  3. Real world simulator

    When we simulate a plc program we have to manually input the changes in input(like magnetic reed switch) For example when a cylinder goes from up to down reed turn OFF and reed down turns ON Is there any program available where we can define such things that will turn on and off during the process automatically.
  4. Good morning experts, is there any way to create two different Alarm display (System)? So, one with collection mode historical and one with only current alarm? Many thanks in advance
  5. Hi I have encountered a problem with CX-integrator. I'm not able to open the program. The following message appears:  System error. Save the date and close the application.  (Error code 0035) I have tried to reinstall the entire CX-one packet.  Any ideas?  Regards MBD
  6. Hey guys,   I know this is a topic that has been discussed before, but I am having trouble finding exactly what I am looking for.. I want to know the most efficient way to record data from my PLC to an Excel file on my PC. I want this to be done without the use of the PLC's webserver.  Specifically I am trying to record vfd speed every 10seconds with a time and date stamp. How can I do this?   Thanks, James  
  7. Hi All, I just take over a project which involve accurate positioning and movement up to 0.010mm(around 10 microns) of a servo motor. I found out that my motor always move to an incorrect position. Let's say I want it to move to absolute position of 5.210mm, I found out that it may move more till 5.235 or move less 5.190(something like that). So i start to check if I'm outputting correct pulse. Using CX-Drive, I connect to the driver then i found out that the pulse is correct and consistent(for example i use my pulse per revolution and pitch to determine how many pulses) Currently I'm using an incremental encoder and servo motor and my PLC cycle time is around 12 ms and my servo move at a speed of 0.66mm/s. So I was wondering if my PLC scan time will affect my accuracy in moving ?? I'm using a CJ2M PLC with CJ1W-NC413 pulse card , incremental encoder and a servo motor. I want to make sure is not software limitation or anything wrong on software side before I bring it to my mechanical team   Appreciate all inputs here and thanks!
  8. Hello, everyone I have to query a SICK distance sensor from an L26CPU via the onboard Ethernet interface. I have created a simple protocol which I start with the function block SP_ECPRTCL. Unfortunately it takes at least 25ms until the next telegram is started. The sensor responds within approx. 1.5ms. Does anyone know whether that works faster or is that a limitation when using the predefined protocols? Sensor manual:  OD5000, 8021391 (sick.com)  (Chapter 7.4) I am grateful for all the hints. Thanks and regards Dave SICK_Protocol.tpc Messaufbau_vTest.gxw
  9. Good Afternoon, I am wanting to do two things with and ORMON PLC and HMI with CX-Programmer and NB-Designer. 1. I want to display the current time from PLC on HMI with the real time clock. 2. I want to be able to enter a time on the HMI which will be compared to the PLC time and will stop a process when when the entered time is equal to the actual PLC time.  If I can have some help with this that would be a great help. Thanks,
  10. I am building a redundant system using S7-1515R-2 CPU with TIA V16 version. Creating the hardware, there is not possible to insert any other card to the rack. Even power modules (PM) can not be inserted to the rack. How should I make the power feeding to the CPU. Should I use two power modules/devices or only one. How can I insert IO-cards to the system, is the only possibility to use Profinet IM-cards. In this system I am connecting the bus to the ring and using S2.  
  11. Is there any way to monitor ethernet/ip bus, states or faults and to make an alarm to the panel alarmlist. I am using IO-stations (1734-AENTR) and I would like to monitor somehow the system. I feel that reading the slot status of the 1734-AENTR device is not enough, because it is not possible to monitor all the cards in a slot. How to get alarm on a screen if I lose any station on the ethernet/ip bus?
  12. So I have a plc program where most of the outputs are based on a counter that goes from 0 to 1000. The counter speed is adjustable and is generally set to run through a full cycle (count from 0 to 1000) anywhere between 0.5 to 2 seconds. The problem is, when I try to energize an output by using an EQU instruction, it will almost always skip the count because the scan time is not fast enough. I've been using a LIM instruction which has been working, but its not quite as accurate as it needs to be. I switched the counter logic to be continuous to try to make it faster which made it almost perfectly accurate... But only in the continuous task; it made the other periodic task significantly less accurate. I was curious if any of you had any tips on how to remedy this or just general help. I am still relatively new to PLCs and ladder logic so any advice would be awesome, Thanks in advance! Edit: The purpose of the counter is to cycle through from 0 to 1000 over and over again. My outputs actuate during a certain interval within this cycle (For example I would say actuate from 300 to 800 and it would stop and end once it hit those values via an EQU or LIM instruction). I wrote the logic as follows: First I calculate how many cycles per minute I want to perform, using that value I calculate how many times I want to increment my counter per millisecond. Then a timer is given a preset of the total cycle time. While that timer is running I continuously multiply the timer's accumulated value by the "cycle count per millisecond" that I calculated earlier; the resulting value is the current count that all my outputs are based on... Hopefully that makes sense, I know it's not the best but I could not figure out a better way of doing it and I know rounding is certainly making the accuracy worse. My hardware is: Allen Bradely PLC (5069 l306erms2), 5069-ob16, 5069-ib16, and a Kinetix 5500s2 Driver for my motor(s)
  13. SoMachine Motion Logic Builder V4.31. Can anyone guide me on how to read the execution time of the STL logic in my application? Thanks.
  14. DATE Instruction for CP PLCs View File Sample code to set the RTC on a CP PLC. Individual sections can be enabled/disabled. Submitter photovoltaic Submitted 03/12/21 Category PLC Sample Code
  15. DATE Instruction for CP PLCs

    Version 1.0.0

    66 downloads

    Sample code to set the RTC on a CP PLC. Individual sections can be enabled/disabled.
  16. Hi Everyone,   I have  NT31C-ST142-V2 and it has a prompt of "System Program not exist or incorrect." I am trying to transfer via NT Series System Installer but I am getting a time-out error. I have Xm2S-09 serial cable with ATEN serial-to-USB cable.I know it is not broken since I can still Upload/download on a CJ2 PLC. I just want to know what other things I can do upload a systemprogram. I have seen a comment on this site that he remove the battery then tried to upload again.   NT is almost 15 years old. I have a back-up program.   I can't seem to upload by this time for pictures of theH MI and the screenshots of software .
  17. The only thing I can find in help re using the buzzer is to use a multi function button. I want to use the buzzer as an alarm buzzer and turn on $SB13 or $SB14 from a bit in the PLC. Can anyone help please?
  18. I'm working to fix/improve the functioning of a program running on an a PLC5/40E.  I think high Scan Times are a big problem with this current program.  ((Backstory:  someone added some quasi motion control, and it sort of worked for a while.  Now that it's broken, the operators of this machine want it back. ))  I'll keep my question simple, PLC5's are new to me: There are 36 rungs with CPT instructions as the sole output, a third of these instruction are executed every scan.  I'm going to replace them with MOV instructions. My question is, is there any sneaky PLC5 reason to do a CPT instead of a MOV?  Is there a better way to do this? The CPT instructions that execute move integer values to a data file used by the HMI to control the coloration of touchscreen buttons.   Thank you for your time. PS: I'm new-ish to this forum, please feel free to let me know if my question was asked correctly or not.
  19. The CC-Link system on a machine has been intermittently dropping out.  Normally the Link Scan Time runs at a solid 87ms.  When the system "drops out", the link scan time will increase.  Sometimes double, triple, or go up 10x. It happens when the machine is running or when it sits idle. There are 33 stations on the network.  The same stations do not always fault but sometimes all of the stations will fault at once (as seen in the attachment pictures.) We have changed the main QJ61BT11N, the processor, the Q62N power supply, the main backplane (base unit), all cards on the main backplane.  Is it possible for one station or one of the cables to create a network wide problem?  Any ideas thrown at us would be appreciated. 
  20. friends, forgive me for my english.  I have a problem.  omron nt620c panel cannot access the system menu.  I reinstalled the system program through NT-SYSTEM INSTALLER.  after which I get the message: no direct information is set !!!  please use the support tool to set the pt control area and the pt notify area.  go to the system menu does not work.  I swing the corners of the screen as described in the manual.  from a video from YouTube I realized that there should be a message connecting to host
  21. I am trying to display the time from an Accumulation timer. Using a data display object I am able to see the time in the following format 00:00:00.0000000. Is there a way to format the time without the decimal seconds I just want to see 00:00:00 (hours:minutes:seconds)
  22. Setting the NB Clock based on the NJ NX Clock View File This document details the updating of the clock on the NB based on the clock in a Sysmac Controller. Submitter Michael Walsh Submitted 05/14/20 Category Tutorials and Quickstarts
  23. Version 1.0.0

    50 downloads

    This document details the updating of the clock on the NB based on the clock in a Sysmac Controller.
  24. EA3 Micro Panel

    I want to display the current time of day on mt Micro HMI, EA3-T6CL. Is there a function for this? How can I get the TOD to display?
  25. So I have done quite a bit of googling and i even reached out to our integrator but i am having a nuisance fault of "Watchdog Fault" Caused by periodic task overlap. The task is scheduled to start again before it is finished. I added all of the Programs in this task MAX scan time and it only came out to 102 ms. the task is scheduled for every 100 ms. The watchdog is set at 500 ms. The task is currently running at 146-148 ms and i confirmed this using a TON instruction at the end of the task followed by a reset. What can i do to get this down?? What would be the best practice? Move programs into another task? Make the task continuous? What would happen if i did make it continuous? I tried setting the task to 150 ms and the controller DID NOT like that. I was barely able to get back on line with it to change it back to 100 ms. CPU usage is at 91% and this task accounts for around 50% of that. Thank you all in advance for your help.