Search the Community

Showing results for tags 'RSLogix 5000 Trial demo v17'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Found 109 results

  1. This is my first post so let me know if there is anything wrong with my post. I am learning Studio 5000 right now for an internship and created a simple project involving a pushbutton and some LEDs. Now I am trying to create an HMI for it in View Designer. My problem now is that I cannot establish a connection to the project because I do not have a physical HMI connected to my plc (Logix 5380). I can't find any way to emulate an HMI module so that I can get it to run. When I emulate my HMI project it tells me "Unable to reach controller TEST" where test is the name of my plc program. I added a module that matched the model in my HMI program (panelview 5510 2715p-t7wd) which I arbitrarily picked at random. But when I go into references and try to add HMI to Controller Path it does not show up (I'm assuming it's because it is faulting in the plc program since it doesn't actually exist). Is there not a way to emulate an HMI or add a virtual HMI to my studio 5000 program that I could connect to from View Designer?
  2. Hello Folks... The pictures show it all... I just need to produce a one-shot inside the IF...THEN, and the Oneshot's input bit goes from 0 to 1 as you see from the trend, but the output bit is not going to 1, or giving a pulse ? can anyone help me understand why i am not getting a pulse in this code ? And is there another easy way to get pulse inside IF...THEN without changing the condition which activates the if loop ? Thanks in advance for your time
  3. I have a Base tag of BOOL logic that will not activate the MOV output.  The Base tag is paralleled with an Alias tag for a NO pushbutton.  When the pushbutton is actuated it produces the desired output.  Has anyone encountered this issue from a togglebit base tag before?  Why would a base tag produce a different outcome from that of an alias tag that function properly?
  4. Axis Attribute Error

    Hello All, First time working with PLC. Get the hang of it from stuff I researched. Having an issue with an axis setup for a servo motor.  When I try to do an auto tune it gives me an error that axis is not configured.  Source: Config Fault    Condition: MotorDeviceCode- INvalid attribute      ACtion: Immediate Stop Fault Entry: Type 8, code 9 subcode: 1314 stopaction: 4 Statechange: 3   I was wondering what am I doing wrong? Any leads or source information I can use to solve this. 
  5. Can anyone explain to me what this would mean in a COP instruction? Source: #N[N187:4]:[N187:5] Dest: #N[N187:1]:0 Length: 20 I am doing a PLC5 conversion to rslogix5000 and some (most) of it has been a nightmare -.-
  6. Hi, I'm fairly new to motion applications and I have an interesting (to me) problem to solve. I'm using Kinetix 5700 with MPL motors to drive a pick&place carousel and a conveyor belt. I have a virtual master that driver the carousel in 1:10 ratio. The virtual master also drives the conveyor belt, the ratio is given by the carousel diameter and the conveyor driving cylinder diameter +  2x the belt thickness. And I'm using MAJ to drive the master and the MAG instruction to drive the carousel and the conveyor. This all works well. BUT: the carousel does not pick the product in the same place every time. That creates irregular gaps, or pitch, between the product on the conveyor which causes some issues down the line. Is there a way how to superimpose a value to the conveyor axis to ensure the pitch is regular at all times. Something like the ADDAX instruction it Trio motion controller for example? I'd want to have a sensor that detects the edge of the product and compares he encoder value to an expected value and slows downs or speeds up the conveyor accordingly. Thanks a milion.
  7. Incrementing Counter Error

    I have a counter tracking the number of cases packed through a robot program and an option to count less than a case (pack now). In order to update the correct number, I'm using math (ADD) to increment the counter by one.  I used that in conjunction with a MOV instruction to increment up the counter by one.  However, when I energize the button, my accumulated value goes up by +220 or so. Any way to fix this?
  8. AVE instruction Error

    A little background information here, I am trying to create a moving average so I accomplished it with the code (imaged attached) The problem i am having is the AVE instruction error bit goes true. it leaved me with a result of 1.#QAN  I did some googling and it said this is typically done when dividing by zero?? so i added a NEQ to 0 prior to loading the array. then it happened again. so i put the error bit in front of the FFL so it will stop loading the array when i get the error bit so i can see what values are in the array when it errors out. Has anyone else had this issue and what could you do to resolve it? I haven't had any luck find something that points me in the right direction. Thanks in advance for your help.
  9. Hello there, I am using a Kinetix 5700 drives to control bunch of axis. HW used : 5069-L320ERMS2 GurdsLogix, 2198-S086-ERS4 Servo Drive with MPM-B2152M-M motor and the 843ES-SIP12BA6 safety encoder. All is working fine except I can't figure out how to dynamically change an axis velocity  controlled by a MAG instruction. I have a virtual master axis controlling the velocity and each physical axis is controlled by a MAG instruction with a gear ratio. In my safety program I have SFX and SLS function block used to determine the safe speed limit. The  SLSLimit output of the SLS function block is linked to a SS1 Request of my servo drive. This causes the axis to stop when safe speed limit acceded.  What I'd like to be able to do is to dynamically change velocity (limit it to safe speed if SLS instruction is active) of each axis without having to change the gearing ratios and thus avoid the SS1 safe stop action.  I know how to do that using JOG or MOVE but is it even possible to do that using the MAG instruction? Regards Martin
  10. Hi all, I've ran into an unusual situation where I could use some suggestions.  I have an AB PLC working in the field, and an existing fixture that needs to be transferred from an Omron PLC into our AB.  I have an integrator who did some offline development with a welder that uses Anybus communication.  He sent a .ACD file to implement the logic from.  The file has an Ethernet module configured but more importantly, it's showing EDS not registered.  I've asked for the EDS he used, and none of them work when trying to register it via right-click and register.  I can export the module, but it won't import into the current PLC program because there's no EDS (shows EDS error after the import).  If I try to take the program that was sent to me online with the PLC, it will automatically upload and overwrite the build.  I can't even open the properties of the module to see what the integrator did. The end goal is to have the offline developed module implemented into the current program, but it seems like everything I've tried to do has me against a wall.  Is there a way to go online without uploading?  Maybe there's a way to implement this I haven't learned yet?  Any suggestions would be much appreciated, and if more information is needed, I'll be glad to provide it. More info:    PLC Type: 1756-L82E ControlLogix 5580    Rev: 30.014    Studio 5000 Version 30.01.00 - Standard Thanks, K
  11. Can I download an old program (written with RS Logix 500 version 5.2) into a newer SLC 5/04 Series C with a higher FRN than my copy of RS Logix supports? I don't want to use any newer functionality. Just wanting to get a spare 5/04 and load the application software on so it is ready to swap out in the event of a failure. I see some 5/04's on eBay that are new in box but have a FRN of 11 which wasn't out at the time my version of RSLogix was created.  
  12. I am using Studio 5000 View Designer v4.3 to create an HMI on Panel View.  I'm having a weird issue where every time I open up my project, the windows are displaying only in the lower right hand corner.  This wasn't happening earlier.  Undocking the window, expanding the window, uninstalling and re-installing View Designer have not helped.  Trying to open View Designer as an administrator has not helped either.  I know there are better HMI platforms, but I am basically complete with the construction of this HMI using Studio 5000 View Designer and now it is too late.  I just want to add a few more buttons and I can't do it because I can't see the bottom of any of my windows.  Since Studio 5000 View Designer is based in Visual Studio, maybe someone would know how I can fix this via Windows registry files?  
  13. Dispersion of an array

    Hi Guys. I have a trouble to determine the dispersion of an array. Like I have an array what have 1000 elements. I need to know the dispersion of the numbers. I checked but I didnt find any instruction for this. Im using RS Logix 5000. Can someone pls help me out ?  Thanks in advance.
  14. Hi all. How to replace an Ethernet ip communications module(1756 en2t) with a new one if the old one stops working. What should be done to configure the new module in rx logix? Should I set the IP address? Or is it plug and play? Thanks in advance.
  15. Hi, All!  I am very new to PLCs and I am currently writing ladder logic for an Allen bradley MLX1200.  I have a number of inputs which i have addressed in the format: I:1.0/1 etc. which should equate to I:Slot.Word/Terminal. I have checked the SLC 500 Instruction Set document which has informed me that this format should be structured correctly however I still receive the error message "ERROR: Address must be specified to the word level!"  Can anyone see where I am going wrong?  For reference Slot 1 is a 4-Channel Thermocouple Input Module (1762-IT4).  Any help would be greatly appreciated.  Thanks C
  16. Team Can anyone help me converting the *.RSS file to PDF format.   R8-41335.RSS
  17. RSLogix 500 Version 3

    I have came across some Allen Bradley SLC processors with no backups running version 3 firmware. Does anyone have software that old or a connection? Rockwell will not support. Any assistance will get appreciated!
  18. I had two esoteric question I was curious if anyone might be able to help with. First, I am playing around with way to monitor the internals of a PLC and I was curious if anyone has any idea on why to pull the internal memory off a ControlLogix 5580. Ideally, I would like to avoid just directly reading the config out and reading individual tags. I prefer to be able to get a little deeper.  Something similar to the crash dump, the RSlogix software can generator or something like the S7dump.exe tool for the S7 PLCs i.e. getting at the actual memory in specific memory addresses. Second, I was curious if anyone knew anyway to grab the actual binary are sent over to the controllogix after the RSLogix 5000 processes a configuration file. In this case I am looking for something similar to the binary files in codesys not the project file. This might be an assumption. Maybe RSLogix doesn’t ever produce anything like that but I figured I would ask
  19. I'm attempting to make a backup of a program, complete with comments. I go connect to the PLC over Ethernet, and select Use Upload File to merge the comments from an original copy of the program. After that, I go file-saveas to backup the program. However the new saved file, complete with comments is only 134 KB, and the very original copy of the program is 230 KB, from 2003. Is there a reason for this, the program hasn't shrunk in size, only minor tweaking of some span calibration numbers.
  20. logix 5000 array

    Hi Guys! I have a problem with array filling. I use rslogix 5000 software. I have to save the timestamp sometimes. I can save it with GET instruciton. Its a dint array which have 7 elements (year, month, day....and so on),  But my problem is I dont know, how can I solve that, they are in a bigger array. So like an array within the array. Idk it is possible ? I hope you know how I mean.  So I have 7 dint value in one array, and I want 1000 array for this. How can increase the position of the array number ?  Can anybody help me with that ?  Thank you in advance.  
  21. controllogix and 500 on IPAD

    Hi, Is it possible to get RS5000 or slc 500 software on an ipad to fault find and troubleshoot or even make edits.
  22. We have two computers and a plc that we use for training purposes to teach new techs the basics of going online with a plc and simple troubleshooting techniques. For some reason a couple classes ago we started getting an error from one of the pc's when we would try and download a program to our teaching plc. The exact same .ACD file can be downloaded to the plc with no issues from pc-1 but from pc-2 it gives the error attached below. I tried uninstalling all Rockwell related software from pc-2 and reinstalling but this didn't solve anything. Once I download using pc-1, pc-2 is able to go online with the plc and make edits no problem; it is just the downloading of the .ACD file it cannot seem to do. Processor: 1756-L55 ControlLogix5555 Firmware Version: 16.21 pc-1 OS: Windows 7 pc-2 OS: Windows 7 I'll be happy to include any extra details if needed but my team and I are just at a loss. Just short of formatting pc-2 we have no idea what could be causing this.
  23. Hello everyone, Working in Automation for the first time as a Co-op student so i'm fairly new to PLC's and the Automation field in general. I've recently been tasked with converting a RSlogix 5 program from an old PLC 5 project into a Studio5000 project. I referenced the manual (I'll attach link below), and had no issues using the RSlogix Project Migrator tool that I downloaded off the Rockwell website. My problem is that once I convert the program, my I/O tags that were originally sequenced in octets(0-7, 10-17, 20-27, ...) from the RSlogix 5 program, are switched into a sequential scheme in Studio5000 that just increments them in order (1, 2, 3, 4, ...). I hope this make sense, but basically the first seven tags match between the projects, but then I:010 in rslogix 5 is equivalent to I[8] in 5000, I:011 is I[9], and so on and so forth. Has anyone had this issue before and found a way to have Studio5000 keep the original octet scheme? I don't see this normally being an issue, but the customer has specifically asked that the I/O tag names be kept the same as the original program. Thanks for any help. - Ben   Converting PLC-5 reference manual link: https://literature.rockwellautomation.com/idc/groups/literature/documents/rm/1756-rm085_-en-p.pdf
  24. I have a new PC that is running Windows 10, I have RSLogix 500 loaded and working no problem, along with RSLinx, Factory Talk Activation... etc. I also loaded the Studio 5000 package and it loaded without a problem however will not run. It starts and allows you to pick a project to work on, then will display the Logix 5000 splash window for a second, then just close. No error message, crash or idea of what it is doing, just closes. So far no help from AB, perhaps someone here is running this on Windows 10 or has an idea how to figure out why it is closing. Thanks
  25. To Whoever might read this: I am currently a journeymen electrician in CA with 12 years experience in the installation, Maintenance and design of commercial electrical systems. I have limited Industrial experience, but I know enough to get myself around without blowing myself up or the customer and their infrastructure. Recently, I have taken a few online courses on PLC programming using RSLogix Micro Lite. I realize this is very entry level stuff, but I thoroughly enjoy the process of forming ladder logic and problem solving and I believe my experience in electrical theory and installation has helped me understand the natural flow of this logic. My interest in this field goes back 10 years or so and I am just now getting around to learning the languages and logic behind the PLC's that I have built entire electrical infrastructures around. With that said, as a full time service electrician who just landed a job in the wastewater electrician/mechanic field, I am seeking opportunities to learn and grow in some form of internship or unpaid position as long as the workload is either remotely operable, or somewhere based out of the greater Sacramento, CA area.   I do not want to sound picky, but I am a young father with a full time career, newly married and a busy full time job schedule to keep up with. SO, I am definitely interested in any opportunity that will give me experience to add to my abilities as a programmer for future ventures. Thank you for your consideration!   MtHowe15 P.S. I am also TOTALLY up for any hints and tips as to what a good next step would be towards gaining experience!