Search the Community

Showing results for tags 'RSLogix 5'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Found 82 results

  1. RSLogix Tag Name Confusion

    I am trying to learn the logic of a process at my new job. There are tag names that I can't make sense of because they end with _xva, _xvb, _xvu, _xvd, _xvo, _xvc, _zsm, _zsu, _zsc, _zso, _zsd and so on and so forth. I know they are associated with motion, but I need to make better sense of them. There are no descriptors. What do they mean and is there a resource available that I can reference?
  2. Dear all, I have 1794 IE8H Hart flex input module to which one Emerson HART flowmeter is connected...I have gone manual of flex module...I have to write program to read 3 parameters from HART transmitter in RSlogix 5000 (compactlogics)....in manual there are so many & geeting confused how to get this...even got sample code from rockwell site...but still nt working...If anyone have any proper document to follow please suggest or mail me on gspatil555@gmail.com.....thanks.
  3. Dear Friends; Good day. First i install the windows  virtual xp mode on Windows 7 64 bit. After installation i installed the FTM, RSLINK,and rslogix 5.0 in virtual xp mode.  Then i activate the software by Factory talk manager and select the hard disk and for a single computer activation. This process successfully acomplished. But when i open the RSLOGIX it shows popup that activation path is not found. Then i again open the factory talk tool and note that there is no activation shows in current activate products, But the activation detail shows in the RE host tab. I re hosted the activation by using go to Rockwell site and message show successfully activation re hosted.   *** Now i am stuck here is i loss my activation?  *** in windows xp virtual mode how i activate my product that application find the correct path of activation file? ** In windows xp mode if i open my Computer there is shows other hard drive partition as well as Local disk C:\  and activation file save in virtual drive instead of real C drive in windows 7. But there is no file path option to save the activation. Its by default save on C:\documents and setting\all user\shared documents\rockwell\activation\*****   Please help me how i activate my product in windows XP mode successfully?  Thanking you. i will remain Regards  
  4. Can't Communicate to 1769-L32E

    I was practicing some concepts on concurrency in periodic tasks where I handle such using SSV instruction to inhibit tasks, as suggested by Logix5000 Programmer Manual and after I downloaded the program through ethernet cable to the PLC (Compact Logix L32E) it became impossible to communicate to it, showing 1789 Virtual Chassis in the Who Active Window isntead of the PLC I'm using. I tried to reconfigure it using RSLinx and serial cable but I had no success, the only solution was reset it by removing its batery. I was wondering what could have caused the problem. Concurrency.ACD
  5. Hello All! I am having difficulties mapping register values. In the TURCK register there are 24 unique register bytes corresponding to different value registers (8bit x 24). These 24(8bit) bytes were mapped into RSLOGIX 5000 as 12(16bit) INT words ....INT[12] .. This means there are 2 bytes (2 unique register values) inside each INT word. WHAT I NEED TO ACHIEVE: 1. (BLUE outline in drawing) Write/Map a value of "32" into byte 7 of the TURCK register so effectively starting at  INT[5].8 in RSLOGIX           Drawing1-Model.pdf This will enable the value of CNT1 (encoder count) to be registered in bytes 8-11... 2.  (PINK outline in drawing) READ/MAP the values registered in bytes8,9,10 and 11(4x8bits) into a SINGLE 32bit INT value which will tell me the CNT1 value of my encoder. I am having problems when ever I try to COP a value of 32 (no matter what kind of array it's sourced from) into INT[5].8 & I haven't tried to map/read the values of bytes 8-11 CAN SOMEONE PLEASE HELP EXPLAIN HOW TO ACHIEVE THIS?! Thanks for your input EVERYONE! :D Drawing1-Model.pdf
  6. Hey guys, this is probably a stupid question so I apologize if it is, but I have a PanelView Plus 6 700 and a CompactLogix L36ERM on one of my machines at my plant.  We have several different molds that run in this machine, so we have 5-7 different PLC programs that can possibly run in this processor, depending on which mold is in.  I'm planning to go to a single program with recipes, but I haven't had the time to set that up yet.  So we use the PanelView for troubleshooting, and adjusting process paramters.  On the main screen in the PanelView I have the time/date and also the program name.  What I have been doing is just creating a string tag in RSLogix 5000 that is the program/processor name (we use the same name for the processor and program) and then on my PanelView I just create a string display that looks at the string tag name in the processor.  That way anytime a mold is changed over and the PLC program is downloaded, the PanelView displays the correct program/processor name.   Now this is all fine and dandy and works as long as if a new program is created, we remember to change the string tag to the name of the new program, we often run new sample parts and what we do is rename an existing program that has similar logic and save it as a new program name.  The problem comes up because if somebody copies an existing program and makes a new one, the string tag is still going to say the name of the old PLC program.  Now if we only had one or two or even 5 machines, it would be simple enough to just remember to change that string tag.  Our, or I should say MY problem is that we have approximately 40ish machines in our plant, and I can't always remember to change that string tag every time we create a new program.  I should say that I have been, but there are times that I may forget. My question is this, is there any way that in FactoryTalk View ME Studio to have a string display the name of the processor or the name of the PLC program automatically without having to manually enter the name into the string tag that I created in RSLogix 5000?  Like is there a system tag somewhere that has the name of the processor or the name of the program?   That was way more explaining then probably necessary.  It's early and I've had way too much coffee haha.   Thanks guys.
  7. Just wondering if I need to set up two Motion Groups to specify the direction of travel along 1 AXIS? (Forward and Reverse) If not, how do I specify direction when using motion instructions (specifically MAM) with incremental motion. 
  8. Good day, We are using Guardlogix 1756-72s controllers for our ESD system. We created safety add-on instruction in RSLogix5000 v20 and wanted to test it using RSLogix Emulate 5000, however we are getting an error that safety add-on instructions are not supported in standard controllers. Is there a way to test safety code using Emualate or Softlogix?
  9. Hello All! This is my first post so please give my descriptions some lee-way please:P I am having trouble finding a solid example of ladder logic which integrates a: PowerFlex (755 in this case) Rotary Incrematal Encode ( or any encoder for that matter) A Prox to reset the resolution at specific points along the axis Also, can I use the standard Motion Instructions (MAJ,MAS,MAM etc) to control the movement sequences of the PowerFlex or are they only meant for use with Servos? I am working on automating a Lumber Treatment Process. The movements will have to move tens of thousands of pounds.. Therefore I would like to use the PowerFlex as a Torque Limiter to control a 15HP squirrel cage motor on a massive gear reduction. I have the distances and pulses per distance traveled from the mechanical engineering guys.. I'm just having problems integrating! After using the Setup Wizard for PowerFlex how can I go about actually inserting movement instructions for the drive into my ladder logic? Some more info on different movement profiles.. I've also included my attempt at trying to piece this together thus far.. Any input would be welcome! (StellaPLC) https://sites.google.com/site/lyncedrgb/eva/rslogix The actual drive and PLC are not available to be me at this time.. could this be an issue while trying to write this motion control program? (obviously not testing & troubleshooting portion) Tugger Speeds Freq. ACCEL TIME DECEL Time E-Stop Decel Torque % of max Notes   VERY SLOW 15HZ 0.5s 0.5s 0s 100     SLOW 30HZ 1s 1s 0s 100 Restricted to slow speed within 3m of ends of transfer deck   HAUL 60HZ 5s 5s 2.5S 100 Max torque limit 250% of FLA   EMPTY TRAVEL 120HZ 2s 0.5S 2.5S 30 Torque Limited to 25%  
  10. analog output PLC

    how i do connect TRIAC with analog output for vary the GATE signal of triac
  11. Micrologix 1000

    Hello,  I am getting this fault when I am trying to load one of my program and set to run mode.  I have the same plc and I have not had this problem again. 1761-L16BWA Any suggestions ? I think this plc is older than the other I have. 
  12. Programmatic Timer/Delay

    Howdy, Wasn't sure the best place to post this Programmatic Timer/Delay question. I need to create a Timer whose 'time' will change programmatically. I am having trouble coding this in RSLogix/Studio 5000. I need to delay a little more every time 1 Product passes through up to a certain count then reset and start over. Basically during a conveyor transition, via a pop=up conveyor, I don't want the product in the same place every time. I want each successive product to be in a little bit different spot, call it the Conveyor Land Point. The product will land a little further each product, then start back at the first land point I have no code to share as all attempts were FAILs Inputs: > Product Count (Count up or down counter) > Product Count Cycle (Number, constant, set able, currently = 4) > Delay Time Sequence Interval (Number, constant, set able, currently = 0.25 seconds) Outputs: A sequencing delay, based on Product Count > Delay Sequence:  1st delay 1 second. 2nd delay 2 seconds, ... up to Product Count Cycle (4) then reset back to 1. Program: (As I was thinking) Set Product Count Cycle, Product Count Cycle = 4 (May change could be 3,4,5, or 6) (Might be hard code, might be an HMI input) Set Delay Time Sequence = 0.25 seconds (May change could be 0.5, 0.75, 1.0 etc.) (Might be hard code, might be an HMI input) Line start, Product Count at one (1) Calculate Delay     Delay   = Delay Time Sequence Interval * Product Count Cycle * Product Count  Product Count increments via PE Repeat e.g. Hopefully I have not 'run' at the mouth, wanted to give as much info upfront                I included a picture Any thoughts, help would be great. thanks,
  13. Add On Instructions Parameters

    I am trying to learn how to use add-on instructions, and to get a better understanding I am trying to do a simplified example. I am trying to make two separate add on instructions that alter an integer tag in different ways. I would like one AOI that multiplies the input integer by 3 and another AOI that adds 3. The integer tag is a InOut parameter.  I named these AOIs "Mult3" and "Add3". When trying to use the AOI's it requires me to have an additional input with datatype the same as the AOI ("Mult3" or "Add3"). I have a couple of questions about this: 1. Why is this data type required? It seems to me that I would only need the InOut integer that I want to modify. 2. I want to use these AOI's in a number of places throughout my code on a number of tags. Would I be able to just use one "Mult3" tag for all the AOI's, or would I need a seperate tag for each use of the AOI?  For Instance if I am using the Mult3 AOI in 3 separate places in my code, two times using "Int1" as the InOut parameter and another time using "Int2" as the InOut parameter, could I just make one tag of "Mult3" datatype and use that for all the instances of the AOI, or would that screw it up in some way. Thanks for any help.
  14. Hi, I am tasked with doing some research for our company. (automation / controls ) and wondered if anyone here might know of a resource to find out what platforms they are using at the various GM plants. I'm looking for the Process PLC / Safety PLC / HMI software. Much thanks,  
  15. Looking for ideas on connectivity issues with RSLinx/RSlogix when using an EWON Cosy 131 running on Windows 10. So here's whats up: Was running windows 7, could connect to the EWON VPN and use the ethernet driver in RSLinx to get to the PLC(compact logix). Also used Automation Direct C-more software with no problem as well. Now on Windows 10, the Automation Direct software still works fine, i can ping the PLC and get to its webserver but rslinx/logix will not pick up the plc. I have tried setting up a new ethernet driver to no avail. I also connected a cable directly to the plc from the pc, bypassing the ewon, and rslinx/logix will then see the plc, so rslinx does seem to "work" in windows 10. Any ideas on how to get connectivity back over the EWON VPN? I have these in customer plants and really dont want to revert back to win 7.   Thanks    
  16. Hi all, Looking to convert older .rss ladder file into newer RSLogix 5000 compatible format. My problem is - I don't have 500 series software (or a computer to run it on) to start the conversion. Any help/suggestions appreciated
  17. RSLogix 500 - remapping symbols

    I have developed some code for a ProSoft comms module in an offline PLC using their sample RSS file. I now need to incorporate into a machine's existing code. This will require re-mapping of many data file elements to avoid conflicts with the existing data files. There is plenty of scope for editing errors. Is it possible for me to assign symbols to each data register/bit that I've used and copy the program rungs with symbolic references rather than physical references? e.g. Rather than copy this XIO B3:17/2 OTU B122:0/1 BNDCould I copy this XIO MY_CONTACT OTU MY_COILand paste into the recipient program? I presume it would be best to make the edits to my development code before pasting it into the new program. Anyone got a procedure? I've looked at the Address / Symbol Editor but editing the address there doesn't change the ladder - it just moves the symbol to the new address.
  18. Hey all, I've reviewed a number of threads regarding converting one data type to another and I have something I'm working on that I'm stumped on and haven't found an answer for yet. Without getting into the details, I need to get a DINT bit value from an entered decimal value. A user will enter in a whole number in an entry box and then it needs to get converted to the number of whatever bits that the DINT number holds. For instance: # Entered Variable Bit Value -----0------------------0 -----1------------------1 -----2------------------3 -----3------------------7 -----4-----------------15 etc... I'm looking for a fairly clean way to do this, with perhaps just two or three instruction blocks to handle it, if possible. I can provide a screenshot of the HMI and the logic (4 rungs) if necessary. Any suggestions or advice from the group would be greatly appreciated!
  19. How do you jump to non LAD2 in RSLogix 5? I know the PLC5 does Lad2 automatically but cant find any info on how to make sure other LADs (like LAD3, LAD4, etc.) run. Unsure if I am supposed to use a JSR in LAD 3 and jump to LAD3 and then put the SBR and RET instructions inside LAD3. Apologize for the stupid question as am used to do everything in RSLogix/Studio 5000.
  20. Hello, I am trying to get a Fanuc R-30iB controller added into my RSLogix program. The PLC is a CompactLogix 1769-L30ER When I search for new modules to add I see a pre setup Fanuc Robot Ethernet module, but I can't get that to work. I tried following Fanuc's instructions and setting it up as a generic ethernet module, but I couldn't get that to work either, it just says i/o not responding for that module. I am definitely able to ping the Fanuc controller, so I believe I am seeing it. When I add the controller in RSLinx, it's there, but there is no icon next to it's name. I'm guessing because its a fairly new controller, and it came out after the version of RSLinx that I'm using? Don't I need to download the EDS file for the new controller so that Linx can recognize it? Any help would be greatly appreciated. Thanks
  21. Greetings, I'm ok with RSLOGX 500 but am an absolute beginer with RSLOGIX 5000 and was wondering if anyone had any simple sample code just to study. I would love something using analog input and or analog output. thanks in advance.
  22. Hi!! I was using RSLogix 500 starter software for Allnen Bradley 1200 PLC. But few days back the PC in which this software was installed had crashed beyond recovery. Now when this software is reinstalled into a new PC, i am facing activation problem. Following the FactoryTalk Activation manager leads to "Validate Activation" option. Once the serial number and product key are given, it shows that i have zero downloadable activation left. I am not sure what to do now. Please guide.
  23. First of all im using a softlogix 5860 processor connected via 1784 PCIDS card to the 1794 devicenet adapter. my first module is a 16 bit DC input followed by a 16 bit output and finally my 2channel input/ 2 channel output. I can write code in 5000 for the digital IO's just fine and i have the .dnt file setup correctly with all lights green and i can see voltage change from rsnetworks when i monitor the input from the 1794 ADN (setup for 0-5v). From the reading i've done, i know i have to use block transfer msg and there is a sample file included with the version of rslogix that i have but its setup with different controllers and adapters. I've read anything i can get my hands on online from rockwell but the docs on these adapters only show the setup example using the ethernet IP version. in the ethernet IP version you can right click on the 1794 IP adapter in rslogix 5000 and add the module.... you cannot do this using the devicenet adapter. I can include my basic logix file but theres not much to it since I have no idea where to go from here. If anyone has ANY experience with this i would be forever greatful thanks in advance.ANALOG.zip
  24. RSLogix 500 Rev 8.20 CPR 9 I'm editing a new program and on a few occassions I have created / edited a comment and discovered that the comment has been applied to the rung and either the one before it (overwriting the existing comment if there is one) or the first rung of the next subroutine. I'm nervous. Anyone seen this behavior. Note: I am using my monitor in portrait mode so program listing is long but I can't imagine that's related.
  25. Good Morning, I have installed and I can download to the emulator, but something is not correct. I can never get it to run. I can go to comms tab and I can see the driver but I can never select it. Is there a trick to this I am missing? Thanks