Search the Community

Showing results for tags 'Factorytalk View Studio'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Found 180 results

  1. AVE instruction Error

    A little background information here, I am trying to create a moving average so I accomplished it with the code (imaged attached) The problem i am having is the AVE instruction error bit goes true. it leaved me with a result of 1.#QAN  I did some googling and it said this is typically done when dividing by zero?? so i added a NEQ to 0 prior to loading the array. then it happened again. so i put the error bit in front of the FFL so it will stop loading the array when i get the error bit so i can see what values are in the array when it errors out. Has anyone else had this issue and what could you do to resolve it? I haven't had any luck find something that points me in the right direction. Thanks in advance for your help.
  2. Hello there, I am using a Kinetix 5700 drives to control bunch of axis. HW used : 5069-L320ERMS2 GurdsLogix, 2198-S086-ERS4 Servo Drive with MPM-B2152M-M motor and the 843ES-SIP12BA6 safety encoder. All is working fine except I can't figure out how to dynamically change an axis velocity  controlled by a MAG instruction. I have a virtual master axis controlling the velocity and each physical axis is controlled by a MAG instruction with a gear ratio. In my safety program I have SFX and SLS function block used to determine the safe speed limit. The  SLSLimit output of the SLS function block is linked to a SS1 Request of my servo drive. This causes the axis to stop when safe speed limit acceded.  What I'd like to be able to do is to dynamically change velocity (limit it to safe speed if SLS instruction is active) of each axis without having to change the gearing ratios and thus avoid the SS1 safe stop action.  I know how to do that using JOG or MOVE but is it even possible to do that using the MAG instruction? Regards Martin
  3. Hello, In my ladder program I have 7 different arrays (containing REAL values) all members of a structure and I wish to extract certain values from the arrays and put them on another structure consisting of REAL values (not arrays). Which is the best way to do that ? I tried AryMove command but I get an error "Conversion from REAL to ANY_ELEMENTARY[], ENUM[], STRUCT[] is impossible. To get a better understanding of my structures and arrays here is an example: Struct wheel_data Global variable SWheel of wheel_data rad[1...10] of real, vary[1...10] of real, varx[1...10] of real struct. 2 wheel Global variable Wheel1, .... , wheel10 of wheel rad REAL, vary REAL, varx REAL what I wish to do is to copy Swheel.rad[1]  to wheel1.rad,  Swheel.vary[1] to wheel1.vary, Swheel.varx[1] to wheel1.varx 2nd structure Swheel.rad[2]  to wheel2.rad,  Swheel.vary[2] to wheel2.vary, Swheel.varx[2] to wheel2.varx until I fill all 10 wheel structure instances with values Thanks in advance.
  4. Is it possible to reset " Motor replacement detected error" ( Error code 95.01) using code without connecting to PLC through sysmac studio? If yes please suggest how to do it... Thanks in advance...
  5. Hi all, I've ran into an unusual situation where I could use some suggestions.  I have an AB PLC working in the field, and an existing fixture that needs to be transferred from an Omron PLC into our AB.  I have an integrator who did some offline development with a welder that uses Anybus communication.  He sent a .ACD file to implement the logic from.  The file has an Ethernet module configured but more importantly, it's showing EDS not registered.  I've asked for the EDS he used, and none of them work when trying to register it via right-click and register.  I can export the module, but it won't import into the current PLC program because there's no EDS (shows EDS error after the import).  If I try to take the program that was sent to me online with the PLC, it will automatically upload and overwrite the build.  I can't even open the properties of the module to see what the integrator did. The end goal is to have the offline developed module implemented into the current program, but it seems like everything I've tried to do has me against a wall.  Is there a way to go online without uploading?  Maybe there's a way to implement this I haven't learned yet?  Any suggestions would be much appreciated, and if more information is needed, I'll be glad to provide it. More info:    PLC Type: 1756-L82E ControlLogix 5580    Rev: 30.014    Studio 5000 Version 30.01.00 - Standard Thanks, K
  6. Sorry if this is covered elsewhere, but my search hasn't revealed anything yet.  I have a number of PanelView graphics created with FactoryTalk View ME and some use a lot of Parameter Files, which link to popup faceplates. So a large number tags are represented with parameter files, which, when clicked on screen, then pop-up an appropriate faceplate, based on tag type or category etc.  I am still digging into the very elaborate FT View ME manual, but at 500 pages, that's quite a deep study.  But I don't see the linkage between the tag's parameter file and how it specifies which faceplate to pop up, and I've not yet found a good article other than keep digging into that FT manual. There does not appear to be a linkage entry in the parameter file itself, where I would have expected it.  Nor do I see any "hot spot" click type event code in the display itself, which would also make sense.  Is it in the PLC code itself?  I would not have expected that, since they seem to be keeping the FT environment self-contained. But there must be some sort of table or linkage somewhere that I'm over looking. Thanks in advance for anyone's thoughts & guidance on this.  Other parts of FT HMI screen development does seem intuitive, just not this dynamic linking.
  7. Hi, Could anyone help me out on how to extract the digits present in a string in sysmac studio... Thanks in advance !!!
  8. Anyone know of a guide about programming a balluff io master device into Sysmac Studio?
  9. Version 4

    28 downloads

    MX Component manual for programming PC - PLC software solutions.   Details MX Component library functions and examples. 
  10. MX Component Programming Manual View File MX Component manual for programming PC - PLC software solutions.   Details MX Component library functions and examples.  Submitter WattUp Submitted 03/13/20 Category Manuals, Tutorials
  11. In CX-Programmer software, we have the ability to make a bunch of copies of the same rung with the "Address Incrememntial Copy" Function. Does Sysmac Studio have a similar function?
  12. A simple request for an Omron novice.  I know Timer values in Sysmac Studio are classified as TIME variables.  How can I modify the Preset of a TON block from my NA HMI since the TON Preset is of a TIME data type? Thanks,
  13. PWM

    Hi  In CX-programmer there is a PWM(891) function. Is there a similar same function block in sysmac studio ?  
  14. Is there any instruction in Sysmac Studio Structure text to detect rising Edge (DIFU/DIFD) ?
  15. Task Priority 16

    I have made a fat bloated program that runs too slow. I tried working under the philosophy that "Premature Optimization" is the biggest time waste in developing programs. Now my program takes to long to run and throws a task error. I am attempt to cut the primary task's cycle time down I tried to move programs that use IO to other tasks. Task 16 is supposed to be able  to handle IO but it doesn't come up as a selection choice of priorities for me. I can do 17 but I get errors trying to use IO variables at that priority level. NX102-1200 controller, Sysmac Studio 1.30.1. Should I be able make a task at priority 16? I have some analog IO that I don't need to update every millisecond and I have some data and loop intensive FB's that only need to run once hour and I'd like to get them off my primary task's to-do list. I'll be busy re-writing my program FB's to accept specific variables instead of bloated structured variables and converting and changing Lreal's to real's and some other Premature Optimization tasks so I can run the sucker. 
  16. I am using Studio 5000 View Designer v4.3 to create an HMI on Panel View.  I'm having a weird issue where every time I open up my project, the windows are displaying only in the lower right hand corner.  This wasn't happening earlier.  Undocking the window, expanding the window, uninstalling and re-installing View Designer have not helped.  Trying to open View Designer as an administrator has not helped either.  I know there are better HMI platforms, but I am basically complete with the construction of this HMI using Studio 5000 View Designer and now it is too late.  I just want to add a few more buttons and I can't do it because I can't see the bottom of any of my windows.  Since Studio 5000 View Designer is based in Visual Studio, maybe someone would know how I can fix this via Windows registry files?  
  17. NJ Modbus

    I need to write c# with modbus TCP to read NJ,  Anyone able to to use PC communicate with NJ by using Modbus TCP?  Any Function need to be added in the PLC, for Example , PC to read Register 40000 to 40020 ?    
  18. Can anyone help me with the issue in the picture? We have the correct version in place yet it gives me a version error stating it needs the version that is installed. Doc1.docx
  19. Dear automation friends,   I just like to put some issue in the clear that I have seen no reported issues on yet, but it is killing me. Maybe some other people in the world also have this issue. We use Windows 2016 on FT View v10. All patched with all compatible patches (both Windows and Rockwell). We install this software a lot but we only got this issue seen/reported on windows 2016. I never had a Rockwell issue that took so long without getting it fixed. Support is also not really helping.   We just have a setup of Windows 2016 with 2x redundant FT View Servers and about 10x Clients with each 4x screens. The HMI clients run perfectly but every few days, 1 application (on 1 of the 4 screens) just crashes "DisplayClient.exe application crash...". That closes the HMI interface and then the users needs to click on the hmi.cli file to launch that screen again. Refering to ntdll.dll in the windows events. No additional info except for the windows error reporting that is unable to contact the internet to send the crash report. Looking in the FT Diagnostics, it happens while the operator is operating the hmi screen. Not when there is no activity.   We reinstalled 1 client completely from scratch, including the OS, domain integration, everything brandnew. And 10 hours later: crash on 1 of the 4x screens. In a control room with almost 30 screens, this is very annoying and unacceptable.   If you have a similar issue or got the issue fixed, please let me know. If you have a similar issue and don't have it fixed, we can share more detailed logs.   Best Regards,
  20. hi dears, I have one CS1D omron Redundant controller ( CP65H) that must be connected to NS15 Touch panel. I want to use Ethernet for connecting HMI and CPUs (CS1D-ETN21D). I have one question. for NS15 we can use CX designer and sysmac studio? is it true? which one is better? what is your recommendation for HMI software? Thanks.
  21. How do I edit an array size ARRAY[0..13] OF REAL to ARRAY[0..15] OF REAL? Sysmac Studio doesn't allow it to be done online, as far as I can see. If I do it offline and then go online and Synchronise, Transfer to Controller I receive error Any ideas?
  22. USER CANNOTE BE AUTHENTICATED

    Hi I wanted to install the FT AssestCenter in my PC but i cannot access to the programs 'causes it shows a pop up that says  User "xxxxx" cannot be authenticated. Contact your administrator I have already add the User in FT Administrative Console (Local and Network) and i added to the administrators group but still isn't working  
  23. FactoryTalk Alarm Messages

    Hello Everyone, I have the .mer files for an HMI application that was developed in FactoryTalk V8.0. I have V10.0 installed, I restored the .mer file and did some development ( added screens , objects and alarm messages). Then I created a V8.0 application file. Everything is ok except for the Alarm Messages. I changed an existing message but when i trigger that alarm I get the old one ( the message before I modified it)  Any ideas??  Like always, thank you 
  24. Hello everyone, I have a problem with packing machine. There are some issues with one of the axis, when axis actual position is near to 1800000 some error appear and operator has to turn off machine on main contactor. This axis is working in Linear mode. I think that rotary mode would be better for this axis. And here is my question. Which instructions, and what options i should change/check when i change count mode in axis's options. Can any1 point me some manuals to read or give me some advice ? Thank you in advance.  
  25. OMRON VS FACTORYTALK

    Hello !!! I am trying to establish a communication between a CJ1M (Omron) CPU with a PanelView Plus 7 (Rockwell). In the simulation (runtime) the communication is established, and the buttons send and receive the information. When I download to the HMI, the "SHORTCUTS NOT DETECTED" alarm appears. Someone to help me?