Search the Community

Showing results for tags 'Control Logix 5000'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Found 168 results

  1. servo auto tuning

    Hello Guys! I have couple of questions about tuning an ab servo motor. -Actually what does the drive or plc doing when I launch a servo auto tuning?  - What are the little boxes like position error integrator ? There are checkmarks in fornt of the lines. Can I choose the methode or something? I mean its not "auto" ? Why it is auto then ? - Can someone send me some basic literature where they explain me what these stuff acutally meaning ?  - What is the hook up test what for is good ?  -When you are doing a servo auto tune what are the parameters that you are monitoring and why ?  -I should do the auto without or with load ? Whats the difference ? I know there are so many question I would be so grateful if someone could help me with these answears, or even just with one. Thanks again. 
  2. Data Types for MAM instruction

    I have inherited a program to work on using MAM motion commands on a CompactLogix 5370 processor. The MAM variables for some parameters state that REAL data type is required. However in looking at the the code those REAL variables are actually declared as DINT. Is this OK. Does Logix somehow accept DINT for these parameters even though REAL is specified. So if parameter is 5600 DINT it somehow interprets this as 5600.00 REAL. Confused!
  3. Kinetix 6000; RSlogix 5000

    Hi guys!  I have several questions connected to kinetix 6000 servo amplifiers. I have a system with AB plc and AB kinetix servo drive. The communication is sercos. Earlier I was worked drives with ethernet communication. I think its better, I could monitor the parmeters durnig as its works. But with the sercos communication I am no longer to be able to do it. One of my question is that like it is possible to check the parameters somehow. I have some problem myabe with the overcurrent recently. But for now I even cant see what is the limit. Is it possible to find it somewhere ?   Also when Im watching the parameters in the RSlogix 5000 which is belongs to the servo drive. I can see a row like (servoname)axis fault code and (servoname) axis code. Is there any table where I can see which number belongs to which fault or status?  If anyone can help me I just appreciate ahead. Thanks Guys.            
  4. NX1P2 Motion Control

    Hi:       I need to change an old PLC  with NX1p2  to control 3 servo motor by means of Analog Outputs couple with encoders, My job is to change the PLC only. So the servo drives and drivers are untouchable (No budget and involve too much mechanical works).   I observed that Sysmac Sttudio Axes setting has this: Servo Axes, Encoder axes, Virtual Servo Axis and Virtual Encoder Axes.   I believe the Encoder Axes couple with Analog Output is able to to do the Job? If so, what function block should i use? If no, do any body have a suggestion of any function block i can use? Thanks  
  5. AB Studio 5000 Lite

    I put together a system a couple of years ago with a L306ERM with I-O, PanelView, etc and I was sold Studio 5000 Lite to program it. It worked out ok on that project but now I have a project that I need to use a Powerflex 525 VFD and the software won't let me add the Powerflex. I've tried several different PFs and none can be added. It crashes at the Create button and puts out the wonderfully descriptive message of "Unknown Error" Email AB support. As of 4-1-21, AB doesn't take emails for Powerflex drives. Anyone know if the Lite version of Studio 5000 will work with a Powerflex 525?Thanks you for looking.
  6. CJ1M con CJ1W-EIP21 a ControlLogix

    Hello I am trying to communicate a CJ1M with a CJ1W-EIP21 Card, with a Logix Control, but I have not been successful, what I am looking for is to read data, from the OMRON and see it in the Logix Control, but I have not been able to establish communication, I am looking for someone You will already have a functional example, with the backups of both PLC'S, to be able to observe how they made the configuration. Thank you for your support Greetings
  7. Hello All, I am new to Studio 5000. I am trying to have my limit sensors energize my stop output, and also have a manual bit that I can toggle that will energize the stop output as well. Currently, toggling my manual bit works for energizing the stop output, but my limit sensors turning on does not energize my stop output. Not getting what I want with or without the ONS. What is going on??? Thanks, Daniel
  8. I'm having trouble with some Powerflex 525 drives. Right now what I need to do is run them manually from the keypad to test conveyor belts.  Is there a way to do this and if so how?   Thanks in advance.
  9. Hello! I have a plc program where I need to start and finish an MAM instruction based on a set amount of time. I am trying to calculate the speed of the motor based on the time but when I do, its always off by some milliseconds which I cannot have. I thought this was due to not considering acceleration time but changing acceleration does not change how long it takes the instruction to complete. Is there a more reliable way to perform this? Currently I have my speed units set to seconds which I thought would work (and did improve it slightly) but there is still a slight offset in time. If there is no reliable way to do this, is there a reliable way to predict what the offset in time may be? or what is even causing the offset? thank you in advance. Edit: Or should using seconds work fine, and its more likely something else in my program?
  10. VM With Studio 5000, FTVSE, Emulate 5000

    Ok, so I was tasked with setting up a virtual for our development team to be able to use to quickly deploy projects hmi, emulated plc, and studio 5000 project together on one virtual.  The main reason for this is when we get a project, many times we have to wait for an available plc.  We have plc’s in our rack but they can’t be used because they are being used for other projects.  I’ve used the compatibility matrix that Rockwell has but my boss wants to stick with Windows 10 Professional like we do in most our projects but according to the matrix, it looks like having FactoryTalk View SE Enterprise version 10, Studio 5000 Logix version 33 and Studio 5000 Logix Emulate version 33, FactoryTalk Gateway 6.11 and RSLinx 4.11 (mainly for communication to the emulated plc) but in the matrix says Windows 7 and Windows Server 2012  is the best choice.  I’ve ran into issues with Emulate opening, it takes up to 20 minutes to open.  Our licenses are on a server and accessed using FactoryTalk Activation Manager and all the activations are there.  Any suggestions would be appreciated.
  11. This is my first post so let me know if there is anything wrong with my post. I am learning Studio 5000 right now for an internship and created a simple project involving a pushbutton and some LEDs. Now I am trying to create an HMI for it in View Designer. My problem now is that I cannot establish a connection to the project because I do not have a physical HMI connected to my plc (Logix 5380). I can't find any way to emulate an HMI module so that I can get it to run. When I emulate my HMI project it tells me "Unable to reach controller TEST" where test is the name of my plc program. I added a module that matched the model in my HMI program (panelview 5510 2715p-t7wd) which I arbitrarily picked at random. But when I go into references and try to add HMI to Controller Path it does not show up (I'm assuming it's because it is faulting in the plc program since it doesn't actually exist). Is there not a way to emulate an HMI or add a virtual HMI to my studio 5000 program that I could connect to from View Designer?
  12. Create TCP/UDP Socket

    I'm trying to send an int over TCP using a MSG Socket,  Compactlogix ==> Arduino Ethernet Shield I have set up TCP communication between two Arduino Uno's using Ethernet shield. I've set up the one as a server, the other as a client. server IP: 192.168.1.21 port 23. If the client is connected it reads incoming data as a byte or an array of bytes. The data between the two has been verified to work. I'm now trying to transition the communications between a compact logix-L32E. I'm looking to send a byte (or int being as there's no byte data type) from the Compactlogix to the Arduino using TCP. To my understanding I need to use a socket create, open, read/write, close. The manual to do this is vague as a step by step procedure. Does anyone have an example code for socket programming? I can open rs500, rs5000, and studio 5000 programs. If I can open a file to use as a reference I can translate it on my own. Any help/advice would be greatly appreciated. 
  13. Hello Folks... The pictures show it all... I just need to produce a one-shot inside the IF...THEN, and the Oneshot's input bit goes from 0 to 1 as you see from the trend, but the output bit is not going to 1, or giving a pulse ? can anyone help me understand why i am not getting a pulse in this code ? And is there another easy way to get pulse inside IF...THEN without changing the condition which activates the if loop ? Thanks in advance for your time
  14. I have a purchased Machine that came with a Siemens LOGO 8.FSR PLC (Smart Relay). Generally we use Allen Bradley or Mitsubishi. Anyway, we need to communicate data between the LOGO and an Allen Bradley Compact Logix.  I do not desire to add an additional network to the AB but as best i can tell the LOGO is exclusively Modbus TCP/IP. Has anyone come across a similar situation?  I look online and did find an  Anybus module that claims to be able to link them together.  Looking for anyone who has faced this challenge and succeeded, or failed.   Thanks
  15. Hello Everyone. We have Schneider TM241 PLC Along with Citect SCADA System at 100MWp Solar Power Plant to monitor and control various equipments like Inverters, Switch-Yard, MFMs, Weather Monitoring Systems etc... Government Authority here asked every solar plant to control the generation as per the instructions by Load Dispatch Center, for that we need to implement logic to control Generation as per requirement. For that we are controlling generation from inverters by giving them generation setpoints calculated by PLC using PID function.   But we are facing one problem while using PID. (FB_PID of Toolbox Library)   Suppose we need to generate only 60MW out of 100MW. So we set PID setpoint to 60MW and according to that we get PID output and according to that PID output value we provide generation setpoint to every inverters.   This system works very fine until the clouds comes into the picture.   Now suppose Setpoint of PID is 60MW and PV is also near about 60MW, and suddenly large cloud comes over plant and block solar radiation.   In this case generation comes down to 10MWp(or any value below 60MW), So output of PID will Increase and keep increasing and settle at the Maximum value. but without solar radiation generation value stays very down then Setpoint.   Now suddenly Cloud moves and again solar radiation increase, but the PID output is maximum at that time so, Suddenly Generation goes from 10MW to near about maximum capacity (100MW) instead of 60MW, and then it will slowly comes down to 60MW.   We need to rectify this generation shoot up when cloud moves. Anyone have idea how can we solve this problem or anyone have programmed PID in this kind of situation.   Is there any function block available to do this correctly like function block of PID with two Reference or something like that...   We are using TM241 which is CoDeSys based PLC.
  16. Hello everyone, I have a Kinetix 6000 CIP drive (unwind) and I need to control its speed by a PID controller. I have everything working except the MCD instruction doesn't pick up on the PID output value change. It changes the JOG speed, which I use to control the unwind, if I set the speed manually, which is slow. The PID changes the speed almost continuously. Any suggestions are welcome. This is how I'm attempting to control the speed: A1_r_JogSpeed = PID output value   Thank you    
  17. I have a Base tag of BOOL logic that will not activate the MOV output.  The Base tag is paralleled with an Alias tag for a NO pushbutton.  When the pushbutton is actuated it produces the desired output.  Has anyone encountered this issue from a togglebit base tag before?  Why would a base tag produce a different outcome from that of an alias tag that function properly?
  18. Constant Web Tension Control

    So I'm having trouble writing a FBD within my current program for a slitting line. I need to keep a constant tension on my web as it is being recoiled onto our recoiler. I wrote a simple program using a sensor to read the growing rate of the coil to get a radius and I have feedback on my torque on the recoiler motor. The simplest math for this application without getting into anything too fancy should be Tension(lbs)= Torque(ftlbs)/coil radius. only problem is when its less than a foot then my calculation is thrown off and it actually shows tension goes up until it reaches the one foot mark then it seems to scale correctly. Do I need to scale something else? Any help on this would be appreciated.
  19. Axis Attribute Error

    Hello All, First time working with PLC. Get the hang of it from stuff I researched. Having an issue with an axis setup for a servo motor.  When I try to do an auto tune it gives me an error that axis is not configured.  Source: Config Fault    Condition: MotorDeviceCode- INvalid attribute      ACtion: Immediate Stop Fault Entry: Type 8, code 9 subcode: 1314 stopaction: 4 Statechange: 3   I was wondering what am I doing wrong? Any leads or source information I can use to solve this. 
  20. Hi, I'm fairly new to motion applications and I have an interesting (to me) problem to solve. I'm using Kinetix 5700 with MPL motors to drive a pick&place carousel and a conveyor belt. I have a virtual master that driver the carousel in 1:10 ratio. The virtual master also drives the conveyor belt, the ratio is given by the carousel diameter and the conveyor driving cylinder diameter +  2x the belt thickness. And I'm using MAJ to drive the master and the MAG instruction to drive the carousel and the conveyor. This all works well. BUT: the carousel does not pick the product in the same place every time. That creates irregular gaps, or pitch, between the product on the conveyor which causes some issues down the line. Is there a way how to superimpose a value to the conveyor axis to ensure the pitch is regular at all times. Something like the ADDAX instruction it Trio motion controller for example? I'd want to have a sensor that detects the edge of the product and compares he encoder value to an expected value and slows downs or speeds up the conveyor accordingly. Thanks a milion.
  21. Signal Tower Error Code(s)

    Hi, got a mental block lol.  Got a machine we are modifying, currently got most of the code in place. Working on a fault routine now. This machine doesn't have an HMI or wide array of PL. Nothing major just a simple vision system check. Currently have 6 faults that will stop the cycle running. I'm wanting to have the beacon light (Red light) blink for the cause of the fault. For example: Scenario 1- Fault stop for bottle check NG:  (two) .5 sec blinks -  2 sec red light off -  (two) .5 sec blinks ..... repeat  Scenario 2- Fault stop for bottle check NG and reject sensor blocked:  (two) .5 sec blinks -2 sec red light off - (three) .5 sec blinks - 2 sec red light off....... repeat I have the code a few different ways but it looks "dirty". Any suggestions? Thanks in advance  
  22. Can someone please suggest a Control Panel Builder that is located in Germany?   I work for a company in Australia and due to Covid 19, we are struggling to meet an onsite date for a project in Germany.   This project uses Siemens PLC gear, Danfoss drives, and mostly Schneider electrical gear. The enclosures are custom and stainless steal.    I have electrical schematics and enclosure drawings for quoting.
  23. Mitsubishi FX5-4LC

    Hello Guys,                      can anyone help me programming of FX5-4LC temperature control module with FX-5U80MT PLC. I want to Read present temperature value of each channel and want to set Temperature Set value from PLC.
  24. AVE instruction Error

    A little background information here, I am trying to create a moving average so I accomplished it with the code (imaged attached) The problem i am having is the AVE instruction error bit goes true. it leaved me with a result of 1.#QAN  I did some googling and it said this is typically done when dividing by zero?? so i added a NEQ to 0 prior to loading the array. then it happened again. so i put the error bit in front of the FFL so it will stop loading the array when i get the error bit so i can see what values are in the array when it errors out. Has anyone else had this issue and what could you do to resolve it? I haven't had any luck find something that points me in the right direction. Thanks in advance for your help.
  25. Hello there, I am using a Kinetix 5700 drives to control bunch of axis. HW used : 5069-L320ERMS2 GurdsLogix, 2198-S086-ERS4 Servo Drive with MPM-B2152M-M motor and the 843ES-SIP12BA6 safety encoder. All is working fine except I can't figure out how to dynamically change an axis velocity  controlled by a MAG instruction. I have a virtual master axis controlling the velocity and each physical axis is controlled by a MAG instruction with a gear ratio. In my safety program I have SFX and SLS function block used to determine the safe speed limit. The  SLSLimit output of the SLS function block is linked to a SS1 Request of my servo drive. This causes the axis to stop when safe speed limit acceded.  What I'd like to be able to do is to dynamically change velocity (limit it to safe speed if SLS instruction is active) of each axis without having to change the gearing ratios and thus avoid the SS1 safe stop action.  I know how to do that using JOG or MOVE but is it even possible to do that using the MAG instruction? Regards Martin