Search the Community

Showing results for tags ' use plc’s channel 0 (serial) or tcp/ip interface module(s) to have as many mb tcp/ip devices or serial devices. (some limits apply based on system configurations'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Found 150 results

  1. Hello, everyone I have to query a SICK distance sensor from an L26CPU via the onboard Ethernet interface. I have created a simple protocol which I start with the function block SP_ECPRTCL. Unfortunately it takes at least 25ms until the next telegram is started. The sensor responds within approx. 1.5ms. Does anyone know whether that works faster or is that a limitation when using the predefined protocols? Sensor manual:  OD5000, 8021391 (sick.com)  (Chapter 7.4) I am grateful for all the hints. Thanks and regards Dave SICK_Protocol.tpc Messaufbau_vTest.gxw
  2. Hello, denizens of Mr.PLC. I'm trying to talk to an old TSX17-20, and have acquired the DOS files for PL7 22. However, when installing via floppy drive, I'm getting a fatal error saying that the User Interface is missing. FATAL ERROR: 251 Your Telemecanique system in incomplete. Ensure that User Interface is correctly installed.   I'm aware that PL722 (and PL7-1/2/3, etc.) require Telemecanique's DOS User Interface to run, but I can't for the life of me find installation files, and, as it is no longer supported by Schneider, no luck getting it from their site. Apparently, it used to be hosted there. Would any of you wonderful folk have the links or files to this user interface? Apparently, PL7 22 5.0/5.1 have never required/no longer require a license. It was a drag to find these files, so I'm posting the PL722 files (in two zips, representing the two floppies) so that there's an easy to find reference for them. PL722D1.ZIP PL722D2.ZIP
  3. Hello! I'm trying to connect my QD75M2 with a MR-J2S40B1 Servo amplifier with an SSCNET cable. The problem is when I try to turn on the Servo ON/OFF on the Intelligent function in GxWorks2, an error occurs saying the servo amplifier is disconnected with my QD75M2. I'm confident that I've wired it properly. What could be the problem? Hoping you might help. Thank you.
  4. Hello, My coworker and I are commissioning a new panel. We have a 1732-AENTR series C remote IO thats Rev 6.1. The project file from a previous identical panel has the module at rev5.3 in the project tree. I downloaded the AOP and ran the installer, it worked no issues. My co worker then did the same thing but now the module is unrecognized in the project tree and the module is missing after installing the AOP. Im concerned he corrupted something. I tried uninstalling and reinstalling the AOP but no luck. It works on my computer but not his? TechConnect said something about corrupting the aop core. My coworker did the first install and he was getting confused about zip files and the virtual machine we run rsl5k on. Maybe he broke it? any suggestions?
  5. GX Works 3

    Hi everybody! Recently I've got problem with installation of GXW3 on my PC There is a message "Any of the MELSOFT products or other software may not be installed normally. Please restart computer before installing this product" during installation. Of course I restarted PC)), delete all Melsoft products from my PC,  please i need your Help here ver 2.7 IQWORKS  I have Windows 10 64bit .  
  6. G9SP Configurator

    I am at a client site that has a line with multiple Omron G9SP-N20S safety controllers installed and I need to make a modification to the system.  I tried to install the Omron Configurator and it asks for a serial number, and will not install without one.  Omron said that it is on the CD that ships with the unit, but the equipment manufacturer did not supply any of the CDs.  The only Omron solution is to order a replacement CD, that will take 5 days, which is 5 days too long as there is a hard stop in 2 days.  I have tried entering numbers found on the controller, with no success.  Does anyone have a better way, special contacts at Omron, to et it faster?
  7. I am building a redundant system using S7-1515R-2 CPU with TIA V16 version. Creating the hardware, there is not possible to insert any other card to the rack. Even power modules (PM) can not be inserted to the rack. How should I make the power feeding to the CPU. Should I use two power modules/devices or only one. How can I insert IO-cards to the system, is the only possibility to use Profinet IM-cards. In this system I am connecting the bus to the ring and using S2.  
  8. Is there any way to monitor ethernet/ip bus, states or faults and to make an alarm to the panel alarmlist. I am using IO-stations (1734-AENTR) and I would like to monitor somehow the system. I feel that reading the slot status of the 1734-AENTR device is not enough, because it is not possible to monitor all the cards in a slot. How to get alarm on a screen if I lose any station on the ethernet/ip bus?
  9. Hi there, I am fairly new to programming serial communications, especially with Mitsubishi PLCs. Can someone walk me through in ladder logic how to bring in ASCII to the PLC, store the data in the data registers. Then send the data out to another PC once an 'X' input is satisfied? ASCII code would go like the following: C2,0,1,123,2,ABC,3,456,CR
  10. HI All,  I have an issue with my SCU32 communication.  Back ground Two SCU32s  (top and bottom side) connected via a 1100M datacable  using port1 ( 9600bps,  8-2-E, start code FF, end code FE, Tx save to d1000-d1200 , Rx save to d2000-d2200). PORT2 of bottom SCU32 is connected to a compass( 2 wire, 8-1-N, 19200 bps, serial gateway MODBUS ). Refer to photo Issue  Without compass, the receiving data at top is very stable and is didn't see any fluctuation. But if is compass is connected at bottom side port2, there is a fluctuation at the top side RX data(specifically d2000-d2005 ) .  I checked the data a bottom side TX (d1000-d1200) and it is stable. Only after sending the data and Receiving at Top side, then only the starting words fluctuate. I am not sure sure what is wrong, I am using logical ports for the DTXDU/DRXDU and compass.   Appreciate all your feedback and suggestions.  
  11. Hello all, I am working on a project where I am communicating with a Mensor CPT6100 pressure transducer using a Micro-850 PLC. For this, I have used an AWA instruction to write some ASCII characters to the sensor. The sensor then responds to the write instruction by sending ASCII characters to the RX buffer and I used ACB and ARD instructions to read the ASCII characters. Now, I have set the ACB trigger type to 0 (msg triggered only once) and it successfully reads from the sensor. However, when I set the ACB trigger type to 1 (msg triggered multiple times), I do not get any reading in the ARD block. As a matter of fact, the ACB Q bit switches off every time the program is executed when the trigger type is set to 1. I am trying to get continuous readings from the sensor, but when the trigger type is set to 0, the program latches on to the first and only reading and it won't change. My question is, how can I change my program so that it can continuously and autonomously read from the sensor without me having to manually trigger the AWA and ACB instructions every time. I am attaching the program to this thread for your reference.  ASCII_Test_Copy.ccwarc
  12. Sorry for my bad english speaking. I want to change the baud rate to 19200,38400,.... for send it via Programmer-Serial-Port. The software GX-Developer can do it!.  
  13. Hello Sirs! I have a problem with PF527. I get alarms 'control sync alarm' and 'module sync alarm' occasionally. I suppose this meaning that PLC is missing some data from the PF527 device. How to confirm this or what should I do with the problem? Any ideas? Motion group update period is 8ms. Also this device is the last device in the ethernet line. I am thinking to pull the cable directly to the switch near PLC. I am not sure does it help?  
  14. Hey Everyone,   My company decided to purchase a piece of equipment from China, and I have the pleasure of updating its terrible existing controls. We were given the PLC program by the manufacturer, so I was able to make my changes pretty easily - or at least that would be the case if I could actually connect to the dang thing. The source program is indeed openable and editable via GX developer (the original configuration shows it as an FX3). I figured connecting should be straightforward, but I was wrong.    I initially used a serial/usb converter that I've used on some older Allen Bradley equipment (which worked fine for that). However, after no luck using it on the "Mitsubishi", I purchased a different cable that I found recommended on this forum (Tripp Lite USA-19HS - https://www.alliedelec.com/product/tripp-lite/usa-19hs/70101537/?gclid=Cj0KCQiAj9iBBhCJARIsAE9qRtB_n8TVAnJdFyYokoEu42W6H6LaT4kVsgJQI1qvPUsUF3rFviKpbt0aApLHEALw_wcB&gclsrc=aw.ds). Still, no luck. I've tried 7E1 and every baud rate possible, as well as some other bit/parity configurations (and yes, I've verified that I'm using the right com port, as well as tried moving the converter to different ports and trying those). Nothing seems to go through.  I have almost no experience with Mitsubishi beyond a couple of FX5s (which have worked fine, but I connect to those via ethernet). Any help would be greatly appreciated; if I can't make these changes, I'm going to end up rebuilding the whole cabinet with a PLC I can rely on.   Thanks in advance.
  15. Hi, I have an Omron NSJ5-SQ00B-M3D Programmable Terminal (HMI) that I am trying to get to communicate with an Omron CJ2H PLC through a DeviceNet module (DRM21) in the main PLC rack.  I don't see how to configure CX-Designer to communicate via DeviceNet.  How is this done?  Many thanks for any help.
  16. Hello, We have a FX3G connected to a FX3U-ENET-ADP inside a main cabinet. We are then using that master PLC to collect data from 2 other fx3g plcs in a node:node serial network. I was assigned a small project of pricing out some wireless adapters so we can upload/download to the two slave plcs. My question is, is it possible to upload/download programs to/from the slave plcs through the ENET adapter and serial network in the main plc? It would save us some money if possible. thanks.
  17. Proface with Serial Printer

    Dear Sir, Good day. I facing difficulty on using proface to print out the data using serial printer. I did follow all the instruction on proface reference manual but still fail to print out anything. Anyone here having experience on this issue? Thanks. 
  18. I have a Siemens HMI 6AV2 124-0MC01-0AX0 in my machine. I want to clone the display on the HMI to PC/Laptop. My question is: 1. What software that I need for this task? 2. What kind of interface that I need between the HMI and PC/Laptop (for example ethernet cable, etc)? 3. Do I need to communicate with PLC connected with HMI or can I just connect with the HMI? Thanks in advance for the answer.
  19. Hi Everyone,   I have  NT31C-ST142-V2 and it has a prompt of "System Program not exist or incorrect." I am trying to transfer via NT Series System Installer but I am getting a time-out error. I have Xm2S-09 serial cable with ATEN serial-to-USB cable.I know it is not broken since I can still Upload/download on a CJ2 PLC. I just want to know what other things I can do upload a systemprogram. I have seen a comment on this site that he remove the battery then tried to upload again.   NT is almost 15 years old. I have a back-up program.   I can't seem to upload by this time for pictures of theH MI and the screenshots of software .
  20. connection to omron CJ1M PLC

    I have an omron PLC (CJ1M type) at home which I would like to connect to, however, lately, I can't anymore.  I'm trying on two different PC's a newer and an older one, both running on windows 10. 1 is just mentioning a DLL error and I can't even start cx-programmer, the other one seems to work, however, when I try to go online it always fails I'm using a usb to serial device and after some searching on the net, I thought the issue was with the prolific driver.  I tried all kind of fixes, but nothing seemed to work.  I have now purchased another device, the XS8801 from usconverters and installed the latest driver.  I have checked if cx programmer is set to work with the correct port and this is the case. My knowledge is very limited but I would really want to connect to that PLC again, so hoping someone out here is able to help me. Thanks a lot    
  21. FBs-CBE distortion

    Hi every one After sending some command to plc using fatek FBs CBE module , router internet connection goes off and internet LED turn red. i mean it works fine for a minute.. then internet connection of router will be off...  why this happens?
  22. Hi All! Can anyone help me regarding the following logic: 1. I have four Silos and one filling station. 2. The filling of silos starts on the bases of silo demad (i.e demand is a digital signal that comes when silo is empty) 3. I have to fill all silos according to their demand 4. Whose demand is first that is filled first 5. for e.g if all four silos are empty they all generate a demand signal. 6. If Filling of silo 1 is done and filling is in progress at silo 2 after that filling will start  in silo 3 then silo 4 as they are empty 7. In the mean time  if silo 1 empy again and filling is in progress at silo 2. The system must fill silo 3 and 4 first then go to silo 1  8. It means which demands first that is filled first (first come first serve)   
  23. Check serial connection to Omron PLC

    Hello, I am building an application in CitectSCADA and I want to communicate with an Omron Sysmac CS1G. The connection between the plc and the Citect computer is through an ethernet to serial adapter (the computer doesn't have com ports on board). I'm having some difficulty establishing the communication and I want to make sure that I can actually reach the plc. Is there a way to check that the computer can reach the plc over the serial connection without using CX programmer? Maybe using Hyper Terminal, Putty or something similar. Thank you, Liron
  24. QD75M4 AND MR-J2S-40B

    Hello i have problem about connection between QD75M4 AND MR-J2S-40B  now MR-j2S is display "Ab" every time i can't solve this problem 
  25. I need a Red Lion HMI to communicate with an IO module (8) IO's ... I don't really need a PLC.  Because the control of a certain LinMot drive for a linear motor can be activated by IO's.  This LinMot drive can store up to 100 curves... which can simply be called into operation by a single binary number between 0 & 255,  defined by eight IO's ..  you input the number on the HMI, the HMI converts to binary and set the (8) IO's in the module which sends the binary number to the LinMot drive..   Yes, there are some other IO's for starting and stopping ... and it may be unrealistic for me to not use a PLC.   I'm trying to get the cost way down...    If a "stand-alone" IO module does not exist... then is there a simple, low budget PLC out there, with 8 or 16 IO's available..?    Thanks much, Michael