Search the Community

Showing results for tags ' use plc’s channel 0 (serial) or tcp/ip interface module(s) to have as many mb tcp/ip devices or serial devices. (some limits apply based on system configurations'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Found 163 results

  1. Serial question

    I have a cell phone modem connected to my Omron CP1L on serial 2   Here is the issue  I need to pull the phone number out of the msg received (receiving text messages)  I receive a text msg and a lot of other crap like time and date ect. RDX says store in D100 the problem is that after I receive the SMS I see the phone number and copy the number to D200 to D2xx The next text comes in and it is added to the length of the previous text and the new phone number is not in the same D area as the first.  It seems the only time the serial port works is if you declare 20 characters and you get 20 characters Works every time. But sometimes I may get 12 characters and other times I can get more than 100. I have used the restart and clear port command with no luck.  If I set RDX to a large number and receive complete will not come on and the next receive will be added to the first.  I need a clear buffer for each receive.  How do I get around this?  If you set the RDX to 10 but 12 characters were received the 2 extra characters will be in the buffer and added to the next receive.  I can’t use end receive if x because there is nothing that is always available in the msg. And even if I do any characters received after end code is left in the buffer and screws up the next receive. I have never seen anything like this. Any ideas? Thanks Rob  
  2. I have a 1747-L30B SLC Brick and it is set to load from EEPROM on boot S:5/8, Error S:1/10, and Run S:1/12. I need to make changes to the program and then store it to EEPROM via "Comms>EEPROM>Store to EEPROM."  When I attempt to store the program with changes, it displays the message "Insufficient Memory Module Size." I assumed the EEPROM memory was maxed out, but I also uploaded the existing program currently stored to EEPROM, made no changes, and attempted storing it back to EEPROM and received the same message. Any advice?
  3. Serial Port issue

    Sorry its long !! I am recieving text from a GSM modem for text msg Send and receive (SMS) works ok but would be better if I could make use of the start code and end code. This way I could cut down on all the crap that is received when a text arrives. I get this  CMTI: "SM",0 I have it stored into D80 and I have that trigger a TXD that sends AT+CMGRD=0 and that tells the GSM to send the msg (The 0 is the current msg in memory) ------ The problem is that there is Carriage  Return and Line Feeds in the received msg ----      AS below ((AT+CMGRD=0 +CMGRD: "REC UNREAD","+19028991212","","22/10/20,16:57:54-16"  Hello this is the msg  OK)) When the PLC sees the carriage return it stops receiving data. And I have no start code or end code setup. (I am using characters received) The way around this is to set a high  character count in the RXD (More than the actual msg (More than the msg length)   The main issue with that is I get garbage in as the msg gets bigger. Its unreliable. I clear the port after each receive and that helps but still get the odd garbage. (Never get garbage when connected to a terminal prg). Any Ideas???? ps Even the Start Code is unreliable as it will start receiving a few characters late. Rob  
  4. memory error

    hai, anyone know what the meaning of "ERR" in unpaired content in the picture?
  5. Serial Ports not working

    I have a CP1L-EM and the serial ports - both of them have an issue with the port ready flag will not turn on. Power cycle still no port ready flag In settings both ports are set up as 15200 8N1 CR/LF Verified and power cycled and still no port ready flag. Is there someplace in the PLC where the ports can be disabled? Rob  
  6. GX Works 3

    Hi everybody! Recently I've got problem with installation of GXW3 on my PC There is a message "Any of the MELSOFT products or other software may not be installed normally. Please restart computer before installing this product" during installation. Of course I restarted PC)), delete all Melsoft products from my PC,  please i need your Help here ver 2.7 IQWORKS  I have Windows 10 64bit .  
  7. Until recently, I haven't had to connect to a piece of hardware using a serial connection in quite sometime. Well, that all changed yesterday when I needed to connect to a Watlow F4T Controller. I dug around in the bottle drawer of my desk and pulled at not one, but two USB-Serial Converters that I saved for just such an occasion! My old ones worked on everything from Allen Bradley SLCs, to Schneider Drives. Unfortunately, neither appear to work in a Windows 10 environment. Searching the internet, I was not able to find any drivers for these old converters, but did find some posts in another forum stating that Microsoft changed how it manages its USB ports from Win 7 to Win 10. Thanks Microsoft! Sorry, I will cut this rant short and just ask my question. Can anyone recommend a USB-Serial Converter that works in a Windows 10/11 environment?  Respectfully, Shane 
  8. Hi, In our machine, we want the homing of linear axis to be - moving to reverse limit. In order to achieve that we connected positive limit to Enable_positive input, negative limit to Enable_negative input of MC_Power function block. We used MC_Home function block and assigned the negative limit to bCalibrationCam of home FB. Things were working correctly.  But one thing we noticed is if the axis is in synchronous operation mode(axis following another master axis), even the limit is engaged axis is not stopping. During discrete movement this was stopping. Is there any other way to configure limit switch in twincat3. 
  9. I'm trying to understand the basics of using a serial to ethernet converter such as this Comtrol DM-EIP-2101, with Studio5000 code. Basically I have a weighing machine that only outputs data via RS-232 and I need to send that data to a PC that will process it through a Studio5000 program and have the data displayed on an HMI using FTview SE. Is it as simple as just connecting the serial and ethernet to the converter and it does all the work? Obviously checking ip addresses and firmware will need to be verified. The main thing I am unsure of is the process of passing the individual data packets from the machine to the Logix code on the PC,  things like what the weight of the item was, was it over weight or under, etc....  Would there be an AOI or tags built into the software for a machine like this Checkweigher? I've worked with much smaller items like Cognex Dataman cameras and I know you can just use their AOI that allows you to simply call a tag if you want to display information like if a scanned barcode was correct or whatever. If anyone has done something similar I'd appreciate any guidance. It can be difficult getting the information from the manufactures so I'm looking for answers anywhere I can. EDIT: I guess I should also clarify that only using one or the other (serial or E/IP) is not an option. It will be a serial connection from the Weighing machine to the converter and then Ethernet to the PC.
  10. Dear forum, I am facing a trouble at the moment and hoping somebody can assist. I have one HMI software, GT Designer 3, HMI: GS2107 and/or GT2107, the software works so far so fine. The software is used on several products, I dont want to maintain two or even more software versions. Two serial devices are connect: 1x MODBUS RS-485 1x MODBUS RS-232. The data transfer is done via DDT, no direct calls. The DDT transfer the MODBUS address to the internal GD-Registers. The GD-Registers are used within the HMI. My trouble is that in some cases, there is no RS-232 device connected. This creates time outs, slows down the HMI and its just not nice looking (I have a warning implemented "WARNING NO CONNECTION TO SERIAL DEVICE RS-232". Is there a way, that I can select (retained) that the RS-232 is connected / or not? Once the software is configured "NO RS-232 CONNECTED" I can handle the rest of the software.   Anybody an idea how to do this? Many thanks.
  11. G9SP Configurator

    I am at a client site that has a line with multiple Omron G9SP-N20S safety controllers installed and I need to make a modification to the system.  I tried to install the Omron Configurator and it asks for a serial number, and will not install without one.  Omron said that it is on the CD that ships with the unit, but the equipment manufacturer did not supply any of the CDs.  The only Omron solution is to order a replacement CD, that will take 5 days, which is 5 days too long as there is a hard stop in 2 days.  I have tried entering numbers found on the controller, with no success.  Does anyone have a better way, special contacts at Omron, to et it faster?
  12. Good morning experts, is there any way to create two different Alarm display (System)? So, one with collection mode historical and one with only current alarm? Many thanks in advance
  13. Here is a post that we recently completed on the Automation Direct USB to RS485 Adapter.  The USB-485M is a 2-wire USB to RS-485 serial communication adapter for RS485 use. It does not require an external power supply or complicated configuration. It has a Type A (plug) USB connector for the computer side and a universal female RJ45/RJ12 modular connector. This will accept RJ12 and RJ45 plugs.  The USB-485M supports multiple baud rates and is USB V2.0 Compliant. Read the rest of the post... YouTube Video on the installation and communication to a Solo Process Temperature Controller via Modbus RTU. https://www.youtube.com/watch?v=aWE05ZNZNXw Let me know what you think, Garry www.accautomation.ca  
  14. I am trying to get a G9SP taking over serial to a NX1P2 using a NX1W-CIF01.  I have the details in Manual P545-E1 and it uses a example file which i am unable to locate OMRON_G9SP_SERI232_LD_EV100.SMC I have got the coms working with a CP1L using the example in Manual Z922-E1.  I was wondering if anyone has the example file or a working example they can share for Sysmac Studio. The serial comms will take a little bit to get going but it is the code for the checksum for the sending data that i would rather not have to translate from CX Programer fort he CP1L to Sysmac Studio...... P545-E1-01.pdf.lnk Z922-E1-07.pdf.lnk
  15. Sorry for my bad english speaking. I want to change the baud rate to 19200,38400,.... for send it via Programmer-Serial-Port. The software GX-Developer can do it!.  
  16. Hello, I've been using Mitsubishi and Omron systems separately (in their own environment), and I am fairly new when it comes to connecting these two brands together(plc and hmi). I've been scouring the net for wiring diagrams for the cable connections and also the parameters to be set for a successful communication between those two components. can anyone point me at the right direction as everything I've tried so far has been a failed attempt of making these two communicate. here are the parts and my current settings if this helps: FX3U-64M FX3U-232-BD NB5Q-TW00B or better yet, is there a proper cable that I need to buy for this to work?
  17. Hi I have encountered a problem with CX-integrator. I'm not able to open the program. The following message appears:  System error. Save the date and close the application.  (Error code 0035) I have tried to reinstall the entire CX-one packet.  Any ideas?  Regards MBD
  18. Serial communication with KINCO PLC

    Hello to everyone. Nice to meet you all. I am programming a KINCO PLC model HP043-20DT using ladder on KINCO BUILDER. I need to establish a serial communication with my PC. The PLC has a RS485 port which I adapted it to USB to connect with my PC. The PLC allows, at least, two ways to establish serial communication: MODBUS or free-protocol. I've read the software manual and tried to reproduce the examples it provides using the instruction blocks for MODBUS (MBUSR and MBUSW) and free-protocol (XMT and RCV) communications. However, I could not receive the data on the PLC. I could effectively transmit data with XMT from the PLC to the PC and I could verify through a tool called Access Port. In relation to MODBUS, I am using a simulation tool called Multiway from OMRON, however, I get no response from the PLC. If any of you have some experience with this software or this device, I would like to ask you how could I solve the problem. Thank you for your attention. Kind regards.
  19. Memory registers on KINCO PLC

    Hello to everyone. I hope you are doing well. I have a KINCO PLC HP043-20DT. I'm communicating through free-protocol instructions XMT and RCV. The manual states that memory registers SMB86, SMB186 and SMB286 contain information about the state of the reception instruction. I would like to ask if any of you know of the existence of an analog register but with respect to the transmission instruction, instead of the reception. The manual does not indicate it and I could not find any information online. I've sended an email to the manufacturer but, until now, I have not receive any answer. Otherwise, how could I search for this information? I tried through the manual providede by the manufacturer, but maybe there is other way. I would appreciate any information. Thank you so much. Kind regards.
  20. Good day everybody,    Currently I am working on an application using 3-axis controlled by a QD77MS4 Simple Motion Module.  In this case, I have already set up most of the configuration, but when I try to execute the program, I get the following error:   SP. UNIT ERROR - The location designated by the FROM/TO instruction set is not the intelligent function module/special function module.  - The module that does not include buffer memory has been specified by the FROM/TO instruction.  - The intelligent function module/special function module, Network module being accessed is faulty.  - Station not loaded was specified using the instruction whose target was the CPU share memory.   The QD77MS4 Module is mounted in Base Slot #3, so I use U2\G800, U2\G1500, etc... to Read/Write from it.  The Diagnostics tool indicates the error occurs as soon as I try to access the U2\G800 Buffer Memory. If I set this part of the program to No Execution the error is no longer displayed.  Additionally, if I try to monito the Buffer Memory area of the Module, it says that "The Module Stat Address is incorrect".   I already tried changing the position of the module in the base (Slot 3 --> Slot 1) and changing the corresponding values to reflect that, but still the problem persists.    What am I doing wrong? Is there some kind of configuration I could be missing?    Thanks in advance for your help!   
  21. Hello, everyone I have to query a SICK distance sensor from an L26CPU via the onboard Ethernet interface. I have created a simple protocol which I start with the function block SP_ECPRTCL. Unfortunately it takes at least 25ms until the next telegram is started. The sensor responds within approx. 1.5ms. Does anyone know whether that works faster or is that a limitation when using the predefined protocols? Sensor manual:  OD5000, 8021391 (sick.com)  (Chapter 7.4) I am grateful for all the hints. Thanks and regards Dave SICK_Protocol.tpc Messaufbau_vTest.gxw
  22. Hello, denizens of Mr.PLC. I'm trying to talk to an old TSX17-20, and have acquired the DOS files for PL7 22. However, when installing via floppy drive, I'm getting a fatal error saying that the User Interface is missing. FATAL ERROR: 251 Your Telemecanique system in incomplete. Ensure that User Interface is correctly installed.   I'm aware that PL722 (and PL7-1/2/3, etc.) require Telemecanique's DOS User Interface to run, but I can't for the life of me find installation files, and, as it is no longer supported by Schneider, no luck getting it from their site. Apparently, it used to be hosted there. Would any of you wonderful folk have the links or files to this user interface? Apparently, PL7 22 5.0/5.1 have never required/no longer require a license. It was a drag to find these files, so I'm posting the PL722 files (in two zips, representing the two floppies) so that there's an easy to find reference for them. PL722D1.ZIP PL722D2.ZIP
  23. Hello! I'm trying to connect my QD75M2 with a MR-J2S40B1 Servo amplifier with an SSCNET cable. The problem is when I try to turn on the Servo ON/OFF on the Intelligent function in GxWorks2, an error occurs saying the servo amplifier is disconnected with my QD75M2. I'm confident that I've wired it properly. What could be the problem? Hoping you might help. Thank you.
  24. Hello, My coworker and I are commissioning a new panel. We have a 1732-AENTR series C remote IO thats Rev 6.1. The project file from a previous identical panel has the module at rev5.3 in the project tree. I downloaded the AOP and ran the installer, it worked no issues. My co worker then did the same thing but now the module is unrecognized in the project tree and the module is missing after installing the AOP. Im concerned he corrupted something. I tried uninstalling and reinstalling the AOP but no luck. It works on my computer but not his? TechConnect said something about corrupting the aop core. My coworker did the first install and he was getting confused about zip files and the virtual machine we run rsl5k on. Maybe he broke it? any suggestions?
  25. I am building a redundant system using S7-1515R-2 CPU with TIA V16 version. Creating the hardware, there is not possible to insert any other card to the rack. Even power modules (PM) can not be inserted to the rack. How should I make the power feeding to the CPU. Should I use two power modules/devices or only one. How can I insert IO-cards to the system, is the only possibility to use Profinet IM-cards. In this system I am connecting the bus to the ring and using S2.