Search the Community

Showing results for tags ' omron'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Found 367 results

  1. Who Have Someone connected Citect with Omron CJ2M CPU32 ? Can i use it? Device communications wizard -> CJ Seres PLCs -> Ethernet    or need to Finsgateway software.    [Setting] 1. Boards TCPIP / 0(Address)  2. Port -I192.168.100.10 -P9600 -U (*PLC: 192.168.100.1 , PC: 192.168.100.51) 3. I/O Device 0/1/1/      /   OMFINS3    [MANUAL]  ----> Fallow the manual ONLY CS1, CV Need to setting  w/n/u/V  or w/n/u/S CJ2M do not need to this setting ?       I/O Devices Form Complete the I/O Devices form as instructed, with the following specific information. I/O Device Address The station address for an Omron CV Series PC is specified as follows : w/n/u/V for CV mode or w/n/u/S for CS1 mode where w is the FINS network address (1-127) n is the FINS node number (1-126) u is the FINS unit address (0) There are no defaults for w, n, or u, but if you do not specify a mode (with a V or S), it will default to CV mode. The FINS node number should be the same as the IP address node number. The FINS network number should be the same for all ETNs on the Ethernet segment. There is no relationship between FINS network numbers and IP network numbers.   Thank you..
  2.  Hello    I need to sent data between PLC CP1L-M30 and  Hyberterminal with serial port (RS232C port 1) ,but there isn't data show up . something is wrong? Could you advise me? my ladder as below  
  3. Hello Omron programmers, have a nice day to you all. I just need your help in this, i hope you have explanation.  I added a few sequence to the machine with compare instruction D2255 and D2259 as memory data. I really wonder what’s going on. D2255 a decimal value of 9, when it transferred to compared instruction it’s 9, but when D2255 become 10 or above, when it transferred to compared instruction it will become 16 or above, there is an additional of 6 to the decimal value when it more than 9. I attached the photos of it for more details. Can somebody please help me? Thank you.            
  4. I am trying to use FINS/UDP network to communicate with a Siemens device (at a customers site over seas from my home office), today I attempted to set up a SEND command based on information my customer received from a local Omron representative but had no luck.  I feel like I am missing something in a setting somewhere, does anyone have experience doing this?  I am using a CJ2M-CPU35's built in Ethernet IP port which is also communicating to 5 other Omron devices over Ethernet IP, so I am wondering if there is an issue having both networks. Thank you!
  5. Any tool to simulate Ethernet/IP for omron PLcs? I need to know the complete packate structure for Omron Ethernet/IP over Omron PLCs. I have read that we can use FINS command inside Ethernet/Ip packet . But how to get full pacakte structure.   Please help , it is urgent.
  6. Struct as FB input

    Hello,  I am trying to define a struct as an input variable for a Function or Function Block. For example the function AddDelimiter (This is a standard Sysmac function), has a input variable with the variable type Struct, an it is possible to couple a struct to this input (See picture below). If i try to make my own function block with a struct or Structure as an input data type, i get the following error (See picture below). When I try to define a struct from the data types (In this case struct: Test) it doesn't give a error. But when I try to couple a struct to this input, that is a layer deeper than the function block struct i get the following error (See picture below). How can i define a struct as an function/ function block input? Thanks in advance.
  7. What is the Use of Number data type for CJ2 Omron PLC? it takes integers as well as float values . we can not map it to D or H memory area.
  8. After getting my logic to work. I went in and implemented the logic with my plc. It worked but in order for me to test part 2 of it, I have to turn the machine off and turn it back on as part of a reset feature. When I turn the machine back on, it wipes out my logic and goes back to its default logic. It's almost like I never changed anything. I connected my pc to the plc and connected to plc, pulled up the code and ran it on "Online Mode" where i can make changes and send them to the plc and yet again it wipes out whatever changes I had made and goes back to its default. Any suggestions?
  9. So a little new to PLC's especially Omron PLC. I have this machine from Japan that uses Omron CP1L which needed some modification. I made the modifications and uploaded it on to the PLC. When I try to put it in "run" mode it gives me the "Failed to change the operating mode the operation mode may be still changing in the PLC" error. After that the machine does not move even with the orginial plc logic. At first I thought it was my logic and so I double checked and did it again. Same thing occured. Has anyone experienced anything like this? How can I fix the PLC? Thanks
  10. CIP betwen CJ2M and NS8 HMI

    Hello I'm quit new in this world and i have several doubts about the comunication of EIP. I'm trying to capture the comunication betwen a CJ2M and an NS8 HMI. I was trying with MolexEIPtool, so i could understand better the communication process and i did a little. Here is the wireshark capture of an get all attributes request: CIP_Molex_tool.pcapng  (The last two packets are  another unconnected request). I can see the request for list services, the register sesion request and the Forward open request. Then, i can see the request for service "get_attributes_all" and how the cj2m responses with all the attributes. Finally, the forward close request. But when i put my computer betwen the two devices, i cant figure it out what is happening. Here is the capture: CIP_OMRON.pcapng I can see that the packets are "SendUnitData", so i think it is a connected transmision, but wireshark cant decode the rest of the frame, so i dont know whats going on. Thanks
  11. Does Omron CP1E support Ethernet/IP? i think it only support FINS not ethernet/ip . Can anybody confirm this?
  12. Does CJ2 Omron PLC support absolute or symbolic adress or both? If absolute then we have to give FINS command to communicate over ethernet/ip? Need an urgent help . 
  13. Remote I/O weidmuller

    Hello,  I am trying to connect a Weidmüller UR20 Ethernet I/P  (Hardware version 1) to a Omron NX1P2 PLC via Sysmac Studio. I have imported the Weidmüller EDS file into Sysmac studio and connected two tags to the target variable 101 and 102 (I also tried using a array of bytes and a single word).   When I transfer this configuration to the controller and set the controller in run i get the following error: Tag Data Link Connection Failed (0x84070000). I have tried to update the firmware of the Weidmüller I/O but this doesn't seem to help. Also the web interface shows no connection with the PLC. I also tried to setup the connection with the CX network configurator but this gave the same result. Is there someone who can help me with this problem Thanks in advance.
  14. Hello, I'm fairly new working with OMRON NA5 and I was wondering: Is it posible to load a pdf file in Runtime so I can see it on screen? I know I'm supposed to load the documents in resources but that would be when I'm programming the project in Sysmac Studio before download it to the HMI (see Image_000 attached), but I have no idea regarding how to load files to the root directory while the project is running I mean, is that function avalieable in the NA5? I think I could use its ftp server but I'm not really sure, I'd appreciate if any of you could guide me regarding this issue or if there is an OMRON manual regarding how to access these directories and such.
  15. Hello Guys, I would like to learn how to communicate a temperature controller omron (E5cc) with Omron PLC s, using rs 485. I Did some diggings and I found out an instruction called PMCR, but I have no idea how does it work. I personally knew that it is possible to read and write data into the temperature controller, but I dont know how to get it done with ladder programming. I do need to learn how to do this in full. Please help me out. thank you  <3 <3 
  16. I am using an Omron NJ controller and a Cognex Dataman 260 bar-code scanner.   At this point I can trigger the scanner and receive data from the scanner via ethernet/ip. My issue is in converting the response from the scanner to something human readable. The bar-code I scanned reads "872-3GSq".  The results of the scan are located in the variable Dataman_to_NJ[8]-[11]. At some point I know I need to use the SWAP function but I believe my lack of data type knowledge in this system is hindering me. How can I convert the value in Dataman_to_NJ[8] to the string "87"? Any assistance would be appreciated.  
  17. Hello everyone, I am working with a NB10W HMI connected to a PLC NJ by Ethernet protocol, I would like to know where to start regarding the sending of data from the PLC to the HMI. I have a 50x15 array and should show all those values in the HMI for read / write. How to proceed? I started working with PLC for a while. I'm using Sysmac Studio to programm the PLC and NB designer to the HMI.
  18. Hello everyone, I need the help to do setting of datalink between CJ2 and LOGIX-5324ER. The Allen bradley PLC was programmed by contractor and I have no software of it, so I am doing the network setting in CX-one network configurator. I tried to do the instruction in the Quick Start Guides on Downloads section here under Omron, but I couldn't find the option to register tags in network configurator. Is there anything wrong here? or is it possibly because of that they not support to do a datalink in these version of PLCs? They appeared like these in the pictures.
  19. Remote I/O refresh problem

    Hi all, I’m having some problems regarding a digital input from a remote ethernet coupler input. My setup contais an Omron CJ2M cpu33, a switch, an Omron NS5 HMI (also ethernet) and 10 Wago Ethernet/IP couplers, all of which have 2 digital in- and 2 digital output cards. Every machine cycle all couplers recieve an input from a regulair proximity switch, this signal is high for about half a second and switches at a frequency of about every 2 seconds. Despite the fact there’s no high speed stuff going on here, the pulses are not processed properly. Monitoring my program I can see that the inputs are skipped and somtimes are not processed even for several machine cycles. Is my network too slow, can it be a scan time issue, or something else. I’ve come a long way building this system but I’m still fairly new to plc programming. Hope someone has a suggestion. Best regards,   Andy      
  20. I'm looking at project with an OMRON NJ-101.  I was planning on using Modbus TCP/IP from the PLC to talk to a MOXA gateway (MB3170) which would then talk to about 7 different slaves over RS-485.  Looking at detail at the blocks that are supplied by OMRON (MTCP_NJ V1.3, available from https://www.myomron.com/index.php?action=kb&article=1245), I noticed that it doesn't send the slave ID, which will mean that it won't be able to talk to different slave ids through the one IP Address. I had a look through the actual code and it sends "FF" in place of the slave id.  In particular I was looking at the "MTCP_Client_Fn03" block. Is there another way to get the NJ101 to talk the full MODBUS TCP/IP protocol? Is it possible to edit the blocks provided by OMRON?  It seems to me that they are locked down. If I could edit it I could just add the functionality Thanks for your help in advance.
  21. Howdy, So the program I have has linked up and I've downloaded to the Omron NS-10 just fine... other than when I go to certain screens the text from all the descriptor labels are gone. I can't figure out if its a setting or if its just getting lost in transmission somewhere. Halp. Thanks,
  22. HMI and Weighing Indicator

    hallo, i have problem here. i want to connect HMI OMRON NB7W-TW00B to weighing indicator with Modbus RTU rs485. i use this link https://www.myomron.com/index.php?action=kb&article=1538 for wiring diagram for rs485. and the baudrate, databit, parity check and stop bit is same between HMI and weighing indicator. but the output in HMI is "[2] PLC No Response: 00-01-2" i think the problem is my rs485 connection. can you help me? thank you.
  23. Omron CJ2M - Wago remote I/O

    Hi there, I’m not sure how familiar most of you are with Wago remote I/O, but I hope you may have some solution for the following connection problem I’m having. I’m working on a project to modernise an old folder collecting machine for which I’m using an Omron CJ2M Cpu33 together with 8 Wago 750-352 remote I/O units over ethernet/ip. These Wago units all contain two 8DI digital input cards and two 8DO digital output cards alongside a 750-610 bus power supply card. Adding them to my network in CX network manager is no problem and all seems to work fine. That is, as long as I don’t physically add the bus power supply card, which I need to, well.. power the Wago bus. Soon as I add this card (which was in place while making all the necessary settings to the Wago and Omron units) it just won’t connect. Remove it and it connects like it should. As far as I know the power supply card has no I/O addresses or other communication functions whatsoever, so I can’t get my head around it. Even stranger is that when instead of it I add an analog input card, with bus power connections build in, it connects without a problem. The .eds file only contains info about the main Wago unit, after installing it I should be able to add any kind of I/O card and address them in the Omron software. Also, the supply card is added and visible as a fifth card in the Wago I/O settings and the I/O status led is green during this error. Therefore I would say the problem is at the Omron side. Any sugestions?   Thanks in advance Andy - The Netherlands  
  24. Programming Analog Outputs - Problems

    Hi All, I've been perusing this forum and I've seen this topic covered before, but I still can't make heads or tails of how to do it still. I'm trying to vary an analog output 10v signal to talk to a VFD according to how much time a certain input bit is energized. Currently I have it set up as a totalising timer, trying to move the PV into a word so I can use it to scale an appropriate output. The trouble is, I'm not having any luck getting the output to do much of anything. No errors show up. For reference, I'm using a CJ2M CPU 12 PLC and the output I'm trying to program is a DA042V, its in slot 05 of the main rack. I'm trying to scale a 0-20 time to a 0-10V signal out. I used to have a problem and I was getting ~-.5V out of output 1, but I enabled a bit and now it's hanging out at 0V. Clearly I did something right. Any help would be much appreciated. I'm sure it's something silly, and I'm new at OMRON PLCs.
  25. CX-Simulator

    Hi guys, Do you have experience or know any good guides to set up a simulation case like this: - Simulating a PLC program such that the "PLC" is accessible on the Ethernet (for example just locally). - In addition, setting up the PLC settings with FINS protocol such that it is possible to write to the PLC with FINS protocol from another device. The first part is  most important. Best regards PC_VS_PLC