Search the Community

Showing results for tags ' are: -1756-en2xx controllogix® ethernet/ip communication modules'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Found 352 results

  1. Hey all - I am working on a car wash system design that will utilize the Nayax payment system. Has anyone utilized them? How do I incorporate the device with PLC to automate the system. After payment is approved how can I send out that signal from them, all via ethernet on a managed switch w/ wifi for exterior comms for the Nayax.
  2. Kinetix 300 Ethernet/IP Locks Up

    I am trying to use an Automation Direct Productivity P2000 to control a Kinetix 300 servo drive using Ethernet/IP.  I got the EIP working fine using Explicit Messaging.  The hardware enable and overtravel limits are hardwired ON.  The drive doesn't show any faults.  When I turn on the software ENABLE bit (bit 7 of byte 0 in the Output Assembly), the Ethernet communication stops.  Motionview continues to work, but if I disconnect and reconnect, it can't find the drive.  I have to physically power down the drive to reestablish Ethernet communication.  Once I power back up, EIP communication resumes with no issues. Any thoughts?  What am I missing?
  3. Hi All, Hope you all doing well in this pandemic life.  I would need your expertise with an issue I have been struggling with for past few days and thought to reach out here. I am working on a migration project with GE PLC and Citect SCADA 7.10. The GE PLC is migrated to ControlLogix L74 Rev24.10 while Citect SCADA is retained. For testing I only have L71 and L82 and could not managed to organise L74. When the code the loaded in L71 and connected to Citect, I cannot see tags in Graphic page but I see the subscription.txt in Debug folder shows all tags good . The same code when loaded in L82, the Citect works instantly.  Does anyone know this behaviour of PLC and SCADA? Regards, DeeEngr    
  4. Hello Guys, I am very new to CIP messaging and in our project, we are trying to Controllogix to SCADA server using CIP messaging: What I understand from the process right now is : 1. SCADA Opens a connection for Large forward Open ( Connection size set at 2500 bytes) 2. PLC responds and establishes a connection 3. SCADA send an MSP request to access tags from PLC 4. PLC responds to this request The problem we are facing is the PLC doesn't send out a response of more than 240 bytes, Have any of you guys have faced a similar issue or can help me with troubleshooting?   Thanks in advance Attached screen captures from wire 
  5. AVE instruction Error

    A little background information here, I am trying to create a moving average so I accomplished it with the code (imaged attached) The problem i am having is the AVE instruction error bit goes true. it leaved me with a result of 1.#QAN  I did some googling and it said this is typically done when dividing by zero?? so i added a NEQ to 0 prior to loading the array. then it happened again. so i put the error bit in front of the FFL so it will stop loading the array when i get the error bit so i can see what values are in the array when it errors out. Has anyone else had this issue and what could you do to resolve it? I haven't had any luck find something that points me in the right direction. Thanks in advance for your help.
  6. Hi all, after my complaing about my lack of network access in the workshop ive been tasked with fixing this so ive have some general questions about networking and concerning Ewons so this network will be used for connecting ewons to test products as well as general computer access the plan is to have 7 computer access points as well as 2 points to connect to product lines for testing my intial thoughts were to run 2 cables from our network to 2 routers, 4 computer access points and one line testing connection on 1 and 3 computer access points and one line testing connection on the other so first question is what type of ethernet cable should i use? i assume cat5 is fine, is it worth going for cat6 or is it just a waste of money? and should i be running crossover cable or straight through? do i need any specific routers or will anything do? will i be able to add splitters later down the line and be fine? or should i future proof a bit with more robust routers? my years of avoiding networking at uni has come back to haunt me i know the basics but thats all really thanks to anyone who can offer some usefull information i mention the Ewon units because ive been told that they need to be the only one on their connection to the network, although i dont know how true this is  
  7. Fatek PLC Communication Problem

    hy all. i am having an error while communicating with fatek plc. when i communicate it gives an error. " Com port open fail, plz check if this port is used by other programme when we online the PLC (Fatek/ WinProLadder). kindly Guide me   as it looks like port is already used by another program . and i dont know how to kill that program ..       
  8. Hello all, I'm trying to control a robot over EtherNet/IP using Omron NX1P2. I have some experience in programming in EtherCAT with Sysmac studio for this robot but no prior experience in EtherNet/IP. I have the EDS file and based on this article I was able to develop the tags. However when I transfer the program to the controller I'm getting the following error and I'm unable to proceed any further. I do not know what I'm doing right or  wrong. If some one can guide me through the steps needed to setup an EtherNet/IP device and building a program with it, it will be of great help. I have set up the Task settings same as the way I do for my EtherCAT program. Is that the correct way to go ? Any help from this community is deeply appreciated. EtherNetIP_Demo.smc2
  9. INFO

    Dear sir, I am working in container terminal, we have Siemens plc  s7-300 , Bromma spreader with SCS-3( codesys software) spreader field device sensor (ifm) connected to slave ifm CR9011, now a days we are facing too much issues in scs-3 so we planned for isolate the SCS-3 but we want to know ifm module Cr9011 how to communicate to Siemens plc  7 how to write in hardware configuration. can you please suggest us.  
  10. Hello there, I am new to OMRON so need some help to communicate two PLC over FINS.   Here are the description of the system... (IO Table image is attached)   PLC1-  CJ2M-CPU33 IP- 10.113.218.34 SUBNET-255.254.0.0 UNIT NO - 00 (set the dial available on the CPU in HEX) NODE - 22 (set the 2 dials available on the CPU in HEX) PLC2-  CJ2M-CPU33 IP- 10.113.218.35 SUBNET-255.254.0.0 UNIT NO - 01 (set the dial available on the CPU in HEX) NODE - 23 (set the 2 dials available on the CPU in HEX)     Now, what i have to do is to transfer the D100 to D110 from PLC1 to PLC2's D200 to D210 and Transfer the D100 to D110 from PLC2 to PLC1's D200 to 210.   I have tried RECV and ECHRD blocks but didn't succeed yet.   Two CPU are connected over ethernet via a industrial switch.   Can you help me to achieve data transmission please...
  11. Hi, I'm trying to communicate with a Keyence Laser Marker MD-X1500 through an RS232 IO module ( QJ71C24N-R2) , and i'm using the GP.OUTPUT command to send the request , and the G.INPUT to receive the Reply from the Laser !!!  No success .    ANY help will be really appreciated       Thanks, 
  12. 1756-dnb connection error

    i'm trying to interface a 1756-dnb to a couple devices. i've got the rsnetworx configuration complete and dowwnloaded to the device. when i go online in studio 5000, the scanner is faulted out. the code is "16#0108 connection request error: connection type (multicast/unicast) not supported". what could be going on here? i'm using an l72s cpu and a 1756-dnb/a on the local chassis
  13. Hello, Can anyone tell me what types of Ethernet/IP device the  QJ71EIP71 can be configured as? Explicit message server, explicit message client, I/O adapter and/or I/O scanner? I'm having trouble finding this information in the manual: https://eu3a.mitsubishielectric.com/fa/en/dl/12484/SH(NA)-081157ENG-B.pdf
  14. Produced and Consumed Tags

    How can I determine if both my Produced and Consumed tags are communicating with each other, and if have the right set of tags since I forgot how I named them?  Is there a way to confirm that both my P & C are communicating.
  15. I have IPC and need to detect status of IPC and PLC communication . I need help with the same that how can in detect it ? Is it possible with message instruction ? if it is then how ?
  16. Hello Everyone, I am new at this forum, seeking help from you guys and gals. Scenario: I have a Controllogix 1756-L71 5570 controller installed with 1756-TIME module. The function of time module is to take time from GPS clock module in NTP format and send it to controller in PTP format. All the status LED's on Time module are OK. Also sync LED is Green. Still the time of controller is not synchronized with GPS clock there is a difference of 45 mins. Fellows please help. I'll be helpful.
  17. We recently added a new analog card to a remote rack that is communicates to a processor rack that has a redundant partner... We made the change when the processor was online, do we need to do anything on the redundant side? 
  18. Hi all,  I am trying to configure an Fx3ge-24M PLC using GX-works 2. I can successfully connect to the PLC using the USB cable, however i am having trouble getting a connection via ethernet. I have attached a photo that contains the only ethernet configuration that i can find, what am i missing here? I'm new to GX works & mitsubishi PLCs.  
  19. We have an application using a Mitsubishi L02CPU-P with a built in ethernet module. At one time the TCP/IP interface became irresponsive and a hard reset was required. The device is configured for binary communication and works fine using a GOT therminal and also operates fine when queried from a GX Works application. During debugging of a custom MELSEC application the TCP/IP interface stopped responding and could no longer be located using GX Works and the GOT terminal also lost contact. The L02CPU-P continued running the control application, but could no longer be contacted. The only way to recover was using the L02CPU-P reset button. I have heard developers being restrictive using the TCP/IP interface remotely over VPN and unstable connection due to the risk of hanging the device and not being able to recover without a personal visit to the device. Any experience from L02CPU-P devices requiring hard reset to come "online" again? Or does it enter some default state due to some internal exception handling?
  20. Hey all, I am having some issues with a Keyence IV2 camera which has Ethernet/IP functionality.  To summarize briefly, it has been configured and reading the data into my PLC (NJ501) into a structure data type.  The issue I'm having is that I cannot control this on a bit level for triggering the camera, etc.  I was reading that a Union type is the way to go, but unfortunately, I stopped getting data into the PLC when setting it up that way.  According to the configuration guide for Rockwell and setting it up in the Network Configurator, I needed to go with the SINT type.  When registering the device, the 8-bit option was necessary since the Input/Output sizes needed to match.  This was predetermined by the EDS file for the IV2. I am stumped as to how to get the data to read into the Union Type, and any suggestions would be greatly appreciated. Thanks, -K  
  21. Can anyone help me with the issue in the picture? We have the correct version in place yet it gives me a version error stating it needs the version that is installed. Doc1.docx
  22. Hi, I would like to connect a  Ramsey Micro-Tech 9101 integrator via Ethernet/IP to a Controllogix. I have read the manual from Ramsey and they show that I should add a Generic Ethernet Module in RSLogix and enter the Input Assembly instance and Output Assembly parameters to get it working. I have tried the settings in the manual but it tells me that the Input Size is not correct, tried different values and couldn't find any that work. Could somebody please assist me? I have emailed Ramsey but have not gotten a reply yet and I also contacted their local office here in South Africa but they could not help me.  
  23. Hi to everybody. I'm beginner on Beckhoff so I'm having issues with connecting Beckhoff CX8090 and Weintek EMT3070a. I'm trying to use Beckhoff TwinCAT PLC Free Tag names to get data from CX8090.  I have followed instructions in EasyBuilderPro which are pretty straightforward. On side of HMI I need to select proper settings which should be: IP: 192.168.1.2, Port no.: 48898, ADS port: 801, AMS NetID: 192.168.1.2.1.1 I have succesfully imported all variables from my PLC program into the EasyBuilderPro. For testing I tried to create HMI just to see status of few inputs. I have no issues uploading program to HMI, but after startup I get message Device no response and communication is not working. On side of Beckhoff I have settings like this: AMS NetID: 192.168.1.2.1.1 Ethernet port X001: DHCP Ethernet port X101/102: IP: 192.168.1.2   I can access to CX using input ports X101/102 and also access to HMI through same connection. I have also tried to log on to windows CE on CX and tried to ping HMI and that also went ok. Also I have tried to add static route on TwinCAT to HMI with settings AMS NetID:192.168.1.3, IP:192.168.1.3 but again no connection. So physical connections are CX8090 X101 - > HMI, CX8090 X102 -> PC. From PC I can access both devices. I'm using TwinCAT 2. Can you tell me what I'm doing wrong?   Thank you
  24. CP1L-EL TCP/IP with VideoJet Printer

    Hello, My previous topic was want to establish communication CP1E --> Videojeet Printer using RS232 serial cable. this project test SUCCESS. by the way distance from printer and PLC was very far almost 500meter. so printer technical team request to use tcp communication using cat5e cable. Problem: 1. I'm using TCP communication protocol that need me to have open,send,receive,close port. 2. Communication testing with PC Hyper Terminal --> OK but HT need in waiting call mode, i don't know why. 3. Using printer no result show. how i'm suppose to know communication already establish? 4. Communication setting on PLC Setting-Built in Enthernet need to add other communication device.? here i'm share some programs to give more understanding. Thanksm TCP with printer.cxp
  25. Hello. I am trying to make a serial RS 232C connection between Schneider Magelis HMIGXU3512 and Omron PLC CP1E. However, there seems to be a communication problems between both of the equipment. I am using cable XBT Z9740 for the serial communication cable. The format used is 8.2.N for both equipment. The baud rate is 115200. No Flow Rate is choose. Anyone can help with this kind of problems?