WireBiter665

MrPLC Member
  • Content count

    4
  • Joined

  • Last visited

Everything posted by WireBiter665

  1. If this has been asked and answered already, please point me in the right direction. I have a production line that uses Gefran Geflex temperature controllers on a Modbus and Machine Net communication system. The main control panel (MCP) is the master on the Modbus and communicates directly with 3 slave Geflex units (Group Leaders?) which then communicate with the others in that group via a Gefran Machine Net type interface (ribbon cable daisy chained from one unit to the next). The issue is twofold: These temperature controllers are slowly becoming harder to find AND they are a PITA to change out because they have to be put in place and then properly addressed using software on a laptop. This means more downtime waiting for someone who knows how to set these up to get there to do it say on a weekend/middle of the night type situation. (I do like my beauty sleep). I'm looking to replace these units with standard SSRs and control them with a PLC (P-2000 most likely). What I would need to be able to do is interface between the MCP and PLC in some way that the MCP still believes it is controlling 24 units (24 Modbus IDs) and have the PLC receive the reads and writes from the MCP and know which ID it was meant for in order to set the SV and respond with the PV and/or alarm codes as that ID. I hope that all makes sense. Basically I need a way for a PLC to act as if it were 24 separate Modbus slave units. Could I just use a separate HMI next to the MCP? Yes, but there are temperature dependent routines in the main operation of the line (extruder run inhibit, etc.) that requires the information reported back on the Modbus. I've looked into Modbus Gateways but the MGs I've found so far don't seem to be capable of assuming the role of 24 different slaves and interfacing with the PLC in a way that would allow the individual control.  Any ideas would be greatly appreciated.
  2. Modbus Gateway (Replacing Slaves With PLC)

    Thank you, Dan. I'll check that out. 
  3. PanelView 1400e Download Issue

    UPDATE: I'm not sure what I did or did different...nothing I can think of, but it finally transferred all the way through. What I did was wrote a quick C# program and made a DB-9 loopback plug (shorted pins 2 and 3) and opened up a terminal, started sending lines of text and received what I sent. I wanted to watch what was going on while I tried a transfer so I downloaded and installed a serial port sniffer. That kinda messed things up so I uninstalled it. I decided to give it one last try and lo and behold, this time it went right through with no issues. I don't think any of that solved the problem. But the app is now on the PanelView and ready to go.
  4. PanelView 1400e Download Issue

    I'm trying to transfer an application file to a PanelView 1400e and I'm having some difficulty. We currently have 4 of these in operation on machinery and we acquired a spare that I'm trying to get ready. All use the same exact application. I tried using a memory card but none of the PanelViews recognize any of the cards I do have at the moment so that option is out (though at one time we did transfer the applications this way so we did have at least one card that worked in the past). I was able to extract the application file from one of the PVs via Transfer Utility 32 on Windows XP. I am unable to transfer it back to the spare PV. I am using a 9 for 9 straight through serial cable on COM1 of the laptop to the 9 pin DB connector on the back of the PV. I match settings between the PV and the TU32 (baud rate, parity, error). I put the PV on Transfer Application screen on the Serial tab. I open up TU32 and choose the application file (approximately 86kb in size). If I select memory partition 1 for the destination, I get a dialog that pops up telling me that partition 1 is full and it shows me the size and free space on both partition 1 and partition 2. The size for partition 2 matches what I see on the PV on the Terminal Information screen (approximately 2200kb in size and same is free). When I then select partition 2 for the destination and click OK, it asks if I want to format the destination. If I click NO, the transfer fails because "User did not format the destination". When I click Yes to format, the PV starts formatting partition 2 and the progress bar goes up to 100%, then a message comes up that the format is complete, waiting for application transfer. On the TU32 screen, the format progress goes up to 11% then hangs and eventually reports that the format failed. I've done this a number of times and it is always 11%. However, when I click OK and then go back to the main screen on TU32 and once again select to transfer, the PV screen goes into transfer mode with a progress bar as does the TU32. No progress is ever made and eventually I get the 4209 error. 4209 error means the TU32 and PV are not communicating, basically. But I'm confused as to why they initially do communicate but only get to a specific point each time before communications stop. Any ideas? EDIT: Once I get the 4209 error, I click OK, and go back to the main TU32 screen. If I immediately click to transfer again, the progress bar on the PV disappears and a message comes up saying File Download failed-Ready for Transfer. If I click to Transfer again, the progress bar reappears but still no progress and this process repeats. Thank you in advance for any help you can offer.