Forums.MrPLC.com: S7-200 tips & tricks - Forums.MrPLC.com

Jump to content

Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

S7-200 tips & tricks Rate Topic: -----

#1
Guest_denni_*

  • Group: Guest
Hello,
I'm a begginer in Siemens PLC s7-200.Yesterday I download a program from this forum (S7-200 tips and tricks : Tip005B) and after that, PLC wont work.
Now i can't download and upload any program to PLC.

:shrug:
The message box said :"communication Time out. check the port number, network address, baud rate & the attached cable".
do you know the problem?

:shrug:
0

#2
User is offline   Crossbow 

  • Automation Engineer
  • Group: MrPLC Admin
  • Posts: 3,643
  • Joined: 30-January 03
  • Gender:Male
  • Location:Edge of Insanity
  • Country:United States
    United States
Sounds like the program had different settings for the communications port. Go into the program in MicroWin and check the com port parameters, then set up your parameters to go online with those settings.

Microwin should be able to search for the PLC too.
0

#3
Guest_Guest_denni_*

  • Group: Guest
I'm sorry, there is internet problem last week here.

the comm port parameters :

remote address : 2
Local address : 0
Module : PC/PPI Cable (COM1)
Protocol : PPI
Transmission Rate : 9.6kbps
Mode : 11-bit

thats all,
thank u
0

#4
User is offline   Crossbow 

  • Automation Engineer
  • Group: MrPLC Admin
  • Posts: 3,643
  • Joined: 30-January 03
  • Gender:Male
  • Location:Edge of Insanity
  • Country:United States
    United States
Open the program you downloaded to the PLC and make sure those are the settings that were sent to the PLC's serial port. If the program changed te parameters, you'll need to change your PC/PPI setup to match to get back online with the PLC.

The settings you mention are the defaults for the S7-200. Just open Microwin and look at the PLC configuration for the program you downloaded to the CPU.
0

#5
User is offline   Crossbow 

  • Automation Engineer
  • Group: MrPLC Admin
  • Posts: 3,643
  • Joined: 30-January 03
  • Gender:Male
  • Location:Edge of Insanity
  • Country:United States
    United States
I've looked at the program for that tip, and you set the serial port to Freeport mode for ASCII send/receive. The settings for the COM port are 9600 8N1 now. The mode on the serial port is being set on the PLC's first scan. One thing you might try it turning off the PLC, turn run/stop switch to STOP, and then power up. This way no first scan is issued, might be able to connect then. If not, I'll ask Siemens how to connect to an S7-200 with the serial port in Freeport from Microwin.
0

#6
Guest_Mika Jylha_*

  • Group: Guest
Had the same problem earlier: I had an older PPI cable that supported only 19,2 kb, and i downloaded a system block with port settings of a 187,5 kb.

For me the only solution was to buy a USB-PPI cable (6ES7 901-3DB30-0XA0)

Best Wishes: Mika Jylha, Finland

mika.jylha@kcigroup.com
0

#7
User is offline   Crossbow 

  • Automation Engineer
  • Group: MrPLC Admin
  • Posts: 3,643
  • Joined: 30-January 03
  • Gender:Male
  • Location:Edge of Insanity
  • Country:United States
    United States
But the problem he is referring to is he has changed the protocol on the port, not the baud rate. Freeport is an ASCII communication language for bar code readers, RFID, etc. It's not PPI. But that sample program has the settings change to Freeport happening on a first scan flag. So turning off the PLC and powering it back up with the Run/Stop switch in Stop should prevent the mode change on the port. It worked fine in my lab (used a 224XP which has 2 serial ports just in case, but it reconnected fine in Stop mode)
0

#8
User is offline   khekd 

  • Sparky
  • PipPipPip
  • Group: MrPLC Member
  • Posts: 42
  • Joined: 13-January 05
  • Location:Indy
  • Country:United States
    United States
There is a program that is installed with Microwin called wipeout.exe. Just do a search on your computer for it. Hook your programming cable the PLC and your computer and run the executable.

What this will do is wipeout the program inside the plc and it doesn't care what the baud rate is set at.

Khek

I have also attached the wipeout program

Attached File(s)


0

Share this topic:


Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

1 User(s) are reading this topic
0 members, 1 guests, 0 anonymous users