Sign in to follow this  
Followers 0
Raalen

FX3GE40M, FX2N48ER-ES, FX2N8EYR, FX3G232BD

5 posts in this topic

I am working on a project using mitsubishi plc's. Initially started with just the FX3GE40M but needed more i/o and a rs232 connection for a Cardinal scale.

In order to increase the number of i/o I am using the FX2N48ER-ES,  FX2N8EYR and the FX3G232BD is for the RS232 connection. 

My question is how do i organize the proper sequence of i/o from one unit to the next using GXWORKS 2?

 

 

Share this post


Link to post
Share on other sites

Its automatic assigned.

the FX3GE40M (main unit) lets say the I/O is:

X0 to X20

Y0 to Y 20

The first expansion unit connect to the main unit will be:

Lets say in your case using FX2N48ER-ES:

X21 to X44

Y21 to Y44

if the FX2N8EYR is connected in right side of your FX2N48ER-ES will be:

X45 to X48

Y45 to Y48

But the main unit have limit of I/O (expansions) you need check the main unit spec.

maybe im wrong and you can assignee the I/O address, im pretty new too using PLC

just write simple code using X21 and Y21 and check the unit led status of the respective I/O

if dont work the X22 and Y22 is the correspondent, and check all one by one if is the case to make sure

Edited by Copyleft

Share this post


Link to post
Share on other sites

From Left to the right I have the FX3GE40M then the FX2N8EYR(8 outputs) then the FX2N48ER-ES

I have assigned the additional i/o in GX works 2 but now when i power the unit on, input [x0] on the FX3GE40M is the only input that responds.

Share this post


Link to post
Share on other sites

The last input on your  FX3GE40M should be X27 therefore the first input on your extension block should be X30, the last output should be Y17 so your first extension block output should be Y20. Note extension blocks always start their addressing with the next available multiple of 10 (30, 40 ,50 etc) if your last input on your PLC was X24 the first input on your extension would be X30. This is all done automatically, and doesn't require any setting up in software.

1 person likes this

Share this post


Link to post
Share on other sites

Thank you all, It was a hardware issue

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0