mr_electrician

Connecting Sysmac Studio HMI to CJ PLC

11 posts in this topic

Hi group,  I am starting to develop an HMI application using Sysmac Studio which is very new to me.  I can easily create graphics but my struggle is figuring out how to connect my graphics to the CJ2M CPU35 PLC.  For example I am trying to simply turn my indication to green when 4004.02 in the PLC is "TRUE".  Can someone point me in the right direction as the manual is a bit vague.

Here is what I have done so far:

 

PLC Configuration.jpg

Address Config.jpg

Variable Mapping.jpg

4004.02 Manual Mode.jpg

Share this post


Link to post
Share on other sites

The Sysmac HMI is designed for use with variable names.  You need to assign variables in the CJ controller, set them for network access, and then import them into Studio, and then use them to create your screen objects.

The NS and NB Series HMI products are designed for use with CJ addresses.  NA is really designed for use with Sysmac NJ/NX controllers.

1 person likes this

Share this post


Link to post
Share on other sites
21 hours ago, Crossbow said:

The Sysmac HMI is designed for use with variable names.  You need to assign variables in the CJ controller, set them for network access, and then import them into Studio, and then use them to create your screen objects.

The NS and NB Series HMI products are designed for use with CJ addresses.  NA is really designed for use with Sysmac NJ/NX controllers.

Well that explains why I cannot get any communication going.  Looks like I will be telling my boss that he spec'd the wrong HMI series unless he wants to re program the PLC to an NJ as well!!

Share this post


Link to post
Share on other sites
19 hours ago, mr_electrician said:

Well that explains why I cannot get any communication going.  Looks like I will be telling my boss that he spec'd the wrong HMI series unless he wants to re program the PLC to an NJ as well!!

He's not saying it wont work.

1) Right click "Device References" and select "Add > External Device". Your picture shows "Internal Device". Internal Device would be a controller project in Sysmac Studio.

2) Save your CX Programmer project as a *.CXT. Default is *.CXP.

3) Import variables from your External Device dialog.

That being said, if you can get an NJ controller, that would be the best option. If cost is a factor then have a look at the NX1P. They have a lot of capabilities for a 'brick' series.

Share this post


Link to post
Share on other sites
1 hour ago, IO_Rack said:

1) Right click "Device References" and select "Add > External Device". Your picture shows "Internal Device". Internal Device would be a controller project in Sysmac Studio.

That's how the object shows.  I did add the PLC as an external device.  I did it 3 separate times and this is how it shows in the tree every time.

Share this post


Link to post
Share on other sites

But did you make variable names in the PLC?  Did you set them to Network Publish?

NA is not designed to see PLC addresses, only variable names that are available on EtherNet/IP.

If you already wrote the program with addresses, you can assign an address to a variable when you create the variable, so you don't have to write the entire program with variables if you prefer not to.

Share this post


Link to post
Share on other sites
On 8/5/2019 at 5:54 AM, eulno said:

Look at the video in this link 

https://www.youtube.com/watch?v=EHepZBY0iBQ

It might help you

Thanks however it's in French.

Share this post


Link to post
Share on other sites

I was able to figure out how to get the addresses in a CJ PLC linked to an NA series HMI created in Sysmac to work!!!!  Actually it was very easy.  All I had to do was creat symbol names in the CX Programmer and then set them to Publish.

After that I could import my Symbols into the Sysmac Developer Environment.

Thanks everyone for all the suggestions.

Share this post


Link to post
Share on other sites
Just now, mr_electrician said:

Thanks however it's in French.

Mute your computer and then watch.  :-)

 

Share this post


Link to post
Share on other sites
Just now, Michael Walsh said:

Mute your computer and then watch.  

Nooooooooo!  Must have sound lol!!!!

:dance:

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now