kevspark

Connect to PLC through GOT HMI

29 posts in this topic

Hello everyone.

New to Mitsubishi PLC's and I'm struggling to create a connection between the HMI and PLC with this mode (PLC Mode:FX5CPU via GOT (direct coupled) transparent mode)

Equipment -

HMI GS2110-WBTD,

FX5U CPU

Software - 

GXworks3

GT Designer3

Im using a USB to communicate to the HMI and thats working fine I can also directly connect to the CPU using an Ethernet cable. I've been told that I can program the PLC directly from the USB cable connected to the GOT HMI, I also have an Ethernet cable between HMI and PLC.

I've tried everything I can find online but I'm still stuck. Both IP address are on the same subnet and I've selected or tried every option available on GXworks with the 'Specify Connection Destination Connection' window.

Any help would be appreciate as I'm guessing its something silly I'm missing.

Many Thanks. 

 

 

Share this post


Link to post
Share on other sites

First is the GOT communicating with the FX5 ?

 

Share this post


Link to post
Share on other sites

Hi sorry for the long delay, been on hols for a few days. No I cant get the HMI to communicate with the CPU.

I've set the IP address on both devices in the same sub network i.e. CPU 192.168.3.*** , HMI 192.168.3.***. I can also ping the cpu from the utility function of the HMI with no issues.

HMI station ID is 3, CPU is 1. Both on network 1

Beginning to pull my hair out with this I cant understand why Mitsubishi just dont have a device search function like Siemens, so much easier.

Share this post


Link to post
Share on other sites

actually it's better. You've tried the direct connection already i saw in your post.
If you don't you can use search and it will find the FX5 even if you're in a complete other IP range!!!! perfect

1) Have you read the read the connection manual ?
2) Did you make melsoft connection port on your PLC side?
3) make a screen capture of the GOT setting for comm. 
If you use the wizard you can't go wrong

 

 

Share this post


Link to post
Share on other sites

Thanks for your quick reply, silly question but wheres the wizard setup option?

Share this post


Link to post
Share on other sites

Hi kevspark,

I think you should change the Controller Type to iQ-F. Also, I suspect that you'll need to change the port no. in Ethernet Controller settings from 5551 to 5556.

Hope that helps.

Share this post


Link to post
Share on other sites

Actually I think it's port 5562 :-1

Share this post


Link to post
Share on other sites

Not sure if this is the wizard your referring too. e tried all sorts of settings on here also. 

Capture34.JPG

Share this post


Link to post
Share on other sites

yes you need to put iQ-F as a driver and FX5U as the PLC. The port will change automatically

Share this post


Link to post
Share on other sites

Hi, the controller is an FX5?

Share this post


Link to post
Share on other sites

The wizard start when creating a new project if it doesn't go to tools options and turn the wizard on(Display New project wizard)

Share this post


Link to post
Share on other sites

Posted (edited)

Just now, kevspark said:

Hi, the controller is an FX5?

Just do it :)
 The FX series is for the previous versions

Edited by Gambit

Share this post


Link to post
Share on other sites

Ok cool, I'll give it a crack now guys, cheers.

Share this post


Link to post
Share on other sites

Ok, must be getting somewhere because every so often I get the SD and RD light flash on the utility Comm Monitor! But still unable to communicate error comes up on GX works3...arrrgg

Share this post


Link to post
Share on other sites

Posted (edited)

Did you create the melsoft port and reset the PLC?

If it still doesn't workt post screencaptures of your settings. or the projects themselves

 

Edited by Gambit

Share this post


Link to post
Share on other sites

Is this what you mean by Melsoft port? Thanks for your quick replays, really appreciate it. 

Capture50.JPG

Capture60.JPG

Capture70.JPG

Share this post


Link to post
Share on other sites

Yes that is what i meant.

The setting look perfect now. 
Did you reset the PLC after downloading adding the melsoft port ?

Can you check your ethernet diagnostics from the FX5U. looks at the ports

Share this post


Link to post
Share on other sites

Yes i reset the PLC after adding the MELSOFT port. I cant check the diagnostics as it wont let me communicate unless I directly connect again and bypass the GOT. Im at a loss here :-(

Share this post


Link to post
Share on other sites

Posted (edited)

Aha you mean you don;t have it connected to a switch !!!
Just as a check can you open the utility menu on the GOT and choose the ping option.
 

Edited by Gambit

Share this post


Link to post
Share on other sites

Yes I can ping the CPU with no issues

Share this post


Link to post
Share on other sites

ok Can you read out the PLC and check if the Melsoft port is there?

Share this post


Link to post
Share on other sites

Sorry Im not with you. How do I carry out this?

Share this post


Link to post
Share on other sites

Posted (edited)

Just close your project. Online =>  read from PLC...... and make your comm settings

Or do a verify. 

 

Edited by Gambit
1 person likes this

Share this post


Link to post
Share on other sites
1 hour ago, kevspark said:

Yes I can ping the CPU with no issues

You tested from the GOT not your PC Right ?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now