LEMON FOAM

ETHERNET COMMUNICATION

7 posts in this topic

I'm new to Mitsubishi PLC programming.

I want to communicate my Q13UDEHCPU (Q-series PLC CPU) and GT2308-VTBA (GOT2000 HMI) by using the built-in Ethernet port on the 2 devices

Picture 1 to 3 shown the setting in the GOT2000 HMI using GT-Designer program, Picture 4 shown the setting in the PLC CPU using GX-Work program

Picture 1: I/F Communication Setting

Picture 2: Controller Setting

Picture 3: GOT Ethernet setting

Picture 4: Built-in Ethernet port Setting

 

Beside than the setting in the 4 pictures, is there any other setting i need to do so that the 2 devices can communicate via built-in Ethernet port

 

 

Picture 1 (IF communication setting).png

Picture 2 (Controller setting).png

Picture 3 (GOT ethernet setting).png

Picture 4 (Built-in Ethernet port setting).png

Share this post


Link to post
Share on other sites

I think that problem is because of setting same station number for Got and PLC.

Please change GOT station number to 40.

Share this post


Link to post
Share on other sites

Posted (edited)

18 hours ago, DaMro said:

I think that problem is because of setting same station number for Got and PLC.

Please change GOT station number to 40.

Sir, what u mean by same station no? Is it the same IP address?

So i need to set the IP address for GOT at picture 3 to 192.168.3.40 and set the IP address for PLC in picture 4 to 192.168.3.39?

But why i need to set them as 40 and 39? Because when i see from the Mitsubishi manual, it set the IP address for GOT and PLC as 18 and 39

Beside than that, in the manual it had stated that setting in PLC side is not needed.

System configuration.JPG

Edited by LEMON FOAM

Share this post


Link to post
Share on other sites

I marked point which you should change.

 

5cfe61d71afbf_Picture2(Controllersetting)_png_2eb24415efb74661f8b7805a41ca6ee7.png

Share this post


Link to post
Share on other sites

Posted (edited)

On 6/12/2019 at 2:47 PM, DaMro said:

I marked point which you should change.

 

Sir, u mean i need to set the PLC and GOT into different station? Beside than that, am I needed to set the IP address port no to different value as shown in the picture below?

System configuration.JPG

Edited by LEMON FOAM

Share this post


Link to post
Share on other sites

Yes, you need to set different stations numbers.

For IP adress you need to set them into same group: 192.168.3.***.

For example:

PLC: 192.168.3.39

GOT: 192.168.3.18

By the way, if you have clean PLC and GOT, you don't have to change anything in PLC parameters and in GT-Designer it is enough to select correct Controller type and connection type. All other settings should stay defaults.

Share this post


Link to post
Share on other sites
11 minutes ago, DaMro said:

Yes, you need to set different stations numbers.

For IP adress you need to set them into same group: 192.168.3.***.

For example:

PLC: 192.168.3.39

GOT: 192.168.3.18

By the way, if you have clean PLC and GOT, you don't have to change anything in PLC parameters and in GT-Designer it is enough to select correct Controller type and connection type. All other settings should stay defaults.

I see, thank you for ur explanation. As conclusion, if we need to connect PLC and GOT by built in ethernet port, we need to set them into different station and IP. Am i right?

And what did u mean a clean PLC and GOT, is it a new PLC and GOT?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now